Subject: [apps-discuss] Fwd: New Version Notification for draft-hausenblas-csv-fragment-01

From: Erik Wilde <[email-masked]>
Date: Sat, 29 Dec 2012 16:06:21 -0800

A new version of I-D, draft-hausenblas-csv-fragment-01.txt
has been successfully submitted by Erik Wilde and posted to the
IETF repository.

Filename:	 draft-hausenblas-csv-fragment
Revision:	 01
Title:		 URI Fragment Identifiers for the text/csv Media Type
Creation date:	 2012-12-29
WG ID:		 Individual Submission
Number of pages: 10
URL: 
http://www.ietf.org/internet-drafts/draft-hausenblas-csv-fragment-01.txt
Status: 
http://datatracker.ietf.org/doc/draft-hausenblas-csv-fragment
Htmlized:        http://tools.ietf.org/html/draft-hausenblas-csv-fragment-01
Diff: 
http://www.ietf.org/rfcdiff?url2=draft-hausenblas-csv-fragment-01

Abstract:
    This memo defines URI fragment identifiers for text/csv MIME
    entities.  These fragment identifiers make it possible to refer to
    parts of a text/csv MIME entity, identified by cell, row, column, or
    slice.

Note to Readers

    This draft should be discussed on the apps-discuss mailing list [12].

The IETF Secretariat

-- 
erik wilde | mailto:[email-masked]  -  tel:+1-510-2061079 |
            | UC Berkeley  -  School of Information (ISchool) |
            | http://dret.net/netdret http://twitter.com/dret |

---

From: Dominik Tomaszuk <[email-masked]>
Date: Sun, 30 Dec 2012 13:59:51 +0100

On 30.12.2012 01:06, Erik Wilde wrote:
> Status: http://datatracker.ietf.org/doc/draft-hausenblas-csv-fragment
> Htmlized:
> http://tools.ietf.org/html/draft-hausenblas-csv-fragment-01
> Diff: http://www.ietf.org/rfcdiff?url2=draft-hausenblas-csv-fragment-01
>
> Abstract:

I propose to add "regexp" scheme. For example:
http://example.com/data.csv#regexp:place=/^G/

Following the listing in § 2, the above CSV fragment selects a slice, 
yielding another CSV table as follows:
date,temperature,place
2011-01-01,1,Galway
2011-01-02,-1,Galway
2011-01-03,0,Galway

Cheers,
Dominik Tomaszuk