Subject: [Autoconf] Applications

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 27 Jul 2009 22:01:58 +0200

During the meeting there was questioning about which applications are 
considered in AUTOCONF?  The obvious answer "MANET applications" is not 
sufficient I believe.

Two different MANET applications:

     --------     --------     --------          --------
    | Fixed  |   | Fixed  |   | Fixed  |        | Fixed  |
    | Access |   | Access |   | Access | . . .  | Access |
    | Point  |   | Point  |   | Point  |        | Point  |
     --------     --------     --------         --------
        |            |            |                 |
        |            |            |                 |
        o            o            o                 o wifi antenna

         o
         |                                   o
       ------      movement                  |
      |Mobile|    ------->                 ------
      |Host  |                    <-----  |Mobile|
       ------                             |Host  |
                                           ------

==========================cut here==============================

         o                                   o
         |                                   |
       ------                              ------
      |Mobile|                            |Mobile|
      |Router|     -----                  |Router|     -----
       ------     |Fixed|                  ------     |Fixed|
         |        |Host |                    |        |Host |
         |         --|--                     |         --|--
       --------------|                     --------------|

These applications necessitate different ways of configuring the 
addresses.  I don't think the rule "/128" could fit both.

Alex

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 27 Jul 2009 14:02:55 -0700

Hello Alex,

Are these "usage scenarios"?  I thought an application
was something that usually communicated through sockets.
For your example, I guess that the access points are
connected to the Internet and offer various subnet
prefixes?  Also, I guess that the fixed hosts have wireless
interfaces and some way of establishing links at layer 2,
but do not offer access to the Internet?

Regards,
Charlie P.

Alexandru Petrescu wrote:
> considered in AUTOCONF?  The obvious answer "MANET applications" is 
> not sufficient I believe.
>
> _______________________________________________
> Autoconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/autoconf
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 27 Jul 2009 23:13:44 +0200

> was something that usually communicated through sockets.

Hi Charles, ok, usage scenarios.

> prefixes?

No, the first usage scenario has fixed access points disconnected from 
the Internet, and not connected to each other by some wire, just by 
their wifi interface, such that the hidden terminal problems are 
exacerbated.

They don't offer various subnet prefixes, there are no /64 prefixes, 
there are only /128 host-based routes.  There is not _one_ single subnet 
prefix either.

(it is not like the usage scenario with Mobile IPv6 and Access Routers
  connected to Internet and each offering a different and distringuished
  IPv6 prefix).

> Also, I guess that the fixed hosts have wireless

Yes, the fixed hosts have wireless interfaces.  Some other times they 
have wired interfaces instead.  And yes, they  don't offer access to the 
Internet.

For these simple usage scenarios it is all disconnected from the Internet.

I wanted to express how much different are they in their needs to 
configure addresses.

Alex

---

From: Ulrich Herberg <[email-masked]>
Date: Tue, 28 Jul 2009 08:39:12 +0200

Hi Alex,

I don't understand what you mean. The second scenario looks for me like
"classical" IP, nothing new. Since it is a host, it does not need to be
exposed to MANET characteristics and can of course be configured by any
prefix short than /128 -- the prefix of the non-MANET interface if that
mobile router. The first scenario is ok, even though I would not name them
mobile hosts, but mobile routers.

Ulrich

On Mon, Jul 27, 2009 at 11:13 PM, Alexandru Petrescu <
[email-masked]> wrote:

> No, the first usage scenario has fixed access points disconnected from the
> Internet, and not connected to each other by some wire, just by their wifi
> interface, such that the hidden terminal problems are exacerbated.
>
> They don't offer various subnet prefixes, there are no /64 prefixes, there
> are only /128 host-based routes.  There is not _one_ single subnet prefix
> either.
>
> Yes, the fixed hosts have wireless interfaces.  Some other times they have
> wired interfaces instead.  And yes, they  don't offer access to the
> Internet.
>
> I wanted to express how much different are they in their needs to configure
> addresses.
>
> Alex
>
>>
>> Regards,
>> Charlie P.
>>
>>

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 28 Jul 2009 11:08:54 +0200

Ulrich Herberg a écrit :
> "classical" IP, nothing new.

There should be something new in the way the mobile routers talk on 
their wifi interfaces otherwise the FixedHosts can't talk to each other.

> Since it is a host, it does not need to be 
> mobile router. 

In that figure, the wifi interfaces of the Mobile Routers behave as if 
they were in a MANET, or so I have been told by many people.

> The first scenario is ok, even though I would not name 
> them mobile hosts, but mobile routers.

Well, a Mobile Router with a single physical interface looks more like a 
  host to me, more than a router.  IMHO.

I also called them hosts because they seem to be the two ends of a 
communicating application and the problem is how to route packets 
between them.  In the second usage scenario the FixedHosts are the two 
ends of the communicating application.

Alex

> 
> Ulrich
> 
> On Mon, Jul 27, 2009 at 11:13 PM, Alexandru Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     No, the first usage scenario has fixed access points disconnected
>     from the Internet, and not connected to each other by some wire,
>     just by their wifi interface, such that the hidden terminal problems
>     are exacerbated.
> 
>     there are only /128 host-based routes.  There is not _one_ single
>     subnet prefix either.
> 
>     Yes, the fixed hosts have wireless interfaces.  Some other times
>     they have wired interfaces instead.  And yes, they  don't offer
>     access to the Internet.
> 
>             During the meeting there was questioning about which
>             applications are considered in AUTOCONF?  The obvious answer
>             "MANET applications" is not sufficient I believe.
> 
>             These applications necessitate different ways of configuring
>             the addresses.  I don't think the rule "/128" could fit both.
> 
>             Alex
>             [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>