Subject: [avtext] Stephen Farrell's No Objection on draft-ietf-avtext-rtp-stream-pause-08: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Wed, 19 Aug 2015 09:58:04 -0700

Stephen Farrell has entered the following ballot position for
draft-ietf-avtext-rtp-stream-pause-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-avtext-rtp-stream-pause/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- 58 pages! There is quite a bit of repetition here but too
late to change now. 

- I see there are 2 IPR declarations, both with possible
royalty/fee and neither that I can see actually specifying
what patent (or other property) is involved despite both
declarations being some years old.  (And there was me thinking
remote controls were almost older than me, but I guess what do
I know and the USPTO must always be right;-) Anyway, can
someone point me at where the working group said they were ok
with this situation?  (The shepherd write up says that
happened so I hope it's not hard to get that pointer.)

- Section 7: in a multiparty call, say participant#1 hits
pause with PauseID = 0x0001, and stuff is resumed some time
later, is participant#2 supposed to use a PauseID of 0x0002
subsequently? In other words does the SHALL there apply to
everyone on the call or just to the participant who sent out
the last PAUSE message?  If the former, does that create a
race condition? Or maybe that's a harmless race? I guess you
could reduce the probability of a race by recommending that
PauseID be randomly selected between last-PauseID-seen and
last-PauseID-seen+(2^14) or something like that?  (And
apologies if all this is obvious to someone expert in RTP, I
am not that person:-)

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 19 Aug 2015 14:23:08 -0500

> happened so I hope it's not hard to get that pointer.)

Hi Stephen,

The wg was at least reminded of the IPR disclosures in HNL[1][2]. I 
can't say if that led to actual discussion, but people in the room had a 
chance to object. (disclaimer: This predates my AD-ness, and I was not 
in the IETF 91 avtext meeting)

I do not see evidence of a similar discussion on the avtext list, at 
least not an explicit "are we okay with this" call.

Keith/Jonathan/Authors: Do any of you have further input?

[1]http://www.ietf.org/proceedings/91/slides/slides-91-avtext-1.pdf 
(page 2)
[2]http://www.ietf.org/proceedings/91/minutes/minutes-91-avtext

Thanks!

Ben.

---

From: Bo Burman <[email-masked]>
Date: Fri, 28 Aug 2015 06:47:38 +0000

Please find my responses to your comments inline below.
Cheers,
Bo

> -----Original Message-----
> From: Stephen Farrell [mailto:[email-masked]]
> Sent: den 19 augusti 2015 18:58
> To: The IESG
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Stephen Farrell's No Objection on draft-ietf-avtext-rtp-stream-pause-08: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines.
> (Feel free to cut this introductory paragraph, however.)
> 
> 
> - 58 pages! There is quite a bit of repetition here but too late to change now.
> 
> - I see there are 2 IPR declarations, both with possible royalty/fee and neither that I can see actually specifying what
> patent (or other property) is involved despite both declarations being some years old.  (And there was me thinking
> remote controls were almost older than me, but I guess what do I know and the USPTO must always be right;-) Anyway,
> can someone point me at where the working group said they were ok with this situation?  (The shepherd write up says
> that happened so I hope it's not hard to get that pointer.)
[BoB] That at least happened when the draft was adopted as a WG draft, at IETF 88 AVTEXT session in Berlin:
http://www.ietf.org/proceedings/89/minutes/minutes-89-avtext

> 
> - Section 7: in a multiparty call, say participant#1 hits pause with PauseID = 0x0001, and stuff is resumed some time later,
> is participant#2 supposed to use a PauseID of 0x0002 subsequently? 
[BoB] Yes.

In other words does the SHALL there apply to
> everyone on the call or just to the participant who sent out the last PAUSE message?  
[BoB] It applies to everyone in the RTP session.

If the former, does that create a
> race condition? Or maybe that's a harmless race? 
[BoB] I would not say it is a race, and it is in any case harmless. If more than one participant sends a PAUSE with the same (current) PauseID, the RTP stream sender will ignore all but the first it receives (last sentence of section 8.1).

I guess you could reduce the probability of a race by recommending
> that PauseID be randomly selected between last-PauseID-seen and
> apologies if all this is obvious to someone expert in RTP, I am not that person:-)
> 
[BoB] There is no race, so even if such approach would likely work, it is not necessary.

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 28 Aug 2015 10:34:04 +0100

Hiya,

Those are all fine, for this document.

Thanks,
S.