Subject: [avtext] I-D Action: draft-ietf-avtext-rid-01.txt

From: [email-masked]
Date: Thu, 03 Mar 2016 14:00:35 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Audio/Video Transport Extensions of the IETF.

        Title           : RTP Stream Identifier (RID) Source Description (SDES)
        Authors         : Adam Roach
                          Suhas Nandakumar
                          Peter Thatcher
	Filename        : draft-ietf-avtext-rid-01.txt
	Pages           : 7
	Date            : 2016-03-03

Abstract:
   This document defines and registers an RTCP SDES item, RID, for
   identification of RTP streams associated with Encoded Streams and
   Dependent Streams.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-avtext-rid/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-avtext-rid-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-avtext-rid-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Adam Roach <[email-masked]>
Date: Thu, 3 Mar 2016 16:03:03 -0600

As Peter, Colin, and I discussed on-list, this version of RID proposes a 
second identifier, RRID, that is suitable for unique identification of 
Redundancy RTP Streams, should that become necessary for some 
application in the future. The only other changes are editorial. Please 
review the diffs (linked below) and comment.

Thanks!

/a

On 3/3/16 16:00, [email-masked] wrote:
> _______________________________________________
> avtext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avtext

---

From: Colin Perkins <[email-masked]>
Date: Sun, 6 Mar 2016 12:14:14 +0000

Hi Jonathan,

This is not my preferred solution, but I don’t object to it going to WG last call.

Colin

> On 4 Mar 2016, at 22:47, Jonathan Lennox <[email-masked]> wrote:
> 
> Colin - can you send a note to the list as to whether this satisfies your comments on -00?  Yours are the only outstanding comments, so if so I’ll probably go ahead and issue a WGLC.
> 
>> On Mar 3, 2016, at 5:03 PM, Adam Roach <[email-masked]> wrote:
>> 
>> As Peter, Colin, and I discussed on-list, this version of RID proposes a second identifier, RRID, that is suitable for unique identification of Redundancy RTP Streams, should that become necessary for some application in the future. The only other changes are editorial. Please review the diffs (linked below) and comment.
>> 
>> Thanks!
>> 
>> /a
>> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Adam Roach <[email-masked]>
Date: Tue, 8 Mar 2016 14:48:59 -0600

On 3/6/16 06:14, Colin Perkins wrote:
> This is not my preferred solution

Can you expand on that?

The most recent version introduces two SDES items to allow unique 
identification of redundancy streams, which is an approach you described 
as "reasonable" back on February 17th.

Basically: the last round of edits were performed exclusively to address 
your concerns. If you think they don't, I'd like to either fix them or 
pull them out. Making the mechanism more complicated while also leaving 
you unsatisfied is a lose/lose situation.

/a

---

From: Colin Perkins <[email-masked]>
Date: Tue, 8 Mar 2016 21:43:35 +0000

> On 8 Mar 2016, at 20:48, Adam Roach <[email-masked]> wrote:
> 
> The most recent version introduces two SDES items to allow unique identification of redundancy streams, which is an approach you described as "reasonable” back on February 17th.

It’s a reasonable compromise, and I don’t object to the new approach, but I also don’t see any great benefit to the change. 

> Basically: the last round of edits were performed exclusively to address your concerns. If you think they don't, I'd like to either fix them or pull them out. Making the mechanism more complicated while also leaving you unsatisfied is a lose/lose situation.

The introduction to the previous draft noted that none of the previous attempts to address this problem “have the proper ordinality to refer to an individual stream; all such identifiers can appear in more than one stream at a time”, then defined a new identifier that can appear in more than one stream at a time. That is, it looked like the draft was aiming to solve the general problem, but it actually defined something much more narrow. 

If you just want to solve the current narrowly defined problem, the approach taken in the previous draft makes more sense than the approach in the new draft (but the text suggesting it’s addressing the more general problem needs to be removed).

If you want to solve the general problem, then the new draft is a step in the right direction. It still retains some application specific semantics around redundancy, that I think will be problematic in future, though. Accordingly, I’m not sure the new draft goes far enough to be the general solution.

-- 
Colin Perkins
https://csperkins.org/