Subject: [babel] Unicast Hellos: on-the-wire encoding

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 07 Apr 2017 17:14:41 +0200

I see three reasonable options for the on-the-wire encoding of Unicast Hellos:

1. Use a new TLV type

Pros:
  - Unicast Hellos are silently ignored by existing implementations.

Cons:
  - the TLV range becomes discontiguous, and we'll need to explain that to
    our grandchildren;
  - every extension needs to specify whether a given sub-TLV is allowed
    for Hello, for Unicast Hello, or for both.

2. Use the Hello type, with a bit in the Reserved field to specify
   unicast.

Pros:
  - the TLV range remains congiguous;
  - every sub-TLV is allowed for both kinds of Hello unless specified otherwise;
  - David likes it.

Cons:
  - existing implementations get confused by Unicast Hellos, links drop on
    each M->U or U->M transition;
  - Markus doesn't like it.

3. Don't distinguish in-band, use the destination address

Pros:
  - no changes to the packet format;
  - Markus likes it.

Cons:
  - this is the only place where a Babel implementation requires the
    destination address;
  - it is impossible to send a (multicast) Hello over multi-unicast;
  - Babel might be deployed in places where the destination address is not
    available;
  - Juliusz hates it.

I'm okay with either (1) or (2), with a mild preference for (1).  If
there's no new argument, I think I'm going to go with a new TLV.

-- Juliusz

---

From: David Schinazi <[email-masked]>
Date: Fri, 07 Apr 2017 09:22:03 -0700

I think the argument between (1) and (2) is a tradeoff between
backwards compatibility and sanity of the protocol long-term.
I have a strong preference for (2), because I think it's early
enough in the lifetime of this standard that we should be able to
make the tough calls to improve things long term.

David

> On Apr 7, 2017, at 08:14, Juliusz Chroboczek <[email-masked]> wrote:
> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel