Subject: [babel] Notes on 6126bis

From: Matthieu Boutier <[email-masked]>
Date: Fri, 21 Jul 2017 13:47:59 +0200

The current 6126bis draft is sometimes using (prefix, plen)
and sometimes (prefix).  I think that this is an implementation
detail: prefixes obviously have a length.  Patch attached.

The draft has inconsistent index ordering.  Patch attached.

The draft use sometimes "route table", and sometimes "routing
table".  A choice should be made.

Missing IANA considerations.  From earlier email:

 0 --       special format (Pad1);
 1-111 --   non-mandatory, specification required;
 112-126 -- non-mandatory, local and experimental use;
 127 --     reserved for expansion of the non-mandatory space;
 128-239 -- mandatory, specification required;
 240-254 -- mandatory, local and experimental use;
 255 --     reserved for expansion of the mandatory space.

Matthieu

---

From: David Schinazi <[email-masked]>
Date: Fri, 21 Jul 2017 23:31:09 +0200

Matthieu,

- patches look good to me, thanks for writing them
- just a thought, should we mark 128 as reserved for symmetry with 0?

David

> On Jul 21, 2017, at 13:47, Matthieu Boutier <[email-masked]> wrote:
> 
> _______________________________________________
> babel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/babel

---

From: Matthieu Boutier <[email-masked]>
Date: Sat, 22 Jul 2017 08:56:20 +0200

Thanks David,

> - just a thought, should we mark 128 as reserved for symmetry with 0?

Do you mean "Mandatory Pad 1" ?  Because for symmetry, the length
would be -1 (no length field)...  and IMHO "mandatory Pad 1" sounds
really weird !

But if people prefer that please manifest since I'm going to use 128
for the Source Prefix sub-TLV.

Matthieu

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Sat, 22 Jul 2017 12:03:26 +0200

> would be -1 (no length field)...  and IMHO "mandatory Pad 1" sounds

I would tend to agree that that would just be weird...

-Toke

---

From: David Schinazi <[email-masked]>
Date: Sat, 22 Jul 2017 12:49:30 +0200

I didn't mean "Mandatory Pad1" because that makes no sense to me :)
I was just thinking of making it "Mandatory Reserved" with a length field for future
expansion but in hindsight I don't have an actual use-case, we already can use
new Mandatory sub-TLVs for future expansion.

David

> On Jul 22, 2017, at 12:03, Toke Høiland-Jørgensen <[email-masked]> wrote:
>

---

From: Matthieu Boutier <[email-masked]>
Date: Sat, 22 Jul 2017 15:20:59 +0200

> expansion

Well, in that case it's no more symmetric with 0:

  - sub-TLV 0 has no length field,
  - sub-TLV 0 is already assigned and can't be used for future extensions…

…

Oh, except if you really like 128 as a number and you wish to keep it for
one of your extensions ! ;-)

Matthieu

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 29 Jul 2017 18:19:16 +0200

> <t>The source table is used to record feasibility distances.  It is indexed
> -by triples of the form (prefix, plen, router-id), and every source table
> -entry contains the following data:
> +by pairs of the form (prefix, router-id), and every source table entry
> +contains the following data:

That's wrong, Matthieu.  The feasibility distance depends on the
router-id, so the source table is indexed by triples (prefix, plen, router-id).

-- Juliusz

---

From: Matthieu Boutier <[email-masked]>
Date: Sat, 29 Jul 2017 18:21:35 +0200

The patch does not touch to "router-id", it removes "plen", which is part
of the prefix.

Matthieu

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 29 Jul 2017 18:23:48 +0200

> The patch does not touch to "router-id", it removes "plen", which is part

Right, sorry.