Subject: Re: [babel] Hi all, about BIER in Babel extension

From: <[email-masked]>
Date: Wed, 11 Oct 2017 07:33:44 +0800 (CST)

Hi Gabriel,

Thanks for your response. 

I cloned the code from (https://github.com/jech/babeld).

But I can't push the code to Juliusz's branch because permission deny. So I just upload the whole project to my branch. 

Maybe I can push the code to Juliusz's branch later. Then the modification detail can be kept.

Thanks,

Sandy

原始邮件

发件人： <[email-masked]>;
收件人：张征00007940;
抄送人： <[email-masked]>; <[email-masked]>; <[email-masked]>;
日 期 ：2017年10月10日 19:14
主 题 ：Re: [babel] Hi all, about BIER in Babel extension

On Tue, Oct 10, 2017 at 8:40 AM,  <[email-masked]> wrote:

Hi all,

I submitted the code for BIER in Babel extension to this link: 

https://github.com/SandyZhang2015/BIER_in_Babel201710 

( I am sorry that the name is too long, next time I will use a shorter name ;-) )

This code is based on Juliusz's code. (https://github.com/jech/babeld) 

Hope that I have found the right code and submitted it right.

I'm sorry, Sandy, but this still suffers from the issues raised during your talk: you should fork https://github.com/jech/babeld and make clean commits on top of it to be reviewed, instead of a single huge "initial version" commit that also includes babeld files, and doesn't allow to see where you branched from easily.

Best,
Gabriel

---

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 11 Oct 2017 01:45:16 +0200

Hi Sandy,

> But I can't push the code to Juliusz's branch because permission deny. So I
> just upload the whole project to my branch.

That's okay.  If you put your changes over my tree, and push your tree to
your repository, anyone can combine the two trees with a simple
"git remote add ...", "git remote update".

Note that my tree has a branch called "rfc6126bis", which I'm planning to
merge into trunk as soon as 6126bis gets into last call.  Since you're
using mandatory bits, that's the branch you should be working on.

-- Juliusz

---

From: Juliusz Chroboczek <[email-masked]>
Date: Wed, 25 Oct 2017 20:47:26 +0200

Hi Sandy.

> just upload the whole project to my branch.

I will hopefully have time to look over the week-end.  Please be patient.

Gabriel, Matthieu, if you have time to have a look, please do.

> Maybe I can push the code to Juliusz's branch later.

I'll pull, it's equivalent.  This way you still get credit, and the
history is kept.

Thanks a lot, I'm looking forward to reading your code.

-- Juliusz

---

From: <[email-masked]>
Date: Thu, 26 Oct 2017 09:27:06 +0800 (CST)

Hi Juliusz,

OK. Thank you very much!

Best Regards,
Sandy
------------------原始邮件------------------
发件人： <[email-masked]>;
收件人：张征00007940;
抄送人： <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>;
日 期 ：2017年10月26日 02:47
主 题 ：Re: [babel] Hi all, about BIER in Babel extension
Hi Sandy.

-- Juliusz