Subject: [bcause] 答复: PFCP not equal to FMC, Why not choose PFCP

From: "Songjun (Network)" <[email-masked]>
Date: Mon, 1 Apr 2019 11:39:39 +0000

Hi, Richard

CMCC organized a study on the gaps of PFCP for BNG in the last year, including Nokia, Huawei, ZTE, H3C,etc.  The conclusion is in the email sent by  Qinfengwei in this maillist.

On 2019-03-28, 5:01 PM, "bcause on behalf of qinfengwei" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:
Hi Sanjay and all,
we have analysed the feasibility used PFCP in DBNG for almost half a year with 3GPP team, of course, your colleage Miao has been involved in the discussion.
PFCP is designed specifically for the wireless, there are lots of gaps between wireless and fixed-network, for example PPPoE, L2TP, Route information, detect result , Nat management and so on. Please get analysis result as the following figure, most BNG attributes need be newly defined in PFCP, and as we all know, there is not communication between different manufactures in wireless network, that means there needs a huge amount of work if PFCP is used to support BNG's function. But we have done lots of work on CUSP, and perform lab interoperation test in July 2019. For the massive deployment in 2020, we need the more professional team (such as IETF) to formulate and perfect the standard.
About 82% BNG attributes have to extend or defined.
Some examples as the following.
CP to send user's flow table to UPs.

Num

Flow Name

Description

3GPP CUSP

1

BRAS_USER_BASIC_INFO

User’s basic information

yes

2

BRAS_USER_PPP_INFO

User’s PPP information

yes

3

BRAS_USER_IFSRV_INFO

User’s access interface

No

4

BRAS_USER_IPV4_INFO

User’s IPv4 address

No

5

BRAS_USER_IPV6_INFO

User’s IPv6 address

No

6

BRAS_USER_QOS_AUTH_INFO

User’s QoS authorization

No

7

BRAS_ROUTEV4_INFO

BRAS IPv4 Routing information

No

8

BRAS_ROUTEV6_INFO

BRAS IPv6 Routing information

No

9

BRAS_STATIC_USER_INFO

Static user information

No

CP to send user's flow table to UPs.

Num

Flow Name

Description

3GPP CUSP

1

BRAS_USER_BASIC_INFO

User’s basic information

yes

2

BRAS_USER_PPP_INFO

User’s PPP information

yes

3

BRAS_USER_IFSRV_INFO

User’s access interface

No

4

BRAS_USER_IPV4_INFO

User’s IPv4 address

No

5

BRAS_USER_IPV6_INFO

User’s IPv6 address

No

6

BRAS_USER_QOS_AUTH_INFO

User’s QoS authorization

No

7

BRAS_ROUTEV4_INFO

BRAS IPv4 Routing information

No

8

BRAS_ROUTEV6_INFO

BRAS IPv6 Routing information

No

9

BRAS_STATIC_USER_INFO

Static user information

No

        IP engineer likes to use IP terms instead of 3GPP’s terms.  This also means changes in PFCP.    200+pages  PFCP standard is not easy to read for IP engineer.
          PFCP uses UDP for high throughput. But in IP network, I do not know which control protocol use UDP.   Using TCP is a simple way to keep control information reliable and in sequence.   CUSP is a lightweight control protocol.

There are many co-operations between BBF and IETF. Normally, BBF defines requirement and architecture, IETF define protocols, such as ANCP.  IETF is more professional in defining protocols.

In any way, I suggest IETF and BBF define protocols by themselves, without lost controlling.    BNG is not a new one. CUSP is just the internal interface of BNG.

Best Regards!

Jun SONG

发件人: Richard Patterson [mailto:[email-masked]]
发送时间: 2019年3月30日 8:05
收件人: Songjun (Network) <[email-masked]>
抄送: [email-masked]
主题: Re: [bcause] PFCP not equal to FMC, Why not choose PFCP

Hi Song Jun,

Thanks for your detailed email.

I think a lot of people will have queries around this particular statement of yours regarding PFCP:
•  We found that nearly all requirements of BNG were needed to extended in current protocol. That seems to rewrite a new protocol.

Could you please elaborate on this statement?   Where do you see that PFCP is deficient for fixed line BNG?
If you've got detailed analysis of this, this would be great to see publicly. From what I've heard, PFCP is easily extendable to satisfy the requirements for fixed-line BNG.

You also make the assertion:  •  IETF is the right place to define a protocol for BNG, 3GPP is the right place to extend PFCP.
There is precedent already for the BBF extending protocols such as DHCP and PPPoE with various options.   I think we need to properly understand the extent of how PFCP needs to be extended, in order to decide where best to make the extension, or if we should just build a new protocol.   I do however agree that if it's more than a small extension required, then perhaps the IETF should start from scratch, but I don't see this right now.

-Richard

---

From: "Songjun (Network)" <[email-masked]>
Date: Mon, 1 Apr 2019 11:55:00 +0000

1)        Design  -->  Open lab test  --> large scale business deployment

Very stage need hard work and time.    When can one BNG-CP by PFCP support 20M session in EANTC?  When can CUPS BNG by PFCP be deployed with more than 100K real users?   This means mature.

2)      Many and many protocols come from success practice
In IP domain, many protocols come from leading companies’ success practice and R&D, such as MPLS from Tag switch, MVPN, SR.  Then IETF works   for standardizing this work or protocol.   IETF needs running code with good performance, not paper work.

发件人: Wadhwa, Sanjay (Nokia - US/Mountain View) [mailto:[email-masked]]
发送时间: 2019年3月30日 2:38
收件人: Songjun (Network) <[email-masked]>; [email-masked]
主题: RE: PFCP not equal to FMC, Why not choose PFCP

PFCP base protocol is in real packet core networks today and runs with UPs that terminate millions of UEs. Fixed-access is relatively less taxing. BTW, these are actual deployments that exercise functionality, resiliency and performance in production, and are not just contrived test scenarios  such as “no AAA, no QOS, no accounting” to showcase performance.

Not sure what is CUSP reference here (no clarity) ? Is it a port of same internal interface that is used between CP and UP on a monolithic chassis, or is it OpenFlow which was originally presented in CUSP drafts but now gone?

Standardization decisions cannot be made on the basis of performance data from proprietary solutions with obscure interfaces and implementation. These should rather be driven from real requirements worked out between vendors and carriers in a transparent manner, which then result in scalable and interoperable solutions. However, you can use this data in your pre-sales. Mileage may vary based on customer savvy though.

-Sanjay

From: Songjun (Network) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, March 29, 2019 10:21 AM
To: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: 答复: PFCP not equal to FMC, Why not choose PFCP

1.       PFCP is mature for mobile core, not for BNG. It is about 2 years behind.

http://www.eantc.de/fileadmin/eantc/downloads/News/2018/EANTC-vBRAS-phase2.pdf

2.       Modifying PFCP is a tough way

ü  Any changes on PFCP will go to 3GPP for approve, then adding into the PFCP document(more than 200 pages now). Any changes against 3GPP principles and rules will be rejected.  (3GPP and IETF have different principles and design mechanisms)

ü  3GPP just claimed to delay 5G standards 6 month.  Extending PFCP for BNG is not a  key task in 3GPP.

ü  There is no group in 3GPP for EPC, where to discussing BNG and EPC merging and the related protocol?

ü  If 3GPP will not use PFCP in the next release or next generation?  3GPP is discussing to use micro service mechanism between SMF and UPF.

发件人: Wadhwa, Sanjay (Nokia - US/Mountain View) [mailto:[email-masked]]
发送时间: 2019年3月29日 22:45
收件人: Songjun (Network); [email-masked]<mailto:[email-masked]>
主题: RE: PFCP not equal to FMC, Why not choose PFCP

I am amused to see the relentless effort here. First, based on Wikipedia PFCP would not work, then number of pages of the spec made it prohibitive, now it is “PFCP is defined by 3GPP, so it is not suitable”.
But then you also suggest you could start with CUSP day one, throw it day two and move to PFCP. Why should we not start with the right interface day one, especially if it can provide a single solution irrespective of access.

BTW, PFCP includes both the interface to exchange state between CP and UP and the interface to pass in-band control e.g. PPPoE/DHCP signaling between UP and CP. You don’t need VxLAN shown in your picture.
The third interface is completely orthogonal and nothing to do with dynamic state between CP and UP. It is a local management interface where CP provide single point for management and control for a set of UPs. You can think of it as a way to provide CLI on the CP for entire CUPS system. It could be NETCONF or gNMI or your favorite one, as long as you have a well-defined data model.

You talk about additional functions in BNG. With PFCP, you don’t need to throw away the underlying protocol if you want to integrate another function in the BNG. PFCP (via PDRs) are flexible in specifying forwarding between different access and network facing encapsulations i.e. [access <-> network] as needed by different functions e.g. for fixed-access this may be [L2 <-> IP], for fixed-wireless [GTP-u <-> IP], for hybrid-access both [L2, GTP-u <-> IP], for (T)WAG [L2oGRE <-> IP or GTP-u]. Hope you get the idea. You also have the flexibility on the transport encapsulations in the access for fixed-network. Could be VLANs, MPLS-PW, VxLAN, L2oGRE, pick your favorite. No change to the underlying protocol.
But wait…what a tragedy that PFCP is defined by 3GPP.

-Sanjay

From: bcause <[email-masked]<mailto:[email-masked]>> On Behalf Of Songjun (Network)
Sent: Friday, March 29, 2019 6:24 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [bcause] PFCP not equal to FMC, Why not choose PFCP

1.       PFCP is not important for FMC

Mobile core is keeping evolution. PFCP must follow on it.

The CUPS interfaces are different between mobile core and BNG.

vBNG-UP and vEPC-UP will run in VM or Container independently. We can do FMC now basing on large-scale deployed protocols (PFCP and S-CUSP), and keep smooth evolution following the development of mobile network and fixed network.

We can guarantee there is PFCP in 6G and 7G. The latest information from 3GPP, they are discussing to change the mechanism between UPF and SMF.

Using PFCP is not equal to implement FMC.

2.       Why not choose PFCP
Why 3GPP not reuse Openflow?

•  PFCP use the openflow mechanism, openflow was a mature protocol then.

•  3GPP has its own requirements, using UDP for high throughput.

•  Defining mobile standard in ONF makes no sense.
Why we did not choose PFCP?

•  In 2016, we studied Openflow and PFCP, and discussed with PFCP editor (Peter from Huawei).

•  Reusing Openflow and PFCP, the CUSP will be heavily affected by ONF and 3GPP. Discussing BNG in ONF and 3GPP makes no sense.

•  We decided to define a new protocol with good points from Openflow and PFCP in IETF for BNG.

•  Mobile core can not use PFCP for interworking with different vendors now in technical reason.

•  When talking about using PFCP, let me recall the story of T-MPLS(MPLS-TP).  IETF asked ITU-T to stop using MPLS or standardize T-MPLS in IETF.  ITU-T lost the control of T-MPLS, and the standard process was delayed.

3.       DBNG story in BBF

•  I attended last two BBF meetings.  I found that they want to put everything into MS-BNG, as the following picture. According to Nokia’s IETF Draft, EPC and 5GC will also be input into it.

•  If just put all function together without any changes of outside interfaces and protocols, it is an implementation issues, not a standard issues. We can do it now because we have all related products.

•  If needing converging functions and changing protocols, someone said that the work could be finished in 5 month.  I do not believe that it can be finished based on running code instead of paperwork.

•  There are about 20 people attend ATA meeting, with more than 1/3 from Huawei and ZTE.

BTW, this picture was rejected in BBF. It is not easy to draw a clear picture including all functions, even to me.

4.       Suggest IETF  start CUPS protocols for BNG

•  CU separation is an internal mechanism, unaware to outside, without adding new functions and changing current protocols. TR-384 shows how to separate the functions into CP and UP, it is enough to start the protocols design, basing on running code and scale deployment.

•  Most BNG in current and in near future, will be used for fixed network users. Requirements on fixed BNG is clear and urgent. How to do FMC is still in discussion, with multiple ways to support it.

•  S-CUSP’s running code is 1/10 of PFCP, because of the different service requirement. CUSP for BNG is a very lightweight protocol, because fixed user does not migrate, always on line, very simple billing. BNG-UP can still forwarding, without BNG-CP. Mobile core reverses. Of cause, we can absorb the good points of Openflow and PFCP.

•  IETF is the right place to define a protocol for BNG, 3GPP is the right place to extend PFCP.

•  If using PFCP and including unclear FMC functions, we will mesh 3 SDOs together, many device functions(BNG,AC,TWAF,HAG,EPC,5GC) together. When can we meet the real IP network requirements?

5.       How to deal with FWA requirements, such as HAG?

•  HAG can be deployed independently or with BNG. CUPS HAG can be added in WT378, with its owner CUSP..

•  Venders can provide independent HAG or integrated HAG with BNG according Carrier’s requirements.

•  Optimization on integrated HAG is a kind of vendor’s implementation, not standard issues.

•  CUSP for HAG can be defined according to HAG requirements, with smooth independent evolution.

Simple and Flexible are the keys for success of IP network, when you think about Ethernet/IP against ATM.

---

From: "Wadhwa, Sanjay (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 1 Apr 2019 18:21:19 +0000

Songjun
See  response from myself and Andrew to Fengwei’s mail on the list on 3/28. I guess you missed it. It should clear the FUD below. BTW, your examples of objects passed are specific to your proprietary protocol and not to PFCP. PFCP uses standard match rules and actions which can have IE extensions or new IEs to program data-path and to send/receive in-band signaling. You don’t need new messages or containers to pass the IEs. These are used as is. I suggest you look deeper into PFCP before posting.

You said below:
>>CUSP is just the internal interface of BNG.

This is not what one wants. What you need is a standard interface that is purpose built for state exchange between a CP and multiple UPs. Just pulling out the proprietary interface on your BNG between CP and UP, and try to force it as a standard is not the best way forward.

-Sanjay

From: bcause <[email-masked]> On Behalf Of Songjun (Network)
Sent: Monday, April 1, 2019 4:40 AM
To: Richard Patterson <[email-masked]>
Cc: [email-masked]
Subject: [bcause] 答复: PFCP not equal to FMC, Why not choose PFCP

Hi, Richard

Num

Flow Name

Description

3GPP CUSP

1

BRAS_USER_BASIC_INFO

User’s basic information

yes

2

BRAS_USER_PPP_INFO

User’s PPP information

yes

3

BRAS_USER_IFSRV_INFO

User’s access interface

No

4

BRAS_USER_IPV4_INFO

User’s IPv4 address

No

5

BRAS_USER_IPV6_INFO

User’s IPv6 address

No

6

BRAS_USER_QOS_AUTH_INFO

User’s QoS authorization

No

7

BRAS_ROUTEV4_INFO

No

8

BRAS_ROUTEV6_INFO

No

9

BRAS_STATIC_USER_INFO

Static user information

No

Num

Flow Name

Description

3GPP CUSP

1

BRAS_USER_BASIC_INFO

User’s basic information

yes

2

BRAS_USER_PPP_INFO

User’s PPP information

yes

3

BRAS_USER_IFSRV_INFO

User’s access interface

No

4

BRAS_USER_IPV4_INFO

User’s IPv4 address

No

5

BRAS_USER_IPV6_INFO

User’s IPv6 address

No

6

BRAS_USER_QOS_AUTH_INFO

User’s QoS authorization

No

7

BRAS_ROUTEV4_INFO

No

8

BRAS_ROUTEV6_INFO

No

9

BRAS_STATIC_USER_INFO

Static user information

No

Best Regards!

Jun SONG

发件人: Richard Patterson [mailto:[email-masked]]
发送时间: 2019年3月30日 8:05
收件人: Songjun (Network) <[email-masked]<mailto:[email-masked]>>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [bcause] PFCP not equal to FMC, Why not choose PFCP

Hi Song Jun,

-Richard

---

From: "Wadhwa, Sanjay (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 1 Apr 2019 20:24:05 +0000

Songjun
I suggest you bring this discussion to BBF now. This list was more for BOF. But just to a final response to the marketing below…  the number of sessions is dependent on your CP implementation rather than the protocol alone. CP as a VNF is expected to load-balance processing amongst multiple VMs, along with auto scale-out as needed. This is the essence to scale number of sessions on the CP, and any reasonable implementation will provide for this.
PFCP uses UDP transport while providing support for reliable delivery of messages not just between peers but actually between PFCP processes on the peers. At the same time, it doesn’t suffer from any HOL issues on the underlying transport.

-Sanjay

From: Songjun (Network) <[email-masked]>
Sent: Monday, April 1, 2019 4:55 AM
To: Wadhwa, Sanjay (Nokia - US/Mountain View) <[email-masked]>; [email-masked]
Subject: 答复: PFCP not equal to FMC, Why not choose PFCP

发件人: Wadhwa, Sanjay (Nokia - US/Mountain View) [mailto:[email-masked]]
发送时间: 2019年3月30日 2:38
收件人: Songjun (Network) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
主题: RE: PFCP not equal to FMC, Why not choose PFCP

-Sanjay

-Sanjay

2.       Why not choose PFCP

3.       DBNG story in BBF