From bxxpwg-admin@lists.invisibleworlds.com  Thu May 17 20:12:15 2001
Received: from trystero.not.invisible.net ([204.62.247.11])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id UAA29103
	for <beep-archive@odin.ietf.org>; Thu, 17 May 2001 20:12:14 -0400 (EDT)
Received: from trystero.not.invisible.net (localhost [127.0.0.1])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id RAA15627;
	Thu, 17 May 2001 17:10:58 -0700 (PDT)
Received: from breakaway.Stanford.EDU (breakaway.Stanford.EDU [171.64.20.202])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id PAA14902
	for <bxxpwg@lists.invisibleworlds.com>; Thu, 17 May 2001 15:08:27 -0700 (PDT)
Received: from localhost (hodges@localhost)
	by breakaway.Stanford.EDU (8.9.3/8.9.3) with ESMTP id PAA25932
	for <bxxpwg@lists.invisibleworlds.com>; Thu, 17 May 2001 15:08:27 -0700 (PDT)
Message-Id: <200105172208.PAA25932@breakaway.Stanford.EDU>
X-Mailer: exmh version 2.0.2 2/24/98
To: bxxpwg@lists.invisibleworlds.com
From: Jeff.Hodges@kingsmountain.com
Reply-to: bxxpwg@lists.invisibleworlds.com
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Date: Thu, 17 May 2001 15:08:12 -0700
Subject: [BXXPwg] terminology wrt "protocol binding" and "BEEP channel profiles"?
Sender: bxxpwg-admin@lists.invisibleworlds.com
Errors-To: bxxpwg-admin@lists.invisibleworlds.com
X-Mailman-Version: 1.1
Precedence: bulk
List-Id: Mailing list for the IETF's BEEP Working Group <bxxpwg.lists.invisible.net>
X-BeenThere: bxxpwg@lists.invisible.net

The question, then some background, and then a proposal..

My question is: 

  "how does one, from 'outside' the BEEP context, talk about specifying 
   the 'binding' of some protocol onto BEEP?"


Background:

The term "protocol binding" is sometimes used to refer to the specification of 
the layering of one protocol onto, or "over", another.

The term "profile" is used (outside of the BEEP context) in the sense of 
making use of a specification (e.g. X.509) in the context of some other spec 
(e.g. PKIX is a "profile" of X.509; c.f. RFC2459).

The BEEP protocol spec (RFC3080) uses the unadorned term "profile" to name a 
collection of definitions of syntax and semantics that specify a particular 
channel behavior.


Proposal:

A proposal is to say something like (where "FOOP" is a short for "FOO 
protocol" (which is imaginary))..

  "In order to specify a protocol binding for FOOP over BEEP, one must write 
   and register a 'BEEP channel profile for FOOP'."

Other ways to say it..

  "FOOP's BEEP channel profile"

  "The FOOP BEEP channel profile"

  "The FOOP-over-BEEP protocol binding is specified via the 
   FOOP BEEP channel profile."

  "The FOOP-over-BEEP protocol binding is specified via the BEEP 
   channel profile for FOOP."

A sub-proposal, implicit in the above, is that when speaking/writing from a 
perspective "outside" of (or "external to") BEEP, one should use "BEEP channel 
profile" to refer unambiguously to what's called simply a "profile" in the 
BEEP context (i.e. RFC3080).


So, does the above make sense?


For completeness, I'll note that the term used to describe the so-called 
"binding" of BEEP itself onto TCP (RFC3081) is "mapping". Nominally, it seems 
to me the above still holds and makes sense even if the word "binding" 
everywhere above were replaced with "mapping".

thanks,

JeffH





_______________________________________________
BXXPwg mailing list
BXXPwg@lists.invisible.net
http://lists.invisible.net/mailman/listinfo/bxxpwg


From bxxpwg-admin@lists.invisibleworlds.com  Fri May 18 14:02:26 2001
Received: from trystero.not.invisible.net ([204.62.247.11])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id OAA09856
	for <beep-archive@odin.ietf.org>; Fri, 18 May 2001 14:02:25 -0400 (EDT)
Received: from trystero.not.invisible.net (localhost [127.0.0.1])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id LAA28338;
	Fri, 18 May 2001 11:01:21 -0700 (PDT)
Received: from dbc.mtview.ca.us (ppp-63-207-83-130.ded.pacbell.net [63.207.83.130])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id LAA28320
	for <bxxpwg@lists.invisibleworlds.com>; Fri, 18 May 2001 11:01:21 -0700 (PDT)
Received: from FATORA (ppp-63-207-83-135.ded.pacbell.net [63.207.83.135])
	by dbc.mtview.ca.us (8.11.0+3.3W/8.11.0) with SMTP id f4IHaTp14462;
	Fri, 18 May 2001 10:36:29 -0700 (PDT)
Message-ID: <10e601c0dfc4$7d5aa350$8753cf3f@FATORA>
From: "Marshall T. Rose" <mrose+mtr.netnews@dbc.mtview.ca.us>
To: <bxxpwg@lists.invisibleworlds.com>
Cc: "Marshall Rose" <mrose@dbc.mtview.ca.us>
References: <200105172208.PAA25932@breakaway.Stanford.EDU>
Subject: Re: [BXXPwg] terminology wrt "protocol binding" and "BEEP channel profiles"?
Date: Fri, 18 May 2001 11:00:56 -0700
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 5.50.4133.2400
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400
Sender: bxxpwg-admin@lists.invisibleworlds.com
Errors-To: bxxpwg-admin@lists.invisibleworlds.com
X-Mailman-Version: 1.1
Precedence: bulk
List-Id: Mailing list for the IETF's BEEP Working Group <bxxpwg.lists.invisible.net>
X-BeenThere: bxxpwg@lists.invisible.net
Content-Transfer-Encoding: 7bit

hi. am i correct in summarizing your proposal to be:

    when talking outside the context of the BEEP specifications, use the
term
    "BEEP channel profile" when referring to what is called a "profile"
inside
    the BEEP specifications

if so, sounds like a fine idea to me.

/mtr



_______________________________________________
BXXPwg mailing list
BXXPwg@lists.invisible.net
http://lists.invisible.net/mailman/listinfo/bxxpwg


From bxxpwg-admin@lists.invisibleworlds.com  Fri May 18 14:30:41 2001
Received: from trystero.not.invisible.net ([204.62.247.11])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id OAA10984
	for <beep-archive@odin.ietf.org>; Fri, 18 May 2001 14:30:40 -0400 (EDT)
Received: from trystero.not.invisible.net (localhost [127.0.0.1])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id LAA28625;
	Fri, 18 May 2001 11:29:43 -0700 (PDT)
Received: from breakaway.Stanford.EDU (breakaway.Stanford.EDU [171.64.20.202])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id LAA28609
	for <bxxpwg@lists.invisibleworlds.com>; Fri, 18 May 2001 11:29:43 -0700 (PDT)
Received: from localhost (hodges@localhost)
	by breakaway.Stanford.EDU (8.9.3/8.9.3) with ESMTP id LAA03723;
	Fri, 18 May 2001 11:29:42 -0700 (PDT)
Message-Id: <200105181829.LAA03723@breakaway.Stanford.EDU>
X-Mailer: exmh version 2.0.2 2/24/98
Subject: Re: [BXXPwg] terminology wrt "protocol binding" and "BEEP channel 
 profiles"?
To: "Marshall Rose" <mrose@dbc.mtview.ca.us>, bxxpwg@lists.invisibleworlds.com
In-reply-to: "Marshall T. Rose" <mrose+mtr.netnews@dbc.mtview.ca.us> 's 
 message of
	Fri, 18 May 2001 11:00:56 -0700
Reply-to: bxxpwg@lists.invisibleworlds.com
From: Jeff.Hodges@kingsmountain.com
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Date: Fri, 18 May 2001 11:29:42 -0700
Sender: bxxpwg-admin@lists.invisibleworlds.com
Errors-To: bxxpwg-admin@lists.invisibleworlds.com
X-Mailman-Version: 1.1
Precedence: bulk
List-Id: Mailing list for the IETF's BEEP Working Group <bxxpwg.lists.invisible.net>
X-BeenThere: bxxpwg@lists.invisible.net

thanks for the note Marshall.

> hi. am i correct in summarizing your proposal to be:
> 
>  when talking outside the context of the BEEP specifications, use the
>  term "BEEP channel profile" when referring to what is called a "profile"
>  inside the BEEP specifications
> 
> if so, sounds like a fine idea to me.

That's part of the proposal. The other part involves how one more generally 
talks about the "binding" or "mapping" of another protocol onto BEEP, from 
outside the context of BEEP.

E.g. Such a binding can conceptually look like this (from outside the context 
of BEEP)..

           +----------------------------+
           | (some protocol, e.g. FOOP) |
           +----------------------------+ <-- the "protocol binding" for
           |  BEEP                      |     FOOP-over-BEEP
           +----------------------------+
           |  TCP                       |
           +----------------------------+
           |  IP                        |
           +----------------------------+

So it seems to me that an unambiguous way to talk about this is thus..

  "In order to specify a protocol binding for FOOP-over-BEEP, one must write 
   and register a 'BEEP channel profile for FOOP'."

My question is whether you will find statements, such as the one immediately 
above, to be clear and unambiguous when you're evaluating them in a context 
external to BEEP (e.g. in the context of, say, designing "FOOP").

thanks

JeffH



_______________________________________________
BXXPwg mailing list
BXXPwg@lists.invisible.net
http://lists.invisible.net/mailman/listinfo/bxxpwg


From bxxpwg-admin@lists.invisibleworlds.com  Fri May 18 18:40:18 2001
Received: from trystero.not.invisible.net ([204.62.247.11])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id SAA18165
	for <beep-archive@odin.ietf.org>; Fri, 18 May 2001 18:40:17 -0400 (EDT)
Received: from trystero.not.invisible.net (localhost [127.0.0.1])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id PAA00265;
	Fri, 18 May 2001 15:39:24 -0700 (PDT)
Received: from dbc.mtview.ca.us (ppp-63-207-83-130.ded.pacbell.net [63.207.83.130])
	by trystero.not.invisible.net (8.9.3+Sun/8.9.3) with ESMTP id PAA00235
	for <bxxpwg@lists.invisibleworlds.com>; Fri, 18 May 2001 15:39:23 -0700 (PDT)
Received: from FATORA (ppp-63-207-83-135.ded.pacbell.net [63.207.83.135])
	by dbc.mtview.ca.us (8.11.0+3.3W/8.11.0) with SMTP id f4IMEUp15223;
	Fri, 18 May 2001 15:14:31 -0700 (PDT)
Message-ID: <133f01c0dfeb$54abd5b0$8753cf3f@FATORA>
From: "Marshall T. Rose" <mrose+mtr.netnews@dbc.mtview.ca.us>
To: <bxxpwg@lists.invisibleworlds.com>
Cc: "Marshall Rose" <mrose@dbc.mtview.ca.us>
References: <200105181829.LAA03723@breakaway.Stanford.EDU>
Subject: Re: [BXXPwg] terminology wrt "protocol binding" and "BEEP channel  profiles"?
Date: Fri, 18 May 2001 15:38:59 -0700
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 5.50.4133.2400
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400
Sender: bxxpwg-admin@lists.invisibleworlds.com
Errors-To: bxxpwg-admin@lists.invisibleworlds.com
X-Mailman-Version: 1.1
Precedence: bulk
List-Id: Mailing list for the IETF's BEEP Working Group <bxxpwg.lists.invisible.net>
X-BeenThere: bxxpwg@lists.invisible.net
Content-Transfer-Encoding: 7bit

>  when talking outside the context of the BEEP specifications, use the
>  term "BEEP channel profile" when referring to what is called a "profile"
>  inside the BEEP specifications

>   In order to specify a protocol binding for FOOP-over-BEEP, one must
write
>   and register a 'BEEP channel profile for FOOP'

yes, fine with me!

/mtr



_______________________________________________
BXXPwg mailing list
BXXPwg@lists.invisible.net
http://lists.invisible.net/mailman/listinfo/bxxpwg


