
From nobody Tue Nov  6 00:53:48 2018
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7E496130F5F for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 00:53:42 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id S722CgTCyXmb for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 00:53:40 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 44685130E72 for <behave@ietf.org>; Tue,  6 Nov 2018 00:53:37 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id 07C1BB80008; Tue,  6 Nov 2018 00:53:23 -0800 (PST)
To: congxiao@cernet.edu.cn, huitema@microsoft.com, marcelo@it.uc3m.es, mohamed.boucadair@orange-ftgroup.com, xing@cernet.edu.cn, spencerdawkins.ietf@gmail.com, ietf@kuehlewind.net, dwing@cisco.com, dthaler@microsoft.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: FredBaker.IETF@gmail.com, behave@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20181106085323.07C1BB80008@rfc-editor.org>
Date: Tue,  6 Nov 2018 00:53:23 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/neViYve8FjxIhbqkKutSa4Q_nQs>
Subject: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Nov 2018 08:53:47 -0000

The following errata report has been submitted for RFC6052,
"IPv6 Addressing of IPv4/IPv6 Translators".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5547

--------------------------------------
Type: Technical
Reported by: Fred Baker <FredBaker.IETF@gmail.com>

Section: 3.1

Original Text
-------------
   The Well-Known Prefix MUST NOT be used to represent non-global IPv4
   addresses, such as those defined in [RFC1918] or listed in Section 3
   of [RFC5735].  Address translators MUST NOT translate packets in
   which an address is composed of the Well-Known Prefix and a non-
   global IPv4 address; they MUST drop these packets.

Corrected Text
--------------
The paragraph should be removed.

Notes
-----
IPv4 packets with private addresses are routinely translated to IPv4 packets with global addresses in NAT44. If a 464XLAT CLAT (stateless NAT64) cannot translate a private address to an IPv6 /96 prefix with that address as an IID (or whatever it's called), then the packet may not be translated to an IPv4 packet with a global address by the 464XLAT PLAT (stateful NAT64). This changes the intent of the sender, and in so doing violates the end to end principle. Practically speaking, it means that a network that uses 464XLAT or MAP-T with IPv4 in the subscriber and translating to IPv4 via NAT64 into the IPv4 Internet, it forces the network or the subscriber to purchase global address space. That's just silly. Let the user use private address space in the home or whatever.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6052 (draft-ietf-behave-address-format-10)
--------------------------------------
Title               : IPv6 Addressing of IPv4/IPv6 Translators
Publication Date    : October 2010
Author(s)           : C. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. Li
Category            : PROPOSED STANDARD
Source              : Behavior Engineering for Hindrance Avoidance
Area                : Transport
Stream              : IETF
Verifying Party     : IESG


From nobody Tue Nov  6 01:24:12 2018
Return-Path: <fredbaker.ietf@gmail.com>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id CE5B6130DC5 for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 01:24:08 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id QHLwZHYjBZgv for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 01:24:01 -0800 (PST)
Received: from mail-pg1-x52c.google.com (mail-pg1-x52c.google.com [IPv6:2607:f8b0:4864:20::52c]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id AB526130DDF for <behave@ietf.org>; Tue,  6 Nov 2018 01:24:01 -0800 (PST)
Received: by mail-pg1-x52c.google.com with SMTP id k1-v6so5563842pgq.1 for <behave@ietf.org>; Tue, 06 Nov 2018 01:24:01 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=from:message-id:mime-version:subject:date:in-reply-to:cc:to :references; bh=gD6iX6OqwlmxS+oMBXecChIp87TdPV29Kroeu4VVJyg=; b=EIasjMqjOcTgoAAUiklPdRktOF5YFcHxVQfSZ6h75A0hIxqCZJ56hJXqYvjHauWRjO 1IP5QhRADOMiJZcagBAGJj7Y87UErmtcquD6/Srey670IjIlTplmVahZRVJCK+9aUxuq ISOo0jM2eEB5SvnX9Uz+6Z8y6aF3RxrAHyle2QayiFGP2IQYxFub5L7LZHh0fn+a5Vdk BVwX3LAtU0VSgbJB96EVxa+lCvnbEwtnk2NqYcg+FXdzDwHb1BQpUPXhGOrrSynEV5Nf kKBUah0DSbU8xvSxppb1ayx3faG/H7urqSHr9g2Ymvu/tcIcUtjQrdPSjEKNCnUUHF8k GxKg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:from:message-id:mime-version:subject:date :in-reply-to:cc:to:references; bh=gD6iX6OqwlmxS+oMBXecChIp87TdPV29Kroeu4VVJyg=; b=h2baN+oO/0cvGiNwYMeDC4tR1/O1YOfox/6n7CS6uYrj5ywZnryqwqepZj7ZzTTtXx C3lLJvyOjlOLGg547ZNntpzTpYYGycGTDDHdhbOu+gEd4EGzRd5i9FIZ7jbivy95h1f9 wiic67i1mmUkqO3cTT93MWdxWqVRNEYGS7b1izJbbcEG2ve3RPSyHCWkMb9TTiye84bR dt5/GS+kF4PjMA+Nz0tfjmsQW2+Qu/HlixqztpqWcZYnKLL+8ZCwE7jlqExXYSKM6hIR SPbgks1FwSxCWu6mOwt1TRvaXen+1hVhwpENlE+kPRWnJp+bCz7lnOQWb/uwiKLwQOlf /CWw==
X-Gm-Message-State: AGRZ1gJDLrYNzdi7FRe8MBTzfMQhj+77QoTI6OkzIgXLtJpUvz8dTYCI gxFeyoWFuFuQ64pEbjIpBK4=
X-Google-Smtp-Source: AJdET5cCtjdncCWxVVGqV8E41RIf/q3GVXfP0IBwPn+njviOK6/vuPOylvRT11und4ZHzSsj17gruw==
X-Received: by 2002:a62:8a0d:: with SMTP id y13-v6mr25595551pfd.142.1541496241219;  Tue, 06 Nov 2018 01:24:01 -0800 (PST)
Received: from ?IPv6:2001:67c:370:1998:341e:679a:13c5:eab0? ([2001:67c:370:1998:341e:679a:13c5:eab0]) by smtp.gmail.com with ESMTPSA id q1sm28515503pgs.14.2018.11.06.01.23.57 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Tue, 06 Nov 2018 01:24:00 -0800 (PST)
From: Fred Baker <fredbaker.ietf@gmail.com>
Message-Id: <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com>
Content-Type: multipart/signed; boundary="Apple-Mail=_322C1F98-6A64-4837-BDCA-5E08BB34614B"; protocol="application/pgp-signature"; micalg=pgp-sha512
Mime-Version: 1.0 (Mac OS X Mail 11.5 \(3445.9.1\))
Date: Tue, 6 Nov 2018 16:23:55 +0700
In-Reply-To: <20181106085323.07C1BB80008@rfc-editor.org>
Cc: Congxiao Bao <congxiao@cernet.edu.cn>, huitema@microsoft.com, MARCELO BAGNULO BRAUN <marcelo@it.uc3m.es>, mohamed.boucadair@orange-ftgroup.com, Xing Li <xing@cernet.edu.cn>, spencerdawkins.ietf@gmail.com, ietf@kuehlewind.net, dwing@cisco.com, Dave Thaler <dthaler@microsoft.com>, behave@ietf.org
To: RFC Errata System <rfc-editor@rfc-editor.org>
References: <20181106085323.07C1BB80008@rfc-editor.org>
X-Mailer: Apple Mail (2.3445.9.1)
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/_f7VqcXSgyQHo7UtNbybqMgMq2w>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Nov 2018 09:24:09 -0000

--Apple-Mail=_322C1F98-6A64-4837-BDCA-5E08BB34614B
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=us-ascii

On second thought, the exact case is incorrect. I still think it's a =
silly restriction, but the private address in the case would not be =
placed into the Well-Known Prefix (and used as a destination address); =
it would be put into a /64 out of the subscriber's prefix (and used as a =
source address). So I can live without this change.

> On Nov 6, 2018, at 3:53 PM, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>=20
> The following errata report has been submitted for RFC6052,
> "IPv6 Addressing of IPv4/IPv6 Translators".
>=20
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5547
>=20
> --------------------------------------
> Type: Technical
> Reported by: Fred Baker <FredBaker.IETF@gmail.com>
>=20
> Section: 3.1
>=20
> Original Text
> -------------
>   The Well-Known Prefix MUST NOT be used to represent non-global IPv4
>   addresses, such as those defined in [RFC1918] or listed in Section 3
>   of [RFC5735].  Address translators MUST NOT translate packets in
>   which an address is composed of the Well-Known Prefix and a non-
>   global IPv4 address; they MUST drop these packets.
>=20
> Corrected Text
> --------------
> The paragraph should be removed.
>=20
> Notes
> -----
> IPv4 packets with private addresses are routinely translated to IPv4 =
packets with global addresses in NAT44. If a 464XLAT CLAT (stateless =
NAT64) cannot translate a private address to an IPv6 /96 prefix with =
that address as an IID (or whatever it's called), then the packet may =
not be translated to an IPv4 packet with a global address by the 464XLAT =
PLAT (stateful NAT64). This changes the intent of the sender, and in so =
doing violates the end to end principle. Practically speaking, it means =
that a network that uses 464XLAT or MAP-T with IPv4 in the subscriber =
and translating to IPv4 via NAT64 into the IPv4 Internet, it forces the =
network or the subscriber to purchase global address space. That's just =
silly. Let the user use private address space in the home or whatever.
>=20
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
>=20
> --------------------------------------
> RFC6052 (draft-ietf-behave-address-format-10)
> --------------------------------------
> Title               : IPv6 Addressing of IPv4/IPv6 Translators
> Publication Date    : October 2010
> Author(s)           : C. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. =
Li
> Category            : PROPOSED STANDARD
> Source              : Behavior Engineering for Hindrance Avoidance
> Area                : Transport
> Stream              : IETF
> Verifying Party     : IESG

=
--------------------------------------------------------------------------=
------
The fact that there is a highway to hell and a stairway to heaven is an =
interesting comment on projected traffic volume...


--Apple-Mail=_322C1F98-6A64-4837-BDCA-5E08BB34614B
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
	filename=signature.asc
Content-Type: application/pgp-signature;
	name=signature.asc
Content-Description: Message signed with OpenPGP

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEctjlJjQmVrp9uMq7EhdRnd2GP+AFAlvhXasACgkQEhdRnd2G
P+A32xAAx80Y6yTmUqUd4CMuOQkKfngEa46VmXVKwWahNXOTvVGJpFpvJhltHhWH
AjN7CPtzHe5BlNQpRPVWSn6XTt/81W3lA7A27YXA0V+DINKvExJjuAqA1iEgWSwM
muHU18Y4Frgy1ZgAxYl6sT2JZYqgdkQiOn1du3B8eQ1M9x66yDQ13lw3u3eV66Tg
/YpZED5kizfPyFBeeyha5hIkRRAtv2s1BWjZAOuQVeaOB2g7MAat/9uk8gH4BEk+
v2vsoiqn47ISGLKN3ZAzilsS7R7dleJMlz0E93LTqr3Al01U1uk5vj8UeLkvZEP5
kHpAdeXiC0Gvv+gYqroRe1cAVE9OMPdnDYZ6/EXd0tLKbUq/38FIvhBu1Urtxyq6
vIX+7ILSRzWQ2eP2/cdjGwPxN0o6K/g+QgekVT2ZGP3HEbBBceEp1Ug4+liSaDDP
Y7kC/Xx9IuLtdtWmmbwLPwKp3ZePFlGNi9Yqfp4GhNnfkIC8I4qM66pqxwcW6kWQ
nqUws06nJ8tLayVdJ5P0Vo4ypabTqzeDZ03izj6fvh00FBUuP/E5CebEY5PlvEal
dfhA+66dYnvqJHTUQZ2xQ9rB4BQR80Sv4HkIe6iIct2cTTKXIbAJBbZy/34ovIHu
3VkpT9DcAQFUAl7zNEp++xF7d+aWpmX0nZT821ovjWnDiK9by3M=
=9PGk
-----END PGP SIGNATURE-----

--Apple-Mail=_322C1F98-6A64-4837-BDCA-5E08BB34614B--


From nobody Tue Nov  6 02:18:15 2018
Return-Path: <huitema@huitema.net>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 28017130ED1 for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 02:18:09 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.601
X-Spam-Level: 
X-Spam-Status: No, score=-2.601 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id SkWe-5dfYFgm for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 02:18:06 -0800 (PST)
Received: from mx43-out1.antispamcloud.com (mx43-out1.antispamcloud.com [138.201.61.189]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 67586130F01 for <behave@ietf.org>; Tue,  6 Nov 2018 02:18:06 -0800 (PST)
Received: from xsmtp04.mail2web.com ([168.144.250.231]) by mx61.antispamcloud.com with esmtps (TLSv1:AES256-SHA:256) (Exim 4.89) (envelope-from <huitema@huitema.net>) id 1gJyQt-0003Db-Eu for behave@ietf.org; Tue, 06 Nov 2018 11:18:04 +0100
Received: from [10.5.2.14] (helo=xmail04.myhosting.com) by xsmtp04.mail2web.com with esmtps (TLS-1.0:DHE_RSA_AES_256_CBC_SHA1:32) (Exim 4.63) (envelope-from <huitema@huitema.net>) id 1gJyQq-0002lB-Oq for behave@ietf.org; Tue, 06 Nov 2018 05:18:01 -0500
Received: (qmail 11525 invoked from network); 6 Nov 2018 10:17:59 -0000
Received: from unknown (HELO [31.133.128.127]) (Authenticated-user:_huitema@huitema.net@[31.133.128.127]) (envelope-sender <huitema@huitema.net>) by xmail04.myhosting.com (qmail-ldap-1.03) with ESMTPA for <behave@ietf.org>; 6 Nov 2018 10:17:58 -0000
To: Fred Baker <fredbaker.ietf@gmail.com>, RFC Errata System <rfc-editor@rfc-editor.org>
Cc: Congxiao Bao <congxiao@cernet.edu.cn>, mohamed.boucadair@orange-ftgroup.com, ietf@kuehlewind.net, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, spencerdawkins.ietf@gmail.com, dwing@cisco.com, huitema@microsoft.com, behave@ietf.org
References: <20181106085323.07C1BB80008@rfc-editor.org> <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com>
From: Christian Huitema <huitema@huitema.net>
Openpgp: preference=signencrypt
Autocrypt: addr=huitema@huitema.net; prefer-encrypt=mutual; keydata= xsBNBFIRX8gBCAC26usy/Ya38IqaLBSu33vKD6hP5Yw390XsWLaAZTeQR64OJEkoOdXpvcOS HWfMIlD5s5+oHfLe8jjmErFAXYJ8yytPj1fD2OdSKAe1TccUBiOXT8wdVxSr5d0alExVv/LO I/vA2aU1TwOkVHKSapD7j8/HZBrqIWRrXUSj2f5n9tY2nJzG9KRzSG0giaJWBfUFiGb4lvsy IaCaIU0YpfkDDk6PtK5YYzuCeF0B+O7N9LhDu/foUUc4MNq4K3EKDPb2FL1Hrv0XHpkXeMRZ olpH8SUFUJbmi+zYRuUgcXgMZRmZFL1tu6z9h6gY4/KPyF9aYot6zG28Qk/BFQRtj7V1ABEB AAHNJ0NocmlzdGlhbiBIdWl0ZW1hIDxodWl0ZW1hQGh1aXRlbWEubmV0PsLAeQQTAQIAIwUC UhFfyAIbLwcLCQgHAwIBBhUIAgkKCwQWAgMBAh4BAheAAAoJEJNDCbJVyA1yhbYH/1ud6x6m VqGIp0JcZUfSQO8w+TjugqxCyGNn+w/6Qb5O/xENxNQ4HaMQ5uSRK9n8WKKDDRSzwZ4syKKf wbkfj05vgFxrjCynVbm1zs2X2aGXh+PxPL/WHUaxzEP7KjYbLtCUZDRzOOrm+0LMktngT/k3 6+EZoLEM52hwwpIAzJoscyEz7QfqMOZtFm6xQnlvDQeIrHx0KUvwo/vgDLK3SuruG1CSHcR0 D24kEEUa044AIUKBS3b0b8AR7f6mP2NcnLpdsibtpabi9BzqAidcY/EjTaoea46HXALk/eJd 6OLkLE6UQe1PPzQC4jB7rErX2BxnSkHDw50xMgLRcl5/b1bOwE0EUhFfyAEIAKp7Cp8lqKTV CC9QiAf6QTIjW+lie5J44Ad++0k8gRgANZVWubQuCQ71gxDWLtxYfFkEXjG4TXV/MUtnOliG 5rc2E+ih6Dg61Y5PQakm9OwPIsOx+2R+iSW325ngln2UQrVPgloO83QiUoi7mBJPbcHlxkhZ bd3+EjFxSLIQogt29sTcg2oSh4oljUpz5niTt69IOfZx21kf29NfDE+Iw56gfrxI2ywZbu5o G+d0ZSp0lsovygpk4jK04fDTq0vxjEU5HjPcsXC4CSZdq5E2DrF4nOh1UHkHzeaXdYR2Bn1Y wTePfaHBFlvQzI+Li/Q6AD/uxbTM0vIcsUxrv3MNHCUAEQEAAcLBfgQYAQIACQUCUhFfyAIb LgEpCRCTQwmyVcgNcsBdIAQZAQIABgUCUhFfyAAKCRC22tOSFDh1UOlBB/94RsCJepNvmi/c YiNmMnm0mKb6vjv43OsHkqrrCqJSfo95KHyl5Up4JEp8tiJMyYT2mp4IsirZHxz/5lqkw9Az tcGAF3GlFsj++xTyD07DXlNeddwTKlqPRi/b8sppjtWur6Pm+wnAHp0mQ7GidhxHccFCl65w uT7S/ocb1MjrTgnAMiz+x87d48n1UJ7yIdI41Wpg2XFZiA9xPBiDuuoPwFj14/nK0elV5Dvq 4/HVgfurb4+fd74PV/CC/dmd7hg0ZRlgnB5rFUcFO7ywb7/TvICIIaLWcI42OJDSZjZ/MAzz BeXm263lHh+kFxkh2LxEHnQGHCHGpTYyi4Z3dv03HtkH/1SI8joQMQq00Bv+RdEbJXfEExrT u4gtdZAihwvy97OPA2nCdTAHm/phkzryMeOaOztI4PS8u2Ce5lUB6P/HcGtK/038KdX5MYST Fn8KUDt4o29bkv0CUXwDzS3oTzPNtGdryBkRMc9b+yn9+AdwFEH4auhiTQXPMnl0+G3nhKr7 jvzVFJCRif3OAhEm4vmBNDE3uuaXFQnbK56GJrnqVN+KX5Z3M7X3fA8UcVCGOEHXRP/aubiw Ngawj0V9x+43kUapFp+nF69R53UI65YtJ95ec4PTO/Edvap8h1UbdEOc4+TiYwY1TBuIKltY 1cnrjgAWUh/Ucvr++/KbD9tD6C8=
Message-ID: <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net>
Date: Tue, 6 Nov 2018 17:17:43 +0700
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1
MIME-Version: 1.0
In-Reply-To: <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com>
Content-Type: multipart/signed; micalg=pgp-sha256; protocol="application/pgp-signature"; boundary="tsSrBb8Ybkw2i8Pt8hadaHPv9bwl27rjs"
X-Originating-IP: 168.144.250.231
X-Spampanel-Domain: xsmtpout.mail2web.com
X-Spampanel-Username: 168.144.250.0/24
Authentication-Results: antispamcloud.com; auth=pass smtp.auth=168.144.250.0/24@xsmtpout.mail2web.com
X-Spampanel-Outgoing-Class: ham
X-Spampanel-Outgoing-Evidence: Combined (0.07)
X-Recommended-Action: accept
X-Filter-ID: EX5BVjFpneJeBchSMxfU5nEuElVuirf4NqrBg0hyj7l602E9L7XzfQH6nu9C/Fh9KJzpNe6xgvOx q3u0UDjvO0VmU7heoGtPbmnM2lug8e3TV/3OdXD2Xdo8CfrY5CQSQYWmdr56PgMSrkRLxuB9p4yz NJVaeAWax4WOe4pTBX2DwIE7VKe+bqpcdCns72R1SgXX4L/wx+t3tnVWiIE8IaXe0Of4jddu9xC8 8+iQ5nb7LoaTAX7mj3bIh4FDz/DsVXAzQwmd1hagmDqzAXJWUgl+86MkQJ6nrl0gGH3bP6cMPaBP aKeQW+/QlaOdv8isl/qMm08Zpim2AHUKEWvQ6G/bWfgucjnNmABpGhD9TTttrFCuZ0NkwnSz2Luu o1u9uevuNfM1HjkNEFwape+IgNezYqxGMqsKjARq8PBC4qjMauXIUif1JzGdiG0o4ggCmdySlZou 9qHIGOZDEEo7Oyc1nq0gsY582CWqKjiRB3ukywmZtiDkyd4mEBjJGGEJE2d52fY0d/1mkgffWkdO 4QEiRQv+PVjjwa+Z5RFCOMRfGK/Ioq0dRA5A4PDP/VsLPwUimsNGvJJilSn4u6QSZF6atNRbXR2b izE1PIZK15Es95DGoDQyh90npG6wuAU16Y3oZJdQ0WXQEIKhyt8GALxCCXdUXmVhCtBec/fcEYvj esdofIZr77ejLGfC2JB7N1zg8T9ahw4hquQDupK1jk8cW9l7L/bUyy3TdA61l2eQQ5sx8WjknhQY ioEvO6DkMOaPSsF5HkEZ1BohyGP+2tIivy+nwsaRXVdompsKqyK6MiFNXPsSc8iR2XN+gTM3647l NwN4qOsSZg+fYhVZGz9r7Mz0gFF1wxz5bb0bhP2vPRlp44C0jVYGRiPSt4ToCZPO2GKNZaMtjfyA obtcMvAFMvX7q8M4x6bP/gjzw0OjTdGcfvx5IojyUdakbY3OIKvEx19waJj/yR/yCVBWvmU/ts+C IC6rClmkQnuoxlv2OKHH5lr9xXvSM4nM3avg
X-Report-Abuse-To: spam@quarantine9.antispamcloud.com
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/ntdPoewA0xChvc8_PYm1kod17to>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Nov 2018 10:18:14 -0000

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--tsSrBb8Ybkw2i8Pt8hadaHPv9bwl27rjs
Content-Type: multipart/mixed; boundary="5GzvHreZWQH2zsG9m42cW0KxkJBhcbAIr";
 protected-headers="v1"
From: Christian Huitema <huitema@huitema.net>
To: Fred Baker <fredbaker.ietf@gmail.com>,
 RFC Errata System <rfc-editor@rfc-editor.org>
Cc: Congxiao Bao <congxiao@cernet.edu.cn>,
 mohamed.boucadair@orange-ftgroup.com, ietf@kuehlewind.net,
 Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>,
 spencerdawkins.ietf@gmail.com, dwing@cisco.com, huitema@microsoft.com,
 behave@ietf.org
Message-ID: <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
References: <20181106085323.07C1BB80008@rfc-editor.org>
 <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com>
In-Reply-To: <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com>

--5GzvHreZWQH2zsG9m42cW0KxkJBhcbAIr
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable
Content-Language: en-US



On 11/6/2018 4:23 PM, Fred Baker wrote:
> On second thought, the exact case is incorrect. I still think it's a si=
lly restriction, but the private address in the case would not be placed =
into the Well-Known Prefix (and used as a destination address); it would =
be put into a /64 out of the subscriber's prefix (and used as a source ad=
dress). So I can live without this change.

Good.

I think that the text should not be changed by an errata. The text is a
fair rendering of our technical assessment at the time. We did not want
to use the WKP to build ambiguous IPv6 addresses, and wanted to make
sure that private IPv4 addresses will be mapped using private prefixes.
It may or may not have been the right decision, but this is definitely
what we intended.

-- Christian Huitema


--5GzvHreZWQH2zsG9m42cW0KxkJBhcbAIr--

--tsSrBb8Ybkw2i8Pt8hadaHPv9bwl27rjs
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQEcBAEBCAAGBQJb4WpQAAoJELba05IUOHVQSPwH/2XXqs+y4+Z3qSjuOmEsKRan
jv9cIzyVmAJZezR50LF/o8uhNTL4y9yxoOvwwXaHezC+58/u6pVVDbfNy7Jfw0vV
ixaSyWP5AluAVEjptIo72vD2ke7d2mYbYZDL7b43CJl/u0jIJIcQrIgqoOn0FTTr
pUbt0AsqYq0cVemkGHerOF3WInkbXaHNfMrkvg3GQGF3HTMiGk7HMrUZnIHDTDb7
qFO3vDjcsxuOBpgxR1TGfKI+DhyU0ix6sS/G93L3E6cGA6JfiPBh8wCFWeQ7avZH
byLlaryMpvOp5QVxc33X5DJwyFma2GEutd99QnlhsNmjTaS1LJcn7VNFNHrPHK0=
=4x8y
-----END PGP SIGNATURE-----

--tsSrBb8Ybkw2i8Pt8hadaHPv9bwl27rjs--


From nobody Tue Nov  6 03:28:14 2018
Return-Path: <fredbaker.ietf@gmail.com>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 1255E130DC3 for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 03:28:13 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id LUHh9gE8Mnd8 for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 03:28:10 -0800 (PST)
Received: from mail-pg1-x533.google.com (mail-pg1-x533.google.com [IPv6:2607:f8b0:4864:20::533]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id D96221274D0 for <behave@ietf.org>; Tue,  6 Nov 2018 03:28:10 -0800 (PST)
Received: by mail-pg1-x533.google.com with SMTP id q5-v6so5705048pgv.0 for <behave@ietf.org>; Tue, 06 Nov 2018 03:28:10 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=from:message-id:mime-version:subject:date:in-reply-to:cc:to :references; bh=Syuc0LUrDh3vU1yWOZZV9HPwImJupHa69YU4gXkXH+Q=; b=XVRpbOpf3PUc/g0ipUGFIk8F9LIhkLRZ+elq8JEcZuo3GRWHAnT0jM9IL7LU3LIlb5 XXG1eYwzI7opOgn10UiLGr7NtP3y+7PTwnQ9p60IX2Q/nqhUv+BusF0jmJBZHXsHoB0N kSmbE89ZMQpcVvexLcuH58eK/ADrIwkQcrfuzyIUs1/cQJ0qzi/5yUxlF/cEH0flY4th LTOgAmajflfooZY1i2CD2I1SN8EF1B8hAjVTlRDf985beAqLEBLRBPW/aEjLHdjBN1Uf fLguFRfyRw2kbe26FzpJZl87tr2U9cj/k1PWmGjKCw5CNa1qxkxTlaBr9O2bIlu+IN4Q gBiA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:from:message-id:mime-version:subject:date :in-reply-to:cc:to:references; bh=Syuc0LUrDh3vU1yWOZZV9HPwImJupHa69YU4gXkXH+Q=; b=XcU9zAXahDMekePzlqJuHZVIBdDd3oupGtsBMYOJeOj8ucks7MeWtyQeZRj3TnaL17 IVIp8N/k0PhRl+pkN9PcFs3q6S0eACD4PxXS456DfmJCZTTCVx1Hq0zw5lve6stuFkUm 5/Ro7esgeHJUopUo6KWguUZsE5hADedSFLETPdqSrBWm8rQEHXbgSFyYMv1yu6DHGmIr zBwtlTeGgSi1kIA4GWE6GilcmsAKm/lMTSJg+zwmrJrXgvlEd6lH07zgjJ6wxu846xoh j0P5jKCQxVH/iZ+CnjEHM8U8owDIXA3H0eQPnkGTorJV/31KhQqj4NjzpvTMFJgUOzqS 271Q==
X-Gm-Message-State: AGRZ1gJoHW+fZiq3vIdnl7aJNpi051nzxQaVCDABcHHvunqRTg1AvyLm onivhTp6rJTbMad4b5Z39bw=
X-Google-Smtp-Source: AJdET5cCRJzeU6RESIMHiYuTZ4Ib6V5bJfIqUwWndMQ9koleCS/2hBkZHYJjf4K95Y4yCH+C8/oV7Q==
X-Received: by 2002:a63:d40a:: with SMTP id a10mr22936711pgh.394.1541503690368;  Tue, 06 Nov 2018 03:28:10 -0800 (PST)
Received: from ?IPv6:2001:67c:1232:144:9df0:b919:995c:c72b? ([2001:67c:1232:144:9df0:b919:995c:c72b]) by smtp.gmail.com with ESMTPSA id l2-v6sm44759266pgp.20.2018.11.06.03.28.07 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Tue, 06 Nov 2018 03:28:09 -0800 (PST)
From: Fred Baker <fredbaker.ietf@gmail.com>
Message-Id: <0F8964C5-7C2F-4C90-854A-D1ADF02D7C08@gmail.com>
Content-Type: multipart/signed; boundary="Apple-Mail=_1481F8BB-A9F9-42DB-AEB8-B73DCBB06068"; protocol="application/pgp-signature"; micalg=pgp-sha512
Mime-Version: 1.0 (Mac OS X Mail 11.5 \(3445.9.1\))
Date: Tue, 6 Nov 2018 18:28:04 +0700
In-Reply-To: <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net>
Cc: RFC Errata System <rfc-editor@rfc-editor.org>, Congxiao Bao <congxiao@cernet.edu.cn>, mohamed.boucadair@orange-ftgroup.com, "Mirja Kuehlewind (IETF)" <ietf@kuehlewind.net>, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, spencerdawkins.ietf@gmail.com, dwing@cisco.com, huitema@microsoft.com, behave@ietf.org
To: Christian Huitema <huitema@huitema.net>
References: <20181106085323.07C1BB80008@rfc-editor.org> <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com> <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net>
X-Mailer: Apple Mail (2.3445.9.1)
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/3dewJpII5c_s91dzoUBo8-_lse8>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Nov 2018 11:28:13 -0000

--Apple-Mail=_1481F8BB-A9F9-42DB-AEB8-B73DCBB06068
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=us-ascii



> On Nov 6, 2018, at 5:17 PM, Christian Huitema <huitema@huitema.net> =
wrote:
>=20
>=20
>=20
> On 11/6/2018 4:23 PM, Fred Baker wrote:
>> On second thought, the exact case is incorrect. I still think it's a =
silly restriction, but the private address in the case would not be =
placed into the Well-Known Prefix (and used as a destination address); =
it would be put into a /64 out of the subscriber's prefix (and used as a =
source address). So I can live without this change.
>=20
> Good.
>=20
> I think that the text should not be changed by an errata. The text is =
a
> fair rendering of our technical assessment at the time. We did not =
want
> to use the WKP to build ambiguous IPv6 addresses,

If the objective was to not create ambiguous addresses, why did we build =
a well-known prefix? A well-known prefix is probably the best possible =
way to create ambiguous addresses.

> and wanted to make
> sure that private IPv4 addresses will be mapped using private =
prefixes.
> It may or may not have been the right decision, but this is definitely
> what we intended.
>=20
> -- Christian Huitema
>=20

=
--------------------------------------------------------------------------=
------
The fact that there is a highway to hell and a stairway to heaven is an =
interesting comment on projected traffic volume...


--Apple-Mail=_1481F8BB-A9F9-42DB-AEB8-B73DCBB06068
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
	filename=signature.asc
Content-Type: application/pgp-signature;
	name=signature.asc
Content-Description: Message signed with OpenPGP

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEctjlJjQmVrp9uMq7EhdRnd2GP+AFAlvhesQACgkQEhdRnd2G
P+BnDQ/+MLw1T8p3wt6XZlDZ8Fezw6LqWKfYpSx4KpTCCthXdJmYBy488dfxyFDp
EU8r2yjgAFcHWZrXxHzZtr8pAtVYkDLt7kQVLWmW+bKKWo9SHxv/hdwDjK3kF0xm
B5VZdkaSy2CPYwXUMzUJH19/5uJNsou//6VLY7PeixvatbV0uoXIk6DzK/QydE3N
KYR8s8udoepB3/64IGdrA3UGhmwYIVaAVAQ1gr5IvZrwkTsYWuII2KHTRUs4h/Nf
QXeuWP1QxybZkxoTuXbC7Ns924PQBGeMFcsVA1aqmsJvv45RWxgf52nAkV+1AguX
LaXyoUUrf1C5ARmmmvr7LWQektbRGJY0gKUfVRAcU08qOucGgDjwOcuPDYn2yhyo
/B2XOViOFuff34nvmKVDd3+H8kJo5mLoBe9O3XEdLpld7DueGDUUNOxBsRMrs+Wy
GlJmxwFXJw3cUYdbbmDxrUyQm2AVV6W17uCymm+dgsCj6RkzK2m3DvE1oMw7KzAw
0g2rk2rpGUQSbZA0LnsxfKi22g77eXIXHv3iou7KaM7dBfhWVgp7zpcCSdmwd0CD
mKMGDh2QdQCw326HTNG6lIUwBKTTWEXx1HESBrmHF/3f0zWr4J4ZrAzSEsh1Pndn
OqW5J6JL3rZLDh6Qsy12k9mmV4VW+7H+jdUceEgiyI1mhqz9+ps=
=NWWi
-----END PGP SIGNATURE-----

--Apple-Mail=_1481F8BB-A9F9-42DB-AEB8-B73DCBB06068--


From nobody Tue Nov  6 04:16:51 2018
Return-Path: <prvs=184881054d=jordi.palet@consulintel.es>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C67CF130DF0 for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 04:16:49 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=consulintel.es
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id PzbGqM9P-gwQ for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 04:16:46 -0800 (PST)
Received: from mail.consulintel.es (mail.consulintel.es [IPv6:2001:470:1f09:495::5]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 94DB3130ECF for <behave@ietf.org>; Tue,  6 Nov 2018 04:16:45 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=simple; d=consulintel.es; s=MDaemon; t=1541506602; x=1542111402; i=jordi.palet@consulintel.es; q=dns/txt; h=User-Agent:Date: Subject:From:To:CC:Message-ID:Thread-Topic:References: In-Reply-To:Mime-version:Content-type:Content-transfer-encoding; bh=a0u1YS3Tfug/lYLXbXLBF/oU4TLGNeAVZqWM7n2GavY=; b=se8cx/OSVtk4R 2LZf6dOD+OdQVf+DcC0gsIS/3S8Ue+9HFTQTv09K3pkxbXR6ZviFcWaDjB7YP6pT Aled5DTXkFCGRRqfOJaLvP9WEsAO/nhxfzWZ3DxX8c2eP8fz8qsBqFMtgQtaHjxN iy66I/kp9+zU3RbZFH/b4RJZhTV3jE=
X-MDAV-Result: clean
X-MDAV-Processed: mail.consulintel.es, Tue, 06 Nov 2018 13:16:42 +0100
X-Spam-Processed: mail.consulintel.es, Tue, 06 Nov 2018 13:16:41 +0100
Received: from [172.20.60.83] by mail.consulintel.es (MDaemon PRO v16.5.2)  with ESMTPA id md50005946446.msg for <behave@ietf.org>; Tue, 06 Nov 2018 13:16:39 +0100
X-MDRemoteIP: 10.8.10.6
X-MDHelo: [172.20.60.83]
X-MDArrival-Date: Tue, 06 Nov 2018 13:16:39 +0100
X-Authenticated-Sender: jordi.palet@consulintel.es
X-Return-Path: prvs=184881054d=jordi.palet@consulintel.es
X-Envelope-From: jordi.palet@consulintel.es
X-MDaemon-Deliver-To: behave@ietf.org
User-Agent: Microsoft-MacOutlook/10.10.3.181015
Date: Tue, 06 Nov 2018 19:16:30 +0700
From: JORDI PALET MARTINEZ <jordi.palet@consulintel.es>
To: Fred Baker <fredbaker.ietf@gmail.com>, Christian Huitema <huitema@huitema.net>
CC: Congxiao Bao <congxiao@cernet.edu.cn>, <mohamed.boucadair@orange-ftgroup.com>, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, <spencerdawkins.ietf@gmail.com>, <dwing@cisco.com>, <huitema@microsoft.com>, "Mirja Kuehlewind (IETF)" <ietf@kuehlewind.net>, <behave@ietf.org>, RFC Errata System <rfc-editor@rfc-editor.org>
Message-ID: <75370789-566F-4187-8374-719E40D59D31@consulintel.es>
Thread-Topic: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
References: <20181106085323.07C1BB80008@rfc-editor.org> <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com> <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net> <0F8964C5-7C2F-4C90-854A-D1ADF02D7C08@gmail.com>
In-Reply-To: <0F8964C5-7C2F-4C90-854A-D1ADF02D7C08@gmail.com>
Mime-version: 1.0
Content-type: text/plain; charset="UTF-8"
Content-transfer-encoding: quoted-printable
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/9xM5gf9H0NEvHikzgzxz_h7e4-o>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Nov 2018 12:16:50 -0000

The advantage I see with a WKP is that you can roam to another NAT64 (and/o=
r DNS64) without changing configs, and also, that you may ignore the prefix=
 discovery mechanism (I've seen this coded in some places), if you presume =
that the WKP is the "default" one ...

Regards,
Jordi
=20
=20

=EF=BB=BF-----Mensaje original-----
De: Behave <behave-bounces@ietf.org> en nombre de Fred Baker <fredbaker.iet=
f@gmail.com>
Fecha: martes, 6 de noviembre de 2018, 18:28
Para: Christian Huitema <huitema@huitema.net>
CC: Congxiao Bao <congxiao@cernet.edu.cn>, <mohamed.boucadair@orange-ftgrou=
p.com>, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, =
<spencerdawkins.ietf@gmail.com>, <dwing@cisco.com>, <huitema@microsoft.com>=
, "Mirja Kuehlewind (IETF)" <ietf@kuehlewind.net>, <behave@ietf.org>, RFC E=
rrata System <rfc-editor@rfc-editor.org>
Asunto: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)

   =20
   =20
    > On Nov 6, 2018, at 5:17 PM, Christian Huitema <huitema@huitema.net> w=
rote:
    >=20
    >=20
    >=20
    > On 11/6/2018 4:23 PM, Fred Baker wrote:
    >> On second thought, the exact case is incorrect. I still think it's a=
 silly restriction, but the private address in the case would not be placed=
 into the Well-Known Prefix (and used as a destination address); it would b=
e put into a /64 out of the subscriber's prefix (and used as a source addre=
ss). So I can live without this change.
    >=20
    > Good.
    >=20
    > I think that the text should not be changed by an errata. The text is=
 a
    > fair rendering of our technical assessment at the time. We did not wa=
nt
    > to use the WKP to build ambiguous IPv6 addresses,
   =20
    If the objective was to not create ambiguous addresses, why did we buil=
d a well-known prefix? A well-known prefix is probably the best possible wa=
y to create ambiguous addresses.
   =20
    > and wanted to make
    > sure that private IPv4 addresses will be mapped using private prefixe=
s.
    > It may or may not have been the right decision, but this is definitel=
y
    > what we intended.
    >=20
    > -- Christian Huitema
    >=20
   =20
    -----------------------------------------------------------------------=
---------
    The fact that there is a highway to hell and a stairway to heaven is an=
 interesting comment on projected traffic volume...
   =20
    _______________________________________________
    Behave mailing list
    Behave@ietf.org
    https://www.ietf.org/mailman/listinfo/behave
   =20



**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or con=
fidential. The information is intended to be for the exclusive use of the i=
ndividual(s) named above and further non-explicilty authorized disclosure, =
copying, distribution or use of the contents of this information, even if p=
artially, including attached files, is strictly prohibited and will be cons=
idered a criminal offense. If you are not the intended recipient be aware t=
hat any disclosure, copying, distribution or use of the contents of this in=
formation, even if partially, including attached files, is strictly prohibi=
ted, will be considered a criminal offense, so you must reply to the origin=
al sender to inform about this communication and delete it.




From nobody Tue Nov  6 05:52:42 2018
Return-Path: <fredbaker.ietf@gmail.com>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 4C4F9124BAA for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 05:52:36 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id sFnMNs3iR2UH for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 05:52:34 -0800 (PST)
Received: from mail-pf1-x435.google.com (mail-pf1-x435.google.com [IPv6:2607:f8b0:4864:20::435]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 86E2112D4F1 for <behave@ietf.org>; Tue,  6 Nov 2018 05:52:34 -0800 (PST)
Received: by mail-pf1-x435.google.com with SMTP id u13-v6so6143590pfm.4 for <behave@ietf.org>; Tue, 06 Nov 2018 05:52:34 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=from:message-id:mime-version:subject:date:in-reply-to:cc:to :references; bh=t70CURAvU+zAI626Oz3rvwcBjXMOZ1tPhY4Q8BjTyVo=; b=t5ZnDY6ou+p0SVMzvixzYsexz8rwNNHlgRgHvdHqL5qXH95KL6gzy0+hBwKcGoCGNH N6bPiYhX/d9UbGgVeraJO1VjZIX4I/Ac5scPcKD7O6yfpVGRU8U6TSiTnR21JikOBMEs BElJM2q4NhJdhoLm9R+q2r2Vf2a5xuHw4LThxeF8ceLlxWu2s5wuxp5JSjZYr4zkUOrR fGAi7EzxP8PXATqaaijuKYSZa3tdhNa8qEg5bfw+aH2r3a94WbvuDUgRMrePEV073N9m yhAcWxClzus9KbxqO1pLdmmDp0JwWtOhrFFPEfb47q+8CIo3gT75mchHo/wjY8Uol6AZ CsBw==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:from:message-id:mime-version:subject:date :in-reply-to:cc:to:references; bh=t70CURAvU+zAI626Oz3rvwcBjXMOZ1tPhY4Q8BjTyVo=; b=FwbJeoAeMdqtCiMpyEoM/4uuzwQ3JcTCJsVjLS0VEQwTRnMWE+hxB7uAvcGdAuTsE8 GzUb8Hqs1hZUL0Htnu8ByHEylYheWAeWpVVfIG89OOyJbynMHahNIfiVsAKoNJZOjbkX 3cZL8bp7YHV6SILClh0RVXDgRUAwHTgQQLs0J5/Vc0Ygr5woJLBVVgTDN/cZ7jv9YS1K JGcusT8AvQcepM98jfYutMhhSutTo2lM6UF1vGvQTNw1luKt5QIzJBEupMSQUFWmXf8K 5Wva3lkh8Es6kR7m79TD2ei0RSy/YUQV0veoZKgRfebnasvVkUFy+1fgi+tmsnHah9LC d5aQ==
X-Gm-Message-State: AGRZ1gJTqPYbMRJrikOpyU41bwJqPL9FXDZ92PQmNNI5lo+9jfZuVJyq tCgC9Lmxclyd3JFcHBioOrA=
X-Google-Smtp-Source: AJdET5cjfYxd1W2kXn7Xyr1rrK8EhLUO2CmIKy4+i4bhwUTN8Bexq/lFR00tebzD46PQ7MAC3i+8gw==
X-Received: by 2002:a63:8f45:: with SMTP id r5mr4275403pgn.222.1541512354050;  Tue, 06 Nov 2018 05:52:34 -0800 (PST)
Received: from ?IPv6:2001:67c:1232:144:9df0:b919:995c:c72b? ([2001:67c:1232:144:9df0:b919:995c:c72b]) by smtp.gmail.com with ESMTPSA id 7-v6sm48226501pgk.31.2018.11.06.05.52.30 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Tue, 06 Nov 2018 05:52:33 -0800 (PST)
From: Fred Baker <fredbaker.ietf@gmail.com>
Message-Id: <FBAAB5CB-2AC4-43B1-A931-15E75662B7EF@gmail.com>
Content-Type: multipart/signed; boundary="Apple-Mail=_24D1271D-25CB-453A-8DD2-7A8E2DB4E484"; protocol="application/pgp-signature"; micalg=pgp-sha512
Mime-Version: 1.0 (Mac OS X Mail 11.5 \(3445.9.1\))
Date: Tue, 6 Nov 2018 20:52:28 +0700
In-Reply-To: <75370789-566F-4187-8374-719E40D59D31@consulintel.es>
Cc: Christian Huitema <huitema@huitema.net>, Congxiao Bao <congxiao@cernet.edu.cn>, mohamed.boucadair@orange-ftgroup.com, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, spencerdawkins.ietf@gmail.com, dwing@cisco.com, huitema@microsoft.com, "Mirja Kuehlewind (IETF)" <ietf@kuehlewind.net>, behave@ietf.org, RFC Errata System <rfc-editor@rfc-editor.org>
To: JORDI PALET MARTINEZ <jordi.palet@consulintel.es>
References: <20181106085323.07C1BB80008@rfc-editor.org> <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com> <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net> <0F8964C5-7C2F-4C90-854A-D1ADF02D7C08@gmail.com> <75370789-566F-4187-8374-719E40D59D31@consulintel.es>
X-Mailer: Apple Mail (2.3445.9.1)
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/MgTATmzT7A01CTSGg5zCQhqkxA0>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Nov 2018 13:52:36 -0000

--Apple-Mail=_24D1271D-25CB-453A-8DD2-7A8E2DB4E484
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=us-ascii



> On Nov 6, 2018, at 7:16 PM, JORDI PALET MARTINEZ =
<jordi.palet@consulintel.es> wrote:
>=20
> The advantage I see with a WKP is that you can roam to another NAT64 =
(and/or DNS64) without changing configs, and also, that you may ignore =
the prefix discovery mechanism (I've seen this coded in some places), if =
you presume that the WKP is the "default" one ...

That, of course, is exactly the problem with RFC 7050. If you are using =
the preferred resolver, you get one prefix, and if you're using 8.8.8.8 =
(as many do), you get another. A Well Known Prefix is a great way to =
pick the wrong one, or one that doesn't exist.
=
--------------------------------------------------------------------------=
------
Victorious warriors win first and then go to war,
Defeated warriors go to war first and then seek to win.
     Sun Tzu


--Apple-Mail=_24D1271D-25CB-453A-8DD2-7A8E2DB4E484
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
	filename=signature.asc
Content-Type: application/pgp-signature;
	name=signature.asc
Content-Description: Message signed with OpenPGP

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEctjlJjQmVrp9uMq7EhdRnd2GP+AFAlvhnJwACgkQEhdRnd2G
P+DcXA/+Jg6TbTS1VmMrThqzw658sn1eXM9VOtrUfCjqP8mHyb6Frr/EBZRhLnkI
ye4y6eYx0U5+NIGrK/SE+UoTwD+uqZlrXUtzUVuE5Rdni8BSwcAMZpkI3fsjWM2Z
gs9HYXNhS9Ip0crlthNMmYhVxpUhQoH3l0ZuZmXMZwbqnfzt2UiDnI2cqvBVU1lT
A3gGFfBTDmse+aygqn8j4J+qTAYoJtyAfiDV1EKdB5I68io+rO8Zw6Lj7KgkLQfh
uEfv0LpJtLgJS2ToxOioWqVlKZFawFVrIJtF7PGUpdufZCU072miXVuaVHaRE/CD
gRsV2GUwoXwsGGNhXVsBljSAZLtNcSyYK4TVRyDrtTIc53xCrzYFXHxW0rZutYLh
e/JKxL+WmqR0lLkBe/jtWy/V4NcVPlUbDF7O6uYCxvvovX1VX5rU9h+iBb6rjOJf
3kGGIYASwFKcFjwF3CbTPKkdVzpavwsgqMr4N08IX6DG3WqoSH8eSbUaVSs1ayIF
yi1IXs66xKhq97PqIsEPAERTv9I0LsAnaYqcpXTvmC+jXm7IMXCj5JGwg+mnFhJQ
Z3CU0N+0ciJ+RfLZN6tXXW0FfxBPvnVGb649BzOMBIcWPWd7KEiG/cmy/02tT9tz
06/2YRz8zlPZyJyml6XbCbhwax2vQm8aVfbLOnumioHT2f2GkWo=
=TDsU
-----END PGP SIGNATURE-----

--Apple-Mail=_24D1271D-25CB-453A-8DD2-7A8E2DB4E484--


From nobody Tue Nov  6 06:07:32 2018
Return-Path: <prvs=184881054d=jordi.palet@consulintel.es>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id AF74812D4F1 for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 06:07:30 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=consulintel.es
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id VzF9mYEGCCCz for <behave@ietfa.amsl.com>; Tue,  6 Nov 2018 06:07:29 -0800 (PST)
Received: from mail.consulintel.es (mail.consulintel.es [IPv6:2001:470:1f09:495::5]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id BBE36124BAA for <behave@ietf.org>; Tue,  6 Nov 2018 06:07:28 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=simple; d=consulintel.es; s=MDaemon; t=1541513246; x=1542118046; i=jordi.palet@consulintel.es; q=dns/txt; h=User-Agent:Date: Subject:From:To:CC:Message-ID:Thread-Topic:References: In-Reply-To:Mime-version:Content-type:Content-transfer-encoding; bh=3IDSC8N9mD+iz7s/CRoFvRHZKQ42zhuTWr8caWdCC+4=; b=VtfQoZCsNNOOP uX2T6ONjjakOxidP0X51awSuMGNAgWM7zCK71UZWgVmwmGcRl2M6x9LL4++1GSSW ANPuy4qv49C9FtJQujlm+59WmJMitXwGpg4msFT6/+mpJ2oRvalYLqsRKd5JjFM5 xy09ZiqoQyvKWc40WIVM2pS7T3yLCI=
X-MDAV-Result: clean
X-MDAV-Processed: mail.consulintel.es, Tue, 06 Nov 2018 15:07:26 +0100
X-Spam-Processed: mail.consulintel.es, Tue, 06 Nov 2018 15:07:24 +0100
Received: from [172.20.60.83] by mail.consulintel.es (MDaemon PRO v16.5.2)  with ESMTPA id md50005946671.msg for <behave@ietf.org>; Tue, 06 Nov 2018 15:07:22 +0100
X-MDRemoteIP: 10.8.10.6
X-MDHelo: [172.20.60.83]
X-MDArrival-Date: Tue, 06 Nov 2018 15:07:22 +0100
X-Authenticated-Sender: jordi.palet@consulintel.es
X-Return-Path: prvs=184881054d=jordi.palet@consulintel.es
X-Envelope-From: jordi.palet@consulintel.es
X-MDaemon-Deliver-To: behave@ietf.org
User-Agent: Microsoft-MacOutlook/10.10.3.181015
Date: Tue, 06 Nov 2018 21:07:04 +0700
From: JORDI PALET MARTINEZ <jordi.palet@consulintel.es>
To: Fred Baker <fredbaker.ietf@gmail.com>
CC: Christian Huitema <huitema@huitema.net>, Congxiao Bao <congxiao@cernet.edu.cn>, <mohamed.boucadair@orange-ftgroup.com>, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, <spencerdawkins.ietf@gmail.com>, <dwing@cisco.com>, <huitema@microsoft.com>, "Mirja Kuehlewind (IETF)" <ietf@kuehlewind.net>, <behave@ietf.org>, RFC Errata System <rfc-editor@rfc-editor.org>
Message-ID: <84FEE0D5-0BC2-4C35-9991-05F1E724B143@consulintel.es>
Thread-Topic: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
References: <20181106085323.07C1BB80008@rfc-editor.org> <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com> <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net> <0F8964C5-7C2F-4C90-854A-D1ADF02D7C08@gmail.com> <75370789-566F-4187-8374-719E40D59D31@consulintel.es> <FBAAB5CB-2AC4-43B1-A931-15E75662B7EF@gmail.com>
In-Reply-To: <FBAAB5CB-2AC4-43B1-A931-15E75662B7EF@gmail.com>
Mime-version: 1.0
Content-type: text/plain; charset="UTF-8"
Content-transfer-encoding: quoted-printable
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/xCh3vDdzwLxIfxpVmBUj5ZDTY2g>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Nov 2018 14:07:31 -0000

Totally agree and is the case that I call "foreign DNS" in draft-ietf-v6ops=
-nat64-deployment, but I was meaning that, as most of the NAT64 deployments=
 use the WKP, changing among them doesn't break, so at least we "break less=
".

Regards,
Jordi
=20
=20

=EF=BB=BF-----Mensaje original-----
De: Fred Baker <fredbaker.ietf@gmail.com>
Fecha: martes, 6 de noviembre de 2018, 20:52
Para: JORDI PALET MARTINEZ <jordi.palet@consulintel.es>
CC: Christian Huitema <huitema@huitema.net>, Congxiao Bao <congxiao@cernet.=
edu.cn>, <mohamed.boucadair@orange-ftgroup.com>, Dave Thaler <dthaler@micro=
soft.com>, Xing Li <xing@cernet.edu.cn>, <spencerdawkins.ietf@gmail.com>, <=
dwing@cisco.com>, <huitema@microsoft.com>, "Mirja Kuehlewind (IETF)" <ietf@=
kuehlewind.net>, <behave@ietf.org>, RFC Errata System <rfc-editor@rfc-edito=
r.org>
Asunto: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)

   =20
   =20
    > On Nov 6, 2018, at 7:16 PM, JORDI PALET MARTINEZ <jordi.palet@consuli=
ntel.es> wrote:
    >=20
    > The advantage I see with a WKP is that you can roam to another NAT64 =
(and/or DNS64) without changing configs, and also, that you may ignore the =
prefix discovery mechanism (I've seen this coded in some places), if you pr=
esume that the WKP is the "default" one ...
   =20
    That, of course, is exactly the problem with RFC 7050. If you are using=
 the preferred resolver, you get one prefix, and if you're using 8.8.8.8 (a=
s many do), you get another. A Well Known Prefix is a great way to pick the=
 wrong one, or one that doesn't exist.
    -----------------------------------------------------------------------=
---------
    Victorious warriors win first and then go to war,
    Defeated warriors go to war first and then seek to win.
         Sun Tzu
   =20
   =20



**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or con=
fidential. The information is intended to be for the exclusive use of the i=
ndividual(s) named above and further non-explicilty authorized disclosure, =
copying, distribution or use of the contents of this information, even if p=
artially, including attached files, is strictly prohibited and will be cons=
idered a criminal offense. If you are not the intended recipient be aware t=
hat any disclosure, copying, distribution or use of the contents of this in=
formation, even if partially, including attached files, is strictly prohibi=
ted, will be considered a criminal offense, so you must reply to the origin=
al sender to inform about this communication and delete it.




From nobody Thu Nov  8 06:00:21 2018
Return-Path: <mohamed.boucadair@orange.com>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 61AD7126CB6 for <behave@ietfa.amsl.com>; Thu,  8 Nov 2018 06:00:20 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.599
X-Spam-Level: 
X-Spam-Status: No, score=-2.599 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001, UNPARSEABLE_RELAY=0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Yh2qS6Hi7pHj for <behave@ietfa.amsl.com>; Thu,  8 Nov 2018 06:00:18 -0800 (PST)
Received: from orange.com (mta135.mail.business.static.orange.com [80.12.70.35]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 2AEE1126BED for <behave@ietf.org>; Thu,  8 Nov 2018 06:00:18 -0800 (PST)
Received: from opfednr01.francetelecom.fr (unknown [xx.xx.xx.65]) by opfednr27.francetelecom.fr (ESMTP service) with ESMTP id 42rQ0J4lVXz4x9T; Thu,  8 Nov 2018 15:00:16 +0100 (CET)
Received: from Exchangemail-eme2.itn.ftgroup (unknown [xx.xx.31.58]) by opfednr01.francetelecom.fr (ESMTP service) with ESMTP id 42rQ0J3kFkzDq8b; Thu,  8 Nov 2018 15:00:16 +0100 (CET)
Received: from OPEXCLILMA3.corporate.adroot.infra.ftgroup ([fe80::60a9:abc3:86e6:2541]) by OPEXCLILM33.corporate.adroot.infra.ftgroup ([fe80::3881:fc15:b4b2:9017%19]) with mapi id 14.03.0415.000; Thu, 8 Nov 2018 15:00:15 +0100
From: <mohamed.boucadair@orange.com>
To: Christian Huitema <huitema@huitema.net>, Fred Baker <fredbaker.ietf@gmail.com>, RFC Errata System <rfc-editor@rfc-editor.org>
CC: Congxiao Bao <congxiao@cernet.edu.cn>, "mohamed.boucadair@orange-ftgroup.com" <mohamed.boucadair@orange-ftgroup.com>, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, "spencerdawkins.ietf@gmail.com" <spencerdawkins.ietf@gmail.com>, "dwing@cisco.com" <dwing@cisco.com>, "huitema@microsoft.com" <huitema@microsoft.com>, "ietf@kuehlewind.net" <ietf@kuehlewind.net>, "behave@ietf.org" <behave@ietf.org>
Thread-Topic: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
Thread-Index: AQHUda5C5UNZI0uinEu8o8U7txAo3qVCaMCAgAAPCICAA3JyQA==
Date: Thu, 8 Nov 2018 14:00:14 +0000
Message-ID: <47e1fae5-21ef-4960-aad3-b0862708b1e5@OPEXCLILM33.corporate.adroot.infra.ftgroup>
References: <20181106085323.07C1BB80008@rfc-editor.org> <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com> <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net>
In-Reply-To: <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net>
Accept-Language: fr-FR, en-US
Content-Language: fr-FR
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
x-originating-ip: [10.168.234.2]
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/y3_YL9eT27TA_AHXYzysU6c2I-Q>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 08 Nov 2018 14:00:20 -0000

Hi all,=20

I echo what Christian said.

Please note that if one wants to relax the constraint about private IPv4 ad=
dress in 6052, the WKP prefix defined in https://tools.ietf.org/html/rfc821=
5 (which Fred is surely familiar with) can be used.=20

Cheers,
Med

> -----Message d'origine-----
> De=A0: Behave [mailto:behave-bounces@ietf.org] De la part de Christian Hu=
itema
> Envoy=E9=A0: mardi 6 novembre 2018 11:18
> =C0=A0: Fred Baker; RFC Errata System
> Cc=A0: Congxiao Bao; mohamed.boucadair@orange-ftgroup.com; Dave Thaler; X=
ing
> Li; spencerdawkins.ietf@gmail.com; dwing@cisco.com; huitema@microsoft.com=
;
> ietf@kuehlewind.net; behave@ietf.org
> Objet=A0: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
>=20
>=20
>=20
> On 11/6/2018 4:23 PM, Fred Baker wrote:
> > On second thought, the exact case is incorrect. I still think it's a si=
lly
> restriction, but the private address in the case would not be placed into=
 the
> Well-Known Prefix (and used as a destination address); it would be put in=
to a
> /64 out of the subscriber's prefix (and used as a source address). So I c=
an
> live without this change.
>=20
> Good.
>=20
> I think that the text should not be changed by an errata. The text is a
> fair rendering of our technical assessment at the time. We did not want
> to use the WKP to build ambiguous IPv6 addresses, and wanted to make
> sure that private IPv4 addresses will be mapped using private prefixes.
> It may or may not have been the right decision, but this is definitely
> what we intended.
>=20
> -- Christian Huitema


From nobody Fri Nov 16 22:00:26 2018
Return-Path: <huitema@huitema.net>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 87F8B126CB6 for <behave@ietfa.amsl.com>; Fri, 16 Nov 2018 22:00:25 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.601
X-Spam-Level: 
X-Spam-Status: No, score=-2.601 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id K7OLWKdZc8qh for <behave@ietfa.amsl.com>; Fri, 16 Nov 2018 22:00:23 -0800 (PST)
Received: from mx43-out1.antispamcloud.com (mx43-out1.antispamcloud.com [138.201.61.189]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id E0774130DC9 for <behave@ietf.org>; Fri, 16 Nov 2018 22:00:22 -0800 (PST)
Received: from xsmtp06.mail2web.com ([168.144.250.232]) by mx128.antispamcloud.com with esmtps (TLSv1:AES256-SHA:256) (Exim 4.89) (envelope-from <huitema@huitema.net>) id 1gNteV-0001sM-4n for behave@ietf.org; Sat, 17 Nov 2018 07:00:20 +0100
Received: from [10.5.2.35] (helo=xmail10.myhosting.com) by xsmtp06.mail2web.com with esmtps (TLS-1.0:DHE_RSA_AES_256_CBC_SHA1:32) (Exim 4.63) (envelope-from <huitema@huitema.net>) id 1gNteP-0005E4-Vn for behave@ietf.org; Sat, 17 Nov 2018 01:00:18 -0500
Received: (qmail 7841 invoked from network); 17 Nov 2018 06:00:10 -0000
Received: from unknown (HELO [192.168.1.100]) (Authenticated-user:_huitema@huitema.net@[172.56.42.239]) (envelope-sender <huitema@huitema.net>) by xmail10.myhosting.com (qmail-ldap-1.03) with ESMTPA for <behave@ietf.org>; 17 Nov 2018 06:00:10 -0000
To: mohamed.boucadair@orange.com, Fred Baker <fredbaker.ietf@gmail.com>, RFC Errata System <rfc-editor@rfc-editor.org>
Cc: Congxiao Bao <congxiao@cernet.edu.cn>, "mohamed.boucadair@orange-ftgroup.com" <mohamed.boucadair@orange-ftgroup.com>, Dave Thaler <dthaler@microsoft.com>, Xing Li <xing@cernet.edu.cn>, "spencerdawkins.ietf@gmail.com" <spencerdawkins.ietf@gmail.com>, "dwing@cisco.com" <dwing@cisco.com>, "huitema@microsoft.com" <huitema@microsoft.com>, "ietf@kuehlewind.net" <ietf@kuehlewind.net>, "behave@ietf.org" <behave@ietf.org>
References: <20181106085323.07C1BB80008@rfc-editor.org> <27516408-05B3-4C08-B40E-B01E44525AB5@gmail.com> <5a5d6ac6-2d9a-96ee-118d-3601e47804cc@huitema.net> <47e1fae5-21ef-4960-aad3-b0862708b1e5@OPEXCLILM33.corporate.adroot.infra.ftgroup>
From: Christian Huitema <huitema@huitema.net>
Openpgp: preference=signencrypt
Autocrypt: addr=huitema@huitema.net; prefer-encrypt=mutual; keydata= xsBNBFIRX8gBCAC26usy/Ya38IqaLBSu33vKD6hP5Yw390XsWLaAZTeQR64OJEkoOdXpvcOS HWfMIlD5s5+oHfLe8jjmErFAXYJ8yytPj1fD2OdSKAe1TccUBiOXT8wdVxSr5d0alExVv/LO I/vA2aU1TwOkVHKSapD7j8/HZBrqIWRrXUSj2f5n9tY2nJzG9KRzSG0giaJWBfUFiGb4lvsy IaCaIU0YpfkDDk6PtK5YYzuCeF0B+O7N9LhDu/foUUc4MNq4K3EKDPb2FL1Hrv0XHpkXeMRZ olpH8SUFUJbmi+zYRuUgcXgMZRmZFL1tu6z9h6gY4/KPyF9aYot6zG28Qk/BFQRtj7V1ABEB AAHNJ0NocmlzdGlhbiBIdWl0ZW1hIDxodWl0ZW1hQGh1aXRlbWEubmV0PsLAeQQTAQIAIwUC UhFfyAIbLwcLCQgHAwIBBhUIAgkKCwQWAgMBAh4BAheAAAoJEJNDCbJVyA1yhbYH/1ud6x6m VqGIp0JcZUfSQO8w+TjugqxCyGNn+w/6Qb5O/xENxNQ4HaMQ5uSRK9n8WKKDDRSzwZ4syKKf wbkfj05vgFxrjCynVbm1zs2X2aGXh+PxPL/WHUaxzEP7KjYbLtCUZDRzOOrm+0LMktngT/k3 6+EZoLEM52hwwpIAzJoscyEz7QfqMOZtFm6xQnlvDQeIrHx0KUvwo/vgDLK3SuruG1CSHcR0 D24kEEUa044AIUKBS3b0b8AR7f6mP2NcnLpdsibtpabi9BzqAidcY/EjTaoea46HXALk/eJd 6OLkLE6UQe1PPzQC4jB7rErX2BxnSkHDw50xMgLRcl5/b1bOwE0EUhFfyAEIAKp7Cp8lqKTV CC9QiAf6QTIjW+lie5J44Ad++0k8gRgANZVWubQuCQ71gxDWLtxYfFkEXjG4TXV/MUtnOliG 5rc2E+ih6Dg61Y5PQakm9OwPIsOx+2R+iSW325ngln2UQrVPgloO83QiUoi7mBJPbcHlxkhZ bd3+EjFxSLIQogt29sTcg2oSh4oljUpz5niTt69IOfZx21kf29NfDE+Iw56gfrxI2ywZbu5o G+d0ZSp0lsovygpk4jK04fDTq0vxjEU5HjPcsXC4CSZdq5E2DrF4nOh1UHkHzeaXdYR2Bn1Y wTePfaHBFlvQzI+Li/Q6AD/uxbTM0vIcsUxrv3MNHCUAEQEAAcLBfgQYAQIACQUCUhFfyAIb LgEpCRCTQwmyVcgNcsBdIAQZAQIABgUCUhFfyAAKCRC22tOSFDh1UOlBB/94RsCJepNvmi/c YiNmMnm0mKb6vjv43OsHkqrrCqJSfo95KHyl5Up4JEp8tiJMyYT2mp4IsirZHxz/5lqkw9Az tcGAF3GlFsj++xTyD07DXlNeddwTKlqPRi/b8sppjtWur6Pm+wnAHp0mQ7GidhxHccFCl65w uT7S/ocb1MjrTgnAMiz+x87d48n1UJ7yIdI41Wpg2XFZiA9xPBiDuuoPwFj14/nK0elV5Dvq 4/HVgfurb4+fd74PV/CC/dmd7hg0ZRlgnB5rFUcFO7ywb7/TvICIIaLWcI42OJDSZjZ/MAzz BeXm263lHh+kFxkh2LxEHnQGHCHGpTYyi4Z3dv03HtkH/1SI8joQMQq00Bv+RdEbJXfEExrT u4gtdZAihwvy97OPA2nCdTAHm/phkzryMeOaOztI4PS8u2Ce5lUB6P/HcGtK/038KdX5MYST Fn8KUDt4o29bkv0CUXwDzS3oTzPNtGdryBkRMc9b+yn9+AdwFEH4auhiTQXPMnl0+G3nhKr7 jvzVFJCRif3OAhEm4vmBNDE3uuaXFQnbK56GJrnqVN+KX5Z3M7X3fA8UcVCGOEHXRP/aubiw Ngawj0V9x+43kUapFp+nF69R53UI65YtJ95ec4PTO/Edvap8h1UbdEOc4+TiYwY1TBuIKltY 1cnrjgAWUh/Ucvr++/KbD9tD6C8=
Message-ID: <86255aa2-73e4-6d14-fea6-83c4b5459525@huitema.net>
Date: Fri, 16 Nov 2018 22:00:05 -0800
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1
MIME-Version: 1.0
In-Reply-To: <47e1fae5-21ef-4960-aad3-b0862708b1e5@OPEXCLILM33.corporate.adroot.infra.ftgroup>
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit
Content-Language: en-US
X-Originating-IP: 168.144.250.232
X-Spampanel-Domain: xsmtpout.mail2web.com
X-Spampanel-Username: 168.144.250.0/24
Authentication-Results: antispamcloud.com; auth=pass smtp.auth=168.144.250.0/24@xsmtpout.mail2web.com
X-Spampanel-Outgoing-Class: ham
X-Spampanel-Outgoing-Evidence: Combined (0.07)
X-Recommended-Action: accept
X-Filter-ID: EX5BVjFpneJeBchSMxfU5r9aIfqK8j3he+MaKyEc2FJ602E9L7XzfQH6nu9C/Fh9KJzpNe6xgvOx q3u0UDjvO0VmU7heoGtPbmnM2lug8e3TV/3OdXD2Xdo8CfrY5CQSxXroeCCW3i6kyb1Z8f4QbYyz NJVaeAWax4WOe4pTBX2DwIE7VKe+bqpcdCns72R1dxQLHgng41NmcjnBNVncyrUJ8oN+d2/1YClf NOnZIS/D6kl279TnLqYAewew3OfA/Sw06ZGLpxBd7JvDiHkjbQbc8oCOV/quMTGbvDHEp1jFkCxZ 25wl+SuGnaEIRu161qkK742y4wCes8FTZAV12aOHsLIgU6CxRwTS/pCI4IAd4WM/pHSp5vEtSzeE iAXwP8biGVaHxdIhJpX2SF/frT/TpQy8kTfRo7YlxVS4t1aI+8ftzFe2XyLppMxgk9v788Sihtgt 7m0LHDdIjFM6BQIPbR6iF0Io2IR6cFULTLnHEgV4HBy01ru1y7iS4JNj78/Vv7ggS7iHB0mlJNSa 0Pvg7iEFLP+SSY+Av5+AiC5Ofg+BvPwC58/yRu8DTPWKPaFteDCANY9ZE9DZtFrkMZLSuSjWnsxb 4CvwConHma2eMNnfXgg9myaSPB/HPOOqfJlbZZh01urflxdd2g4lVBsXybHsG54cmqy4G6ri+/v3 Y80OmAux3oN13+ztUzne+sZB21+ph/wEUPoLmwbaG9r9ZdPSjq7LLQXOTkb//f0jppyC/apigmXL /XNm5XGW3nsncPbcxYxawQCSrHmTUlFfEoXm0/FPF8PR0w363ln2vwxpYOJbUV/+bJKKFZGLu6S+ IfGfexeTMSvN1RdgRYu1gPmxmMWQMERQ8LpknpvIWsRCHwGOxwHtV/mrwPG03jR5NeVaJQBh0uaw l0Cg8sKH0lJP3SQ3Hl0AH0QpMBIkYAzMcdhZar+1dDSXmWgfeWn7/ueLrlp+ZPRlQaamlokd2x35 zAiBFPp64JaIysDeBo8dSr9xryLrvIVUMlnB
X-Report-Abuse-To: spam@quarantine9.antispamcloud.com
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/v2l6QP_csfsgoi9bOl6Ec8P43AU>
Subject: Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 17 Nov 2018 06:00:25 -0000

To be clear, I am not trying to assert that RFC 6052 is technically
perfect. There may very well be good reasons to write an RFC 6052bis. We
have now several years of deployment experience, and we may possibly
have learned a thing or two. I am just saying that the errata process is
the wrong way to do that.

-- Christian Huitema


On 11/8/2018 6:00 AM, mohamed.boucadair@orange.com wrote:
> Hi all, 
>
> I echo what Christian said.
>
> Please note that if one wants to relax the constraint about private IPv4 address in 6052, the WKP prefix defined in https://tools.ietf.org/html/rfc8215 (which Fred is surely familiar with) can be used. 
>
> Cheers,
> Med
>
>> -----Message d'origine-----
>> De : Behave [mailto:behave-bounces@ietf.org] De la part de Christian Huitema
>> Envoyé : mardi 6 novembre 2018 11:18
>> À : Fred Baker; RFC Errata System
>> Cc : Congxiao Bao; mohamed.boucadair@orange-ftgroup.com; Dave Thaler; Xing
>> Li; spencerdawkins.ietf@gmail.com; dwing@cisco.com; huitema@microsoft.com;
>> ietf@kuehlewind.net; behave@ietf.org
>> Objet : Re: [BEHAVE] [Technical Errata Reported] RFC6052 (5547)
>>
>>
>>
>> On 11/6/2018 4:23 PM, Fred Baker wrote:
>>> On second thought, the exact case is incorrect. I still think it's a silly
>> restriction, but the private address in the case would not be placed into the
>> Well-Known Prefix (and used as a destination address); it would be put into a
>> /64 out of the subscriber's prefix (and used as a source address). So I can
>> live without this change.
>>
>> Good.
>>
>> I think that the text should not be changed by an errata. The text is a
>> fair rendering of our technical assessment at the time. We did not want
>> to use the WKP to build ambiguous IPv6 addresses, and wanted to make
>> sure that private IPv4 addresses will be mapped using private prefixes.
>> It may or may not have been the right decision, but this is definitely
>> what we intended.
>>
>> -- Christian Huitema


From nobody Mon Nov 26 04:33:06 2018
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: behave@ietfa.amsl.com
Delivered-To: behave@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 9FB18130F3A; Mon, 26 Nov 2018 04:32:54 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id W-fsOkJXzhb4; Mon, 26 Nov 2018 04:32:52 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id C46E6130F36; Mon, 26 Nov 2018 04:32:52 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id DE778B80D5D; Mon, 26 Nov 2018 04:32:18 -0800 (PST)
To: FredBaker.IETF@gmail.com, congxiao@cernet.edu.cn, huitema@microsoft.com, marcelo@it.uc3m.es, mohamed.boucadair@orange-ftgroup.com, xing@cernet.edu.cn
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: ietf@kuehlewind.net, iesg@ietf.org, behave@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20181126123218.DE778B80D5D@rfc-editor.org>
Date: Mon, 26 Nov 2018 04:32:18 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/behave/E-BzHIwWigZ8G9GQQNPBHxrxI3Q>
Subject: [BEHAVE] [Errata Rejected] RFC6052 (5547)
X-BeenThere: behave@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: mailing list of BEHAVE IETF WG <behave.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/behave>, <mailto:behave-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/behave/>
List-Post: <mailto:behave@ietf.org>
List-Help: <mailto:behave-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/behave>, <mailto:behave-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 26 Nov 2018 12:32:55 -0000

The following errata report has been rejected for RFC6052,
"IPv6 Addressing of IPv4/IPv6 Translators".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5547

--------------------------------------
Status: Rejected
Type: Technical

Reported by: Fred Baker <FredBaker.IETF@gmail.com>
Date Reported: 2018-11-06
Rejected by: Mirja Kühlewind (IESG)

Section: 3.1

Original Text
-------------
   The Well-Known Prefix MUST NOT be used to represent non-global IPv4
   addresses, such as those defined in [RFC1918] or listed in Section 3
   of [RFC5735].  Address translators MUST NOT translate packets in
   which an address is composed of the Well-Known Prefix and a non-
   global IPv4 address; they MUST drop these packets.

Corrected Text
--------------
The paragraph should be removed.

Notes
-----
IPv4 packets with private addresses are routinely translated to IPv4 packets with global addresses in NAT44. If a 464XLAT CLAT (stateless NAT64) cannot translate a private address to an IPv6 /96 prefix with that address as an IID (or whatever it's called), then the packet may not be translated to an IPv4 packet with a global address by the 464XLAT PLAT (stateful NAT64). This changes the intent of the sender, and in so doing violates the end to end principle. Practically speaking, it means that a network that uses 464XLAT or MAP-T with IPv4 in the subscriber and translating to IPv4 via NAT64 into the IPv4 Internet, it forces the network or the subscriber to purchase global address space. That's just silly. Let the user use private address space in the home or whatever.
 --VERIFIER NOTES-- 
The orginial text was intended at time of publication. If this is not current anymore, the RFC needs to be updated by an IETF consensus doc.

--------------------------------------
RFC6052 (draft-ietf-behave-address-format-10)
--------------------------------------
Title               : IPv6 Addressing of IPv4/IPv6 Translators
Publication Date    : October 2010
Author(s)           : C. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. Li
Category            : PROPOSED STANDARD
Source              : Behavior Engineering for Hindrance Avoidance
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

