
From gonzalo.camarillo@ericsson.com  Tue May 29 03:52:28 2012
Return-Path: <gonzalo.camarillo@ericsson.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 55A0621F86D8 for <bfcpbis@ietfa.amsl.com>; Tue, 29 May 2012 03:52:28 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -106.369
X-Spam-Level: 
X-Spam-Status: No, score=-106.369 tagged_above=-999 required=5 tests=[AWL=-0.120, BAYES_00=-2.599, HELO_EQ_SE=0.35, RCVD_IN_DNSWL_MED=-4, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Kyp7kYFH6ShY for <bfcpbis@ietfa.amsl.com>; Tue, 29 May 2012 03:52:27 -0700 (PDT)
Received: from mailgw7.ericsson.se (mailgw7.ericsson.se [193.180.251.48]) by ietfa.amsl.com (Postfix) with ESMTP id 2AB9821F87C0 for <bfcpbis@ietf.org>; Tue, 29 May 2012 03:52:26 -0700 (PDT)
X-AuditID: c1b4fb30-b7f606d0000002be-c6-4fc4aa69c73c
Received: from esessmw0247.eemea.ericsson.se (Unknown_Domain [153.88.253.125]) by mailgw7.ericsson.se (Symantec Mail Security) with SMTP id 4F.DF.00702.96AA4CF4; Tue, 29 May 2012 12:52:26 +0200 (CEST)
Received: from [131.160.36.95] (153.88.115.8) by esessmw0247.eemea.ericsson.se (153.88.115.94) with Microsoft SMTP Server id 8.3.264.0; Tue, 29 May 2012 12:52:25 +0200
Message-ID: <4FC4AA69.2040004@ericsson.com>
Date: Tue, 29 May 2012 13:52:25 +0300
From: Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com>
User-Agent: Mozilla/5.0 (Windows NT 6.0; rv:12.0) Gecko/20120428 Thunderbird/12.0.1
MIME-Version: 1.0
To: bfcpbis@ietf.org
X-Enigmail-Version: 1.4.1
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: 7bit
X-Brightmail-Tracker: H4sIAAAAAAAAA+NgFnrLJMWRmVeSWpSXmKPExsUyM+JvrW7WqiP+BtuvcFj8W3eUyYHRY8mS n0wBjFFcNimpOZllqUX6dglcGYcufWUuWMRYsa7nCGsDY3UXIyeHhICJxObrCxkhbDGJC/fW s4HYQgKnGCUmP1DtYuQCslczSpya0AWW4BXQlpi5dyEziM0ioCpxbfNsVhCbTcBCYsut+ywg tqhAsMS87pssEPWCEidnPgGzRQREJHbMughWLww0Z+KtPSwQiyUlDv67xg5iMwvoSUy52sII YctLbH87hxniIG2J5c9aWCYw8s9CMnYWkpZZSFoWMDKvYhTOTczMSS8310stykwuLs7P0ytO 3cQIDLKDW34b7GDcdF/sEKM0B4uSOK+e6n5/IYH0xJLU7NTUgtSi+KLSnNTiQ4xMHJxSDYxx qsJp5b8Ml1c/iNyszhi7L7ntT+2mv08L5idZXebsFDXVbOAz9tXkm3s/afvicvknyuKlYefD S1IOyD1+J8i0zL+Nc+2C1psVRx/d4d+bzX9b7unhUP3zL7hOfZ0WcT21/dFlP9VauwuVZyZ4 sfL4L/9VfWHJ+ux1xziVnp9ddKNOImHd/C9KLMUZiYZazEXFiQDhBuIGAAIAAA==
Subject: [bfcpbis] No activity in this WG for a while
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 29 May 2012 10:52:28 -0000

Folks,

I have not seen any activity in this WG for a while. Please, I would
like to see more activity around the WG's chartered items.

Thanks,

Gonzalo

From wuym2000cn@gmail.com  Wed May 30 02:31:55 2012
Return-Path: <wuym2000cn@gmail.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id F2BC711E8083 for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 02:31:54 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.237
X-Spam-Level: 
X-Spam-Status: No, score=-1.237 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, J_CHICKENPOX_72=0.6, MISSING_SUBJECT=1.762, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id f70UAZam1xwZ for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 02:31:54 -0700 (PDT)
Received: from mail-qa0-f49.google.com (mail-qa0-f49.google.com [209.85.216.49]) by ietfa.amsl.com (Postfix) with ESMTP id 63A8E11E8079 for <bfcpbis@ietf.org>; Wed, 30 May 2012 02:31:54 -0700 (PDT)
Received: by qabj40 with SMTP id j40so2332653qab.15 for <bfcpbis@ietf.org>; Wed, 30 May 2012 02:31:53 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:date:message-id:subject:from:to:content-type; bh=X6BdrcaPrr3Og30so0IOvq02LDltZ4J/3FY/QcJI4Bs=; b=WcVkk2HWjSl6tR0SdVid22R9fnFCTqszdx6vuS7gme0ebt4oSEEtrrc9TZF0QdhW9o 1uYIkA11QtDZFTsEG5ljF3fbQD3s2OsWhrP5c6uMUzyr4mtl0pT0t60aLVnQ5bB/+pXw P1nLGxsB1KswXS3pzxtQT9szOAL+RohGuoPvVQAxgqLx+o/ISV67+5LaZ74R+7BtB16v 7JXSOGCQ4WGK325NOAFm5wome07aCys0/rWAfr+0ZC4B/H4qJvCG+HNohdTZpY4kkb5O iPB63vc+OxGMddUUuT9zAtSy2jSIquIpTFXtIfFAViX6L2DJBkmxb89qcPTQWO8Exvgo pggg==
MIME-Version: 1.0
Received: by 10.229.137.146 with SMTP id w18mr4371390qct.38.1338370313742; Wed, 30 May 2012 02:31:53 -0700 (PDT)
Received: by 10.229.239.19 with HTTP; Wed, 30 May 2012 02:31:53 -0700 (PDT)
Date: Wed, 30 May 2012 17:31:53 +0800
Message-ID: <CAMxBvpArA8HA5xMnGX-P=rdoUOGOEwCfAZTRcdaP-djcSac=Ug@mail.gmail.com>
From: Woo Johnman <wuym2000cn@gmail.com>
To: bfcpbis@ietf.org
Content-Type: text/plain; charset=ISO-8859-1
Subject: [bfcpbis] (no subject)
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 30 May 2012 09:31:55 -0000

Hi,
   I feel BFCP over DTLS is not well documented in rfc4582bis.
  At section 7 "Lower-Layer Security".
It says "BFCP floor control servers
   and clients MUST support TLS for transport over TCP and MUST support DTLS for
   transport over UDP [4]." But reference [4] is only about  BFCP over TLS.
Reference for BFCP over DTLS seems missing.
At the end of the same section,it seems say DTLS connection setup
procedure shall
follow [7].  If it is true, does it mean BFCP message is packeted as
SRTP? If not, would it be better to
give more details about DTLS connection setup and packetization.

  Please give more explain.

Thanks in advance,

Youngmin

From wuym2000cn@gmail.com  Wed May 30 02:35:04 2012
Return-Path: <wuym2000cn@gmail.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id E1A3021F866C for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 02:35:04 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.237
X-Spam-Level: 
X-Spam-Status: No, score=-1.237 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, J_CHICKENPOX_72=0.6, MISSING_SUBJECT=1.762, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id eyVwWCCH+xdr for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 02:35:04 -0700 (PDT)
Received: from mail-qc0-f172.google.com (mail-qc0-f172.google.com [209.85.216.172]) by ietfa.amsl.com (Postfix) with ESMTP id 9775E21F8669 for <bfcpbis@ietf.org>; Wed, 30 May 2012 02:35:04 -0700 (PDT)
Received: by qcsq13 with SMTP id q13so2984297qcs.31 for <bfcpbis@ietf.org>; Wed, 30 May 2012 02:35:04 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:date:message-id:subject:from:to:content-type; bh=X6BdrcaPrr3Og30so0IOvq02LDltZ4J/3FY/QcJI4Bs=; b=sU4edQ+hAbwRoZG1I9SSKzdAeOSKgj+7dBBfv8CkmKnEUzIHRHgKiO2lI7Odv4jvTz 7QRd8TMIAgCqlExZy1YJQ3z1FaXAuSlLr+VK4N6U9wlbfIImnvau6m9XX/ADgpOYXGHx kWigPVL7M0otPsHk2UGfU/ZdnSZal5jOMATYc5crZnGoO6Nq1rMJjuFSmL9sxkO6qEBJ FFW7WbR6Td2Qk3gJjL3dFEw6xX2tbWYwPWqB+zAdk+W+tdcQoH4o0f5rcsygcYU9+CtT DM7BYJSmXoJg6c0odRcmkcUFQy/a0eXvHYhoWayyNXVx2X6P5sU+8DESPEHCOKSZnu5q 1TqQ==
MIME-Version: 1.0
Received: by 10.224.203.7 with SMTP id fg7mr15272089qab.48.1338370503995; Wed, 30 May 2012 02:35:03 -0700 (PDT)
Received: by 10.229.239.19 with HTTP; Wed, 30 May 2012 02:35:03 -0700 (PDT)
Date: Wed, 30 May 2012 17:35:03 +0800
Message-ID: <CAMxBvpB0pnr4Rr31m=mrypiXBJxZjk2bCvroguWAvXxzPRKjiQ@mail.gmail.com>
From: Woo Johnman <wuym2000cn@gmail.com>
To: bfcpbis@ietf.org
Content-Type: text/plain; charset=ISO-8859-1
Subject: [bfcpbis] BFCP over DTLS
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 30 May 2012 09:35:05 -0000

Hi,
   I feel BFCP over DTLS is not well documented in rfc4582bis.
  At section 7 "Lower-Layer Security".
It says "BFCP floor control servers
   and clients MUST support TLS for transport over TCP and MUST support DTLS for
   transport over UDP [4]." But reference [4] is only about  BFCP over TLS.
Reference for BFCP over DTLS seems missing.
At the end of the same section,it seems say DTLS connection setup
procedure shall
follow [7].  If it is true, does it mean BFCP message is packeted as
SRTP? If not, would it be better to
give more details about DTLS connection setup and packetization.

  Please give more explain.

Thanks in advance,

Youngmin

From alanford@cisco.com  Wed May 30 04:53:51 2012
Return-Path: <alanford@cisco.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B952B21F86AD for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 04:53:51 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -8.157
X-Spam-Level: 
X-Spam-Status: No, score=-8.157 tagged_above=-999 required=5 tests=[AWL=1.842,  BAYES_00=-2.599, J_CHICKENPOX_72=0.6, RCVD_IN_DNSWL_HI=-8]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id xlT7KPGmL+xu for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 04:53:51 -0700 (PDT)
Received: from ams-iport-3.cisco.com (ams-iport-3.cisco.com [144.254.224.146]) by ietfa.amsl.com (Postfix) with ESMTP id BD08421F86A3 for <bfcpbis@ietf.org>; Wed, 30 May 2012 04:53:50 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=cisco.com; i=alanford@cisco.com; l=1502; q=dns/txt; s=iport; t=1338378830; x=1339588430; h=date:subject:from:to:message-id:in-reply-to:mime-version: content-transfer-encoding; bh=ImuIpuVrENqZ7sqJDtK3+O+yT7wKvNrAz7Otj4SOXbQ=; b=JaDjaLgnyId+CmyEkKbTFjUi8dONrGw8QoKyVh3UyB+VwGwBd9u4Kb5d SA5xl4X1MBcR3yrYiQfX0B3YnXaAzycwtqBfdQA7W7fHcKYX3V4PxGEz6 wxZtK3E3uqdH7Ynmx707CPG1WoZdJ65epfoRXaNUSrOzkhpKk5AeJmSZb o=;
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-Anti-Spam-Result: Av8EAJsJxk+Q/khR/2dsb2JhbABEtA2BB4IXAQEBAwEBAQEPAScCATEQDQEIDlkGMAEBBAESIodbAwYFC5kUlkANiUoEiiRhhUIDlRiKeIMVgWaCYQ
X-IronPort-AV: E=Sophos;i="4.75,683,1330905600";  d="scan'208";a="5146108"
Received: from ams-core-1.cisco.com ([144.254.72.81]) by ams-iport-3.cisco.com with ESMTP; 30 May 2012 11:53:49 +0000
Received: from xbh-ams-201.cisco.com (xbh-ams-201.cisco.com [144.254.75.7]) by ams-core-1.cisco.com (8.14.5/8.14.5) with ESMTP id q4UBrnrs004310; Wed, 30 May 2012 11:53:49 GMT
Received: from xmb-ams-203.cisco.com ([144.254.75.14]) by xbh-ams-201.cisco.com with Microsoft SMTPSVC(6.0.3790.4675);  Wed, 30 May 2012 13:53:49 +0200
Received: from 10.55.89.253 ([10.55.89.253]) by XMB-AMS-203.cisco.com ([144.254.75.14]) with Microsoft Exchange Server HTTP-DAV ;  Wed, 30 May 2012 11:53:48 +0000
User-Agent: Microsoft-Entourage/12.33.0.120411
Date: Wed, 30 May 2012 12:53:48 +0100
From: Alan Ford <alanford@cisco.com>
To: Woo Johnman <wuym2000cn@gmail.com>, <bfcpbis@ietf.org>
Message-ID: <CBEBC8DC.A448%alanford@cisco.com>
Thread-Topic: [bfcpbis] BFCP over DTLS
Thread-Index: Ac0+Wt9sGmIB8V5ajkO1FRnf/5rJCg==
In-Reply-To: <CAMxBvpB0pnr4Rr31m=mrypiXBJxZjk2bCvroguWAvXxzPRKjiQ@mail.gmail.com>
Mime-version: 1.0
Content-type: text/plain; charset="US-ASCII"
Content-transfer-encoding: 7bit
X-OriginalArrivalTime: 30 May 2012 11:53:49.0438 (UTC) FILETIME=[E04799E0:01CD3E5A]
Subject: Re: [bfcpbis] BFCP over DTLS
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 30 May 2012 11:53:51 -0000

Hi,

Yes, there should indeed be a reference to RFC6347 for DTLS in Section 7.

The line referencing [7] says:

   For a UDP/ DTLS connection established using the same exchange,
   either party can be the DTLS server depending on the setup attributes
   exchanged, as defined in [7].

This is referring to the use of the DTLS setup attributes (a=setup) in the
SDP, which is discussed in [7] (Section 7.1). It definitely does not suggest
the use of SRTP. I guess it could be a bit clearer in the text; the updates
in 4572bis also touch on this.

Regards,
Alan

On 30/05/2012 10:35, "Woo Johnman" <wuym2000cn@gmail.com> wrote:

> Hi,
>    I feel BFCP over DTLS is not well documented in rfc4582bis.
>   At section 7 "Lower-Layer Security".
> It says "BFCP floor control servers
>    and clients MUST support TLS for transport over TCP and MUST support DTLS
> for
>    transport over UDP [4]." But reference [4] is only about  BFCP over TLS.
> Reference for BFCP over DTLS seems missing.
> At the end of the same section,it seems say DTLS connection setup
> procedure shall
> follow [7].  If it is true, does it mean BFCP message is packeted as
> SRTP? If not, would it be better to
> give more details about DTLS connection setup and packetization.
> 
>   Please give more explain.
> 
> Thanks in advance,
> 
> Youngmin
> _______________________________________________
> bfcpbis mailing list
> bfcpbis@ietf.org
> https://www.ietf.org/mailman/listinfo/bfcpbis




From 2mkristensen@gmail.com  Wed May 30 23:07:11 2012
Return-Path: <2mkristensen@gmail.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A804121F862B for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 23:07:10 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.999
X-Spam-Level: 
X-Spam-Status: No, score=-2.999 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, J_CHICKENPOX_13=0.6, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Soy5j42pp+m5 for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 23:07:09 -0700 (PDT)
Received: from mail-ob0-f172.google.com (mail-ob0-f172.google.com [209.85.214.172]) by ietfa.amsl.com (Postfix) with ESMTP id 13A8221F8628 for <bfcpbis@ietf.org>; Wed, 30 May 2012 23:07:09 -0700 (PDT)
Received: by obbeh20 with SMTP id eh20so955796obb.31 for <bfcpbis@ietf.org>; Wed, 30 May 2012 23:07:08 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; bh=hJwNIecJvIe2GL7C68aewWXXJPWhBdmUQl8NyLrAcQU=; b=zWMsyHyVGUcR7WnuSovaP7y6Nl2S030PFKHVHxnbCleOikbwTvHFLBUxR0B3+Pad7Y mqJv8MaNsqlMEiiyukkPSh9vk2aMlGGBEC8jBkfrCcUw8R0o/wxBlMNzUGjz5pHNdZe/ 5qElbb3H9IjCAmDMUxTerqWzqSmZlfBSgFVK22b4kMYcpUQSWpATTmY+x3m7XFkoKDpc jyMRXRVm3yifc0pdapHuJfeNBGuq5da+YeGn+rdcNpYIETmBnPWnijfBhL9uv7KvItqH E29Gpp99RjBUHQI1B3F0+k2vIBzTjk4psxPsaOYidi+CZdY23KwxGoaGZGiUh7B1tq9W O7zQ==
MIME-Version: 1.0
Received: by 10.182.72.42 with SMTP id a10mr2535201obv.22.1338444428458; Wed, 30 May 2012 23:07:08 -0700 (PDT)
Received: by 10.182.72.232 with HTTP; Wed, 30 May 2012 23:07:08 -0700 (PDT)
In-Reply-To: <4F8BFAB6.2050900@ericsson.com>
References: <4F8BFAB6.2050900@ericsson.com>
Date: Thu, 31 May 2012 08:07:08 +0200
Message-ID: <CAFHv=r9yskMxgQaSn1MCWTq=oMXEucaQyNUney-XpfAMFp-hFA@mail.gmail.com>
From: Tom Kristensen <2mkristensen@gmail.com>
To: Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Cc: "bfcpbis@ietf.org" <bfcpbis@ietf.org>
Subject: Re: [bfcpbis] Old comments on RFC 4582
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 31 May 2012 06:07:11 -0000

All three comments fixed in upcoming rfc4582bis draft. Will be posted today=
.

(1) and (2) clarified as suggested by Alfred H=F6nes below, to achieve a
clearer and consistent usage of ABNF throughout the document.
(3) was a bug and is already fixed in current version. This was
mentioned in the presentation at last IETF in Paris (and verified
later by Gonzalo Camarillo).

-- Tom

On 16/04/2012, Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com> wrote:
> Hi,
>
> below you can find an old thread with comments on RFC 4582 that should
> be fixed in the new revision of the spec.
>
> Cheers,
>
> Gonzalo
>
>
> -------- Original Message --------
> Subject: Re: RFC 4582 additional note
> Date: Tue, 23 Jan 2007 13:55:14 +0200
> From: Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com>
> To: Alfred ? <ah@tr-sys.de>
> CC: jo@netlab.hut.fi,  drage@lucent.com
> References: <200612301007.LAA23236@TR-Sys.de>
> <200612301044.LAA23279@TR-Sys.de>
>
> Hi,
>
> good catch. I will also log this comment.
>
> Thanks,
>
> Gonzalo
>
> Alfred ? wrote:
>> Hello,
>> in my first note on RFC 4582, by accident I have omitted an item
>> initially intended to be included there.
>> Here we go with it:
>>
>>
>> (3)  duplicate text
>>
>> Section 13.1.1 of RFC 4582 contains two instances of the same
>> paragraph: the last paragraph on page 49 -- up to line formatting /
>> hyphenation -- is a replication of the third-to-last paragraph on
>> the same page.
>>
>>
>> Best regards,
>>   Alfred.
>
>
>
>
>
>
>
>
>
> -------- Original Message --------
> Subject: Re: RFC 4582 (BFCP) ABNF issues
> Date: Tue, 23 Jan 2007 13:50:27 +0200
> From: Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com>
> To: Alfred ? <ah@tr-sys.de>
> CC: jo@netlab.hut.fi,  drage@lucent.com
> References: <200612301007.LAA23236@TR-Sys.de>
>
> Hi Alfred,
>
> regarding 1), I agree with you that it is a formally-allowed slight
> abuse of ABNF. I will log your comments so that, if we need to revise
> the spec at some point, we fix it.
>
> Regarding 2), it is just a variation of [FLOOR-ID]. As you point out in
> 1), we could have used either [xxx] or *1(xxx) throughout the spec. It
> is unfortunate that we have used both in the same spec. However, even if
> this can be confusing, it is still correct. I will also log this comment
> for a potential future revision.
>
> Thanks a lot for your comments.
>
> Best regards,
>
> Gonzalo
>
>
>
> Alfred ? wrote:
>> Hello,
>> after studying the recently published RFC 4582 (BFCP) authored
>> by you, I'd like to report some concerns related to the ABNF
>> found in that memo.
>>
>>
>> (1)  general concern
>>
>> In ABNF, the notation   [ <group> ]   is a shorthand for:
>>                      0*1( <group> )   or shortly:
>>                       *1( <group> )  , i.e. zero or one of <group>.
>>
>> RFC 4582 repeatedly uses the ABNF notation,
>>     "*[ <group> ]" ,
>> literally meaning:
>>     "any number of { zero or one occurrences of <group> }".
>>
>> Although formally allowed by the ABNF RFC 4234, IMHO this is
>> some sort of slight abuse of ABNF;
>> as in other places, RFC 4582 better should have used
>>     "*( <group> )"
>> instead of the above notation (maybe even omitting the
>> parentheses -- but I do not recommend that, for clarity).
>>
>> This issue occurs in Figures 22, 24, 26, 28, 30, and 31..43 .
>>
>>
>> (2)  (potential) specific issue
>>
>> RFC 4582 pervasively uses the "optional" ABNF,  "[<group>]" ,
>> to denote optional syntax elements.  But there is one exception;
>> in Section 5.3.8, on page 33, Figure 38 contains the line:
>>
>>                           *1(FLOOR-ID)
>>
>> It is not evident from the context whether this is just an
>> accidential variation in the use of ABNF, i.e. intended to say:
>>
>>                           [FLOOR-ID]
>>
>> or if in fact it was intended to say:
>>
>>                           1*(FLOOR-ID)
>>
>> If the latter is true, the line in the RFC is in error and
>> I strongly recommend that you submit, as soon as possible,
>> an Author's Errata Note to the RFC Editor's RFC Errata web
>> pages, to correct this issue.
>>
>> Please comment.
>>
>>
>> Best regards,
>>   Alfred H?nes.
>>
>
> _______________________________________________
> bfcpbis mailing list
> bfcpbis@ietf.org
> https://www.ietf.org/mailman/listinfo/bfcpbis
>


--=20
# Cisco                         |  http://www.cisco.com/telepresence/
## tomkrist@cisco.com  |  http://www.tandberg.com
###                               |  http://folk.uio.no/tomkri/

From 2mkristensen@gmail.com  Wed May 30 23:58:41 2012
Return-Path: <2mkristensen@gmail.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 5DB3C11E80E5 for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 23:58:41 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.299
X-Spam-Level: 
X-Spam-Status: No, score=-3.299 tagged_above=-999 required=5 tests=[AWL=0.300,  BAYES_00=-2.599, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id pdhfX9len3MR for <bfcpbis@ietfa.amsl.com>; Wed, 30 May 2012 23:58:40 -0700 (PDT)
Received: from mail-ob0-f172.google.com (mail-ob0-f172.google.com [209.85.214.172]) by ietfa.amsl.com (Postfix) with ESMTP id 4852611E8093 for <bfcpbis@ietf.org>; Wed, 30 May 2012 23:58:40 -0700 (PDT)
Received: by obbeh20 with SMTP id eh20so1025834obb.31 for <bfcpbis@ietf.org>; Wed, 30 May 2012 23:58:39 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; bh=e7A3bbKyUb28j1MjIfuwAf/VV13Bhv6wPleA0zIwYhE=; b=eLWdnslQ+ezUARGAn2UzMxlZydj1izrfKoYru1hBoaOWTFTZy4YF6woJ6YHq/6Eogc Sc7lVmaOXAA5J83m5DftjfzltqWRWEa8s+u70S1Kml5uJrYQXufqvWpoWMLrIMt+oGSr 5SXO4YIQ/wz1XM7TqZ3o4fM0nYklQL+aM6pldKml61WMXiWsEra3T0eJVwPhaqJvVq7S zh3kc1iXQYa097fNmISlkuS8CtIiHXo2g0punLcWQdYA4D/nlrb6n7FQNRrEdi7s3PwG +L6wlRv3ybwvKJCMamRvLrp9wawd92IcZ3lHoQJGgg7sYMX189EfjLgCC+FkDuTx193F 97rg==
MIME-Version: 1.0
Received: by 10.182.155.2 with SMTP id vs2mr940824obb.47.1338447519632; Wed, 30 May 2012 23:58:39 -0700 (PDT)
Received: by 10.182.72.232 with HTTP; Wed, 30 May 2012 23:58:39 -0700 (PDT)
In-Reply-To: <4F8BFB3C.7040207@ericsson.com>
References: <49DD8DED.3010908@ericsson.com> <4F8BFB3C.7040207@ericsson.com>
Date: Thu, 31 May 2012 08:58:39 +0200
Message-ID: <CAFHv=r-HYXM-F+-aTz8hc94tkx0=L9NwXZOsuA-4veDrS-sM8g@mail.gmail.com>
From: Tom Kristensen <2mkristensen@gmail.com>
To: Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com>
Content-Type: text/plain; charset=ISO-8859-1
Cc: "bfcpbis@ietf.org" <bfcpbis@ietf.org>
Subject: Re: [bfcpbis] More comments on RFC 4582
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 31 May 2012 06:58:41 -0000

On 16/04/2012, Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com> wrote:
> Hi,
>
> below you can find another old email with more comments on RFC 4582.
[...]

I've commented the issues inline below.
The two new error codes is included in the upcoming draft version.

-------------------------------------------------------------------------------------
> [...]                                            I got the action
> point to list the things that could be fixed in a potential revised
> BFCP spec. These are the contents of my notes. Of course, if someone
> knows of more issues, please let us know:
>
> o When a user performs a third-party floor request the beneficiary of
> the floor is not informed when the floor is granted. This may not be
> a problem because endpoints using third-party floor requests probably
> have different means to get in synch but we may want to add some text
> about this.

Tom: Not sure this is needed, as it is stated in Section 2 that:
"... The protocol between a floor participant and a media participant
 (that are not colocated) is outside the scope of this document".

> o We do not have errors for an unsupported version of the protocol or
> for wrong message length. We do not have a general error either.

Tom: Unsupported version is handled in the current version of the
rfc4582bis draft. The other two is added to the upcoming version,
i.e. Incorrect Message Length and Generic Error.

> o When we get more experience on queue management from real
> deployments, it would be nice to explaining it further in the spec.

Tom: I have no knowledge of queue management from deployments.
Does anyone else out there have any deployment experience? If not,
we don't really have much to add at present.

> o UserStatus
>
> UserStatus =   (COMMON-HEADER)
>                  [BENEFICIARY-INFORMATION]
>                1*(FLOOR-REQUEST-INFORMATION) -> remove the 1
>                 *[EXTENSION-ATTRIBUTE]

Tom: Was already correct in RFC4582, outdated note I presume.

> o A message may need to be longer than the maximum message length
> supported by the protocol

Tom: We've solved the fragmentation issue. No demands voiced for length
exceeding the maximum message length for reliable transport voiced in
BFCPbis.

> o A rather small number of typos

Tom: A couple of typos fixed in both current and upcoming version of
rfc4582bis. Reviewers might find more!
-------------------------------------------------------------------------------------


-- Tom

-- 
# Cisco                         |  http://www.cisco.com/telepresence/
## tomkrist@cisco.com  |  http://www.tandberg.com
###                               |  http://folk.uio.no/tomkri/

From 2mkristensen@gmail.com  Thu May 31 00:00:37 2012
Return-Path: <2mkristensen@gmail.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 520F611E80E5 for <bfcpbis@ietfa.amsl.com>; Thu, 31 May 2012 00:00:37 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.449
X-Spam-Level: 
X-Spam-Status: No, score=-3.449 tagged_above=-999 required=5 tests=[AWL=0.150,  BAYES_00=-2.599, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id C1VJoVkJZKdv for <bfcpbis@ietfa.amsl.com>; Thu, 31 May 2012 00:00:36 -0700 (PDT)
Received: from mail-ob0-f172.google.com (mail-ob0-f172.google.com [209.85.214.172]) by ietfa.amsl.com (Postfix) with ESMTP id 9D64511E8093 for <bfcpbis@ietf.org>; Thu, 31 May 2012 00:00:34 -0700 (PDT)
Received: by obbeh20 with SMTP id eh20so1028696obb.31 for <bfcpbis@ietf.org>; Thu, 31 May 2012 00:00:33 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; bh=v+Xhy4bKYfQjgmoIb8s7pRFxtsse/SsvPhie0wSuxI8=; b=jPvtbWXyQxhj0bUYY3pldBUaT1YIrB2ehT24nqyQ1en/IGp+r76f8NPl7kicd3xdJA IaRWUsPfFOxoTnu+LwYDSGVvIdRpISSU1BLMWLF3+uJHWsfqt+COBwWsx7tZlojMPpdS yCkRpkso+/PlCaiGstOfold+JYLy0bJV4za+RtGj4Idx5NXZUwtYlFVdshw+iOwjM4lW HXqKTPBPZ8PK52pEqZhsZWkcz9OXInoVNn+iewUmK8JTAxNrSDuu6Uhmup99a99UyOAR kBkBRIsXWwZlqZPBYxhHGJ5FB7rSRu57e8M6owU6JtaTt7a38GrNQhf0l9ypWHgxC1Ns UFtQ==
MIME-Version: 1.0
Received: by 10.60.4.165 with SMTP id l5mr17826951oel.41.1338447633462; Thu, 31 May 2012 00:00:33 -0700 (PDT)
Received: by 10.182.72.232 with HTTP; Thu, 31 May 2012 00:00:33 -0700 (PDT)
In-Reply-To: <4FC4AA69.2040004@ericsson.com>
References: <4FC4AA69.2040004@ericsson.com>
Date: Thu, 31 May 2012 09:00:33 +0200
Message-ID: <CAFHv=r-SJCEFZMvuDk9_k3LUkccya_aQeNW-7oRmHXKbGnmEKw@mail.gmail.com>
From: Tom Kristensen <2mkristensen@gmail.com>
To: Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com>
Content-Type: text/plain; charset=ISO-8859-1
Cc: bfcpbis@ietf.org
Subject: Re: [bfcpbis] No activity in this WG for a while
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 31 May 2012 07:00:37 -0000

On 29/05/2012, Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com> wrote:
> Folks,
>
> I have not seen any activity in this WG for a while. Please, I would
> like to see more activity around the WG's chartered items.

As the main activity maker, I'm sorry for this. Responses now
provided, the upcoming draft versions for review by WG will be posted
ASAP.

-- Tom

-- 
# Cisco                         |  http://www.cisco.com/telepresence/
## tomkrist@cisco.com  |  http://www.tandberg.com
###                               |  http://folk.uio.no/tomkri/

From eckelcu@cisco.com  Thu May 31 08:46:11 2012
Return-Path: <eckelcu@cisco.com>
X-Original-To: bfcpbis@ietfa.amsl.com
Delivered-To: bfcpbis@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 5626C11E8128 for <bfcpbis@ietfa.amsl.com>; Thu, 31 May 2012 08:46:11 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -10.499
X-Spam-Level: 
X-Spam-Status: No, score=-10.499 tagged_above=-999 required=5 tests=[AWL=0.100, BAYES_00=-2.599, RCVD_IN_DNSWL_HI=-8]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id IboOGMcL-H27 for <bfcpbis@ietfa.amsl.com>; Thu, 31 May 2012 08:46:10 -0700 (PDT)
Received: from mtv-iport-4.cisco.com (mtv-iport-4.cisco.com [173.36.130.15]) by ietfa.amsl.com (Postfix) with ESMTP id 65ABB11E811C for <bfcpbis@ietf.org>; Thu, 31 May 2012 08:46:10 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=cisco.com; i=eckelcu@cisco.com; l=3492; q=dns/txt; s=iport; t=1338479170; x=1339688770; h=mime-version:content-transfer-encoding:subject:date: message-id:in-reply-to:references:from:to:cc; bh=Pjr0usQyMbU1drp1f73KxVAac7ZQ6k8dZFUaGt0WgFc=; b=KiLHG75XNtqlqWgUDK3s5mDFHlMHlzZzXpuzbK46kYG2uLhJOyuzgsSZ 8qR+X6MCoyi1OvQQ6mNlJC9E7lnM2c/OP1mpKOfekwJ08H0xEhV04e8XI b4Kah/fsJw3AE7IWCUJ7jkzT1Ykklp1Htz4WbEYw6DLdaSkn3VGTEkb+V k=;
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-Anti-Spam-Result: AgAFAHORx0+rRDoH/2dsb2JhbABEtAyBB4IYAQEBBAEBAQ8BFAkKGxkLDAQCAQgOAwQBAQEKBhcBBgEmHwkIAQEEARIIGodoAQuZN59ZixGEZmADiECNZ4lsgxKBZoMAgT8
X-IronPort-AV: E=Sophos;i="4.75,693,1330905600"; d="scan'208";a="47043116"
Received: from mtv-core-2.cisco.com ([171.68.58.7]) by mtv-iport-4.cisco.com with ESMTP; 31 May 2012 15:46:10 +0000
Received: from xbh-sjc-231.amer.cisco.com (xbh-sjc-231.cisco.com [128.107.191.100]) by mtv-core-2.cisco.com (8.14.5/8.14.5) with ESMTP id q4VFkA0Q010262; Thu, 31 May 2012 15:46:10 GMT
Received: from xmb-sjc-234.amer.cisco.com ([128.107.191.111]) by xbh-sjc-231.amer.cisco.com with Microsoft SMTPSVC(6.0.3790.4675);  Thu, 31 May 2012 08:46:09 -0700
X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
Date: Thu, 31 May 2012 08:46:06 -0700
Message-ID: <E1CBF4C7095A3D4CAAAEAD09FBB8E08C0738688C@xmb-sjc-234.amer.cisco.com>
In-Reply-To: <CAFHv=r-HYXM-F+-aTz8hc94tkx0=L9NwXZOsuA-4veDrS-sM8g@mail.gmail.com>
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
Thread-Topic: [bfcpbis] More comments on RFC 4582
Thread-Index: Ac0++tvA2M2IzxSgSfinQ3pyrMlGRgASV+Mg
References: <49DD8DED.3010908@ericsson.com><4F8BFB3C.7040207@ericsson.com> <CAFHv=r-HYXM-F+-aTz8hc94tkx0=L9NwXZOsuA-4veDrS-sM8g@mail.gmail.com>
From: "Charles Eckel (eckelcu)" <eckelcu@cisco.com>
To: "Tom Kristensen" <2mkristensen@gmail.com>, "Gonzalo Camarillo" <Gonzalo.Camarillo@ericsson.com>
X-OriginalArrivalTime: 31 May 2012 15:46:09.0906 (UTC) FILETIME=[7FDBF520:01CD3F44]
Cc: bfcpbis@ietf.org
Subject: Re: [bfcpbis] More comments on RFC 4582
X-BeenThere: bfcpbis@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: BFCPBIS working group discussion list <bfcpbis.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/bfcpbis>
List-Post: <mailto:bfcpbis@ietf.org>
List-Help: <mailto:bfcpbis-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/bfcpbis>, <mailto:bfcpbis-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 31 May 2012 15:46:11 -0000

(as an individual)

I agree with Tom's assessments and think the comments have been
addressed adequately.

Cheers,
Charles

> -----Original Message-----
> From: bfcpbis-bounces@ietf.org [mailto:bfcpbis-bounces@ietf.org] On
> Behalf Of Tom Kristensen
> Sent: Wednesday, May 30, 2012 11:59 PM
> To: Gonzalo Camarillo
> Cc: bfcpbis@ietf.org
> Subject: Re: [bfcpbis] More comments on RFC 4582
>=20
> On 16/04/2012, Gonzalo Camarillo <Gonzalo.Camarillo@ericsson.com>
> wrote:
> > Hi,
> >
> > below you can find another old email with more comments on RFC 4582.
> [...]
>=20
> I've commented the issues inline below.
> The two new error codes is included in the upcoming draft version.
>=20
>
-----------------------------------------------------------------------
> --------------
> > [...]                                            I got the action
> > point to list the things that could be fixed in a potential revised
> > BFCP spec. These are the contents of my notes. Of course, if someone
> > knows of more issues, please let us know:
> >
> > o When a user performs a third-party floor request the beneficiary
of
> > the floor is not informed when the floor is granted. This may not be
> > a problem because endpoints using third-party floor requests
probably
> > have different means to get in synch but we may want to add some
text
> > about this.
>=20
> Tom: Not sure this is needed, as it is stated in Section 2 that:
> "... The protocol between a floor participant and a media participant
>  (that are not colocated) is outside the scope of this document".
>=20
> > o We do not have errors for an unsupported version of the protocol
or
> > for wrong message length. We do not have a general error either.
>=20
> Tom: Unsupported version is handled in the current version of the
> rfc4582bis draft. The other two is added to the upcoming version,
> i.e. Incorrect Message Length and Generic Error.
>=20
> > o When we get more experience on queue management from real
> > deployments, it would be nice to explaining it further in the spec.
>=20
> Tom: I have no knowledge of queue management from deployments.
> Does anyone else out there have any deployment experience? If not,
> we don't really have much to add at present.
>=20
> > o UserStatus
> >
> > UserStatus =3D   (COMMON-HEADER)
> >                  [BENEFICIARY-INFORMATION]
> >                1*(FLOOR-REQUEST-INFORMATION) -> remove the 1
> >                 *[EXTENSION-ATTRIBUTE]
>=20
> Tom: Was already correct in RFC4582, outdated note I presume.
>=20
> > o A message may need to be longer than the maximum message length
> > supported by the protocol
>=20
> Tom: We've solved the fragmentation issue. No demands voiced for
length
> exceeding the maximum message length for reliable transport voiced in
> BFCPbis.
>=20
> > o A rather small number of typos
>=20
> Tom: A couple of typos fixed in both current and upcoming version of
> rfc4582bis. Reviewers might find more!
>
-----------------------------------------------------------------------
> --------------
>=20
>=20
> -- Tom
>=20
> --
> # Cisco                         |  http://www.cisco.com/telepresence/
> ## tomkrist@cisco.com  |  http://www.tandberg.com
> ###                               |  http://folk.uio.no/tomkri/
> _______________________________________________
> bfcpbis mailing list
> bfcpbis@ietf.org
> https://www.ietf.org/mailman/listinfo/bfcpbis
