Subject: [Bier] WGLC: draft-ietf-bier-ospf-bier-extensions-05

From: Greg Shepherd <[email-masked]>
Date: Wed, 14 Jun 2017 14:34:31 -0700

BIER, OSPF

At BIER WG meeting, IETF97 in Chicago, we decided to move forward to WGLC for
some of our docs. We learned that even once published the IESG has a
process to change the track of the RFC if the WG makes the case to move the
work from Informational to Standards track. The feedback from operators is
that RFC status was more important than track, and we won't be able to meet
our charter requirements to change track without deployment experience and
operator support.

This email starts a two week timer for feedback on the draft:
https://datatracker.ietf.org/doc/draft-ietf-bier-ospf-bier-extensions/

WGLC to run in parallel in both BIER and OSPF WGs due to the scope of the
work.

Thanks,
Greg
(BIER Chairs)

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sun, 18 Jun 2017 18:40:13 +0000

Hi Greg, Authors,

I support publication. Also, I have two comments.

   1. It is somewhat strange to make protocol drafts standards track while the architecture and encapsulations are experimental.
   2. The OSPF encoding will not support the second example in https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt. In this example, the BSL 256 and 512 are intermixed. While with the encoding, they would need to be two separate ranges of labels.

I also have some editorial comments but I’ll just pass them to the authors.

Thanks,
Acee

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Greg Shepherd <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, June 14, 2017 at 5:34 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: [Bier] WGLC: draft-ietf-bier-ospf-bier-extensions-05

BIER, OSPF

At BIER WG meeting, IETF97 in Chicago, we decided to move forward to WGLC for some of our docs. We learned that even once published the IESG has a process to change the track of the RFC if the WG makes the case to move the work from Informational to Standards track. The feedback from operators is that RFC status was more important than track, and we won't be able to meet our charter requirements to change track without deployment experience and operator support.

WGLC to run in parallel in both BIER and OSPF WGs due to the scope of the work.

Thanks,
Greg
(BIER Chairs)

---

From: Tony Przygienda <[email-masked]>
Date: Sun, 18 Jun 2017 12:17:05 -0700

Acee, can you refer to more specific section in  https://www.ietf.org/id/
<https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt>
draft-ietf-bier-mpls-encapsulation-07.txt
<https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt>
<https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt> ? I
don't think that it is assumed that BSL 256 and 512 in the same subdomain
would ever share labels ...  I sent the conceptual model on the AD review
for -architecture that all drafts follow (as far I understood/helped
writing them) ...

--- tony

On Sun, Jun 18, 2017 at 11:40 AM, Acee Lindem (acee) <[email-masked]> wrote:

>    1. It is somewhat strange to make protocol drafts standards track while
> the architecture and encapsulations are experimental.
>    2. The OSPF encoding will not support the second example in
> https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt. In
> this example, the BSL 256 and 512 are intermixed. While with the encoding,
> they would need to be two separate ranges of labels.
>
> From: BIER <[email-masked]> on behalf of Greg Shepherd <
> [email-masked]>
> Reply-To: "[email-masked]" <[email-masked]>
> To: "[email-masked]" <[email-masked]>, OSPF WG List <[email-masked]>
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>
>

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 19 Jun 2017 01:12:54 +0000

Hi Tony,

I’m not saying they that BSL 256 and 512 bit strings would share any labels. What I’m saying is that the OSPF encoding (didn’t look at IS-IS) doesn’t allow them to share the same label range yet the example in the MPLS encapsulation draft implies that they are interleaved by SD in the same label range. Here is the second example:

      L1:   corresponding to SD 0, BSL 256, SI 0.

      L2:   corresponding to SD 0, BSL 256, SI 1.

      L3:   corresponding to SD 0, BSL 256, SI 2.

      L4:   corresponding to SD 0, BSL 256, SI 3.

      L5:   corresponding to SD 0, BSL 512, SI 0.

      L6:   corresponding to SD 0, BSL 512, SI 1.

      L7:   corresponding to SD 1, BSL 256, SI 0.

      L8:   corresponding to SD 1, BSL 256, SI 1.

      L9:   corresponding to SD 1, BSL 256, SI 2.

      L10:  corresponding to SD 1, BSL 256, SI 3.

      L11:  corresponding to SD 1, BSL 512, SI 0.

      L12:  corresponding to SD 1, BSL 512, SI 1.

Note that they are ordered by SD – not BSL. However, that the OSPF encoding is BSL specific. So, a label range would only include the SD/SI labels for a single BSL.

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |              Type             |             Length            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |Lbl Range Size |                Label Range Base               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   | BS Length |                    Reserved                       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

I think the example should be updated to match the protocol encoding.

Thanks,
Acee

From: Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Date: Sunday, June 18, 2017 at 3:17 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WGLC: draft-ietf-bier-ospf-bier-extensions-05

Acee, can you refer to more specific section in  https://www.ietf.org/id/<https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt>draft-ietf-bier-mpls-encapsulation-07.txt<https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt><https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt> ? I don't think that it is assumed that BSL 256 and 512 in the same subdomain would ever share labels ...  I sent the conceptual model on the AD review for -architecture that all drafts follow (as far I understood/helped writing them) ...

--- tony

On Sun, Jun 18, 2017 at 11:40 AM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg, Authors,

Thanks,
Acee

BIER, OSPF

Thanks,
Greg
(BIER Chairs)

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

--
We’ve heard that a million monkeys at a million keyboards could produce the complete works of Shakespeare; now, thanks to the Internet, we know that is not true.
—Robert Wilensky

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 19 Jun 2017 01:17:40 +0000

Hi,
I see now that all the documents are standards track so scratch the first comment. I’m not sure where I got the “experimental”…
Thanks,
Acee

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Acee Lindem <[email-masked]<mailto:[email-masked]>>
Date: Sunday, June 18, 2017 at 2:40 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WGLC: draft-ietf-bier-ospf-bier-extensions-05

Hi Greg, Authors,

Thanks,
Acee

BIER, OSPF

Thanks,
Greg
(BIER Chairs)

---

From: Tony Przygienda <[email-masked]>
Date: Sun, 18 Jun 2017 19:21:26 -0700

The example is correct even under the assumption label values  L1-L11 are
ordered.  Encoding says for subdomain label range encodings in 2.2:

It MAY appear multiple times in the BIER Sub-TLV.

That aligns as well with the conceptual model I sent out ...

ISIS and OSPF encodings are 100% alligned ...

On Sun, Jun 18, 2017 at 6:12 PM, Acee Lindem (acee) <[email-masked]> wrote:

> Hi Tony,
>
> I’m not saying they that BSL 256 and 512 bit strings would share any
> labels. What I’m saying is that the OSPF encoding (didn’t look at IS-IS)
> doesn’t allow them to share the same label range yet the example in the
> MPLS encapsulation draft implies that they are interleaved by SD in the
> same label range. Here is the second example:
>
>
> Note that they are ordered by SD – not BSL. However, that the OSPF
> encoding is BSL specific. So, a label range would only include the SD/SI
> labels for a single BSL.
>
>     0                   1                   2                   3
> From: Tony Przygienda <[email-masked]>
> To: Acee Lindem <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>,
> OSPF WG List <[email-masked]>
> <https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt>dr
> aft-ietf-bier-mpls-encapsulation-07.txt
>>    1. It is somewhat strange to make protocol drafts standards track
>> while the architecture and encapsulations are experimental.

---

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 19 Jun 2017 10:54:22 +0200

Hi Acee,

Thanks for the comments.

The ordering is not by SD, but SI.

The text below this example says the following:

"The first label in the range could correspond to SI 0, and the second to SI 1."

The “key” for the Label range is {SD, BSL}, and the index into the range is SI. So in the example below you see a Label range of 4 labels (L1-L4) for {0,256}, 2 labels (L5-L6) for {0,512}, etc….

Does that clarify it?

Thx,

Ice.

> On 19 Jun 2017, at 03:12, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Tony, 
> 
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, OSPF WG List <[email-masked]>
> Acee, can you refer to more specific section in  https://www.ietf.org/id/draft-ietf-bier-mpls-encapsulation-07.txt ? I don't think that it is assumed that BSL 256 and 512 in the same subdomain would ever share labels ...  I sent the conceptual model on the AD review for -architecture that all drafts follow (as far I understood/helped writing them) ... 
> 
> --- tony 
> 
> From: BIER <[email-masked]> on behalf of Greg Shepherd <[email-masked]>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 19 Jun 2017 11:41:22 +0000

Ice, Tony,
I think It would be good then to tie the IGP encodings to the two examples. The second example in the MPLS encapsulation draft implies a single contiguous range of labels when, in fact, it must be encoded as 4 separate label ranges in the OSPF draft.

Thanks,
Acee

From: "IJsbrand Wijnands (iwijnand)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, June 19, 2017 at 4:54 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: Tony Przygienda <[email-masked]<mailto:[email-masked]>>, OSPF WG List <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WGLC: draft-ietf-bier-ospf-bier-extensions-05

Hi Acee,

Thanks for the comments.

Does that clarify it?

Thx,

Ice.

On 19 Jun 2017, at 03:12, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tony,

    0                   1                   2                   3

Thanks,
Acee

--- tony

Thanks,
Acee

BIER, OSPF

Thanks,
Greg
(BIER Chairs)

---

From: Eric C Rosen <[email-masked]>
Date: Mon, 19 Jun 2017 17:44:07 -0400

> It is somewhat strange to make protocol drafts standards track while 

I believe the documents are all supposed to be Experimental. However, 
this is not necessarily reflected correctly on the first page of each draft.

> The second example in the MPLS encapsulation draft implies a single 
> contiguous range of labels when, in fact, it must be encoded as 4 
> separate label ranges in the OSPF draft. 

That implication is unintended, as there is no suggestion that the 
labels L1, ..., L12 are successive numeric values.  At least, there was 
no intent to suggest that.  I can add a sentence to make that clearer.

> I think It would be good then to tie the IGP encodings to the two 
> examples.

I think it is appropriate in that example to point out that twelve 
labels must be allocated, each corresponding to a different <SD, BDL, 
SI> triple.  How those twelve labels get signaled is outside the scope 
of the encapsulation spec, and is totally a matter for the signaling 
documents to address.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 19 Jun 2017 21:52:24 +0000

Hi Eric, 

>this is not necessarily reflected correctly on the first page of each

They seem to be all “Standards Track” right now.
>no intent to suggest that.  I can add a sentence to make that clearer.

Yes - that would definitely satisfy my comment.

>of the encapsulation spec, and is totally a matter for the signaling

I agree. After our protracted discussion, I did see that the OSPF draft
explicitly specifies "A unique label range is allocated for each BitStream
length and Sub-domain-ID.” However, I still think it would be clearer if
the protocol draft said something like: "For example, to advertise the
labels of the BitStrings in the second example in […], four labels ranges
would be advertised, one for each unique Sub-Domain and Bit String Length
tuple.”

Thanks,
Acee