Subject: [Bier] Alissa Cooper's No Objection on draft-ietf-bier-architecture-07: (with COMMENT)

From: Alissa Cooper <[email-masked]>
Date: Wed, 05 Jul 2017 10:23:03 -0700

Alissa Cooper has entered the following ballot position for
draft-ietf-bier-architecture-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bier-architecture/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I'm a bit confused about the experimental status of this document as well,
given that the other WG drafts that define protocol extensions to support BIER
seem to be headed for the standards track. If what is documented here really is
the only experimental part, this seems like the place to document the
experiment.

---

From: Alia Atlas <[email-masked]>
Date: Wed, 5 Jul 2017 13:33:05 -0400

The entire WG is chartered as Experimental.  There is a document in the
charter (item 9) to justify progressing this work onto the Standards
Track.  The protocol extension drafts are going to be Experimental for now
as well. This is precisely at the narrow point of the hourglass - a
multicast encapsulation to go with IP.

Regards,
Alia

---

From: "Dolganow, Andrew (Nokia - SG/Singapore)" <[email-masked]>
Date: Mon, 10 Jul 2017 03:37:07 +0000

We have discussed this at the last WG meeting. I was one who raised a concern about Experimental vs Standards move. My concern is still valid but it does not really apply to BIER WG (although I may be biased☺).

As IETF, we lack a clear definition of what “standard” must be met when moving things from one track to another. As result, working groups can one by one chip away from what the rules should be met and create more and more relaxed criteria. We need to strike a proper balance here I believe. The two common “criteria” discussed are:

-          We want multiple implementations that interop – but implementations are not equal, I would argue we want commercial implementations. I would also say we want a clear number of implementations required - that allows enough to drive interop, allow small vendor innovation/disruption or critical mass from large vendors

-          We want deployments – again this is tricky, I do not think we need to wait for mass deployments, but we at least need few lab evaluations with serious intend to deploy, again we may put some number how many are needed and again allow both small operators or large operator to create a “bar” that is fair and balanced

I think, that BIER is at a point when both industry (vendors) and operators would meet even strict rules of the move to standards but we (a WG) should not be guessing what rules we need to meet and it seemed to me at the last , meeting we were.

Andrew

From: Alia Atlas <[email-masked]>
Date: Thursday, July 6, 2017 at 1:33 AM
To: Alissa Cooper <[email-masked]>
Cc: The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, Greg Shepherd <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Alissa Cooper's No Objection on draft-ietf-bier-architecture-07: (with COMMENT)
Resent-From: <[email-masked]>
Resent-To: "(Ice) IJsbrand Wijnands" <[email-masked]>, Eric Rosen <[email-masked]>, Andrew Dolganow <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Thursday, July 6, 2017 at 1:33 AM

The entire WG is chartered as Experimental.  There is a document in the charter (item 9) to justify progressing this work onto the Standards Track.  The protocol extension drafts are going to be Experimental for now as well. This is precisely at the narrow point of the hourglass - a multicast encapsulation to go with IP.

Regards,
Alia

On Wed, Jul 5, 2017 at 1:23 PM, Alissa Cooper <[email-masked]<mailto:[email-masked]>> wrote:
Alissa Cooper has entered the following ballot position for
draft-ietf-bier-architecture-07: No Objection