Subject: [Bier] Kathleen Moriarty's Discuss on draft-ietf-bier-mpls-encapsulation-11: (with DISCUSS)

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 25 Oct 2017 19:28:10 -0700

Kathleen Moriarty has entered the following ballot position for
draft-ietf-bier-mpls-encapsulation-11: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bier-mpls-encapsulation/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I share the concerns of the SecDir reviewer and would like to see more text in
the Security Considerations that reflect the inherent trust model and also the
lack of integrity protection for the BIER encapsulation.  Having these items
detailed explicitly is an important consideration for implementers.  I do
realize that this is the current state with MPLS, but it bears repeating for a
new encapsulation.

https://mailarchive.ietf.org/arch/msg/secdir/w8qqQtzlEi00uToUGT0N8XVuHkI

Thank you.

---

From: Eric C Rosen <[email-masked]>
Date: Fri, 27 Oct 2017 13:12:05 -0400

Hi Kathleen,

Please let me know if the revised Security Considerations section 
(below) is satisfactory.  If so, I'll put it in revision 12.  If not, 
I'll keep trying ;-)

Eric

6.  Security Considerations

    Insofar as this document makes use of MPLS, it inherits any security
    considerations that apply to the use of the MPLS data plane.

    If a BIER encapsulation header is modified in ways other than those
    specified in [BIER_ARCH] and in this document, packets may be lost,
    stolen, or otherwise misdelivered.  Such modifications are likely to
    go undetected, as the BIER encapsulation does not provide
    cryptographic integrity protection.

    Layer 2 encryption can be used to ensure that a BIER-encapsulated
    packet is not altered while in transit between adjacent BFRs.  If a
    BFR itself is compromised, there is no way to prevent the compromised
    BFR from making illegitimate modifications to the BIER header, or to
    prevent it from misforwarding or misdelivering the a BIER-
    encapsulated packet.

    If the routing underlay (see Section 4.1 of [BIER_ARCH]) is based on
    a unicast routing protocol, BIER assumes that the routers
    participating in the unicast routing protocol have not been
    compromised.  BIER has no procedures to ensure that the unicast
    routing adjacencies have not been compromised; that falls within the
    scope of whatever unicast routing protocols are being used.

    BIER-encapsulated packets should generally not be accepted from
    untrusted interfaces or tunnels.  For example, an operator may wish
    to have a policy of accepting BIER-encapsulated packets only from
    interfaces to trusted routers, and not from customer-facing
    interfaces.

    There may be applications that require a BFR to accept a BIER-
    encapsulated packet from an interface to a system that is not
    controlled by the network operator.  For instance, there may be an
    application in which a Virtual Machine in a Data Center submits BIER-
    encapsulated packets to a router.  In such a case, it is desirable to
    verify that the packet is from a legitimate source, and that its
    BitString denotes only systems to which that source is allowed to
    send.  However, the BIER encapsulation itself does not provide a way
    to verify that the source is legitimate, or that the source is really
    the system denoted by the BFIR-id, or that the source is allowed to
    set any particular set of bits in the BitString.

    Insofar as this document relies upon IGP extensions, it inherits any
    security considerations that apply to the IGP.

    The security considerations of [BIER_ARCH] also apply.

On 10/25/2017 10:28 PM, Kathleen Moriarty wrote:
> Please refer to https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=-DXB84eU9m4cIlq2OOcCJCQQAwJXQQswyu3F0kG0VNo&m=f76c-ykCe8xC9AXPXrsuMm5HjZ-QAzYgxKtY_ihqMVo&s=OfYzxJSZV4RmKEHFryUgx2-0gTSjNW_0eG8nmtK-1OY&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dbier-2Dmpls-2Dencapsulation_&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=-DXB84eU9m4cIlq2OOcCJCQQAwJXQQswyu3F0kG0VNo&m=f76c-ykCe8xC9AXPXrsuMm5HjZ-QAzYgxKtY_ihqMVo&s=9IMDF-PfGbw9KB9ReDE4iAVHyv0ZiOT1Vy7q_7zocvM&e=
>
>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_secdir_w8qqQtzlEi00uToUGT0N8XVuHkI&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=-DXB84eU9m4cIlq2OOcCJCQQAwJXQQswyu3F0kG0VNo&m=f76c-ykCe8xC9AXPXrsuMm5HjZ-QAzYgxKtY_ihqMVo&s=szYawOrHFpLG9vyXf4ebNeTwfqA7UJJ8mhxiObDzaS0&e=
>
> Thank you.
>
>
>
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 27 Oct 2017 14:06:38 -0400

Eric,

Thank you very much, that is a big improvement.  Once -12 is posted, I
will clear.

Best regards,
Kathleen

On Fri, Oct 27, 2017 at 1:12 PM, Eric C Rosen <[email-masked]> wrote:
> Hi Kathleen,
>
> Please let me know if the revised Security Considerations section (below) is
> satisfactory.  If so, I'll put it in revision 12.  If not, I'll keep trying
> ;-)
>
> Eric
>
>> Please refer to
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=-DXB84eU9m4cIlq2OOcCJCQQAwJXQQswyu3F0kG0VNo&m=f76c-ykCe8xC9AXPXrsuMm5HjZ-QAzYgxKtY_ihqMVo&s=OfYzxJSZV4RmKEHFryUgx2-0gTSjNW_0eG8nmtK-1OY&e=

-- 

Best regards,
Kathleen

---

From: Alia Atlas <[email-masked]>
Date: Fri, 27 Oct 2017 14:25:16 -0400

Thanks to you both.

On Oct 27, 2017 2:07 PM, "Kathleen Moriarty" <
[email-masked]> wrote:

> (below) is
> >> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwICaQ&c=
> HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=-
> DXB84eU9m4cIlq2OOcCJCQQAwJXQQswyu3F0kG0VNo&m=f76c-ykCe8xC9AXPXrsuMm5HjZ-
> QAzYgxKtY_ihqMVo&s=OfYzxJSZV4RmKEHFryUgx2-0gTSjNW_0eG8nmtK-1OY&e=
> >> https://urldefense.proofpoint.com/v2/url?u=https-3A__
> datatracker.ietf.org_doc_draft-2Dietf-2Dbier-2Dmpls-
> 2Dencapsulation_&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=-DXB84eU9m4cIlq2OOcCJCQQAwJXQQswyu3F0kG0VNo&m=f76c-
> ykCe8xC9AXPXrsuMm5HjZ-QAzYgxKtY_ihqMVo&s=9IMDF-
> PfGbw9KB9ReDE4iAVHyv0ZiOT1Vy7q_7zocvM&e=
> >>
> >>
> >>
> >> the Security Considerations that reflect the inherent trust model and
> also
> >> the
> >> https://urldefense.proofpoint.com/v2/url?u=https-3A__
> mailarchive.ietf.org_arch_msg_secdir_w8qqQtzlEi00uToUGT0N8XVuHkI&d=
> DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=-
> DXB84eU9m4cIlq2OOcCJCQQAwJXQQswyu3F0kG0VNo&m=f76c-ykCe8xC9AXPXrsuMm5HjZ-
> QAzYgxKtY_ihqMVo&s=szYawOrHFpLG9vyXf4ebNeTwfqA7UJJ8mhxiObDzaS0&e=
> >>
> >> Thank you.
> >>
> >>
> >>
> >>
> >
>
>
>
> --
>
> Best regards,
> Kathleen
>
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>