Subject: Re: [Bier] RFC 8279 on Multicast Using Bit Index Explicit Replication (BIER))

From: Toerless Eckert <[email-masked]>
Date: Wed, 22 Nov 2017 00:12:56 +0100

If you wonder why there is no big hurray !!!!!!,
congratulations for the RFC here on the mailing list,
here are my top guesses:

a) We already had it in Singapore in the BIER WG meeting.
c) We're all still in jet lag koma after flying back from Singapore
b) We're all getting ready for thanksgiving

Nevertheless: hurray!!!!!

Happy thanksgiving (applicable to U.S. residents)
  Toerless

In-Reply-To: <[email-masked]>

On Mon, Nov 20, 2017 at 12:40:27PM -0800, [email-masked] wrote:
> A new Request for Comments is now available in online RFC libraries.
> 
>         
>         RFC 8279
> 
>         Title:      Multicast Using Bit Index Explicit 
>                     Replication (BIER) 
>         Author:     I. Wijnands, Ed.,
>                     E. Rosen, Ed.,
>                     A. Dolganow,
>                     T. Przygienda,
>                     S. Aldrin
>         Status:     Experimental
>         Stream:     IETF
>         Date:       November 2017
>         Mailbox:    [email-masked],
>                     [email-masked],
>                     [email-masked],
>                     [email-masked],
>                     [email-masked]
>         Pages:      43
>         Characters: 97283
>         Updates/Obsoletes/SeeAlso:   None
> 
>         I-D Tag:    draft-ietf-bier-architecture-08.txt
> 
>         URL:        https://www.rfc-editor.org/info/rfc8279
> 
>         DOI:        10.17487/RFC8279
> 
> This document specifies a new architecture for the forwarding of
> multicast data packets.  It provides optimal forwarding of multicast
> packets through a "multicast domain".  However, it does not require a
> protocol for explicitly building multicast distribution trees, nor
> does it require intermediate nodes to maintain any per-flow state.
> This architecture is known as "Bit Index Explicit Replication"
> (BIER).  When a multicast data packet enters the domain, the ingress
> router determines the set of egress routers to which the packet needs
> to be sent.  The ingress router then encapsulates the packet in a
> BIER header.  The BIER header contains a bit string in which each bit
> represents exactly one egress router in the domain; to forward the
> packet to a given set of egress routers, the bits corresponding to
> those routers are set in the BIER header.  The procedures for
> forwarding a packet based on its BIER header are specified in this
> document.  Elimination of the per-flow state and the explicit
> tree-building protocols results in a considerable simplification.
> 
> This document is a product of the Bit Indexed Explicit Replication Working Group of the IETF.
> 
> 
> EXPERIMENTAL: This memo defines an Experimental Protocol for the
> Internet community.  It does not specify an Internet standard of any
> kind. Discussion and suggestions for improvement are requested.
> Distribution of this memo is unlimited.
> 
> This announcement is sent to the IETF-Announce and rfc-dist lists.
> To subscribe or unsubscribe, see
>   https://www.ietf.org/mailman/listinfo/ietf-announce
>   https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
> 
> For searching the RFC series, see https://www.rfc-editor.org/search
> For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk
> 
> Requests for special distribution should be addressed to either the
> author of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for
> unlimited distribution.
> 
> 
> The RFC Editor Team
> Association Management Solutions, LLC
> 
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

-- 
---
[email-masked]

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 21 Nov 2017 15:16:21 -0800

Indeed a truly multi-vendor and open achievement. Congrats to all!

Dino

> On Nov 21, 2017, at 3:12 PM, Toerless Eckert <[email-masked]> wrote:
>

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 21 Nov 2017 15:42:09 -0800

To be fair, a small hard-core crowd of four original acolytes that started
it all is recovering from a till-3-AM town-bash in celebration in Singapore
;-) Some may caught me sleeping day after in open area meeting, my co-chair
was even worse for wear ;-)

Hurray!

Just the beginning, we're talking recharter now, accepting tons interesting
pending work into the group and looking fwd' to standards track and many
years of interesting applications in the field ...

--- tony

---

From: <[email-masked]>
Date: Wed, 22 Nov 2017 08:29:29 +0800 (CST)

Congratulations!
:.☆\(~▽~)/$:*°★*

Sandy
------------------原始邮件------------------
发件人： <[email-masked]>;
收件人： <[email-masked]>;
日 期 ：2017年11月22日 07:13
主 题 ：Re: [Bier] RFC 8279 on Multicast Using Bit Index ExplicitReplication (BIER))
If you wonder why there is no big hurray !!!!!!,
congratulations for the RFC here on the mailing list,
here are my top guesses:

--
---
[email-masked]

---

From: "Dolganow, Andrew (Nokia - SG/Singapore)" <[email-masked]>
Date: Wed, 22 Nov 2017 01:03:26 +0000

Tony hit a nail in the head☺

This has been best multi-vendor work I have ever done at the IETF!!! Let’s get BIER rolling out and keep good work coming!

Andrew

From: BIER <[email-masked]> on behalf of Tony Przygienda <[email-masked]>
Date: Wednesday, November 22, 2017 at 7:43 AM
To: Toerless Eckert <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Bier] RFC 8279 on Multicast Using Bit Index Explicit Replication (BIER))

To be fair, a small hard-core crowd of four original acolytes that started it all is recovering from a till-3-AM town-bash in celebration in Singapore ;-) Some may caught me sleeping day after in open area meeting, my co-chair was even worse for wear ;-)

Hurray!

Just the beginning, we're talking recharter now, accepting tons interesting pending work into the group and looking fwd' to standards track and many years of interesting applications in the field ...

--- tony

On Tue, Nov 21, 2017 at 3:12 PM, Toerless Eckert <[email-masked]<mailto:[email-masked]>> wrote:
If you wonder why there is no big hurray !!!!!!,
congratulations for the RFC here on the mailing list,
here are my top guesses:

In-Reply-To: <[email-masked]<mailto:[email-masked]>>

On Mon, Nov 20, 2017 at 12:40:27PM -0800, [email-masked]<mailto:[email-masked]> wrote:
>         Mailbox:    [email-masked]<mailto:[email-masked]>,
>                     [email-masked]<mailto:[email-masked]>,
>                     [email-masked]<mailto:[email-masked]>,
>                     [email-masked]<mailto:[email-masked]>,
>                     [email-masked]<mailto:[email-masked]>
>         Pages:      43
>         Characters: 97283
> author of the RFC in question, or to [email-masked]<mailto:[email-masked]>.  Unless
> [email-masked]<mailto:[email-masked]>

--
---
[email-masked]<mailto:[email-masked]>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: Xiejingrong <[email-masked]>
Date: Wed, 22 Nov 2017 01:17:21 +0000

Hurray !

Many years of interesting applications are waiting for this new jet. Haha.

XieJingrong

From: BIER [mailto:[email-masked]] On Behalf Of Tony Przygienda
Sent: Wednesday, November 22, 2017 7:42 AM
To: Toerless Eckert <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bier] RFC 8279 on Multicast Using Bit Index Explicit Replication (BIER))

Hurray!

--- tony

---

From: IJsbrand Wijnands <[email-masked]>
Date: Wed, 22 Nov 2017 21:04:52 +0100

Awesome work everybody, its a true pleasure to be part of this working group :-)

Happy thanksgiving for those who are celebrating it!

Thx,

Ice.

> On 22 Nov 2017, at 02:03, Dolganow, Andrew (Nokia - SG/Singapore) <[email-masked]> wrote:
>

---

From: "Bidgoli, Hooman (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 22 Nov 2017 21:12:13 +0000

Dito! great achievement!

Regards

Hooman
From: BIER [mailto:[email-masked]] On Behalf Of IJsbrand Wijnands
Sent: Wednesday, November 22, 2017 3:05 PM
To: Dolganow, Andrew (Nokia - SG/Singapore) <[email-masked]>
Cc: [email-masked]; Toerless Eckert <[email-masked]>
Subject: Re: [Bier] RFC 8279 on Multicast Using Bit Index Explicit Replication (BIER))

Thx,

Ice.

On 22 Nov 2017, at 02:03, Dolganow, Andrew (Nokia - SG/Singapore) <[email-masked]<mailto:[email-masked]>> wrote:

Andrew

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 22, 2017 at 7:43 AM
To: Toerless Eckert <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] RFC 8279 on Multicast Using Bit Index Explicit Replication (BIER))

Hurray!

--- tony