Subject: [Bier] Questions about draft-eckert-bier-te-frr-02

From: <[email-masked]>
Date: Mon, 11 Dec 2017 08:30:28 +0800 (CST)

Hi,

I have questions about section "3.1.  FRR Key Concepts" of the draft "Protection Methods for BIER-TE (draft-eckert-bier-te-frr-02)".

In this section, The description about the failing link :

"First, we consider that the link from P towards F fails."

but in the multicast tree mentioned in this section, 

1. no P and F are found.

2. there are two "p8"  (the bitposition should be unique under the same <SD,SI,BSL>? )

Is this tree incomplete?

---

From: Wolfgang Braun <[email-masked]>
Date: Mon, 11 Dec 2017 15:26:34 +0100

Hi,

I have answered the questions about bier-te-frr but forgot to add the list in the address field.

Best regards
Wolfgang

-------- Forwarded Message --------
Subject: Re: Fwd: [Bier] Questions about draft-eckert-bier-te-frr-02
Date: Mon, 11 Dec 2017 13:48:31 +0100
From: Wolfgang Braun <[email-masked]>
To: [email-masked]
CC: [email-masked], Michael Menth <[email-masked]>

Dear Gu,

> -------- Weitergeleitete Nachricht --------
> Betreff: 	[Bier] Questions about draft-eckert-bier-te-frr-02
> Datum: 	Mon, 11 Dec 2017 08:30:28 +0800 (CST)
> Von: 	[email-masked]
> An: 	[email-masked]
> 
> 
> 
> Hi,
> 
> 
> I have questions about section "3.1.  FRR Key Concepts" of the draft
> "Protection Methods for BIER-TE (draft-eckert-bier-te-frr-02)".

the notation in the figure and the text are inconsistent.  We have to fix this in the next version of the draft.

I have attached a txt-file with the corrections at this mail.  You find more explanations below.
   
> but in the multicast tree mentioned in this section,

It is wrong notated in the text.  P is BFR4 and F is BFR7.  D2 also appears in the text and it must be BFR9.

> 2. there are two "p8"  (the bitposition should be unique under the same

The tree is complete but I have made some mistakes labeling the adjacencies.  You can find the correct bit positions and notations in the attached txt-file.

If there are sill questions, please feel free to ask.

Best regards
Wolfgang
-- 
Dipl.-Inform. Wolfgang Braun
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70509, fax: (+49)-7071/29-5220
mailto: [email-masked]