Subject: MIB updates for P802.1u

From: Andrew Smith <[email-masked]>
Date: Wed, 3 May 2000 10:38:58 -0700

Michael,

No, there is no MIB for the new stuff yet. You're right, that needs some
extra work, just a couple of new objects in existing tables I think. I
supose we should ask Keith McCloghrie who is chair of the IETF Bridge MIB
group to see what he wants to do about cranking up the WG again. We will
also want to do some other changes for 802.1s, 802.1v and 802.1w too
although it might be a little early for those just now. 

Feel free to propose some additions to RFC 2674 to cover 802.1u - it should
be easy to add them (would have to be a separate MIB/document at this point
but could be merged with 2674 at a later date). 

Andrew

> -----Original Message-----
> From: Soerensen, Michel [mailto:[email-masked]]
> Sent: Wednesday, May 03, 2000 12:14 AM
> To: 'Andrew Smith'
> Subject: RE: P802.1u/D5 Ballot - Comments (with approve)
> 
> 
> Thanks for answering.
> I just see the current version of rfc2674 as August 1999, 
> which includes the
> general GMRP/GVRP stuff. I was primarily thinking on the 
> "restricted VLAN
> Registration" in .1u, which is not in that version.
> So is there a newer kind of rfc "draft" that includes this?
> 
> Michel
> 
> > -----Original Message-----
> > From: Andrew Smith [mailto:[email-masked]]
> > Sent: 2. maj 2000 19:18
> > To: 'Soerensen, Michel'; [email-masked]
> > Subject: RE: P802.1u/D5 Ballot - Comments (with approve)
> > 
> > 
> > See RFC 2674.
> > 
> > > -----Original Message-----
> > > From: Soerensen, Michel [mailto:[email-masked]]
> > > Sent: Tuesday, May 02, 2000 7:12 AM
> > > To: [email-masked]
> > > Cc: 'Tony Jeffree'
> > > Subject: P802.1u/D5 Ballot - Comments (with approve)
> > > 
> > > 
> > > P802.1u/D5 EMAIL BALLOT
> > > 28 March 2000
> > > TO: Tony Jeffree
> > > Editor, P802.1u
> > > SUBJECT: PP802.1u/D5 - VLANs - Technical and Editorial Corrections
> > > 
> > > _XX____ I Approve (may attach non-binding comments below)
> > > _____ I Disapprove (must attach binding comments below)
> > > _____ Non-Voter - Comment Only (comments attached below)
> > > _____ I Abstain for the following reasons (may attach 
> > > non-binding comments
> > > below):
> > > ______ Lack of Time
> > > ______ Lack of Expertise
> > > ______ Other: _______________________________________________
> > > 
> > > Michel Sørensen_________________________________________
> > > (Name)
> > > +45 4527 5595___________________________________________
> > > (Telephone No.)
> > > --------------------------------------------------------------
> > > INCLUDE COMMENTS BELOW THIS POINT
> > > 
> > > NAME:		Michel Soerensen
> > > COMMENT TYPE:	E
> > > CLAUSE:	12
> > > PAGE:		16
> > > LINE:		
> > > COMMENT START:
> > > I this standard we don't include the MIB, so when is the new 
> > > GMRP/GVRP stuff
> > > go into MIBs?
> > > COMMENT END:
> > > SUGGESTED CHANGES START:
> > > Get an answer from an IETF member or create a MIB.
> > > SUGGESTED CHANGES END:
> > > 
> > > 
> > 
>

---

From: "Christensen, Anders SW" <[email-masked]>
Date: Thu, 4 May 2000 01:03:20 -0700

All,

It seems that a simple addition to the dot1qPortVlanTable can cover the new
Restricted VLAN registration parameter:

Dot1qPortVlanEntry ::=
    SEQUENCE {
        dot1qPvid
            VlanIndex,
        dot1qPortAcceptableFrameTypes
            INTEGER,
        dot1qPortIngressFiltering
            TruthValue,
        dot1qPortGvrpStatus
            EnabledStatus,
	  dot1qPortRestrictedRegistration
		TruthValue,

dot1qPortRestrictedRegistration OBJECT-TYPE
    SYNTAX      TruthValue
    MAX-ACCESS  read-write
    STATUS      current
    DESCRIPTION
	  "The state of Restricted Registration on this port.
         If the value of this control is true(1), then
         creation of a new dynamic VLAN entry is permitted only
         if there is a Static VLAN Registration Entry for the
         VLAN concerned, in which the Registrar Administrative
         Control value for this port is Normal Registration."
    DEFVAL      { false }
    ::= { dot1qPortVlanEntry 5 }

Regards,
Anders Christensen,
Intel Corporation, Denmark

-----Original Message-----
From: Andrew Smith [mailto:[email-masked]]
Sent: 3. maj 2000 19:39
To: 'Soerensen, Michel'
Cc: 'Keith McCloghrie'; 'P802.1'; Bridge Mib (E-mail)
Subject: MIB updates for P802.1u

Michael,

Andrew