Subject: [anonsec] Name for this work

From: Black_David at emc.com ([email-masked])
Date: Fri Sep 17 14:31:19 2004

I agree with Steve Kent's statement:

> Since Nicholas cites examples of how he wants to use 
> these mechanisms to provide authenticated channel bindings, it seems
> likely that any notion of anonymity is not really integral to the 
> mechanisms and scenarios that are "within scope" for the activity.

I think there's an important conceptual difference between
unauthenticated (authentication not performed) and
unauthenticatable (authentication can't be performed).

The authenticated channel bindings scenario suggests that
the work currently known as ANONSEC as unauthenticated, but
not unauthenticatable - in the channel binding case, there
will be an authentication that is cryptographically tied to
the unauthenticated key exchange, and a suitably designed
binding can defeat an MITM attack on the unauthenticated
key exchange.  The objections to the use of "anonymous" appear
to be that its usual use in the context of security implies
unauthenticatable (possibly to the point of unidentifiable),
which is definitely not the case here.

"Authentication Agnostic" seems to be a good description
what is intended here, as this work doesn't care what
authentication is performed, or even if any is performed
(cf. "leap of faith").  Unfortunately, that doesn't yield
a pronounceable acronym (AUAGSEC?), and noticing that Au
and Ag are the chemical symbols for gold and silver is
getting entirely too clever ... so perhaps DCAUTHSEC
("Don't Care" [about] Authentication Security)?

Thanks,
--David

----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: kent at bbn.com (Stephen Kent)
Date: Sun Sep 19 17:50:19 2004

I second David's "authentication agnostic" suggestion. It seems to 
capture the real flavor of what is intended here

Steve

---

From: touch at ISI.EDU (Joe Touch)
Date: Mon Sep 20 11:02:31 2004

> unauthenticatable (authentication can't be performed).

What is the difference between these?

If you don't authenticate who you are, then correlations of the ID 
you've used or reused are meaningless anyway.

Joe
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/anonsec/attachments/20040920/2da4fbdc/signature.bin

---

From: touch at ISI.EDU (Joe Touch)
Date: Mon Sep 20 11:05:30 2004

> capture the real flavor of what is intended here

Agnostic implies 'doesn't care'. While some of the system could be 
useful regardless of which authentication used, I'm not sure that's an 
appropriate implication for the entire system.

What's really being authenticated is, to some extent, behavior, i.e., 
that you're the same party that I've been talking to. Were this really 
agnostic, that might not apply either.

Joe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/anonsec/attachments/20040920/ec163800/signature.bin