Subject: [anonsec] Automatic detection of BTNS capability

From: yogesh.swami at acm.org (Yogesh Prem Swami)
Date: Wed, 16 Mar 2005 08:56:50 -0800 (PST)

--- Paul Hoffman <paul.hoffman at vpnc.org> wrote:
> At 8:50 AM -0800 3/15/05, Eric Rescorla wrote:
> >This basically buys you zilch aainst zombies, which are the current
> >major threeat.
> 
> Are you suggesting that prevention of attack by zombies be put in the 
> charter? If so, why should that be in BTNS' charter but no one else's?
> 

While I don't think the charter should contain solution for Zombies, I do think
that BTNS should provide what it promises: "Better than no security." If having
BTNS means easier ways to do zombie DoS attacks (and I guess Joe and I have
discussed this before on the TCPM mailing list), then,  in my opinion BTNS is
not better than no security, (it's only trading one form of DoS attacks with
another form, like moving back door lock to front door). And yes, you can do
zombie attacks using 3rd party certs too, but the degree and ease of attacks
are different. DoS ultimately is about degree, isn't it?

If BTNS becomes a wg, It would be nice to at least produce an informational
document/conference-paper which does a through analysis of different trade-offs
involved. 

Yogesh

--

http://people.nokia.net/~yogesh

---

From: Nicolas.Williams at sun.com (Nicolas Williams)
Date: Wed, 16 Mar 2005 11:03:55 -0600

> are different. DoS ultimately is about degree, isn't it?

Noone has argued that BTNS makes zombie DoS/DDoS attacks easier, nor do
I see how it would.

As to what is meant by "better than no security:" better than just
sending and accepting unauthenticated plaintext.

So should BTNS' charter say anything about zombie DoS protection?  I
don't think so, at least not until we figure out that BTNS has something
to offer there.

Nico
--

---

From: touch at ISI.EDU (Joe Touch)
Date: Wed, 16 Mar 2005 11:45:12 -0800

> are different. DoS ultimately is about degree, isn't it?

The issue is degree of work required for an attack. BTNS raises the bar 
-- better then nothing, but not better than endpoint authentication via 
CA or shared secret.

> document/conference-paper which does a through analysis of different trade-offs

This would be in the applicability statement. I.e., it makes it harder 
for zombies to attack via shooting out stray packets, but allows them to 
continue to attack by making full connections. Note that this doesn't 
make things worse than 'nothing' - it's still better, or in the worst 
case, 'no worse than nothing.'

Joe
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/anonsec/attachments/20050316/16f9dc61/signature.bin