Subject: [Ietf-calsify] Multiple iCalendar Objects

From: Chris_Stoner at notesdev.ibm.com ([email-masked])
Date: Wed Sep 7 10:51:37 2005

RFC 2445 allows for multiple iCalendar objects, but I'm not so sure this is
a good idea.  Does anyone know of an implementation that makes use of
multiple iCalendar objects?

I would like to change: "Typically, this information will consist of a
single iCalendar object. However, multiple iCalendar objects can be
sequentially grouped together. "

...to read this instead: "This information will consist of a single
iCalendar object."

Thoughts on this?
-Chris Stoner

6.?iCalendar Objects

The Calendaring and Scheduling Core Object is a collection of calendaring
and scheduling information. Typically, this information will consist of a
single iCalendar object. However, multiple iCalendar objects can be
sequentially grouped together. The first line and last line of the
iCalendar object MUST contain a pair of iCalendar object delimiter strings.

---

From: Doug at Royer.com (Doug Royer)
Date: Wed Sep 7 11:29:01 2005

Skipped content of type multipart/mixed-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 4696 bytes
Desc: S/MIME Cryptographic Signature
Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050907/05ca8aa2/smime.bin

---

From: pete at linkingarts.com (Peter Jacobson)
Date: Wed Sep 7 11:30:51 2005

this is my first post to this list so forgive me if I misinterpret your
comment.

I'm building a Web app that in part deals with film and video equipment
rentals. A customer can look up availability of and book equipment using a
calendar interface. Their order corresponds to an iCalendar object.
However, customers can book equipment for more than one occasion at a
time, which would in our case be represented by two separate orders, or
calendars, both of which are associated with that customer.

In addition, each piece of equipment has its own iCalendar (so you can
look up that video camera to see when it is available).

Does that example fit the case?

Peter Jacobson

<quote who="[email-masked]">
> _______________________________________________
> Ietf-calsify mailing list
> [email-masked]
> http://lists.osafoundation.org/mailman/listinfo/ietf-calsify
>
>

......................................................
Linking Arts Web Development
www.linkingarts.com

---

From: Chris_Stoner at notesdev.ibm.com ([email-masked])
Date: Wed Sep 7 12:01:09 2005

That's a good point.  So you mean that if I have a handheld device and I
want to pull down my January 2006 calendar, I would want to tranfer in one
shot with many iCalendar objects, each having a method param telling me how
to display this?

Is that paraphrased about right?  Seems like a good use case to me!
-CS

[email-masked] wrote on 09/07/2005 02:28:55 PM:

>
> Multiple iCalendar objects in one object is essential when
> copying calendars that have METHOD properties in them.
> Otherwise, there is no way to transport them in a single transfer.
>
> Its needed in both synchronization and when transferring
> a calendar in iCal format.
>
>
>    BEGIN:VCALENDAR
>    METHOD:PUBLISH
>    ...
>    END:VCALENDAR
>    BEGIN:VCALENDAR
>    METHOD:ADD
>    ...
>    END:VCALENDAR
>    ...
>
>
> [email-masked] wrote:
> > 6. iCalendar Objects
> --
> Doug Royer                     | http://INET-Consulting.com
> -------------------------------|-----------------------------
>
>                We Do Standards - You Need Standards
>
> [attachment "Doug.vcf" deleted by Chris Stoner/Westford/IBM]
> [attachment "smime.p7s" deleted by Chris Stoner/Westford/IBM]

---

From: Doug at Royer.com (Doug Royer)
Date: Wed Sep 7 12:43:23 2005

Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050907/67dbe057/smime.bin

---

From: oren at washington.edu (Oren Sreebny)
Date: Wed Sep 7 16:40:20 2005

That may be, but I will note that there are many calendar programs  
currently on the market that can't handle multiple VCALENDAR objects   
within a single file - I wrote about this in 2003 at

http://staff.washington.edu/oren/weblog2/archives/2003/12/ 
more_on_ical_or.html

- Oren

On Sep 7, 2005, at 12:43 PM, Doug Royer wrote:

> Yes. I do not know of a handheld that does iTIP yet. It however
> is accurate for my laptop synchronizing with my desktop.
>
> So the existing 2445 text looks accurate to me.
>
> -- 
>
> <Doug.vcf>

---

From: TimHare at comcast.net (Tim Hare)
Date: Wed Sep 7 17:51:29 2005

One other use case of multiple calendar objects is the very common 
METHOD:PUBLISH use case, for example an events calendar, is it not? Or am I 
misinterpreting this part?

BEGIN:VCALENDAR
METHOD:PUBLISH
BEGIN:VEVENT
END:VEVENT
BEGIN:VEVENT
END:VEVENT
--- etcetera ---
END:VCALENDAR

In any case, I don't see any real programming problems dealing even with 
multiple VCALENDARs in one file; if it's a memory constraint problem, read 
the file until the first END:VCALENDAR, or END:VEVENT for that matter, 
process what you have, and then move on. Of course, my roots are in the 
mainframe world where thinking of files in a sequential manner is perhaps 
more common, but I believe this would work...

>>So the existing 2445 text looks accurate to me.

Tim Hare
Interested Bystander, Non-Inc.

---

From: Doug at Royer.com (Doug Royer)
Date: Wed Sep 7 19:23:20 2005

Url : http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20050907/0741e7b7/smime-0001.bin

---

From: Chris_Stoner at notesdev.ibm.com ([email-masked])
Date: Thu Sep 8 06:47:37 2005

Right, I think that's where Doug was going with his post.  I think PUBLISH
is a good Use Case for multiple calendar objects.

Thanks everyone-
CS

             Tim Hare                                                      
             <TimHare@comcast.                                             
             net>                                                       To 
             Sent by:                  [email-masked]      
             ietf-calsify-boun                                          cc 
             ces@osafoundation                                             
             .org                                                  Subject 
                                       Re: [Ietf-calsify] Multiple         
                                       iCalendar Objects                   
             09/07/2005 08:51                                              
             PM                                                            

BEGIN:VCALENDAR
METHOD:PUBLISH
BEGIN:VEVENT
END:VEVENT
BEGIN:VEVENT
END:VEVENT
--- etcetera ---
END:VCALENDAR

Tim Hare