Subject: [ietf-calsify] Double quotes in CN param?

From: Reinhold Kainhofer <[email-masked]>
Date: Tue, 9 Dec 2008 16:59:32 +0100

Hi all,
I just realized that currently, the rfc2445bis (and already rfc2445) forbids 
any double quotes in the cn parameter value:

      cnparam    = "CN" "=" param-value
      param-value   = paramtext / quoted-string
      paramtext     = *SAFE-CHAR
      quoted-string = DQUOTE *QSAFE-CHAR DQUOTE
      QSAFE-CHAR    = WSP / %x21 / %x23-7E / NON-US-ASCII
      ; Any character except CONTROL and DQUOTE
      SAFE-CHAR     = WSP / %x21 / %x23-2B / %x2D-39 / %x3C-7E
                    / NON-US-ASCII
      ; Any character except CONTROL, DQUOTE, ";", ":", ","

So, if I read this correctly, the common name to be displayed must not contain 
any double quotes, not even if they are escaped. 

My problem with this is that some entities use double quotes as part of their 
official name. For example, our choir has the official Name 
     Chorvereinigung "Jung-Wien"
which is officially registered as the association's formal name and is also 
registered and protected as a trademark. RFC2445 now forbids us to use that as 
the CN of the Organizer when sending out invitations.... (which is kind of 
embarassing, because we are very picky when a concert organizer writes our 
name without the quotes)

Am I interpreting things correctly?

Cheers,
Reinhold
-- 
------------------------------------------------------------------
Reinhold Kainhofer, Vienna University of Technology, Austria
email: [email-masked], http://reinhold.kainhofer.com/
 * Financial and Actuarial Mathematics, TU Wien, http://www.fam.tuwien.ac.at/
 * K Desktop Environment, http://www.kde.org, KOrganizer maintainer
 * Chorvereinigung "Jung-Wien", http://www.jung-wien.at/
_______________________________________________
ietf-calsify mailing list
[email-masked]
http://lists.osafoundation.org/mailman/listinfo/ietf-calsify

---

From: Bernard Desruisseaux <[email-masked]>
Date: Tue, 09 Dec 2008 12:31:53 -0500

> Am I interpreting things correctly?
Yes.

This was previously discussed at IETF 65, but never tracked as an issue 
nor addressed.

http://www.ietf.org/proceedings/06mar/slides/calsify-1/sld9.htm

http://tools.ietf.org/wg/calsify/minutes?item=minutes65.html

(03:28:35) rlbob: bd: not possible to handle double-quotes in param 
value, eg RL "Bob"
(03:29:18) rlbob: bd: could propose backslash-escaping, could be compat 
problem
(03:29:39) rlbob: cn: IMAP made this change going from -2 to -4 ...

As a workaround, you could use other DOUBLE QUOTATION MARK supported by 
Unicode, see:

http://www.unicode.org/charts/PDF/U2000.pdf

Cheers,
Bernard