Subject: [calsify] Alignment of CUTYPE and KIND

From: Mike Douglass <[email-masked]>
Date: Tue, 13 Jul 2010 14:59:38 -0400

While implementing calendar client support using carddav for attendee 
lookup we came across the inconsistencies in vcard KIND and attendee 
CUTYPE which I believe ought to be addressed.

KIND has

      KIND-param = "VALUE=text" / any-param
      KIND-value = "individual" / "group" / "org" / "location" / "thing"

CUTYPE has

        cutypeparam        = "CUTYPE" "="
                           ("INDIVIDUAL"   ; An individual
                          / "GROUP"        ; A group of individuals
                          / "RESOURCE"     ; A physical resource
                          / "ROOM"         ; A room resource
                          / "UNKNOWN"      ; Otherwise not known
                          / x-name         ; Experimental type
                          / iana-token)    ; Other IANA-registered
                                           ; type
        ; Default is INDIVIDUAL

So INDIVIDUAL and GROUP align OK
CUTYPE.RESOURCE = KIND.thing?

No CUTYPE equivalent for KIND.ORG
KIND.LOCATION is better than CUTYPE.ROOM (an event might take place on a 
sports field)

On 07/13/2010 11:36 AM, Simon Perreault wrote:
> On 2010-07-13 10:59, Cyrus Daboo wrote:
>    
>> So there is a real problem here. For example, if in the future I define
>> a new property FOO that uses a ;-delimited compound value, then I want
>> to be sure that clients not aware of this property will properly
>> "round-trip" it. So if I send such a client this:
>>
>> FOO:delimited;text\;string
>>      
> Right, there is a problem with the current text.
>
> Assume we specify that semicolons that are not component separators MUST
> be escaped. Then a client can correctly interpret this unknown property
> as having two components. And it will always output it exactly the way
> it received it. That fixes the problem, right?
>
> If so, this would point toward the acceptance of proposal 1.
>
> Simon
>    

-- 

Mike Douglass                           [email-masked]
Senior Systems Programmer
Communication&  Collaboration Technologies      518 276 6780(voice) 2809
(fax)
Rensselaer Polytechnic Institute 110 8th Street, Troy, NY 12180

---

From: Mike Douglass <[email-masked]>
Date: Tue, 13 Jul 2010 14:59:38 -0400

KIND has

CUTYPE has

-- 

_______________________________________________
calsify mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/calsify