Subject: Re: [calsify] ECMAScript Extensions to RFC 3339

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 03 Dec 2020 22:25:18 +1100

Hi all,

I raised this work briefly at the last IETF in both the DISPATCH and CALEXT working groups, just to make everyone aware that it's going on, but I also made myself a note to follow up on it - so here's my follow up :)

How's the work going?   Are you still planning to bring it to the IETF?  Do you need any help with anything in that process?

Cheers,

Bron.

(loosely wearing my CALEXT chair hat, but also generally interested)

On Wed, Sep 2, 2020, at 12:55, Shane Carr wrote:
> Dear CalExt experts,
> 
> My name is Shane and I am helping push the ECMAScript Temporal proposal, bringing new date/time types to JavaScript.  It's our version of Joda Time.
> 
> I would like your feedback on the following extensions that we are proposing to the ISO-8601 / RFC 3339 strings outputted by Temporal.
> 
> https://github.com/tc39/proposal-temporal/blob/main/docs/iso-string-ext.md
> 
> Of particular interest is our proposed representation of dates in non-Gregorian calendar systems.
> 
> I would appreciate it if you could send feedback!
> 
> Thanks,
> Shane
> 
> _______________________________________________
> calsify mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/calsify
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Ronald Tse <[email-masked]>
Date: Thu, 3 Dec 2020 11:34:32 +0000

Hi Bron,

Ujjwal has already taken the initiative to start a new draft for RFC 3339.

The draft is at https://github.com/ryzokuken/draft-ryzokuken-datetime-extended/

Kind regards,
Ron

_____________________________________

Ronald Tse
Ribose Inc.

+=========================================================+
This message may contain confidential and/or privileged
information.  If you are not the addressee or authorized to
receive this for the addressee, you must not use, copy,
disclose or take any action based on this message or any
information herein.  If you have received this message in
error, please advise the sender immediately by reply e-mail
and delete this message.  Thank you for your cooperation.
+=========================================================+

On Dec 3, 2020, at 7:25 PM, Bron Gondwana <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Cheers,

Bron.

Thanks,
Shane

_______________________________________________
calsify mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/calsify

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]<mailto:[email-masked]>

_______________________________________________
calsify mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/calsify

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 03 Dec 2020 22:46:08 +1100

Ahh excellent.  Thanks Ronald.

RFCs don't work quite the same was as ISO numbers (you don't get to use the old number again, it would be a new RFC number which replaces the old one, so 3339 will only be mentioned in the metadata) - and if it's going to be published at the IETF we'll need to find the right venue for the work to happen.  Hence my question about the publishing plans.

Cheers,

Bron.

On Thu, Dec 3, 2020, at 22:34, Ronald Tse wrote:
>> On Dec 3, 2020, at 7:25 PM, Bron Gondwana <[email-masked]> wrote:
>> 
>> Hi all,
>>

---

From: Ujjwal Sharma <[email-masked]>
Date: Thu, 3 Dec 2020 17:42:04 +0530

Hi Bron! Thanks Ron!

As Ron mentioned, I've started hacking on a draft in that GitHub
repository, and plan to make significant progress on it in the coming
weeks. I've made it an I-D that obsoletes 3339, but the README was
copied over from the 3339 template and needs to be changed.

I'll clean up the GitHub repo, continue making updates and hopefully
publish a version on datatracker soon. That said, I'm still not too
familiar with the process so please feel free to let me know if I'm
missing a step.

Thanks,
Ujjwal

On 12/3/20 5:16 PM, Bron Gondwana wrote:
> RFCs don't work quite the same was as ISO numbers (you don't get to use
> the old number again, it would be a new RFC number which replaces the
> old one, so 3339 will only be mentioned in the metadata) - and if it's
> going to be published at the IETF we'll need to find the right venue for
> the work to happen.  Hence my question about the publishing plans.
> 
> Cheers,
> 
> Bron.
> 
>> The draft is
>> at https://github.com/ryzokuken/draft-ryzokuken-datetime-extended/
>> <https://github.com/ryzokuken/draft-ryzokuken-datetime-extended/>
>>
>> Kind regards,
>> Ron
>>
>>> I raised this work briefly at the last IETF in both the DISPATCH and
>>> CALEXT working groups, just to make everyone aware that it's going
>>> on, but I also made myself a note to follow up on it - so here's my
>>> follow up :)
>>>
>>> How's the work going?   Are you still planning to bring it to the
>>> IETF?  Do you need any help with anything in that process?
>>>
>>> Cheers,
>>>
>>> Bron.
>>>
>>>> My name is Shane and I am helping push the ECMAScript Temporal
>>>> proposal, bringing new date/time types to JavaScript.  It's our
>>>> version of Joda Time.
>>>>
>>>> I would like your feedback on the following extensions that we are
>>>> proposing to the ISO-8601 / RFC 3339 strings outputted by Temporal.
>>>>
>>>> <https://github.com/tc39/proposal-temporal/blob/main/docs/iso-string-ext.md>
>>>>
>>>> [email-masked] <mailto:[email-masked]>
>>>> <https://www.ietf.org/mailman/listinfo/calsify>
>>>>
>>>
>>> --
>>>   [email-masked] <mailto:[email-masked]>
>>>
>>>
>>> [email-masked] <mailto:[email-masked]>
>>> <https://www.ietf.org/mailman/listinfo/calsify>
> 
> --

-- 
Ujjwal "Ryzokuken" Sharma (he/him)

Compilers Hacker, Node.js Core Collaborator and Speaker

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 04 Dec 2020 13:08:47 +1100

Excellent, I'm glad to hear that it's coming along.  That's totally fine, and it doesn't even matter if the first draft uploaded to the datatracker is riddled with metadata errors because people will be happy to help you fix those!  The main thing is having a draft that I can do a call for adoption from and we can get it onto the calext agenda for March (or even ask people to look at it between meetings).

Cheers,

Bron.