Subject: [calsify] [Technical Errata Reported] RFC8984 (6872)

From: RFC Errata System <[email-masked]>
Date: Mon, 7 Mar 2022 08:32:10 -0800 (PST)

The following errata report has been submitted for RFC8984,
"JSCalendar: A JSON Representation of Calendar Data".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6872

--------------------------------------
Type: Technical
Reported by: Robert Stepanek <[email-masked]>

Section: 4.4.3.

Original Text
-------------
   "private":  The details of the object are hidden; only the basic time
      and metadata are shared.  The following properties MAY be shared;
      any other properties MUST NOT be shared:

      *  @type

      *  created

      *  due

      *  duration

      *  estimatedDuration

      *  freeBusyStatus

      *  privacy

      *  recurrenceOverrides (Only patches that apply to another
         permissible property are allowed to be shared.)

      *  sequence

      *  showWithoutTime

      *  start

      *  timeZone

      *  timeZones

      *  uid

      *  updated

Corrected Text
--------------
   "private":  The details of the object are hidden; only the basic time
      and metadata are shared.  The following properties MAY be shared;
      any other properties MUST NOT be shared:

      *  @type

      *  created

      *  due

      *  duration

      *  estimatedDuration

      *  excludedRecurrenceRules

      *  freeBusyStatus

      *  privacy

      *  recurrenceOverrides (Only patches that apply to another
         permissible property are allowed to be shared.)

      *  recurrenceRules

      *  sequence

      *  showWithoutTime

      *  start

      *  timeZone

      *  timeZones

      *  uid

      *  updated

Notes
-----
Adds the recurrenceRules and excludedRecurrenceRules properties to the list of allowed properties of private events.

Only the combination of recurrence rules, excluded recurrence rules and recurrence overrides allows to generate the full recurrence set for this event.

Omitting the properties was an oversight during the initial publication of this RFC.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8984 (draft-ietf-calext-jscalendar-32)
--------------------------------------
Title               : JSCalendar: A JSON Representation of Calendar Data
Publication Date    : July 2021
Author(s)           : N. Jenkins, R. Stepanek
Category            : PROPOSED STANDARD
Source              : Calendaring Extensions
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: "Neil Jenkins" <[email-masked]>
Date: Tue, 08 Mar 2022 15:18:27 +1100

> Omitting the properties was an oversight during the initial publication of this RFC.

I agree with this. Robert, I think we need to explicitly state *excluded* as an allowed property too though to make it clear that this should still be included in recurrenceOverrides?

Cheers,
Neil.

---

From: "Robert Stepanek" <[email-masked]>
Date: Tue, 08 Mar 2022 09:20:19 -0500

On Mon, Mar 7, 2022, at 11:18 PM, Neil Jenkins wrote:
> I think we need to explicitly state *excluded* as an allowed property too though to make it clear that this should still be included in recurrenceOverrides?

Right, need to add that! I can't figure out how to update an errata, so maybe I need to cancel this one and create a new errata?

Cheers,
Robert

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 8 Mar 2022 14:22:37 +0000

On 08/03/2022 14:20, Robert Stepanek wrote:

>> I think we need to explicitly state *excluded* as an allowed property 
>> too though to make it clear that this should still be included in 
>> recurrenceOverrides?
>
> Right, need to add that! I can't figure out how to update an errata, 
> so maybe I need to cancel this one and create a new errata?
Just ask the responsible AD to edit the text, ADs can do that.

---

From: "Robert Stepanek" <[email-masked]>
Date: Wed, 09 Mar 2022 09:14:43 -0500

Hi Francesca,

could you please update the errata text as follows? Many thanks in advance.

Corrected text:

      *  @type

      *  created

      *  due

      *  duration

      *  estimatedDuration

      *  excluded

      *  freeBusyStatus

      *  privacy

      *  recurrenceId

      *  recurrenceIdTimeZone

      *  recurrenceRules

      *  sequence

      *  showWithoutTime

      *  start

      *  timeZone

      *  timeZones

      *  uid

      *  updated

Notes
Adds the excluded, excludedRecurrenceRules, recurrenceId, reccurenceIdTimeZone and recurrenceRules properties to the list of shared properties of private events.

Only the combination of all recurrence properties allows to generate the full recurrence set for the event.

Thanks,
Robert