Subject: [CCAMP] I-D Action: draft-ietf-ccamp-gmpls-ospf-g709v3-01.txt

From: [email-masked]
Date: Wed, 18 Jan 2012 07:35:53 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Common Control and Measurement Plane Working Group of the IETF.

	Title           : Traffic Engineering Extensions to OSPF for Generalized MPLS (GMPLS) Control of Evolving G.709 OTN Networks
	Author(s)       : Daniele Ceccarelli
                          Diego Caviglia
                          Fatai Zhang
                          Dan Li
                          Sergio Belotti
                          Pietro Vittorio Grandi
                          Rajan Rao
                          Khuzema Pithewan
                          John E Drake
	Filename        : draft-ietf-ccamp-gmpls-ospf-g709v3-01.txt
	Pages           : 31
	Date            : 2012-01-18

   The recent revision of ITU-T Recommendation G.709 [G709-V3] has
   introduced new fixed and flexible ODU containers, enabling optimized
   support for an increasingly abundant service mix.

   This document describes OSPF routing protocol extensions to support
   Generalized MPLS (GMPLS) control of all currently defined ODU
   containers, in support of both sub-lambda and lambda level routing
   granularity.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-ospf-g709v3-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-ccamp-gmpls-ospf-g709v3-01.txt

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 18 Jan 2012 16:44:31 +0100

Hi CCAMP,
 
We have uploaded the -01 version of the OSPF OTN draft and the -03 version of the OTN info model one.

The OSPF one has been updated according to the comments receiverd Fred Gruman on the mailing list and some suggestions from the authors.
We have not changed the Switching Capability part (the discussion has not been concluded but the draft needed an update).
What is changed from the last -01 version is:
  
- Added Section 5.2.1: Example of different TSGs
- Added Section 5.7: Example of non homogeneous hierarchies
- Added text to section to section 4.1 on OUDflex max lsp bandwidth advertisement
        On the other hand, in
      case of variable containers (Type 2) the Unreserved/MAX LSP
      Bandwidth fields MUST be 32 bits long and expressed in IEEE
      floating point format.  The advertisement of the MAX LSP bandwidth
      MUST take into account HO OPUk bit rate tolerance and be
      calculated according to the following formula:
 
      Max LSP BW = (# available TS) * (ODTUk.ts nominal bit rate) *
         (1-HO OPUk bit rate tolerance)
 
- Added text to section 4.1 on ODUflex resizable and non resizable advertisement
 
         With respect to ODUflex, ODUflex CBR and ODUflex GFP-F MUST
         always be advertised separately as they use different
         adaptation functions.  In the case both GFP-F resizable and non
         resizable (i.e. 21 and 22) are supported, Signal Type 21
         implicitely supports also signal Signal Type 22, so only Signal
         Type 21 MUST be advertised.  Signal Type 22 MUST be used only
         for non resizable resources.
 
On the other side, with respect to the info model doc, we modified the TSG section as per the outcomes of Taipei meeting (split of the section between data plane and control plane considerataions). Section 4.1 with related subparagraphs.

BR
 
Daniele, Sergio, Pietro

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of [email-masked]
>Sent: mercoledì 18 gennaio 2012 16.36
>To: [email-masked]
>Cc: [email-masked]
>Subject: [CCAMP] I-D Action: draft-ietf-ccamp-gmpls-ospf-g709v3-01.txt
>
>
>A New Internet-Draft is available from the on-line 
>Internet-Drafts directories. This draft is a work item of the 
>Common Control and Measurement Plane Working Group of the IETF.
>
>	Title           : Traffic Engineering Extensions to 
>OSPF for Generalized MPLS (GMPLS) Control of Evolving G.709 
>OTN Networks
>_______________________________________________
>CCAMP mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ccamp
>