Subject: [CCAMP] Fwd: New Version Notification for draft-martinelli-wson-interface-class-02.txt

From: Giovanni Martinelli <[email-masked]>
Date: Tue, 06 Mar 2012 17:58:29 +0100

Dear Ccamp,

here's an update on  Optical Interface Class draft.

The idea is to make WSON protocol extensions independent of explicit 
optical parameters encoding as currently defined in following IDs 
(referring only to wg documents):
- draft-ietf-ccamp-rwa-info-13
- draft-ietf-ccamp-rwa-wson-encode-13
- draft-ietf-pce-wson-routing-wavelength-06
And related draft protocol extensions that make use of them:
- draft-ietf-ccamp-wson-signal-compatibility-ospf-07
- draft-ietf-ccamp-wson-signaling-02

As and additional benefit,  the optical interface class can be fully 
compatible with ITU application code concept.

Draft was first presented in Quebec and there were several good 
reactions from the room, so please provide comments!

Thanks in advance
Giovanni & co-authors

-------- Original Message --------
Subject: 	New Version Notification for 
draft-martinelli-wson-interface-class-02.txt
Date: 	Tue, 06 Mar 2012 08:30:45 -0800
From: 	[email-masked]
To: 	[email-masked]
CC: 	[email-masked], [email-masked], 
[email-masked], [email-masked]

A new version of I-D, draft-martinelli-wson-interface-class-02.txt has been successfully submitted by Giovanni Martinelli and posted to the IETF repository.

Filename:	 draft-martinelli-wson-interface-class
Revision:	 02
Title:		 WSON Optical Interface Class
Creation date:	 2012-03-06
WG ID:		 Individual Submission
Number of pages: 13

Abstract:
    Current work on wavelength switched optical network includes several
    considerations regarding the interface signal compatibility.  In
    particular ingress and egress optical interfaces will require a check
    on several optical parameters to assess if the signal generated by
    the ingress interface can be compatible with the receiving interface.
    Current solution available encode all parameters in WSON protocol
    extensions while in this draft will propose an alternative method to
    keep into account the signal compatibility issue at protocol level.

The IETF Secretariat

---

From: Leeyoung <[email-masked]>
Date: Thu, 22 Mar 2012 17:03:25 +0000

Hi Giovanni,

It looks like your draft is in the context of black links and the use of some of ITU-T interface model for impairment context. Your reference is G.698.1 and .2.

This seems to belong to impairment/black link model which is beyond the current WSON scope. The part of confusion is the fact that G.698.1 and .2 talk about some modulation type (such as NRZ’s).  But this was discussed in the context of black link.  We are discussing Modulation and FEC  in the context of resource block property (OEO/REG). Our ITU-T reference is 709, 975 and 959.1.

One of the referred entities in your interface class is fiber type, which is an important factor in impairment modeling, but this is beyond the scope of non-impairment WSON, which is our current scope.

Regards,
Young
From: [email-masked] [mailto:[email-masked]] On Behalf Of Giovanni Martinelli
Sent: Tuesday, March 06, 2012 10:58 AM
To: CCAMP
Subject: [CCAMP] Fwd: New Version Notification for draft-martinelli-wson-interface-class-02.txt

Dear Ccamp,

The idea is to make WSON protocol extensions independent of explicit optical parameters encoding as currently defined in following IDs (referring only to wg documents):

As and additional benefit,  the optical interface class can be fully compatible with ITU application code concept.

Draft was first presented in Quebec and there were several good reactions from the room, so please provide comments!

Thanks in advance
Giovanni & co-authors

-------- Original Message --------
Subject:

New Version Notification for draft-martinelli-wson-interface-class-02.txt

Date:

Tue, 06 Mar 2012 08:30:45 -0800

From:

[email-masked]<mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Revision:       02

Number of pages: 13

Abstract:

The IETF Secretariat

---

From: Giovanni Martinelli <[email-masked]>
Date: Fri, 23 Mar 2012 14:12:35 +0100

Hi Young,

appreciate your comments! The part of the draft which report references 
to G.698.x is the encoding that shows how the interface class concept is 
fully compatible with the ITU application code.   In the next revision 
we could figure out code points for all ITU applications codes available 
now (including G.959).

I would like to mention however that the Optical Interface Class is 
fully in scope with current WSON rwa activity (not only with 
impairments) since even for RWA you need to assess at least signal 
compatibility. Current WSON proposal have explicit parameters 
definitions (e.g. FEC and Modulation formats), with the Interface class 
concept you don't need to explicit them since the semantic of the class 
will be defined elsewhere.

The goal is not saving bits in encoding but making protocol WSON 
extensions a bit more independent from explicit optical parameters 
definitions.

Cheers
G

On 3/22/12 18:03 , Leeyoung wrote:
>
> Hi Giovanni,
>
> It looks like your draft is in the context of black links and the use 
> of some of ITU-T interface model for impairment context. Your 
> reference is G.698.1 and .2.
>
> This seems to belong to impairment/black link model which is beyond 
> the current WSON scope. The part of confusion is the fact that G.698.1 
> and .2 talk about some modulation type (such as NRZ’s).  But this was 
> discussed in the context of black link.  We are discussing Modulation 
> and FEC  in the context of resource block property (OEO/REG). Our 
> ITU-T reference is 709, 975 and 959.1.
>
> One of the referred entities in your interface class is fiber type, 
> which is an important factor in impairment modeling, but this is 
> beyond the scope of non-impairment WSON, which is our current scope.
>
> Regards,
>
> Young
>
> *From:[email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Giovanni Martinelli
> *Sent:* Tuesday, March 06, 2012 10:58 AM
> *To:* CCAMP
> *Subject:* [CCAMP] Fwd: New Version Notification for 
> *Subject: *
> *Date: *
> *From: *
> [email-masked] <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>
>
> *CC: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>
>