Subject: [CCAMP] draft-margaria-ccamp-label-set-ero-00?

From: Lou Berger <[email-masked]>
Date: Mon, 26 Mar 2012 15:53:15 +0200

We had to cut off discussion on this draft given the folks for the next
meeting coming in.  Had we more time, we would have asked if there is
any interest in this function (not solution approach).

So, is there any interest in the function described in this document?

Does anyone think it's a bad idea (again, this is a question on any
specific mechanism, but on the requirement)?

Thanks,
Lou

---

From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 28 Mar 2012 11:22:09 +0200

Hi, 

I have interest (as author :-), a short summary on why we think the label set is required to be specified at any node: 
 
1) In any switching having label restriction (WSON being the well-known example), to control the label assignment on some path section. The label set is only required to be restricted on nodes having this restriction. Explicit label set allows to have this without requiring all the nodes to be aware of those restrictions.
  
2) restricting the label selection to one label rather than a set of label is too strong.

3) To allow PCE (via PCEP) to indicate to the PCC which set of label to use.

This apply for Distributed RWA, policy based label assignment or physical restrictions. 

Best regards / Mit freundlichen Grüßen
Cyril Margaria

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of ext Lou Berger
> Sent: Monday, March 26, 2012 3:53 PM
> To: CCAMP
> Subject: [CCAMP] draft-margaria-ccamp-label-set-ero-00?
> 
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Ramon Casellas <[email-masked]>
Date: Sat, 31 Mar 2012 09:27:49 +0200

> So, is there any interest in the function described in this document?
Lou, all (note: speaking as a co-author)

Yes I think the proposed function is interesting:
- Extend explicit label control to a set (>1) of labels, notably in 
constrained environments such as D-WA in transparent segments
- Enable exclusive-explicit label control
- More efficient encodings when including / excluding labels e.g. in 
IRO/XRO (although secondarily and subject to PCE-wg opinion following 
Julien's guidelinets)

thanks
Ramon