Subject: [CCAMP] Comments/questions on draft-ietf-ccamp-wson-signaling-03

From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 27 Mar 2012 10:21:43 +0200

Hi, 

I have the following questions on draft-ietf-ccamp-wson-signaling-03.

Q1.Sextion 3.3, Editor note : Do you refer to section 5 or other points as well?

Q2. Section 4.2. "Signal Attributes and Processing"

This section indicate options, it would be helpful to indicate preferences or indication on pro/cons at this stage.
In this context one point that can be considered for discussion is that using LSP_ATTRIBUTE would require PCEP extensions, (Similar consideration on LSP_ATTRIBUTE is addressed in draft-margaria-ccamp-label-set-ero-00.txt) 

Q3. Section 4.2. "Signal Attributes and Processing", processing object definition:

In case of bidirectional LSP a node can have 2 transmitter and 2 receivers (one couple for each direction).
To what refer the transmitter /receiver capabilities?  

Q4. Explicit Resource block information.
The OSPF draft make use of Resource Block, but it is not possible to explicitly signal it.
I think it can be useful to support explicit selection for the Resource to be used, especially if the PCE took into account more information that is capable the local node.

Mit freundlichen Grüßen / Best Regards
Cyril Margaria

Nokia Siemens Networks GmbH & Co. KG
NWS DWDM RD
St.Martin-Str. 76
D-81541 München
Germany
mailto:[email-masked]
Phone: +49-89-5159-16934
Fax:   +49-89-5159-44-16934
----------------------------------------------------------------
Nokia Siemens Networks GmbH & Co. KG 
Sitz der Gesellschaft: München / Registered office: Munich 
Registergericht: München / Commercial registry: Munich, HRA 88537 
WEEE-Reg.-Nr.: DE 52984304 
Persönlich haftende Gesellschafterin / General Partner: Nokia Siemens Networks Management GmbH 
Geschäftsleitung / Board of Directors: Dr. Hermann Rodler, Lydia Sommer, Olaf Horsthemke 
Vorsitzender des Aufsichtsrats / Chairman of supervisory board: Herbert Merz 
Sitz der Gesellschaft: München / Registered office: Munich 
Registergericht: München / Commercial registry: Munich, HRB 163416

---

From: Giovanni Martinelli <[email-masked]>
Date: Wed, 28 Mar 2012 00:29:46 +0200

Hi Cyril,

> Q1.Sextion 3.3, Editor note : Do you refer to section 5 or other points as well?
[GM] yes, btw given current section 5 we can drop this note.
> In this context one point that can be considered for discussion is that using LSP_ATTRIBUTE would require PCEP extensions, (Similar consideration on LSP_ATTRIBUTE is addressed in draft-margaria-cca…
[GM] honestly I don't have strong opinion here on best solution...  I 
lean toward ero extensions but would love to hear solicited comments on 
your ID here above as well.

> To what refer the transmitter /receiver capabilities?
[GM] yes agree. The first step we did was was removing duplicated 
information and refer to wson info model and encoding whenever 
possible...  so work in progress.

> I think it can be useful to support explicit selection for the Resource to be used, especially if the PCE took into account more information that is capable the local node.
[GM] Good point let's discuss more on this

Cheers
G
> Nokia Siemens Networks GmbH&  Co. KG
> NWS DWDM RD
> St.Martin-Str. 76
> D-81541 München
> Germany
> Nokia Siemens Networks GmbH&  Co. KG
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp