Subject: [CCAMP] I-D Action: draft-ietf-ccamp-rsvp-te-srlg-collect-00.txt

From: [email-masked]
Date: Tue, 26 Jun 2012 14:53:32 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Common Control and Measurement Plane Working Group of the IETF.

	Title           : RSVP-TE Extensions for Collecting SRLG Information
	Author(s)       : Fatai Zhang
                          Dan Li
                          Oscar Gonzalez de Dios
                          Cyril Margaria
	Filename        : draft-ietf-ccamp-rsvp-te-srlg-collect-00.txt
	Pages           : 9
	Date            : 2012-06-26

Abstract:
   This document provides extensions for the Resource ReserVation
   Protocol-Traffic Engineering (RSVP-TE) to support automatic
   collection of Shared Risk Link Group (SRLG) Information for the TE
   link formed by a LSP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-rsvp-te-srlg-collect

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ccamp-rsvp-te-srlg-collect-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sidd Aanand <[email-masked]>
Date: Thu, 28 Jun 2012 02:55:09 +0000

Hello Authors,

I have a basic question about the draft. 

OSPF-TE is already advertising the SRLGs associated with each TE-link (AFAIK this includes LSPs that are modeled as TE-links). So each node in the network already has the information on the set of SRLGs a TE link belongs to.

Each node can compute a path through the network and the path would typically be computed using a path computation algorithm that uses the topology information distributed by OSPF-TE (or any other equivalent routing protocol). Once the path is computed (source routing), then the TE-links used by the path is known at the head-end. Once TE-links are known, SRLG information is also known (from above).

So where does the need to carry the SRLG info the RROs arise?

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, June 27, 2012 3:24 AM
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-rsvp-te-srlg-collect-00.txt

Abstract:

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 28 Jun 2012 06:09:45 +0000

Hi Sidd, 

We of course know that SRLG is one of attributes of TE links including physical links or FA.

However, this draft addresses how to collect the SRLG of an H-LSP or S-LSP, which will be formed as an FA or private TE links in the upper layer (inter-layer scenario) or another domain (inter-domain scenario). 

I think you can get more information from [draft-zhang-ccamp-srlg-fa-configuration-04.txt], which provides more background or motivations of this function. In draft-zhang-ccamp-srlg-fa-configuration-05.txt or draft-ietf-ccamp-rsvp-te-srlg-collect-00.txt, some information has been removed based on the feedback of WG. 

Thanks

Fatai

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Sidd Aanand
发送时间: 2012年6月28日 10:55
收件人: [email-masked]; [email-masked]
抄送: [email-masked]
主题: Re: [CCAMP] I-D Action: draft-ietf-ccamp-rsvp-te-srlg-collect-00.txt

Hello Authors,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, June 27, 2012 3:24 AM
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-rsvp-te-srlg-collect-00.txt

Abstract: