Subject: [CCAMP] WSON updates for Optical Interface Classes

From: Greg Bernstein <[email-masked]>
Date: Wed, 08 Aug 2012 10:04:11 -0700

Hi CCAMPers, per working group consensus we have updated the following 
WSON drafts:

http://tools.ietf.org/html/draft-ietf-ccamp-wson-signal-compatibility-ospf-10
http://tools.ietf.org/html/draft-ietf-ccamp-rwa-wson-encode-15
http://tools.ietf.org/html/draft-ietf-ccamp-rwa-info-15.

We have removed "modulation type", "FEC type", and "Bit rate range" and replace with the "Optical Interface Class".
We have applied the changes suggested on the CCAMP list and in the OIC draft.
There are some undefined references that need to be filled in by the authors of the OIC draft.
Please furnish references or suitable text.
Info draft:
..."Where the term <OPTICAL_INT_CLASS> is defined by [xyz]."
           
Encoding draft:
..."The Optical Interface Class format is defined within [x-ref-tbd]."

See updated drafts for further context. Also if an encoding example is desired for
appendix A of the encoding draft please furnish.

To ease and expedite further changes on the OIC issue
MS Word versions of these documents can be found at:
http://www.grotto-networking.com/sites/default/files/draft-ietf-ccamp-wson-signal-compatibility-ospf-10a.docx
http://www.grotto-networking.com/sites/default/files/draft-ietf-ccamp-rwa-wson-encode-15a.docx
http://www.grotto-networking.com/sites/default/files/draft-ietf-ccamp-rwa-info-15a.docx

Best Regards
Greg B.

-- 
===================================================
Dr Greg Bernstein, Grotto Networking (510) 573-2237

---

From: Lou Berger <[email-masked]>
Date: Wed, 15 Aug 2012 17:40:12 -0400

Greg/Authors,
	When do you expect to have a rev of the signaling draft to match the
recent updates (including the previous addition of WSON-LSC type)?

Thanks,
Lou

---

From: Greg Bernstein <[email-masked]>
Date: Thu, 16 Aug 2012 09:19:10 -0700

Hi Lou, I'll try to update today or tomorrow.  On WSON routing, I still 
haven't heard from the OIC draft authors on resolving the undefined 
references mentioned below.
Best Regards
Greg

---

From: "Ong, Lyndon" <[email-masked]>
Date: Thu, 16 Aug 2012 12:45:06 -0400

Hi Greg, Lou,

Sorry, a little confused - aren't you defining the OIC format within the wson encoding draft itself?  I would think the external references you need are for the ITU-T application codes, rather than the OIC format.  Am I missing something?

The ITU-T references would be 
[ITU-G.698.1] ITU-T Recommendation G.698.1, "Multichannel DWDM applications with
single-channel optical interfaces", November, 2009.
[ITU-G.698.2] ITU-T Recommendation G.698.2, "Amplified multichannel dense wavelength division multiplexing applications with single channel optical interfaces", November, 2009.
[ITU-G.959.1] ITU-T Recommendation G.959.1, "Optical transport networks physical layer interfaces", February, 2012.

Cheers,

Lyndon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Greg Bernstein
Sent: Thursday, August 16, 2012 9:19 AM
To: Lou Berger
Cc: CCAMP; [email-masked]
Subject: Re: [CCAMP] WSON updates for Optical Interface Classes

Hi Lou, I'll try to update today or tomorrow.  On WSON routing, I still haven't heard from the OIC draft authors on resolving the undefined references mentioned below.
Best Regards
Greg
On 8/15/2012 2:40 PM, Lou Berger wrote:
>> Hi CCAMPers, per working group consensus we have updated the 
>> following WSON drafts:
>>
>> See updated drafts for further context. Also if an encoding example 
>> is desired for appendix A of the encoding draft please furnish.
>>
>> To ease and expedite further changes on the OIC issue MS Word 
>> versions of these documents can be found at:

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Thu, 16 Aug 2012 18:33:14 +0000

Hi,

In addition to the ones that Lyndon mentioned, should also include 
[ITU-T G.695]	Recommendation ITU-T G.695 (2010), Optical interfaces for coarse wavelength division multiplexing applications.

Regards,
Kam
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ong, Lyndon
> Sent: Thursday, August 16, 2012 12:45 PM
> To: Greg Bernstein; Lou Berger
> Sorry, a little confused - aren't you defining the OIC format within
> the wson encoding draft itself?  I would think the external references
> you need are for the ITU-T application codes, rather than the OIC
> format.  Am I missing something?
> 
> [ITU-G.698.2] ITU-T Recommendation G.698.2, "Amplified multichannel
> dense wavelength division multiplexing applications with single channel
> optical interfaces", November, 2009.
> [ITU-G.959.1] ITU-T Recommendation G.959.1, "Optical transport networks
> physical layer interfaces", February, 2012.
> 
> Cheers,
> 
> Lyndon
> 
> >> http://tools.ietf.org/html/draft-ietf-ccamp-wson-signal-
> compatibility
> >> -ospf-10
> >> We have removed "modulation type", "FEC type", and "Bit rate range"
> and replace with the "Optical Interface Class".
> >> http://www.grotto-networking.com/sites/default/files/draft-ietf-
> ccamp
> >> -wson-signal-compatibility-ospf-10a.docx
> >> http://www.grotto-networking.com/sites/default/files/draft-ietf-
> ccamp
> >> -rwa-wson-encode-15a.docx
> >> http://www.grotto-networking.com/sites/default/files/draft-ietf-
> ccamp
> >> -rwa-info-15a.docx
> >>
> >> Best Regards
> >> Greg B.
> >>
> >>
> >>
> 
> 
> --

---

From: Greg Bernstein <[email-masked]>
Date: Thu, 16 Aug 2012 14:51:28 -0700

We implemented the WSON Info changes requested in Giovanni's CCAMP list 
email dated 07/05/2012. Don't know what those references were referring 
to.  Please review changes to updated WSON info and WSON encoding drafts 
and send us any deltas.
Best Regards
Greg

---

From: "Ong, Lyndon" <[email-masked]>
Date: Thu, 16 Aug 2012 18:07:32 -0400

Hi Greg,

Well my two cents would be the following:

1) WSON encoding draft, section 5.2: 
The Optical Interface Class format is defined within [x-ref-tbd].

Propose to remove the sentence as the format is defined within the encoding draft itself.

2) WSON information model draft, section 5.3:
Where the term <OPTICAL_INT_CLASS> is defined by [xyz?].

Propose to replace the sentence with text from draft-martinelli section 3.1 (with some grammatical edits):
   The Optical Interface Class is a unique number that identifies all
   information related to optical characteristics of a physical
   interface.  The class may include other optical parameters related
   to other interface properties.  A class MUST always include signal
   compatibility information.

   The content of each class is out of the scope of this draft and can
   be defined by other entities (e.g.  ITU, optical equipment vendors,
   etc.).

   Since even current implementation of physical interfaces may support
   different optical characteristics, a single interface may support
   multiple interface classes.  Which optical interface class is used
   among all the ones available for an interface is out of the scope
   of this draft but is an output of the RWA process.

Cheers,

Lyndon
-----Original Message-----
From: Greg Bernstein [mailto:[email-masked]] 
Sent: Thursday, August 16, 2012 2:51 PM
To: Ong, Lyndon
Cc: Lou Berger; CCAMP; [email-masked]
Subject: Re: [CCAMP] WSON updates for Optical Interface Classes

We implemented the WSON Info changes requested in Giovanni's CCAMP list email dated 07/05/2012. Don't know what those references were referring to.  Please review changes to updated WSON info and WSON encoding drafts and send us any deltas.
Best Regards
Greg
On 8/16/2012 9:45 AM, Ong, Lyndon wrote:
> [ITU-G.698.1] ITU-T Recommendation G.698.1, "Multichannel DWDM 
> applications with single-channel optical interfaces", November, 2009.
> Of Greg Bernstein
>>> http://tools.ietf.org/html/draft-ietf-ccamp-wson-signal-compatibilit
>>> y
>>> -ospf-10
>>> http://www.grotto-networking.com/sites/default/files/draft-ietf-ccam
>>> p -wson-signal-compatibility-ospf-10a.docx
>>> http://www.grotto-networking.com/sites/default/files/draft-ietf-ccam
>>> p
>>> http://www.grotto-networking.com/sites/default/files/draft-ietf-ccam
>>> p
>>> -rwa-info-15a.docx
>>>
>>> Best Regards
>>> Greg B.
>>>
>>>
>>>
>
> --

---

From: Greg Bernstein <[email-masked]>
Date: Thu, 16 Aug 2012 16:21:35 -0700

Hi Lyndon and CCAMPers, we have updated the drafts with your suggested 
changes. Please see:

http://tools.ietf.org/html/draft-ietf-ccamp-rwa-wson-encode-16
http://tools.ietf.org/html/draft-ietf-ccamp-rwa-info-16

The authors believe that these drafts and the draft

are now ready for last call.
Best Regards
Greg