Subject: [CCAMP] 答复: WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

From: Fatai Zhang <[email-masked]>
Date: Tue, 13 Nov 2012 06:32:21 +0000

Hi Lou and all, 

A new version has been submitted with the udpates based on the comments from Lou.

Please see more in-line below marked with [Fatai]. 

Best Regards

Fatai

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Lou Berger
发送时间: 2012年10月20日 7:06
收件人: CCAMP; [email-masked]
主题: [CCAMP] WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Authors,
	I have the following LC comments:

General comment:
- I have a comment related to the info document, that I'll cover in a
separate mail on the info-model document .

- I found appendix A to not be very informative and thing there are
better examples in the other documents, suggest either moving one ore
more to this document or drop the appendix.

[Fatai] The appendix has been dropped, because we think it is better to keep the examples in the other documents. 

The remaining comments are editorial in nature

- Please verify that abbreviations are defined before being used .
There are a number of these.

[Fatai] Checked and updated. 

- Please use a consistent decimal representation (sometimes commas are
used other times periods)

[Fatai] Checked and commas are used.

- the references [G709-v1] and [G709-v3] each actually refer to multiple
documents, each documented needs to have it's own (correct) reference,
i.g., [G709-v1] and [G709-v1a1]. The document text will need to be
revisited to ensure the proper reference is made.

[Fatai] [G709-V3A2] is introduced and referenced in the right place.
-
http://tools.ietf.org/idnits?url=http://tools.ietf.org/id/draft-ietf-ccamp-gmpls-g709-framework-09.txt
shows there are unresolved nits that need to resolved .  I'm using line
numbers from this url in my subsequent comments.

- Line 46: How about replace "as consented in October 2009" with "as
published in 2009."

[Fatai] Accepted.

- Line 255: Drop "approved in 2009" the reference is sufficient

[Fatai] Accepted.

- Line 260: suggest the following change:
OLD
                2.5Gb/s     1.25Gb/s           Nominal Bit rate
NEW
                Time Slot Granularity
                2.5Gb/s     1.25Gb/s           Nominal Bit rate

[Fatai] Accepted.

- Lines 272-274: Please add the appropriate reference to G.709 section
or table that points to where one finds the information on determining
actual bit rate.

[Fatai] Accepted.

- Line 307: suggest changing "into the OTUk" --> "into a specific OTUk"

[Fatai] Accepted.

- Line 340/1: need a reference to where this is defined.

[Fatai] Accepted and added.

- Line 346-347: Need a reference to where this behavior is defined.

[Fatai] Accepted and added.

- Lines 387/388.  Isn't this sentence OBE and should be dropped?

[Fatai] Accepted.

- Page 11, RWA is used in a few places on this page as is OCh layer,
suggest replacing all instances of RWA with OCH or "OCh layer".

[Fatai] Accepted.

- Line 500: what do you mean by "including OCh layer visibility."? this
isn't really reflected in the solutions documents (other than as MLN).

[Fatai] Deleted to avoid ambiguity. 

- Line 589: replace "New label" with "A new label format"

[Fatai] Accepted.

- Line 636: replace "some" with "sufficient"

[Fatai] Accepted.

- Lines 639-641: drop lines (seems redundant with following paragraph)

[Fatai] Accepted and dropped.

- Line 686: your usage of "just" is a bit odd, how about replace "be
just switched" with "restricted to switching"

[Fatai] Accepted.

- Line 688: similarly how about replace "just terminated" to "restricted
to termination"

[Fatai] Accepted.

- lines 714-719, probably should have a reference to [rfc4201]

[Fatai] Accepted.

- Line 879: Replace "contrary" with "opposite" or "reverse"

[Fatai] Accepted.

- Line 888. I suggest adding "Although, this is not greater than the
risks presented by the existing OTN control plane as defined by
[RFC4203] and [RFC4328]."

[Fatai] Accepted.

- Lines 888-890, I suggest dropping the sentence starting with "The data
plane technology..." for multiple reasons, not least of which is that
the ITU-T owns the data plane so the comment is completely out of scope.

[Fatai] Accepted.

- Lines 1081/2: The whole document is non-normative, so just drop this
sentence.

[Fatai] Accepted.

That's it on this document.

Lou

On 10/8/2012 4:47 PM, Lou Berger wrote:
> This mail begins a two week working group last call on:
> 
> http://tools.ietf.org/html/draft-ietf-ccamp-gmpls-g709-framework-09
> (Informational)
> 
> http://tools.ietf.org/html/draft-ietf-ccamp-otn-g709-info-model-04
> (Informational)
> 
> http://tools.ietf.org/html/draft-ietf-ccamp-gmpls-ospf-g709v3-03
> (Standards Track)
> 
> http://tools.ietf.org/html/draft-ietf-ccamp-gmpls-signaling-g709v3-04
> (Standards Track)
> 
> This working group last call ends on October 22.  Comments should be
> sent to the CCAMP mailing list.  Please remember to include the
> technical basis for any comments.
> 
> Please note that we're still missing a few IPR statements, and look
> for these to come in during the LC period.  Any forthcoming publication
> request will be delayed by late IPR statements/disclosures.
> 
> Thank you,
> Lou (and Deborah)
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
> 
> 
> 
> 
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Lou Berger <[email-masked]>
Date: Tue, 13 Nov 2012 08:56:01 -0500

Fatai, Authors,
	Thank you for the update.  Please see below for specific responses.

> [Fatai] The appendix has been dropped, because we think it is better to keep the examples in the other documents. 

Okay.  You might want to have a reference to examples in other documents
where appropriate.

> [Fatai] Checked and updated. 

great.

> [Fatai] Checked and commas are used.

okay.

> [Fatai] [G709-V3A2] is introduced and referenced in the right place.

It looks like v1 still has this issue.

> numbers from this url in my subsequent comments.

In your next update, please resolve the nits as reported in
http://tools.ietf.org/idnits?url=http://tools.ietf.org/id/draft-ietf-ccamp-gmpls-g709-framework-10.txt

The rest looks good.

Much thanks,
Lou

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 14 Nov 2012 01:24:58 +0000

Hi Lou,

Regarding [G709-v1] reference, there is only general reference to [G709-v1] and [G709-v1a1], ie., no specific text is referenced from some specific place of these two documents, so we reused the same approach used by [RFC4328], otherwise, [G709-v1] and [G709-v1a1] should be used together to replace the alone [G709-v1] (because it is really difficult to differentiate either [G709-v1] or [G709-v1a1] should be referenced). 

Here is the referenced used by [RFC4328]: 
[ITUT-G709] ITU-T, "Interface for the Optical Transport Network (OTN)," G.709 Recommendation (and Amendment 1), February 2001 (October 2001).

Is that acceptable for you?

In addition, the nits will be resolved in the next update.

Best Regards

Fatai

-----邮件原件-----
发件人: Lou Berger [mailto:[email-masked]] 
发送时间: 2012年11月13日 21:56
收件人: Fatai Zhang; [email-masked]
抄送: CCAMP
主题: Re: 答复: [CCAMP] WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Fatai, Authors,

great.

okay.

The rest looks good.

Much thanks,
Lou

---

From: Lou Berger <[email-masked]>
Date: Wed, 14 Nov 2012 07:47:54 -0500

> Is that acceptable for you?

I don't understand how one reference can be used for two documents.  I
suspect this slipped by the RFC editor.  I think it makes most sense to
have one reference per document.

> In addition, the nits will be resolved in the next update.

Thanks.

Lou

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 14 Nov 2012 14:54:54 +0000

Hi,

For RFC4328, both the Recommendation and Amendment were the current references at the time. It is questionable if should do as one reference or two, but it doesn't matter, as now these have all been superseded (incorporated in) by the latest G.709 dated 02/2012. We should use that (only) as reference. Similar for G.798, we should only use the latest pub. For ITU, one only needs to reference the latest pub.

Thanks,
Deborah

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, November 14, 2012 7:48 AM
To: Fatai Zhang
Cc: CCAMP; [email-masked]
Subject: Re: [CCAMP] 答复: 答复: WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Thanks.

Lou

---

From: Huub van Helvoort <[email-masked]>
Date: Wed, 14 Nov 2012 23:14:47 +0100

Somehow this email did not appear in the CCAMP list.

-------- Original Message --------
Subject: Re: [CCAMP] 答复: 答复:  WG Last Call comments on
draft-ietf-ccamp-gmpls-g709-framework-09
Date: Wed, 14 Nov 2012 10:48:28 +0100
From: Huub van Helvoort <[email-masked]>
Reply-To: [email-masked]
To: Fatai Zhang <[email-masked]>
CC: Lou Berger <[email-masked]>,
"[email-masked]"
<[email-masked]>, CCAMP
<[email-masked]>

Hello Fatai,

(only focusing  on the reference)

You wrote:

> Regarding [G709-v1] reference, there is only general reference to
> [G709-v1] and [G709-v1a1], ie., no specific text is referenced from
> some specific place of these two documents, so we reused the
> same approach used by [RFC4328], otherwise, [G709-v1] and
> [G709-v1a1] should be used together to replace the alone
> [G709-v1] (because it is really difficult to differentiate either
> [G709-v1] or [G709-v1a1] should be referenced).
> 
> [ITUT-G709] ITU-T, "Interface for the Optical Transport Network 
> (OTN)," G.709 Recommendation (and Amendment 1), February
> 2001 (October 2001).

Please note that the current in-force version of G.709 is from
February 2012, it includes all previous amendments, no need
to reference them separately.
Also G.709 has an additional Y.1331 number, so the reference
can be:

[ITUT-G709] ITU-T, "Interface for the Optical Transport Network
(OTN)," G.709/Y.1331 Recommendation, February 2012.

Regards, Huub.

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 15 Nov 2012 01:22:12 +0000

Hi Huub,

Thanks.

I just checked and we may need to use [G709-V4] to replace [G709-V3] and [G709-V3A2]. 

Best Regards

Fatai

-----邮件原件-----
发件人: Huub van Helvoort [mailto:[email-masked]] 
发送时间: 2012年11月14日 17:48
收件人: Fatai Zhang
抄送: Lou Berger; [email-masked]; CCAMP
主题: Re: [CCAMP] 答复: 答复: WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Hello Fatai,

Regards, Huub.

-- 
*****************************************************************
              请记住，你是独一无二的，就像其他每一个人一样

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 15 Nov 2012 01:59:15 +0000

Hi Chairs,

Thanks for your comments and suggestions.

A couple of things that I want to clarify on the reference:

(1)The "new" G.709: The latest version of G.709 in force is V4, so we need to reflect the newest one for the new features of OTN as what Deborah and Huub suggested, ie., we need to use [G709-V4] to replace [G709-V3] and [G709-V3A2]. In this way, the file name of solution drafts (draft-ietf-ccamp-gmpls-signaling-g709v3, draft-ietf-ccamp-gmpls-ospf-g709v3) should be changed (ie., remove v3 in the file name). 

Is that OK?

(2) The "old" G.709: We need to reference the "old" G.709 when we talk about the history of G.709 including data plane and control plane. For the ITU-T recommendations (data plane), there are a couple of versions (including V1=G.709/Y.1331 (02/2001), V1.1= G.709/Y.1331 (2001) Amd. 1 (11/2001), V2=G.709/Y.1331 (03/2003) ) before RFC4328 published in 2006. Actually, I think RFC4328 should reference V2, but it referenced V1 and V1.1 (v1amd1). So when we talked about the control plane history, RFC4328 only supports V1 and V1.1 (RFC4328 may not support something of V2). Note that an amd means amendment (delta info) and it is not a complete version of a recommendation.
This is the reason that we reused the same approach as RFC4328. Does this make sense?

Best Regards

Fatai

-----邮件原件-----
发件人: BRUNGARD, DEBORAH A [mailto:[email-masked]] 
发送时间: 2012年11月14日 22:55
收件人: Lou Berger; Fatai Zhang
抄送: CCAMP; [email-masked]
主题: RE: [CCAMP] 答复: 答复: WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Hi,

Thanks,
Deborah

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, November 14, 2012 7:48 AM
To: Fatai Zhang
Cc: CCAMP; [email-masked]
Subject: Re: [CCAMP] 答复: 答复: WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Thanks.

Lou

---

From: Lou Berger <[email-masked]>
Date: Wed, 14 Nov 2012 21:23:38 -0500

On 11/14/2012 8:59 PM, Fatai Zhang wrote:
> (1)The "new" G.709: The latest version of G.709 in force is V4, so we
> need to reflect the newest one for the new features of OTN as what
> Deborah and Huub suggested, ie., we need to use [G709-V4] to replace

how about [G709-2012] (per Deborah)?

> [G709-V3] and [G709-V3A2]. In this way, the file name of solution
> drafts (draft-ietf-ccamp-gmpls-signaling-g709v3,
> draft-ietf-ccamp-gmpls-ospf-g709v3) should be changed (ie., remove v3
> in the file name).
>
> Is that OK?

NO. Please don't try to change the file name(s). It's just a file name
and changing it will complicate the process.

> (2) The "old" G.709: We need to reference the "old" G.709 when we
> talk about the history of G.709 including data plane and control
> plane. For the ITU-T recommendations (data plane), there are a couple
> of versions (including V1=G.709/Y.1331 (02/2001), V1.1= G.709/Y.1331
> (2001) Amd. 1 (11/2001), V2=G.709/Y.1331 (03/2003) ) before RFC4328
> published in 2006. Actually, I think RFC4328 should reference V2, but
> it referenced V1 and V1.1 (v1amd1). So when we talked about the
> control plane history, RFC4328 only supports V1 and V1.1 (RFC4328 may
> not support something of V2). Note that an amd means amendment (delta
> info) and it is not a complete version of a recommendation.
> 

> This is the reason that we reused the same approach as RFC4328. Does this make sense?

I'm not sure what your question is here, but please follow Deborah's
advice with respect to the old versions.

Lou

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 15 Nov 2012 02:49:04 +0000

Hi Lou,

OK to use [G709-2012] and keep the file names.

By following Deborah's, my understanding is to use the same approach as RFC4328 to reference the "old" G.709, am I right?

Best Regards

Fatai

-----邮件原件-----
发件人: Lou Berger [mailto:[email-masked]] 
发送时间: 2012年11月15日 10:24
收件人: Fatai Zhang
抄送: BRUNGARD, DEBORAH A; CCAMP; [email-masked]
主题: Re: 答复: [CCAMP] 答复: 答复: WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Lou

---

From: Lou Berger <[email-masked]>
Date: Thu, 15 Nov 2012 08:07:33 -0500

On 11/14/2012 9:49 PM, Fatai Zhang wrote:
> By following Deborah's, my understanding is to use the same approach
> as RFC4328 to reference the "old" G.709, am I right?

By "following Deborah's advice" I mean look at the mail she sent to the
authors and use her suggested approach.  Her mail said:

    To make it simple, we can avoid the v1 vs. v3 by only referencing
    RFC4328 and so avoid referencing a reference of a reference -
    RFC4328's reference of G709- in our document.

And then continued with some suggested language.

So no, do not reference [G709-V1].

Lou

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 16 Nov 2012 01:56:17 +0000

Hi Lou,

Thanks, will move to that direction.

Best Regards

Fatai

-----邮件原件-----
发件人: Lou Berger [mailto:[email-masked]] 
发送时间: 2012年11月15日 21:08
收件人: Fatai Zhang
抄送: BRUNGARD, DEBORAH A; CCAMP; [email-masked]
主题: Re: 答复: 答复: [CCAMP] 答复: 答复: WG Last Call comments on draft-ietf-ccamp-gmpls-g709-framework-09

Lou