Subject: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-02 a WG document

From: Lou Berger <[email-masked]>
Date: Fri, 07 Dec 2012 15:48:19 -0500

All,

This is to start a two week poll on making
draft-margaria-ccamp-lsp-attribute-ero-02 a ccamp working
group document. Please send mail to the list indicating "yes/support"
or "no/do not support".  If indicating no, please state your technical
reservations with the document.

The poll ends Friday December 21.

Much thanks,
Lou (and Deborah)

PS We're still waiting on one IPR statement.

---

From: Eric Gray <[email-masked]>
Date: Fri, 7 Dec 2012 21:13:14 +0000

Not support

(At least not at this time)

There are a couple of technical issues:

1) I do not see any explanation of - or examples for - the use case where LSP attributes would apply to a 
hop in an LSP and not to the entire LSP.  If attributes apply to an entire LSP, than there are existing ways
to do this. If it is possible to have an attribute that applies to a single hop in the LSP, does this not raise
issues with "weak-links"?

2) I strongly suspect that this approach MUST rely on information present at the signaling initiator that 
would be "too much information" about nodes and links in the LSP-path.  This information may change,
even between the time that the path is determined (by whatever means) and the time that signaling is
initiated.

--
Eric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Friday, December 07, 2012 3:48 PM
To: [email-masked]
Subject: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-02 a WG document

All,

This is to start a two week poll on making
draft-margaria-ccamp-lsp-attribute-ero-02 a ccamp working group document. Please send mail to the list indicating "yes/support"
or "no/do not support".  If indicating no, please state your technical reservations with the document.

Much thanks,
Lou (and Deborah)

PS We're still waiting on one IPR statement.
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Leeyoung <[email-masked]>
Date: Fri, 7 Dec 2012 22:43:11 +0000

Yes/support.

Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Friday, December 07, 2012 2:48 PM
To: [email-masked]
Subject: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-02 a WG document

All,

Much thanks,
Lou (and Deborah)

---

From: Oscar González de Dios <[email-masked]>
Date: Sun, 09 Dec 2012 20:16:45 +0000

Yes, support

Best Regards,

        Óscar

-----Mensaje original-----
De: [email-masked] [mailto:[email-masked]] En nombre de Lou Berger
Enviado el: viernes, 07 de diciembre de 2012 21:48
Para: [email-masked]
Asunto: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-02 a WG document

All,

Much thanks,
Lou (and Deborah)

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Mach Chen <[email-masked]>
Date: Mon, 10 Dec 2012 01:08:22 +0000

Yes/support.

I think this is a very useful draft, it provides the capability to enforce per-hop attribute. 

I see there are at least two use cases, one is the "Control plane based Lock Instruct and Loopback" (http://tools.ietf.org/html/draft-dong-ccamp-rsvp-te-mpls-tp-li-lb-05 ), the other is the "Designation of PLRs in TE FRR"(http://tools.ietf.org/html/draft-dong-ccamp-rsvp-te-plr-designation-00), both cases can use the per-hop attribute mechanisms defined in this draft. 

Best regards,
Mach

> Sent: Saturday, December 08, 2012 4:48 AM
> To: [email-masked]

---

From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 10 Dec 2012 08:55:35 +0100

Yes/support 

Best regards / Mit freundlichen Grüßen
Cyril Margaria

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of ext Lou Berger
> Sent: Friday, December 07, 2012 9:48 PM
> To: [email-masked]
> Subject: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-
> 02 aWG document
> 
> All,
> 
> draft-margaria-ccamp-lsp-attribute-ero-02 a ccamp working group
> document. Please send mail to the list indicating "yes/support"

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Mon, 10 Dec 2012 08:58:16 +0100

Yes/support 

Best regards,
Nurit

---

From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 10 Dec 2012 09:39:30 +0100

Hi, 

This document was created because several documents are targeting LSP attributes to specific nodes, and a common solution based was seen usefull.
Several documents are targeting specific attributes at nodes
draft-dong-ccamp-rsvp-te-mpls-tp-li-lb-05
draft-ietf-ccamp-wson-signaling-04
draft-ali-ccamp-rsvp-te-include-route-02
draft-margaria-ccamp-label-set-ero-00
draft-zhang-ccamp-gmpls-h-lsp-mln

The next revision of the document will detail this.

Regarding the second point, the node adding the ERO, most likely the initiator, would need to know this information, but I do not see why it would be too much information. In the different use cases presented by the documents above the information is either a policy/management input or a constraints that are described as the minimum required (WSON). The documents make a good case why this information needs to be present.

This information may change between the time its determined and the times its signaled, but this is a general signaling problem, the same applies for explicit labels, we are not trying to solve this problem here.

Do you think the document should recommend some limitation on the number of attributes to include, or include new mechanism to address the fact that the attributes cannot be applied anymore (new Error codes?).

Do this clarify your questions?

> Of ext Eric Gray
> Sent: Friday, December 07, 2012 10:13 PM
> To: [email-masked]
> Subject: Re: [CCAMP] poll onmaking draft-margaria-ccamp-lsp-attribute-
> ero-02 a WG document
> 
> Not support
> 
> 1) I do not see any explanation of - or examples for - the use case
> where LSP attributes would apply to a hop in an LSP and not to the
> entire LSP.  If attributes apply to an entire LSP, than there are
> existing ways to do this. If it is possible to have an attribute that
> applies to a single hop in the LSP, does this not raise issues with
> "weak-links"?
> 
> 2) I strongly suspect that this approach MUST rely on information
> present at the signaling initiator that would be "too much information"
> about nodes and links in the LSP-path.  This information may change,
> even between the time that the path is determined (by whatever means)
> and the time that signaling is initiated.
> 
> --
> Eric
> 
> Of Lou Berger
> 02 a WG document

---

From: Jie Dong <[email-masked]>
Date: Mon, 10 Dec 2012 09:03:30 +0000

Yes/support.

As Cyril and Mach said, there are several use cases which indicate requirements for this function. And I'd like to encourage people to also review these use case drafts and give comments.

Best regards,
Jie

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Margaria, Cyril (NSN - DE/Munich)
> Sent: Monday, December 10, 2012 4:40 PM
> To: ext Eric Gray; [email-masked]
> Subject: Re: [CCAMP] poll onmaking draft-margaria-ccamp-lsp-attribute-ero-02
> a WG document
> 
> Hi,
> 
> This document was created because several documents are targeting LSP
> attributes to specific nodes, and a common solution based was seen usefull.
> Regarding the second point, the node adding the ERO, most likely the initiator,
> would need to know this information, but I do not see why it would be too
> much information. In the different use cases presented by the documents above
> the information is either a policy/management input or a constraints that are
> described as the minimum required (WSON). The documents make a good case
> why this information needs to be present.
> 
> This information may change between the time its determined and the times its
> signaled, but this is a general signaling problem, the same applies for explicit
> labels, we are not trying to solve this problem here.
> 
> Do you think the document should recommend some limitation on the number
> of attributes to include, or include new mechanism to address the fact that the
> attributes cannot be applied anymore (new Error codes?).
>

---

From: Ramon Casellas <[email-masked]>
Date: Mon, 10 Dec 2012 10:07:54 +0100

Yes/support

thanks

R.

---

From: Jonathan Hardwick <[email-masked]>
Date: Mon, 10 Dec 2012 09:29:50 +0000

Yes/support.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 07 December 2012 20:48
To: [email-masked]
Subject: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-02 a WG document

All,

Much thanks,
Lou (and Deborah)

---

From: Steve Balls <[email-masked]>
Date: Mon, 10 Dec 2012 10:18:52 +0000

Yes/support.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 07 December 2012 20:48
To: [email-masked]
Subject: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-02 a WG document

All,

Much thanks,
Lou (and Deborah)

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 10 Dec 2012 15:52:24 +0530

Yes / Support.

Dhruv

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Mon, 10 Dec 2012 10:34:42 +0000

Yes, I support.

Regards, 

Gabriele

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy
www.cisco.com/global/IT/ <http://www.cisco.com/global/IT/>

[email-masked]
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Mon, 10 Dec 2012 11:26:44 +0000

Yes/Support. 

Regards,

Xian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 2012年12月8日 4:48
To: [email-masked]
Subject: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-ero-02 a WG document

All,

Much thanks,
Lou (and Deborah)

---

From: John E Drake <[email-masked]>
Date: Mon, 10 Dec 2012 13:29:46 +0000

Hi,

I agree with Eric and think this appears to be a solution looking for a problem. 

Irrespectively Yours,

John

> Of Eric Gray
> Sent: Friday, December 07, 2012 1:13 PM
> To: [email-masked]
> Subject: Re: [CCAMP] poll on making draft-margaria-ccamp-lsp-attribute-
> ero-02 a WG document
> 
> Not support
>

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Mon, 17 Dec 2012 08:38:50 +0000

yes/support

cheers
G (co-author)

---

From: [email-masked]
Date: Mon, 17 Dec 2012 16:53:58 +0800

Yeah/Support

Fei 

Lou Berger <[email-masked]> 
发件人:  [email-masked]
2012/12/08 04:48

收件人
[email-masked]
抄送

主题
[CCAMP] poll on making  draft-margaria-ccamp-lsp-attribute-ero-02 a     WG 
document

All,

Much thanks,
Lou (and Deborah)

---

From: Lou Berger <[email-masked]>
Date: Sat, 22 Dec 2012 16:12:33 -0500

This message concludes the poll.  The cairs believe there is sufficient
(although not unanimous) support for making this document a working
group document.  Please keep in mind that this marks the formal *start*
of the WG's work on this topic.  We do expect there to be technical
evolution of this document based on WG feedback, including the feedback
provided at the last meetings.

Authors,

Please submit an unmodified version of the document as
draft-ietf-ccamp-lsp-attribute-ro-00 (e intentionally dropped.)

The chairs will approve publication only once the final IPR disclosure
is posted on the list ([email-masked] has not been heard
from) and any resulting discussion concludes.

Thank you and happy holidays!

Lou (and Deborah)