Subject: [CCAMP] Draft Microwave Radio Link YANG model

From: Marko Vaupotic <[email-masked]>
Date: Fri, 20 Jan 2017 13:51:35 +0000

Hi all

Great to see things progressing.

To >kick-off< discussin, I  went through the yang model (also compared it quickly with the one from the first half of last year) and here are some of my questions:

*         I see that Spectrum Efficiency Class (SEC) was removed from the mode, any particular reasons?

*         I was aware of the fact that tdm-connection info was added in but I am not really sure how/why this is used (I am probably asking question here that was already answered on other meetings). Example if you have 4 E1's connected to RTL, will there be a single tdm-connections instance in the list that has tdm-type set to E1 and tdm-connections set to 4? Why is this information needed? I presume that exactly which E1 is actually connected to the specific RTL is out of scope of this yang and needs to be defined in a separate data model (if this is the case why do we need anything about E1 here). And contrary if we have list for TDM info, do we need also a similar list for Ethernet interfaces (or is it always assumed that RTL is connected to one >virtual< Ethernet interface).

o   (by the way list tdm-connections bears the same name as leaf tdm-connections - just for clarity I suggest that we use different names here)

*         I see that we have removed actual-rx-cm, any particular reasons?

*         I see that g.826 stats have been added only to carrier section. I think they need to be at RTL level as they define performance parameters of a SERVICE (and service in this case is radio link that may consist of multiple carriers!). Also if we added a couple of G.826 parameters (bbe, es, ses, uas) I suggest that we extend it with all required ones (eb, esr, sesr, etc). Also what about history tables, etc. In the description of some parameter it states "during a fixed measurement interval ". Where is this measurement interval defined, can the counters be reset, etc?

Regards

Marko

---

From: Jonas Ahlberg <[email-masked]>
Date: Fri, 20 Jan 2017 15:31:48 +0000

Hi Marko and all,

Thanks for your feedback.
See my inline response below.

Let's get the discussion going.
Feedback from more of you would be very much appreciated :)

Regards
JonasA

From: CCAMP [mailto:[email-masked]] On Behalf Of Marko Vaupotic
Sent: den 20 januari 2017 14:52
To: [email-masked]
Subject: [CCAMP] Draft Microwave Radio Link YANG model

Hi all

[JonasA] We have only had a brief discussion in the Microwave Designs Team about this attribute and concluded that since it is not required by all vendors we agreed not to include it in the standard model, at least for now. Instead, the vendors that need it can include it in the vendor/product specific extensions. I think this could be a topic for further discussion in order to understand how compliance to the SEC can be ensured by the radio link configuration without such attribute.

[JonasA] The purpose of having information about TDM in the RLT is to describe how much of the total RLT capacity has been allocated for the TDM capacity and what remains for the packet capacity.
The description of how that capacity is used and to which E1 interfaces and Ethernet interface it is connected is based on the standard data nodes interfaces-state: higher-layer-if and lower-layer-if in RFC 7223.

o   (by the way list tdm-connections bears the same name as leaf tdm-connections - just for clarity I suggest that we use different names here)
[JonasA] You are right and we should change that in the next revision of the model.

*         I see that we have removed actual-rx-cm, any particular reasons?
[JonasA] It seems like it is not supported by all vendors and we decided to not include in the standard model. It can however be added in a vendor/product specific extension or in the standard model going forward.

*         I see that g.826 stats have been added only to carrier section. I think they need to be at RTL level as they define performance parameters of a SERVICE (and service in this case is radio link that may consist of multiple carriers!). Also if we added a couple of G.826 parameters (bbe, es, ses, uas) I suggest that we extend it with all required ones (eb, esr, sesr, etc). Also what about history tables, etc. In the description of some parameter it states "during a fixed measurement interval ". Where is this measurement interval defined, can the counters be reset, etc?
[JonasA] You are right that g.826 is related to the service. We did not include it on the RLT level since we believed it could be derived from the information in CT, but we might need to reconsider that. It might be better to explicitly report that performance data on the RLT level. We should bring that discussion into the continued evolution of the model.

Regards

Marko

---

From: Jonas Ahlberg <[email-masked]>
Date: Fri, 20 Jan 2017 15:38:39 +0000

Hi again,

I just want to clarify that the model discussed is "A YANG Data Model for Microwave Radio Link" that can be found at:
https://tools.ietf.org/html/draft-mwdt-ccamp-mw-yang-01

I've also attached a presentation explaining the key concepts and shows some examples on what a GUI could look like based on the model.

Regards
JonasA

From: CCAMP [mailto:[email-masked]] On Behalf Of Jonas Ahlberg
Sent: den 20 januari 2017 16:32
To: Marko Vaupotic <[email-masked]>; [email-masked]
Subject: Re: [CCAMP] Draft Microwave Radio Link YANG model

Hi Marko and all,

Regards
JonasA

From: CCAMP [mailto:[email-masked]] On Behalf Of Marko Vaupotic
Sent: den 20 januari 2017 14:52
To: [email-masked]<mailto:[email-masked]>
Subject: [CCAMP] Draft Microwave Radio Link YANG model

Hi all

Regards

Marko