Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 7 Apr 2017 07:27:17 +0000

Working group,

We now have the IPR declaration replies from all the authors (thanks for the prompt replies!).
This starts a two weeks poll on making  draft-mwdt-ccamp-mw-yang-01 a CCAMP working group document.
Please send email to the list indicating "yes/support" or "no/do not support" and a motivation for  your reply, mandatory for the "not support" and nice to have for the "support".
Please note that the IPR declarations can be found in the document history (https://datatracker.ietf.org/doc/draft-mwdt-ccamp-mw-yang/history/ ) and that no IPR was disclosed against this document.
The polling will end on Friday April 21st.

Thanks,
Daniele & Fatai

---

From: Eric Gray <[email-masked]>
Date: Fri, 7 Apr 2017 07:39:20 +0000

I support making this document a CCAMP WG document.

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Friday, April 07, 2017 3:27 AM
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: "Yemin (Amy)" <[email-masked]>
Date: Mon, 10 Apr 2017 04:32:14 +0000

yes/support as an co-author.
The draft defines the YANG model for the mw/mmw devices, which augments on RFC 7223 to allow a unified interface, and is flexible for implementation specific features.

BR,
Amy
From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Friday, April 07, 2017 3:27 PM
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: Loa Andersson <[email-masked]>
Date: Mon, 10 Apr 2017 12:37:48 +0800

Folks,

I've read the draft and think it is ready for adoption.

/Loa

On 2017-04-10 12:32, Yemin (Amy) wrote:
> The draft defines the YANG model for the mw/mmw devices, which augments
> on RFC 7223 to allow a unified interface, and is flexible for
> implementation specific features.
>
>
>
> BR,
>
> Amy
>
> *From:*CCAMP [mailto:[email-masked]] *On Behalf Of *Daniele
> Ceccarelli
> *Sent:* Friday, April 07, 2017 3:27 PM
> *To:* CCAMP ([email-masked]) <[email-masked]>
> *Subject:* [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01
>
>
>
> Working group,
>
>
>
> Please send email to the list indicating "yes/support" or "no/do not
> support" and a motivation for  your reply, mandatory for the "not
> support" and nice to have for the "support".
>
> Please note that the IPR declarations can be found in the document
> history
> (https://datatracker.ietf.org/doc/draft-mwdt-ccamp-mw-yang/history/ )
> and that no IPR was disclosed against this document.
>
> The polling will end on *Friday April 21st*.
>
>
>
> Thanks,
>
> Daniele & Fatai
>
>
>
>
>
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 9 Apr 2017 22:18:15 -0700

yes/support

Regards,
Jeff

---

From: Xi Li <[email-masked]>
Date: Mon, 10 Apr 2017 08:01:23 +0000

Best regards
Xi

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Freitag, 7. April 2017 09:27
To: CCAMP ([email-masked])
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: Koji Kawada <[email-masked]>
Date: Mon, 10 Apr 2017 11:28:08 +0000

Best Regards,
Kawada

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Friday, April 07, 2017 4:27 PM
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: Jonas Ahlberg <[email-masked]>
Date: Mon, 10 Apr 2017 12:36:20 +0000

Hi,

Yes/support the WG adoption as a co-author.

Regards
JonasA

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: den 7 april 2017 09:27
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 10 Apr 2017 18:27:16 -0700

yes/support

Regards,
Greg

On Fri, Apr 7, 2017 at 12:27 AM, Daniele Ceccarelli <
[email-masked]> wrote:

> support" and a motivation for  your reply, mandatory for the "not support"
> and nice to have for the "support".
>
> Please note that the IPR declarations can be found in the document history
> (https://datatracker.ietf.org/doc/draft-mwdt-ccamp-mw-yang/history/ ) and
> that no IPR was disclosed against this document.
>

---

From: Zhenghaomian <[email-masked]>
Date: Fri, 14 Apr 2017 02:16:26 +0000

Yes/Support.

Best wishes,
Haomian

发件人: CCAMP [mailto:[email-masked]] 代表 Daniele Ceccarelli
发送时间: 2017年4月7日 15:27
收件人: CCAMP ([email-masked])
主题: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 14 Apr 2017 12:42:21 +0000

Yes/Support.

Igor

Working group,

Thanks,
Daniele & Fatai

---

From: Leeyoung <[email-masked]>
Date: Fri, 14 Apr 2017 15:11:13 +0000

Yes, support

Young

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Friday, April 07, 2017 2:27 AM
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Fri, 14 Apr 2017 16:01:47 +0000

yes/support

Thanks
Sergio

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Friday, April 07, 2017 9:27 AM
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 14 Apr 2017 13:50:48 -0400

yes/support.

Regards,

- Xufeng

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Friday, April 7, 2017 3:27 AM
To: CCAMP ([email-masked]) <[email-masked]>
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

We now have the IPR declaration replies from all the authors (thanks for the
prompt replies!). 

This starts a two weeks poll on making  draft-mwdt-ccamp-mw-yang-01 a CCAMP
working group document.

Thanks,

Daniele & Fatai

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Mon, 17 Apr 2017 23:23:55 +0200

Hi,

Thanks,

Carlos

On Fri, 2017-04-07 at 07:27 +0000, Daniele Ceccarelli wrote:
> history (https://datatracker.ietf.org/doc/draft-mwdt-ccamp-mw-yang/hi
> story/ ) and that no IPR was disclosed against this document.
>

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Mon, 17 Apr 2017 21:36:52 +0000

Hi all,

No, I do not support the adoption. The rationale for that is as follows:

The initial need of having a model for microwave in IETF was argued for having formal consistency with the rest of the YANG models developed in IETF. The model claims that uses several sources for defining the parameters, like the ONF model and the draft-ahlberg-ccamp-microwave-radio-link-01, but also other sources (e.g., ETSI, etc) have been taken into account. My concern is that considering the draft as it is now, it is not clear where it is the responsibility for the definition, update, modification or maintenance of the parameters considered in the model. As operator I would expect a clear identification of the organization responsible of each parameter, in order to progress towards a coherent specification development in this domain. In other words, the future responsibilities for the change, update or modification in the parameters in the model have to be clearly reflected here to avoid confusion and inconsistencies in the industry. Furthermore, as claimed in the framework document, the main idea was to cover identified gaps. It is not clear what is a gap, and in consequence what is not a gap and because of that, responsibility of a different fora.

Best regards

Luis

__________________________________
Luis M. Contreras

Technology and Planning
Transport, IP and Interconnection Networks
Telefónica I+D / Global CTO unit / Telefónica

Distrito Telefónica, Edificio Sur 3, Planta 3
28050 Madrid
España / Spain

Skype (Lync): +34 91 312 9084
Mobile: +34 680 947 650
[email-masked]<mailto:[email-masked]>

De: CCAMP [mailto:[email-masked]] En nombre de Daniele Ceccarelli
Enviado el: viernes, 7 de abril de 2017 9:27
Para: CCAMP ([email-masked]) <[email-masked]>
Asunto: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Italo Busi <[email-masked]>
Date: Wed, 19 Apr 2017 11:20:26 +0000

Yes/support

Italo

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: venerdì 7 aprile 2017 09:27
To: CCAMP ([email-masked])
Subject: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 20 Apr 2017 20:41:36 +0000

Hi Luis,

Let us try to better understand your concerns.
You say that "it is not clear where it is the responsibility for the definition, update, modification or maintenance of the parameters considered in the model". We are not defining or modifying data plane parameters for Microwave, but defining yang models, which is IETF (CCAMP) responsibility. If your concern is about the identification of where the parameter is from,  it seems reasonable (e.g. the OTN Tunnel YANG model refers to G.709 defined by ITU-T), and it can be easily fixed and it shouldn't be a showstopper for the progress of the draft.
Please also consider that the working group status means that the working group is interested in working on the topic and that this document is a good foundation for such work.

Given the high number of support replies and that as working group we can have a say only on WG documents and not on individual ones, our inclination is to progress with the adoption and solve your concerns in the -01 version.

In the meanwhile please let us know if you have any more technical comments that should be addressed by WG process.

Thanks
Daniele & Fatai

From: LUIS MIGUEL CONTRERAS MURILLO [mailto:[email-masked]]
Sent: lunedì 17 aprile 2017 23:37
To: Daniele Ceccarelli <[email-masked]>; CCAMP ([email-masked]) <[email-masked]>
Subject: RE: WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Hi all,

Best regards

Luis

Technology and Planning

De: CCAMP [mailto:[email-masked]] En nombre de Daniele Ceccarelli
Enviado el: viernes, 7 de abril de 2017 9:27
Para: CCAMP ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Asunto: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Working group,

Thanks,
Daniele & Fatai

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 21 Apr 2017 09:04:40 +0000

Working group,

the poll is now closed and the draft adopted as CCAMP WG document.

Authors, please publish the draft as: "draft-ietf-ccamp-mw-yang-00" changing ONLY the name and date.

We will start on working on version -01 immediately trying to solve Luis' concerns.

Thanks
Daniele & Fatai

Working group,

Thanks,
Daniele & Fatai

---

From: <[email-masked]>
Date: Fri, 21 Apr 2017 14:22:38 +0000

Dear Daniele,
All,

No, I do not support the adopting of this draft, as is.

I'd like to second the concerns raised by Luis.

Before rushing on with a new YANG model, the data plane/technology-specific baseline (i.e. data plane specification, typically technology-specific information models for the data plane at hand, that CCAMP refers to) and the coordination framework for the work in CCAMP should be clear.
I understood this was a pre-condition (and common practice) for other data modeling work items in CCAMP (e.g. OTN).

I have raised similar concerns at the time of the adoption of the framework, and was told CCAMP would look into addressing this during/as part of the work on the framework.

Thanks,
Manuel

Von: CCAMP [mailto:[email-masked]] Im Auftrag von LUIS MIGUEL CONTRERAS MURILLO
Gesendet: Montag, 17. April 2017 23:37
An: Daniele Ceccarelli; CCAMP ([email-masked])
Betreff: Re: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Hi all,

Best regards

Luis

Technology and Planning

Working group,

Thanks,
Daniele & Fatai

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 24 Apr 2017 08:20:43 +0000

Hi Manuel,

thanks for your input. We'll make sure to have them addressed in v-01.

Authors, could you please explicitly reference the data plane sources and what are you planning to cover in the draft?
I would say that saying which parameters from which standard documents (from which SDOs) should work.

Thanks
Daniele

From: [email-masked] [mailto:[email-masked]]
Sent: venerdì 21 aprile 2017 16:23
To: Daniele Ceccarelli <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: AW: WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Dear Daniele,
All,

Thanks,
Manuel

Von: CCAMP [mailto:[email-masked]] Im Auftrag von LUIS MIGUEL CONTRERAS MURILLO
Gesendet: Montag, 17. April 2017 23:37
An: Daniele Ceccarelli; CCAMP ([email-masked]<mailto:[email-masked]>)
Betreff: Re: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Hi all,

Best regards

Luis

Technology and Planning

Working group,

Thanks,
Daniele & Fatai

---

From: "Yemin (Amy)" <[email-masked]>
Date: Mon, 24 Apr 2017 09:06:03 +0000

Hi all,

The data plane for microwave is defined in ETSI and ITU-R.
We will update the draft to reference the related specification/recommendation.

BR,
Amy
From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Monday, April 24, 2017 4:21 PM
To: [email-masked]; [email-masked]
Subject: Re: [CCAMP] WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Hi Manuel,

Thanks
Daniele

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: venerdì 21 aprile 2017 16:23
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: AW: WG adoption poll on draft-mwdt-ccamp-mw-yang-01

Dear Daniele,
All,

Thanks,
Manuel

Hi all,

Best regards

Luis

Technology and Planning

Working group,

Thanks,
Daniele & Fatai