Subject: [CCAMP] [OPSAWG] Draft on YANG for state machine

From: nicola sambo <[email-masked]>
Date: Tue, 25 Jul 2017 12:38:24 +0200

Dear all,

I'd like to continue the discussion related to the draft:

https://datatracker.ietf.org/doc/draft-sambo-opsawg-ccamp-supa-ext-yang-fsm/

In particular, please let me know if you have comments about

- working group of the draft
- use cases of application
- other

Slides presented at the meeting are available here
<https://www.dropbox.com/s/qhq2n6bmlp8ifkj/draft-sambo-opsawg-ccamp-supa-ext-yang-fsm-00.pptx?dl=0>.
Any comment and contribution are welcome.

Thanks. Best,
Nicola

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 25 Jul 2017 16:14:25 +0000

Hi Nicola,

Thanks for bringing this up. As i said during the OPSAWG session @IETF99 I believe you should have a generalized version of this document (not starting from an optical use case) and then build on new use cases and possibly technology specific extensions.
Personally I believe the work should be done in the OPS area, probably in the OPSAWG or even better in NETMOD WG.

Cheers
Daniele

From: nicola sambo [mailto:[email-masked]]
Sent: martedì 25 luglio 2017 12:38
To: [email-masked]; [email-masked]
Cc: Greg Mirsky <[email-masked]>; Fioccola Giuseppe <[email-masked]>; Daniele Ceccarelli <[email-masked]>; [email-masked]
Subject: [OPSAWG][CCAMP] Draft on YANG for state machine

Dear all,

Slides presented at the meeting are available here<https://www.dropbox.com/s/qhq2n6bmlp8ifkj/draft-sambo-opsawg-ccamp-supa-ext-yang-fsm-00.pptx?dl=0>. Any comment and contribution are welcome.

Thanks. Best,
Nicola

---

From: Fioccola Giuseppe <[email-masked]>
Date: Tue, 25 Jul 2017 16:57:24 +0000

Hi Daniele and All,
As one of the coauthors of this draft, I also agree about the purpose to generalize this proposal.
And regarding this aspect, we will add a new use case for IP and Overlay Network that is inspired by a well-known IPPM methodology (draft-ietf-ippm-alt-mark) and in particular its application in an SDN oriented environment (draft-fioccola-ippm-multipoint-alt-mark).
Of course, NETMOD WG could be also taken into consideration.

Best Regards,

Giuseppe

Da: Daniele Ceccarelli [mailto:[email-masked]]
Inviato: martedì 25 luglio 2017 18:14
A: nicola sambo; [email-masked]; [email-masked]
Cc: Greg Mirsky; Fioccola Giuseppe; [email-masked]
Oggetto: RE: [OPSAWG][CCAMP] Draft on YANG for state machine

Hi Nicola,

Cheers
Daniele

From: nicola sambo [mailto:[email-masked]]
Sent: martedì 25 luglio 2017 12:38
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Greg Mirsky <[email-masked]<mailto:[email-masked]>>; Fioccola Giuseppe <[email-masked]<mailto:[email-masked]>>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [OPSAWG][CCAMP] Draft on YANG for state machine

Dear all,

Thanks. Best,
Nicola

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: nicola sambo <[email-masked]>
Date: Wed, 26 Jul 2017 11:13:42 +0200

Hi Daniele,

thanks for the suggestion. We will generalize it and include further use
cases as the one anticipated by Giuseppe.

And we are open to include further contributions if any.

Best,
Nicola

Il martedì 25 luglio 2017, Fioccola Giuseppe <
[email-masked]> ha scritto:

> And regarding this aspect, we will add a new use case for IP and Overlay
> Network that is inspired by a well-known IPPM methodology
> (draft-ietf-ippm-alt-mark) and in particular its application in an SDN
> oriented environment (draft-fioccola-ippm-multipoint-alt-mark).
>
> *Da:* Daniele Ceccarelli [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Inviato:* martedì 25 luglio 2017 18:14
> *A:* nicola sambo; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *Cc:* Greg Mirsky; Fioccola Giuseppe; [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *Oggetto:* RE: [OPSAWG][CCAMP] Draft on YANG for state machine
>
>
>
> Hi Nicola,
>
>
>
> Thanks for bringing this up. As i said during the OPSAWG session @IETF99 I
> believe you should have a generalized version of this document (not
> starting from an optical use case) and then build on new use cases and
> possibly technology specific extensions.
>
> *From:* nicola sambo [mailto:[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
> *Sent:* martedì 25 luglio 2017 12:38
> *To:* [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>;
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *Cc:* Greg Mirsky <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>; Fioccola
> Giuseppe <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>;
> Daniele Ceccarelli <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>;
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> *Subject:* [OPSAWG][CCAMP] Draft on YANG for state machine
>
>
>
> Dear all,
>
>
>
> Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle
> persone indicate. La diffusione, copia o qualsiasi altra azione derivante
> dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora
> abbiate ricevuto questo documento per errore siete cortesemente pregati di
> darne immediata comunicazione al mittente e di provvedere alla sua
> distruzione, Grazie.
>
> * This e-mail and any attachments is confidential and may contain
> privileged information intended for the addressee(s) only. Dissemination,
> copying, printing or use by anybody else is unauthorised. If you are not
> the intended recipient, please delete this message and any attachments and
> advise the sender by return e-mail, Thanks. *
>
> *Rispetta l'ambiente. Non stampare questa mail se non è necessario.*
>

---

From: "t.petch" <[email-masked]>
Date: Wed, 26 Jul 2017 17:35:12 +0100

Nicola

The title of this I-D caught my eye but when I read it, I struggle to
see the connection between the content and the title.

If you are really extending YANG, then to me it is axiomatic that the
work should be done in the NETMOD WG.  Reading the I-D, I struggle to
see what extensions you want to make to YANG.

Starting from an FSM perspective, I would have thought that a data
modelling language would not make a good starting point.

And the phraseology used in the I-D surprises me e.g.

" First, NETCONF
   supports both control and management functionalities, thus permits
   high programmability. "
Um, NETCONF is an application protocol that can transfer such things as
chunks of ASN.1 or SQL from A to B using a paradigm of RPC (with events
tacked on the side).

How this relates to control and management funtionalities I struggle to
see.

Perhaps a non-optical example would make things clearer.

Tom Petch

----- Original Message -----
From: "nicola sambo" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>
Cc: "Greg Mirsky" <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Wednesday, July 26, 2017 10:13 AM

Hi Daniele,

Best,
Nicola

Il martedì 25 luglio 2017, Fioccola Giuseppe <
[email-masked]> ha scritto:

> Hi Daniele and All,
>
> As one of the coauthors of this draft, I also agree about the purpose
to
> generalize this proposal.
>
> Personally I believe the work should be done in the OPS area, probably
in
> the OPSAWG or even better in NETMOD WG.
>
>
>
> Cheers
>
> Daniele
>
>
>
> *To:* [email-masked]
<javascript:_e(%7B%7D,'cvml',[email-masked]');>;
> Slides presented at the meeting are available here
<https://www.dropbox.com/s/qhq2n6bmlp8ifkj/draft-sambo-opsawg-ccamp-supa
-ext-yang-fsm-00.pptx?dl=0>.
> *Rispetta l'ambiente. Non stampare questa mail se non è necessario.*

------------------------------------------------------------------------
--------

> _______________________________________________
> OPSAWG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/opsawg
>

---

From: nicola sambo <[email-masked]>
Date: Thu, 27 Jul 2017 10:41:43 +0200

Dear Tom,

many thanks for the comments. I reply inline below:

> see what extensions you want to make to YANG.
We have decided to modify the title (and the content) in the next version
of the draft by removing the word "extension". Indeed, also from a previous
email exchange before the Prague meeting, after a comment from Robert by
Cisco, we noticed that this word can create misunderstanding since we
actually do not use the "extension" keyword supported by YANG.
Regarding the working group we are still discussing among co-authors, also
depending on the use cases we will find.

> modelling language would not make a good starting point.

Within IETF, we have seen proposals for modeling policies with YANG.
Formally, here is something similar.

> How this relates to control and management funtionalities I struggle to

We can rephrase that sentence. What we meant is that NETCONF supports
messages for configuration (e.g., <edit-conf>) and others such as the
<notification> message that can be used to implement alarms based on a
notification subscription (<create-subscription>).

> Perhaps a non-optical example would make things clearer.

We are working on that. Thanks.

Best regards,
Nicola

> -ext-yang-fsm-00.pptx?dl=0