Subject: [CCAMP] Fw: New Version Notification for draft-zheng-ccamp-otn-client-signal-yang-00.txt

From: Zhenghaomian <[email-masked]>
Date: Thu, 19 Oct 2017 03:51:23 +0000

Dear CCAMPers, 

We have submitted a new draft about the YANG model for client signals. This motivation came out when we implemented the TE and OTN YANG model to carry the client service. It was observed that a service model is required to technically specify what information the client-layer network are requesting, and then the controller can obtain what the service-layer network need to response. 

Corresponding service may include Ethernet, OTN client signal, SDH/SONET and so on. Currently the draft only consider how to represent the Ethernet service, as the initial version. Other client types will be integrated in future version. Please feel free to comment or connect us if you are interested in defining such models, thank you very much. 

Best wishes,
Haomian (on behalf of all authors & contributors)

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2017年10月19日 11:16
收件人: Zhenghaomian; Yunbin Xu; Aihuaguo (Aihua Guo, CRC); Zhenghaomian; Italo Busi; Yang Zhao
主题: New Version Notification for draft-zheng-ccamp-otn-client-signal-yang-00.txt

A new version of I-D, draft-zheng-ccamp-otn-client-signal-yang-00.txt
has been successfully submitted by Haomian Zheng and posted to the IETF repository.

Name:		draft-zheng-ccamp-otn-client-signal-yang
Revision:	00
Title:		A YANG Data Model for Optical Transport Network Client Signals
Document date:	2017-10-19
Group:		Individual Submission
Pages:		27
URL:            https://www.ietf.org/internet-drafts/draft-zheng-ccamp-otn-client-signal-yang-00.txt
Status:         https://datatracker.ietf.org/doc/draft-zheng-ccamp-otn-client-signal-yang/
Htmlized:       https://tools.ietf.org/html/draft-zheng-ccamp-otn-client-signal-yang-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-zheng-ccamp-otn-client-signal-yang-00

Abstract:
   A transport network is a server-layer network to provide connectivity
   services to its client.  The topology and tunnel information in the
   transport layer has already been defined by Traffic-engineered models
   and OTN models, however, the access to the network has not been
   described.  These information is useful to both client and provider.

   This draft describe how the client signals are carried over OTN and
   defined corresponding YANG data model which is required during
   configuration procedure.  More specifically, several client signal
   (of OTN) models including ETH, STM-n, FC and so on, are defined in
   this draft.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 19 Oct 2017 09:39:52 +0000

Hi Haomian,

thanks for the proposal. I definitely think it is needed.
I would ask the question the TEAS chairs would 😊

The work seems to be something that can be generalized to any type of client-server relationship and then specialized to technology specific clients and technology specific servers, is this right?

Thanks,
Daniele

> -----Original Message-----
> From: CCAMP [mailto:[email-masked]] On Behalf Of Zhenghaomian
> Sent: giovedì 19 ottobre 2017 05:51
> To: [email-masked]
> Subject: [CCAMP] Fw: New Version Notification for draft-zheng-ccamp-otn-
> client-signal-yang-00.txt
> 
> Dear CCAMPers,
> 
> We have submitted a new draft about the YANG model for client signals. This
> motivation came out when we implemented the TE and OTN YANG model to
> carry the client service. It was observed that a service model is required to
> technically specify what information the client-layer network are requesting,
> and then the controller can obtain what the service-layer network need to
> response.
> 
> Corresponding service may include Ethernet, OTN client signal, SDH/SONET
> and so on. Currently the draft only consider how to represent the Ethernet
> service, as the initial version. Other client types will be integrated in future
> version. Please feel free to comment or connect us if you are interested in
> defining such models, thank you very much.
> 
> Best wishes,
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Zhenghaomian <[email-masked]>
Date: Fri, 20 Oct 2017 03:50:53 +0000

Hi, Daniele, 

Thanks for the prompt reply, currently this work is based on our implementation with China Mobile, which is technology-specific, i.e., service over OTN network. My expectation is to separate the generalized work in teas and technology-specific work in ccamp, as we usual did. I am not an expert in L2/L3, but would like to hear any comments on the common part of , we are also looking forward to see the feedback from TEAS chairs. The effort for generalization is greatly appreciated, and I believe this work can be used as one of the foundations. 

Any comments are welcomed, thank you. 

Best wishes,
Haomian

-----邮件原件-----
发件人: Daniele Ceccarelli [mailto:[email-masked]] 
发送时间: 2017年10月19日 17:40
收件人: Zhenghaomian; [email-masked]
主题: RE: New Version Notification for draft-zheng-ccamp-otn-client-signal-yang-00.txt

Hi Haomian,

Thanks,
Daniele

> Subject: [CCAMP] Fw: New Version Notification for 
> draft-zheng-ccamp-otn- client-signal-yang-00.txt
> 
> Dear CCAMPers,
> 
> We have submitted a new draft about the YANG model for client signals. 
> This motivation came out when we implemented the TE and OTN YANG model 
> to carry the client service. It was observed that a service model is 
> required to technically specify what information the client-layer 
> network are requesting, and then the controller can obtain what the 
> service-layer network need to response.
> 
> Corresponding service may include Ethernet, OTN client signal, 
> SDH/SONET and so on. Currently the draft only consider how to 
> represent the Ethernet service, as the initial version. Other client 
> types will be integrated in future version. Please feel free to 
> comment or connect us if you are interested in defining such models, thank you very much.
> 
> Best wishes,
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 20 Oct 2017 12:57:48 +0000

Thanks a lot for already considering it.

BR
Daniele  

> From: Zhenghaomian [mailto:[email-masked]]
> Sent: venerdì 20 ottobre 2017 05:51
> To: Daniele Ceccarelli <[email-masked]>; [email-masked]
> Subject: 答复: New Version Notification for draft-zheng-ccamp-otn-client-
> signal-yang-00.txt
> 
> Hi, Daniele,
> 
> Thanks for the prompt reply, currently this work is based on our
> implementation with China Mobile, which is technology-specific, i.e., service
> over OTN network. My expectation is to separate the generalized work in
> teas and technology-specific work in ccamp, as we usual did. I am not an
> expert in L2/L3, but would like to hear any comments on the common part of
> , we are also looking forward to see the feedback from TEAS chairs. The
> effort for generalization is greatly appreciated, and I believe this work can be
> used as one of the foundations.
> 
> The work seems to be something that can be generalized to any type of
> client-server relationship and then specialized to technology specific clients
> and technology specific servers, is this right?
> 
> Thanks,
> Daniele
> 
> > 收件人: Zhenghaomian; Yunbin Xu; Aihuaguo (Aihua Guo, CRC);
> Zhenghaomian;
> > Italo Busi; Yang Zhao
> > Htmlized:       https://tools.ietf.org/html/draft-zheng-ccamp-otn-client-
> signal-
> > yang-00
> > Htmlized:       https://datatracker.ietf.org/doc/html/draft-zheng-ccamp-
> otn-
> > client-signal-yang-00
> >
> >
> > Abstract: