Subject: [Cellar] deprecating TrackTimecodeScale

From: Dave Rice <[email-masked]>
Date: Sat, 14 Jan 2017 16:09:27 -0500

Hi all,

At one point in Matroska history there was a TrackTimecodeScale which was intended for cases as having a video track from a film along with an audio track from NTSC and a audio track from PAL (in PAL it is typical to speed up the film from 24 to 25 fps whereas NTSC slows down the film from 24 to 24000/1001 fps). There was some discussion on https://lists.matroska.org/pipermail/matroska-devel/2010-May/003646.html <https://lists.matroska.org/pipermail/matroska-devel/2010-May/003646.html> and in 2012 it was deprecated here: https://github.com/Matroska-Org/foundation-source/commit/ca8263bfbbcd2a3ce69369465aaa1ebe0c3c779e <https://github.com/Matroska-Org/foundation-source/commit/ca8263bfbbcd2a3ce69369465aaa1ebe0c3c779e>.

Although it is deprecated there is still a large section of documentation about it in https://github.com/Matroska-Org/matroska-specification/blob/dff36b4e01b6b1921e5bbdafa020e6485064dfd4/notes.md#tracktimecodescale <https://github.com/Matroska-Org/matroska-specification/blob/dff36b4e01b6b1921e5bbdafa020e6485064dfd4/notes.md#tracktimecodescale>.

Should this documentation be removed altogether from the RFC draft? Or should that documentation be marked with a caveat that it is documentation of a deprecated Element?

Dave Rice

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 22 Jan 2017 15:15:09 +0100

Hi,

In the current "official" specs it says that it's deprecated in newer
versions, compared to other deprecated elements considered as not used
in any version of Matroska. On top of that it was mandatory so some
muxers may have written the value, likely to the default value. I
don't see think we can ignore the elements in the current RFC.

I created a PR to fix the XML specification as the minver/maxver
should be 1 and 3, rather than 0 and 0.
https://github.com/Matroska-Org/matroska-specification/pull/86

I just noticed that will finishing my parser to generate the libxml(2)
code from the specs, which is now done even though the code is very
dirty. I noticed another issue in the XML file, the MasteringMetadata
parent was set incorrectly.

2017-01-14 22:09 GMT+01:00 Dave Rice <[email-masked]>:
> Hi all,
>
> At one point in Matroska history there was a TrackTimecodeScale which was
> intended for cases as having a video track from a film along with an audio
> track from NTSC and a audio track from PAL (in PAL it is typical to speed up
> the film from 24 to 25 fps whereas NTSC slows down the film from 24 to
> 24000/1001 fps). There was some discussion on
> https://lists.matroska.org/pipermail/matroska-devel/2010-May/003646.html and
> in 2012 it was deprecated here:
> https://github.com/Matroska-Org/foundation-source/commit/ca8263bfbbcd2a3ce69369465aaa1ebe0c3c779e.
>
> Although it is deprecated there is still a large section of documentation
> about it in
> https://github.com/Matroska-Org/matroska-specification/blob/dff36b4e01b6b1921e5bbdafa020e6485064dfd4/notes.md#tracktimecodescale.
>
> Should this documentation be removed altogether from the RFC draft? Or
> should that documentation be marked with a caveat that it is documentation
> of a deprecated Element?
>
> Dave Rice
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>

-- 
Steve Lhomme
Matroska association Chairman

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 22 Jan 2017 16:46:52 +0100

> parent was set incorrectly.

Turns out I spoke too fast. I finished libmatroska2 but not
libmatroska. The Projection sub-elements had the wrong parent. I
updated the ebml_specification.xml file accordingly.