Subject: [Cellar] enumeration lists for EBML Schema

From: Dave Rice <[email-masked]>
Date: Wed, 1 Feb 2017 19:01:02 -0500

Hi cellar,

These pull requests relate to an issue Steve opened at https://github.com/Matroska-Org/ebml-specification/issues/114 for defining an enumeration list for EBML Elements.

This pull request includes an update to the EBMLSchema.xsd to allow <enum> elements along with documentation in the EBML spec, https://github.com/Matroska-Org/ebml-specification/pull/130. And this updates the EBML Schema for Matroska accordingly: https://github.com/Matroska-Org/matroska-specification/pull/92. This is inspired by the restriction element of XML Schemas (http://www.w3schools.com/xml/schema_facets.asp).

So:

<element name="TrackType" path="1*1(\Segment\Tracks\TrackEntry\TrackType)" id="0x83" type="uinteger" minOccurs="1" maxOccurs="1" minver="1" range="1-254”>
  <documentation lang="en">A set of track types coded on 8 bits (1: video, 2: audio, 3: complex, 0x10: logo, 0x11: subtitle, 0x12: buttons, 0x20: control).</documentation>
</element>

becomes:

<element name="TrackType" path="1*1(\Segment\Tracks\TrackEntry\TrackType)" id="0x83" type="uinteger" minOccurs="1" maxOccurs="1" minver="1" range="1-254">
  <documentation lang="en">A set of track types coded on 8 bits.</documentation>
  <restriction>
    <enum value="1" label="video" />
    <enum value="2" label="audio" />
    <enum value="3" label="complex" />
    <enum value="16" label="logo" />
    <enum value="17" label="subtitle" />
    <enum value="18" label="buttons" />
    <enum value="32" label="control" />
  </restriction>
</element>

This impacts the definition of the following Elements:

ChapterTranslateCodec
TrackType
TrackTranslateCodec
FlagInterlaced
FieldOrder
StereoMode
OldStereoMode
DisplayUnit
AspectRatioType
MatrixCoefficients
ChromaSitingHorz
ChromaSitingVert
Range
TransferCharacteristics
Primaries
ProjectionType
TrackPlaneType
ChapProcessTime

Comments welcome,
Dave

---

From: Steve Lhomme <[email-masked]>
Date: Sat, 4 Feb 2017 14:23:12 +0100

Both LGTM. Reto pointed a possible typo but other than that it's fine.

2017-02-02 1:01 GMT+01:00 Dave Rice <[email-masked]>:
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman