Subject: Re: [Cellar] Film: color handling - container or codec?

From: Reto Kromer <[email-masked]>
Date: Sat, 4 Feb 2017 16:09:29 +0100

Steve Lhomme wrote:

>In general we need to tell in the Matroska very clearly how
>it works between the codec and the container.

Indeed.

>IMO the
>sensitive way to do it is leave it to the codec when it
>knows, and put it in the container when the codec doesn't
>have the information. When it is found in the container AND
>in the codec, it should mean that the container decided to
>override whatever the codec says.

Sorry, Steve, I am personally not convinced. From a previous
discussion I have understood that when both the container
and the codec hold an information, then the codec should
have the precedence, because the probability it is kept safe
during a trans-muxing is per se much higher.

Just my thoughts, as I started doing so for our own
restoration applications (using NUT, not Matroska, but the
principle seems to me to be the same). Reto

AV Preservation by reto.ch
chemin du Suchet 5 | 1024 Ecublens | Switzerland
Web: https://reto.ch | Twitter: @retoch

---

From: Steve Lhomme <[email-masked]>
Date: Sat, 4 Feb 2017 16:50:41 +0100

Le 4 févr. 2017 16:09, "Reto Kromer" <[email-masked]> a écrit :

Indeed.

IMO it's either preserved or lost but the chance of being modified by
accident during remuxing should be low.

If by design it must be there only to change the value of the codec (that
would include non existent value) then losing it or changing it means the
muxer is broken.

Now if the question is whether FFV1 should store it or Matroska, I would
say FFV1. In the container it should be to alter it or provide the
information that isn't known from that codec (like raw video or audio).

_______________________________________________
Cellar mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cellar