Subject: Re: [Cellar] TimeSlice and LaceNumber, deprecated in an unknown version

From: Steve Lhomme <[email-masked]>
Date: Sun, 26 Feb 2017 17:40:15 +0100

2016-05-28 20:10 GMT+02:00 Dave Rice <[email-masked]>:
> Hi all,
>
> From specdata.xml is:
>
> <element name="TimeSlice" level="4" id="0xE8" type="master" multiple="1" minver="1" divx="0">Contains extra time information about the data contained in the Block. While there are a few files in the wild with this Element, it is no longer in use and has been deprecated. Being able to interpret this Element is not required for playback.</element>
>
> <element name="LaceNumber" cppname="SliceLaceNumber" level="5" id="0xCC" type="uinteger" minver="1" default="0" divx="0">The reverse number of the frame in the lace (0 is the last frame, 1 is the next to last, etc). While there are a few files in the wild with this Element, it is no longer in use and has been deprecated. Being able to interpret this Element is not required for playback.</element>
>
> These elements are noted as deprecated, but there is no declared maxver. Anyone remember when these were deprecated or what the maxver should be?

I went through the specs on the Wayback machine and they were never
marked deprecated. They are marked as deprecated on the WebM page
though:
http://www.webmproject.org/docs/container/

When v2 was added it was part of it, but the text actually said it was
deprecated. So I think we can put maxver="1".

> Dave Rice
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman

---

From: Dave Rice <[email-masked]>
Date: Sun, 26 Feb 2017 11:48:08 -0500

> On Feb 26, 2017, at 11:40 AM, Steve Lhomme <[email-masked]> wrote:
> 

Updated here: https://github.com/Matroska-Org/matroska-specification/pull/105 <https://github.com/Matroska-Org/matroska-specification/pull/105>.

[...]

Dave