Subject: [Cellar] define FFV1 in Matroska

From: Dave Rice <[email-masked]>
Date: Sat, 4 Feb 2017 11:00:52 -0500

Hi cellar,

I submitted this pull request to define an FFV1 Codec Mapping for Matroska, https://github.com/Matroska-Org/matroska-specification/pull/94. Currently all FFV1 in Matroska uses the V_MS/VFW/FOURCC Mapping. In addition to what is listed below I think the V_MS/VFW/FOURCC definition may need to be extended to say that when V_MS/VFW/FOURCC is used for FFV1, and the FFV1 is version 3 or greater, then the BITMAPINFOHEADER MUST have the Configuration Record as Private Data.

Comments? Is it advantageous to define this when V_MS/VFW/FOURCC is already the practice?

Here is the text of the proposed Codec Mapping:

### V_FFV1

Codec ID: V_FFV1

Codec Name: FF Video Codec 1

Description: FFV1 is a lossless intra-frame video encoding format designed to efficiently compress video data in a variety of pixel formats. Compared to uncompressed video, FFV1 offers storage compression, frame fixity, and self-description, which makes FFV1 useful as a preservation or intermediate video format. [Draft FFV1 Specification](https://datatracker.ietf.org/doc/draft-niedermayer-cellar-ffv1/)

Initialisation: For FFV1 versions 2 or less, `Private Data` SHOULD NOT be written. For FFV1 version 3 and greater, the `Private Data` MUST contain the FFV1 Configuration Record structure, as defined in https://tools.ietf.org/html/draft-niedermayer-cellar-ffv1-01#section-4.1, and no other data.

Dave Rice

---

From: Steve Lhomme <[email-masked]>
Date: Sun, 5 Feb 2017 12:33:24 +0100

> Comments? Is it advantageous to define this when V_MS/VFW/FOURCC is already the practice?

The VFW codecs should only be for codecs that were primarily found as
Video For Windows codecs, with much less else documentation. For new
formats and/or formats with proper documentation we should use a
properly named mapping. So V_FFV1 is a lot better.

> Initialisation: For FFV1 versions 2 or less, `Private Data` SHOULD NOT be written. For FFV1 version 3 and greater, the `Private Data` MUST contain the FFV1 Configuration Record structure, as define…

LGTM.

> Dave Rice
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

-- 
Steve Lhomme
Matroska association Chairman

---

From: Michael Niedermayer <[email-masked]>
Date: Sun, 5 Feb 2017 12:36:11 +0100

> properly named mapping. So V_FFV1 is a lot better.

+1

[...]
-- 
Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Into a blind darkness they enter who follow after the Ignorance,
they as if into a greater darkness enter who devote themselves
to the Knowledge alone. -- Isha Upanishad

---

From: Reto Kromer <[email-masked]>
Date: Sun, 5 Feb 2017 13:13:40 +0100

Michael Niedermayer wrote:

>> The VFW codecs should only be for codecs that were
>> primarily found as Video For Windows codecs, with much
>> less else documentation. For new formats and/or formats
>> with proper documentation we should use a properly named
>> mapping. So V_FFV1 is a lot better.
>
>+1

+1

Best regards, Reto