Subject: Re: [Cellar] adding VP8 and VP9

From: Tessa Fallon <[email-masked]>
Date: Wed, 15 Mar 2017 23:28:42 -0400

Resurrecting this thread: was the intent to document use VP8 and VP9 in the
Matroska specification? Was there any action on this?

On Sat, Feb 4, 2017 at 9:56 AM, Dave Rice <[email-masked]> wrote:

> The VP9 link is updated to http://www.webmproject.org/vp9.
> https://github.com/Matroska-Org/matroska-specification/pull/91 should be
> ready.
> Dave
>
> > On Feb 4, 2017, at 9:50 AM, Dave Rice <[email-masked]> wrote:
> >
> > The VP9 format specification is still in draft form. We could use
> https://storage.googleapis.com/downloads.webmproject.org/
> docs/vp9/vp9-bitstream-specification-v0.6-20160331-draft.pdf as used on
> http://www.webmproject.org/vp9/. This link is not hosted by IETF but is
> more up to date.
> >
> > Is the IETF actively working on VP9?
> > Dave
> >
> >> On Feb 4, 2017, at 8:14 AM, Steve Lhomme <[email-masked]> wrote:
> >>
> >> They definitely need to go in. The VP9 link should be changed to
> >> something more stable and revent. Otherwise LGTM.
> >>
> >> 2017-02-01 23:57 GMT+01:00 Dave Rice <[email-masked]>:
> >>> Hi cellar,
> >>>
> >>> Just before the cellar wg became active there was a proposal on
> >>> matroska-devel to document use of VP8 and VP9 in Matroska, similar to
> how
> >>> they have been defined in webm. I started a pull request at
> >>> https://github.com/Matroska-Org/matroska-specification/pull/91 to add
> them.
> >>>
> >>> The original thread also proposes adding WEBVTT but it seems there’s
> some
> >>> open questions there about how to do so.
> >>>
> >>> Dave Rice
> >>>
> >>>
> >>> _______________________________________________
> >>> Cellar mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/cellar
> >>>
> >>
> >>
> >>
> >> --
> >> Steve Lhomme
> >> Matroska association Chairman
> >
> > _______________________________________________
> > Cellar mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/cellar
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>

---

From: Dave Rice <[email-masked]>
Date: Thu, 16 Mar 2017 09:58:03 -0400

Hi Tessa,
It looks like Steve merged the patch into the codec_spec.md document back on February 4th. See https://github.com/Matroska-Org/matroska-specification/pull/91 <https://github.com/Matroska-Org/matroska-specification/pull/91>. VP8 and VP9 had been in regular use in Matroska but the documentation on this had never been finished in MKV, although it was in webm. The patch resolved one of the discrepancies between mkv and webm.
Dave

> On Mar 15, 2017, at 11:28 PM, Tessa Fallon <[email-masked]> wrote:
> 
> Resurrecting this thread: was the intent to document use VP8 and VP9 in the Matroska specification? Was there any action on this?
> 
> On Sat, Feb 4, 2017 at 9:56 AM, Dave Rice <[email-masked] <mailto:[email-masked]>> wrote:
> The VP9 link is updated to http://www.webmproject.org/vp9 <http://www.webmproject.org/vp9>. https://github.com/Matroska-Org/matroska-specification/pull/91 <https://github.com/Matroska-Org/matroska-specification/pull/91> should be ready.
> Dave
> 
> > On Feb 4, 2017, at 9:50 AM, Dave Rice <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > The VP9 format specification is still in draft form. We could use https://storage.googleapis.com/downloads.webmproject.org/docs/vp9/vp9-bitstream-specification-v0.6-20160331-draft.pdf <https://storage.googleapis.com/downloads.webmproject.org/docs/vp9/vp9-bitstream-specification-v0.6-20160331-draft.pdf> as used on http://www.webmproject.org/vp9/ <http://www.webmproject.org/vp9/>. This link is not hosted by IETF but is more up to date.
> >
> >> On Feb 4, 2017, at 8:14 AM, Steve Lhomme <[email-masked] <mailto:[email-masked]>> wrote:
> >>
> >> 2017-02-01 23:57 GMT+01:00 Dave Rice <[email-masked] <mailto:[email-masked]>>:
> >>> Hi cellar,
> >>>
> >>> matroska-devel to document use of VP8 and VP9 in Matroska, similar to how
> >>> https://github.com/Matroska-Org/matroska-specification/pull/91 <https://github.com/Matroska-Org/matroska-specification/pull/91> to add them.
> >>>
> >>> The original thread also proposes adding WEBVTT but it seems there’s some
> >>> [email-masked] <mailto:[email-masked]>
> >>> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> >>>
> >>
> >>
> >>
> >> --
> >> Steve Lhomme
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cellar <https://www.ietf.org/mailman/listinfo/cellar>
>