Subject: Re: [Cellar] IETF current milestones: request for feedback

From: Tessa Fallon <[email-masked]>
Date: Wed, 15 Mar 2017 23:24:44 -0400

RE:

Jul 2017 Submit specification for FFV1 video codec version 4 to
IESG (Standards Track)
Sep 2017 Submit specification for Matroska container format version 4
to IESG (Standards Track)
Mar 2017 Submit informational specification for FFV1 video codec versions
0, 1 and 3 to IESG for publication
Mar 2017 Submit specification for EBML to IESG (Standards Track)
May 2017 Submit informational specification for Matroska container
format versions 1, 2 and 3 to IESG for publication

If these seem like reasonable dates to contributors, I will move to update
milestones.

RE: FLAC, backburner IMO until other milestones are on track.  If there are
folks who only want to work on FLAC and who are not actively working on
other specs, I would ask them to speak up here to organize.  I know there
were some efforts a while ago, but I am not personally aware of any
progress.

Tessa

On Sun, Feb 26, 2017 at 6:31 PM, Dave Rice <[email-masked]> wrote:

> Hi Tessa, Steve, cellar,
>
> On Sep 18, 2016, at 3:44 AM, Steve Lhomme <[email-masked]> wrote:
>
> 2016-09-13 15:58 GMT+02:00 Tessa Fallon <[email-masked]>:
>
> At the CELLAR meeting in July, it was decided that working group milestones
> would need to be revised.   The current list is below.
>
> Would those working on FFV1, EBML, and Matroska weigh in on the state of
> the
> specifications and projected timelines for work to be completed?  I note
> that the most recent changes to EBML were submitted on Sunday 9/11.  Where
> does this leave the document?
>
>
> It's an on-going effort. There are currently 16 issues opened on the
> EBML specs alone:
> https://github.com/Matroska-Org/ebml-specification/issues
>
>
> EBML is down to 7 issues now, though some are ideas/considerations rather
> than issues. I propose that a milestone for submitting EBML to IESG is
> reset to a date in the near-future (end of March), and nudge for more
> comprehensive peer-reviews of the EBML specification.
>
> There are 5 on Matroska but that's because most of the effort has been
> concentrated on EBML yet:
> https://github.com/Matroska-Org/matroska-specification/issues
>
>
> Matroska is now up to 19 issues since it’s been more active lately. It’s
> certainly a large specification so perhaps we should set a new list of more
> granular milestones for the components of the specification:
>
> - attachments
> - chapters / menu
> - codec_specs
> - cues
> - diagram
> - the EBML Schema of Matroska
> - index / notes / order_guidelines / streaming
> - subtitles
> - tagging / metadata
>
> Volunteers to manage a review of the state of each component?
>
> With FFV1, there’s 6 open issues and half refer to future version
> enhancements. Volunteers willing, I think it’s likely a version 0, 1, 2, 3
> specification of FFV1 could be ready to submit to the IESG at the end of
> March as well.
>
> However these depend on sufficient peer-reviews. Perhaps we could
> collaborate with one of the other audiovisual working groups for a
> cross-peer-review.
>
> Here’s a new draft of a milestone list, please comment/advice:
>
> ? Submit specification for FLAC audio codec to IESG (Standards Track)
> Jul 2017 Submit specification for FFV1 video codec version 4 to
> IESG (Standards Track)
> Sep 2017 Submit specification for Matroska container format version 4
> to IESG (Standards Track)
> Mar 2017 Submit informational specification for FFV1 video codec versions
> 0, 1 and 3 to IESG for publication
> Mar 2017 Submit specification for EBML to IESG (Standards Track)
> May 2017 Submit informational specification for Matroska container
> format versions 1, 2 and 3 to IESG for publication
>
> Although since Matroska version 4 has been in use for so longer, perhaps
> the milestone to work on a future Matroska version should be changed to
> ‘version 5’ rather than 4.
>
> Also FLAC? There’s been a few volunteer to get this started (self
> included), but as far as I know, there’s no progress on this specification.
>
> Thanks much,
> Dave
>
> There are way more elements to defined in Matroska, various
> interactions between them and all kinds of loopholes that we need to
> iron out.
>
> Much thanks,
> Tessa
>
> Date
> Dec 2016 Submit specification for FLAC audio codec to IESG (Standards
> Track)
> Sep 2016 Submit specification for FFV1 video codec version 4 to IESG
> (Standards Track)
> Jul 2016 Submit specification for Matroska container format version 4 to
> IESG (Standards Track)
> Jul 2016 Submit informational specification for FFV1 video codec versions
> 0,
> 1 and 3 to IESG for publication
> Jun 2016 Submit specification for EBML to IESG (Standards Track)
> Jun 2016 Submit informational specification for Matroska container format
> versions 1, 2 and 3 to IESG for publication
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>
>
>
>
> --
> Steve Lhomme
> Matroska association Chairman
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>
>
>

---

From: Brian Willoughby <[email-masked]>
Date: Wed, 15 Mar 2017 21:42:31 -0700

Hello,

I am one of the folks who joined this mailing list to contribute regarding my experience with FLAC code development and end use of the technology. So far, I've just been deleting Matroska messages as they come through because I do not have the bandwidth to study the other standards - so I'm clearly not working on other specs.

If someone wants to organize a distinct FLAC list or group, please feel free to contact me at the above email address and perhaps we can make progress.

My contribution would be to make sure that the original capabilities and intents of FLAC are maintained as its spec is absorbed in others. If Josh Coalson is available, he would certainly be the ultimate authority, but I've been involved to an extent for quite a long time. Of course, I would need a summary of the goals for the new specifications in order to make sense of the situation.

Brian Willoughby
Sound Consulting

On Mar 15, 2017, at 8:24 PM, Tessa Fallon <[email-masked]> wrote:
> RE: FLAC, backburner IMO until other milestones are on track.  If there are folks who only want to work on FLAC and who are not actively working on other specs, I would ask them to speak up here to organize.  I know there were some efforts a while ago, but I am not personally aware of any progress.
> 
> Tessa
> 
>> Also FLAC? There’s been a few volunteer to get this started (self included), but as far as I know, there’s no progress on this specification.
>> 
>> Thanks much,
>> Dave
>> 
>>>> Much thanks,
>>>> Tessa
>>>> 
>>>> Date
>>>> Dec 2016 Submit specification for FLAC audio codec to IESG (Standards Track)
>>

---

From: Pierre-Yves Thoulon <[email-masked]>
Date: Thu, 16 Mar 2017 05:51:09 +0100

Same here. I have not been involved in the matroska effort as I have neither the bandwidth nor the knowledge to do so, but I've been working extensively these years with Flac. Unfortunately I don't have time to organize anything on the matter, but I will make some to participate in the spec review. 

Kind regards. 

Pyt.

> Le 16 mars 2017 à 05:42, Brian Willoughby <[email-masked]> a écrit :
> 
> Hello,
>

---

From: "Peter B." <[email-masked]>
Date: Thu, 16 Mar 2017 10:14:58 +0100

Hi everyone! :D

> to IESG (Standards Track)

Which new features are planned/desired to be in FFV1 version 4?

So far I only know of plans for (film-grade) color-handling.
Doi we have a consensus on whether which parts of it are gonna be in the
codec and/or the container?

Cheers,
Pb

---

From: Jerome Martinez <[email-masked]>
Date: Thu, 16 Mar 2017 12:58:46 +0100

Le 16/03/2017 à 04:24, Tessa Fallon a écrit :
> Mar 2017 Submit informational specification for FFV1 video codec 
> versions 0, 1 and 3 to IESG for publication
> If these seem like reasonable dates to contributors, I will move to 
> update milestones.

I would like to do a review of FFV1 specs, is it an issue if we put FFV1 
in April?
Or is it considered by others as enough reviewed?

>
> RE: FLAC, backburner IMO until other milestones are on track.  If 
> there are folks who only want to work on FLAC and who are not actively 
> working on other specs, I would ask them to speak up here to 
> organize.  I know there were some efforts a while ago, but I am not 
> personally aware of any progress.

I started to review the current spec, I did not have the time to write 
"patches" about it. Definitely on my todo-list and I am happy to see 
that there is some people interested to join the effort,  but on my side 
I'll focus on it only after EBML/Matroska/FFV1.0-3 is finished.

---

From: Jerome Martinez <[email-masked]>
Date: Thu, 16 Mar 2017 12:59:44 +0100

> Jul 2017 Submit specification for FFV1 video codec version 4 to 

 From my point of view focus on FFV1 v4 should be done only after v3 is 
standardized.

---

From: Andrew James Weaver <[email-masked]>
Date: Sat, 18 Mar 2017 14:51:33 -0700

Hi all,

I would be interested in helping out with some of the FLAC efforts as well.
I am happy to participate in some of the nitty gritty such as helping to
convert the spec into markdown etc.

Best,
Andrew

-- 
Andrew Weaver, MLIS
American Archive of Public Broadcasting
National Digital Stewardship Resident @ CUNY TV
[email-masked]