Subject: [Cellar] intro to ffv1

From: Dave Rice <[email-masked]>
Date: Wed, 7 Jun 2017 21:09:38 -0400

HI all,

With the current version of the ffv1 draft, it is not easy to understand that the document defines three distinct versions of FFV1. I extended the Introduction section to summarize the version history a bit and extend the introductory description. This changes the intro from:

> The FFV1 video codec is a simple and efficient lossless intra-frame only codec.

to:

> This document describes FFV1, a lossless video encoding format. The design of FFV1 considers the storage of image characteristics, data fixity, and the optimized use of encoding time and storage requirements. FFV1 is designed to support a wide range of lossless video applications such as long-term audiovisual preservation, scientific imaging, screen recording, and other video encoding scenarios that seek to avoid the generational loss of lossy video encodings.
> 
> This document defines a version 0, 1, and 3 of FFV1. The distinctions of the versions are provided throughout the document, but in summary:
> 
> - Version 0 of FFV1 was the original implementation of FFV1 and has been in non-experimental use since April 14, 2006 [@?FFV1_V0].
> 
> - Version 1 of FFV1 adds support of more video bit depths and has been in use since April 24, 2009 [@?FFV1_V1].
> 
> - Version 2 of FFV1 only existed in experimental form and is not described by this document.
> 
> - Version 3 of FFV1 adds several features such as increased description of the characteristics of the encoding images and embedded CRC data to support fixity verification of the encoding. Version 3 has been in non-experimental use since June 25, 2016 [@?FFV1_V3].

The citation references point to the first public corresponding libav and ffmpeg commits that mark these points in the development of the encoding.

The pull request is at https://github.com/FFmpeg/FFV1/pull/72. Comments?

Best Regards,
Dave Rice

---

From: Tessa Fallon <[email-masked]>
Date: Thu, 8 Jun 2017 10:14:10 -0400

Dave,

This is helpful. It makes it clear that all three versions of FFV1 are
contained within a single spec. I support the change.

Best,
Tessa

On Wed, Jun 7, 2017 at 9:09 PM, Dave Rice <[email-masked]> wrote:

> HI all,
>
> With the current version of the ffv1 draft, it is not easy to understand
> that the document defines three distinct versions of FFV1. I extended the
> Introduction section to summarize the version history a bit and extend the
> introductory description. This changes the intro from:
>
> > This document describes FFV1, a lossless video encoding format. The
> design of FFV1 considers the storage of image characteristics, data fixity,
> and the optimized use of encoding time and storage requirements. FFV1 is
> designed to support a wide range of lossless video applications such as
> long-term audiovisual preservation, scientific imaging, screen recording,
> and other video encoding scenarios that seek to avoid the generational loss
> of lossy video encodings.
> >
> > This document defines a version 0, 1, and 3 of FFV1. The distinctions of
> the versions are provided throughout the document, but in summary:
> >
> > - Version 0 of FFV1 was the original implementation of FFV1 and has been
> in non-experimental use since April 14, 2006 [@?FFV1_V0].
> >
> > - Version 3 of FFV1 adds several features such as increased description
> of the characteristics of the encoding images and embedded CRC data to
> support fixity verification of the encoding. Version 3 has been in
> non-experimental use since June 25, 2016 [@?FFV1_V3].
>
> The citation references point to the first public corresponding libav and
> ffmpeg commits that mark these points in the development of the encoding.
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>