Subject: [Cellar] FFV1 for Film

From: Joshua Michael Yocum <[email-masked]>
Date: Mon, 30 Oct 2017 16:55:30 +0000

Hi everyone,

I’ve been doing some tests with FFV1 and DPX sequences these last few months and put together a document with some of my observations.  I’d be interested in hearing from people who have looked into using FFV1 for film or have been considering it and what your experiences or thoughts have been.  Hopefully this can generate a little discussion about what aspects of FFV1 still need improvement for handling digitized film given current film scanning practices and workarounds that others have considered for using the current version of FFV1 with such materials.  From my tests, FFV1 was very promising and offered a lot of benefits over other formats, although I also observed the Color Primaries change that has been noted by Kieran O’Leary and others when converting from DPX.  I also encountered some quirks when playing back files with both VLC and ffplay, and I hope that others who are a little more knowledgeable about these programs can chime in about that.

Here’s a link to a folder on Google drive with the document I’ve put together and some sample files.  The DPX sequences that I tested reflect what we have received from one vendor, so it would be interesting to see how this compares with DPX sequences that others are working with.
https://drive.google.com/drive/folders/0ByhHZqh-q6bEbmNVUFN4QzRTaWc?usp=sharing

And here’s a direct link to the Google Doc in that folder as well:
https://drive.google.com/open?id=1-nZj53eCuY_81qYVkVDdZRa_pkHicVzETaTAxkCcYD8

Joshua Yocum

---

From: Kieran O Leary <[email-masked]>
Date: Tue, 31 Oct 2017 14:08:17 +0000

Hi Joshua,

I was adding some comments there but it looks like google have taken
down the doc?

Best,

Kieran.

On Mon, Oct 30, 2017 at 4:55 PM, Joshua Michael Yocum
<[email-masked]> wrote:
> Hi everyone,
>
>
>
> I’ve been doing some tests with FFV1 and DPX sequences these last few months
> and put together a document with some of my observations.  I’d be interested
> in hearing from people who have looked into using FFV1 for film or have been
> considering it and what your experiences or thoughts have been.  Hopefully
> this can generate a little discussion about what aspects of FFV1 still need
> improvement for handling digitized film given current film scanning
> practices and workarounds that others have considered for using the current
> version of FFV1 with such materials.  From my tests, FFV1 was very promising
> and offered a lot of benefits over other formats, although I also observed
> the Color Primaries change that has been noted by Kieran O’Leary and others
> when converting from DPX.  I also encountered some quirks when playing back
> files with both VLC and ffplay, and I hope that others who are a little more
> knowledgeable about these programs can chime in about that.
>
>
>
> Here’s a link to a folder on Google drive with the document I’ve put
> together and some sample files.  The DPX sequences that I tested reflect
> what we have received from one vendor, so it would be interesting to see how
> this compares with DPX sequences that others are working with.
>
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar
>

---

From: Jim Shupert <[email-masked]>
Date: Tue, 31 Oct 2017 10:57:39 -0400

That is a shame.... i am interested in this
I am a DPX , FFV1 , ffmpeg , film , tape etc etc kind o dude.

I anxiously look forward to reading about your efforts.

best wishes

jim shupert, jr.

---

From: Kieran O Leary <[email-masked]>
Date: Tue, 31 Oct 2017 17:29:58 +0000

Aye, it looks like this issue is affecting a lot of people today:
https://www.google.ie/search?safe=off&ei=hbL4WYT_GeKugAaH0aeIDQ&q=google+docs++terms+of+service&oq=google+docs++terms+of+service&gs_l=psy-ab.3..0i7i30k1j0l2j0i30k1.1774.2313.0.2796.6.6.0.0.0.0.119.407.5j1.6.0....0...1.1.64.psy-ab..1.5.344...0i67k1j0i8i7i30k1j0i8i30k1.0.WBEP6nwmq0s

---

From: "McDowell, Blake" <[email-masked]>
Date: Tue, 31 Oct 2017 17:46:27 +0000

Looking forward to reading this once Google figures the problem out. Thanks!

Blake

From: Cellar [mailto:[email-masked]] On Behalf Of Joshua Michael Yocum
Sent: Monday, October 30, 2017 1:08 PM
To: [email-masked]
Subject: [Cellar] FFV1 for Film

Hi everyone,

Joshua Yocum

---

From: Joshua Michael Yocum <[email-masked]>
Date: Tue, 31 Oct 2017 18:01:46 +0000

Hopefully it will be back soon.  If Google Docs continues to cause issues, I’ll make some changes based on comments people have left and try attaching it as a word document.

Just to add a little more context on the document.  This only reflects some basic tests we’ve done at Northwestern University out of an interest in seeing how well FFV1 might work for film projects we’ve gotten in the past and are planning in the future.  It’s definitely not intended to be an authoritative document on film digitization, DPX, or FFV1 and is intended more to spark some discussion about FFV1 as a codec for digitized film.  The feedback that people have left so far has been very helpful and informative.

Josh

On 10/31/17, 12:30 PM, "Cellar on behalf of Kieran O Leary" <[email-masked] on behalf of [email-masked]> wrote:

    Aye, it looks like this issue is affecting a lot of people today:
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.google.ie_search-3Fsafe-3Doff-26ei-3DhbL4WYT-5FGeKugAaH0aeIDQ-26q-3Dgoogle-2Bdocs-2B-2Bterms-2Bof-2Bservice-26oq-3Dgoogle-2Bdocs-2B-2Bterms-2Bof-2Bservice-26gs-5Fl-3Dpsy-2Dab.3..0i7i30k1j0l2j0i30k1.1774.2313.0.2796.6.6.0.0.0.0.119.407.5j1.6.0....0...1.1.64.psy-2Dab..1.5.344...0i67k1j0i8i7i30k1j0i8i30k1.0.WBEP6nwmq0s&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=3uPv3PtY7qiKsPYnfXUwzrqBtZ8tdQiGPQy3G4rg5fQ&e= 
    
    On Tue, Oct 31, 2017 at 2:57 PM, Jim Shupert <[email-masked]> wrote:
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__drive.google.com_drive_folders_0ByhHZqh-2Dq6bEbmNVUFN4QzRTaWc-3Fusp-3Dsharing&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=nO8De6G8le3hMhlHSzZk086Gcf3b6nzq0W6jzQS5QFI&e= 
    >
    >
    >
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__drive.google.com_open-3Fid-3D1-2DnZj53eCuY-5F81qYVkVDdZRa-5FpkHicVzETaTAxkCcYD8&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=QrJOlsO0ewkElTCc62xI42Fk_5JGc0ifE_BHYUbGb8Y&e= 
    >
    >
    >
    >
    >
    > Joshua Yocum
    >
    >
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm-y0CpXy4Mc24s&e= 
    >
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm-y0CpXy4Mc24s&e= 
    >
    >
    >
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm-y0CpXy4Mc24s&e= 
    >
    
    _______________________________________________
    Cellar mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm-y0CpXy4Mc24s&e=

---

From: Kieran O Leary <[email-masked]>
Date: Tue, 31 Oct 2017 18:42:39 +0000

The doc is back up and running!

On 31 Oct 2017 18:02, "Joshua Michael Yocum" <[email-masked]>
wrote:

> Hopefully it will be back soon.  If Google Docs continues to cause issues,
> I’ll make some changes based on comments people have left and try attaching
> it as a word document.
>
> Just to add a little more context on the document.  This only reflects
> some basic tests we’ve done at Northwestern University out of an interest
> in seeing how well FFV1 might work for film projects we’ve gotten in the
> past and are planning in the future.  It’s definitely not intended to be an
> authoritative document on film digitization, DPX, or FFV1 and is intended
> more to spark some discussion about FFV1 as a codec for digitized film.
> The feedback that people have left so far has been very helpful and
> informative.
>
> Josh
>
>
> On 10/31/17, 12:30 PM, "Cellar on behalf of Kieran O Leary" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> google.ie_search-3Fsafe-3Doff-26ei-3DhbL4WYT-
> 5FGeKugAaH0aeIDQ-26q-3Dgoogle-2Bdocs-2B-2Bterms-2Bof-
> 2Bservice-26oq-3Dgoogle-2Bdocs-2B-2Bterms-2Bof-
> 2Bservice-26gs-5Fl-3Dpsy-2Dab.3..0i7i30k1j0l2j0i30k1.1774.
> 2313.0.2796.6.6.0.0.0.0.119.407.5j1.6.0....0...1.1.64.psy-2Dab..1.5.344...
> 0i67k1j0i8i7i30k1j0i8i30k1.0.WBEP6nwmq0s&d=DwIGaQ&c=
> yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=
> RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-
> UbxB7zKZ7SvhtTEE28&s=3uPv3PtY7qiKsPYnfXUwzrqBtZ8tdQiGPQy3G4rg5fQ&e=
>
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__drive.
> google.com_drive_folders_0ByhHZqh-2Dq6bEbmNVUFN4QzRTaWc-3Fusp-
> 3Dsharing&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=
> RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-DXaoeYlmSBBETWTtS5EKU_-
> UbxB7zKZ7SvhtTEE28&s=nO8De6G8le3hMhlHSzZk086Gcf3b6nzq0W6jzQS5QFI&e=
>     >
>     >
>     >
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__drive.
> google.com_open-3Fid-3D1-2DnZj53eCuY-5F81qYVkVDdZRa-
> 5FpkHicVzETaTAxkCcYD8&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNX
> t_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-
> DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=QrJOlsO0ewkElTCc62xI42Fk_
> 5JGc0ifE_BHYUbGb8Y&e=
>     >
>     >
>     >
>     >
>     >
>     > Joshua Yocum
>     >
>     >
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNX
> t_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-
> DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm
> -y0CpXy4Mc24s&e=
>     >
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNX
> t_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-
> DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm
> -y0CpXy4Mc24s&e=
>     >
>     >
>     >
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNX
> t_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-
> DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm
> -y0CpXy4Mc24s&e=
>     >
>
>     https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_cellar&d=DwIGaQ&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNX
> t_d012z2PA6ws&r=RNiFWQPZa07L2HoPIFJyELgdRuvqlOp9K3mLZTSUqo0&m=D-
> DXaoeYlmSBBETWTtS5EKU_-UbxB7zKZ7SvhtTEE28&s=dLCGG1cn5LS4AYXE903SBaXONBiCWm
> -y0CpXy4Mc24s&e=
>
>