Subject: [clouds] Announcing Clouds bar BoF during IETF-77 (March, 2010, Anaheim, CA)

From: Bhumip Khasnabish <[email-masked]>
Date: Sun, 21 Feb 2010 01:33:33 -0500

Dear All,
We wish to inform you of the intent to have a bar BoF during the IETF-77
meeting in Anaheim, CA (_March 21-26, 2010_) on defining
applications/services and their provisioning/management over cloud-based
system (A/SPOCS).

A new alias has been created for discussion on this topic:  [email-masked].

We will send out information about a survey of the time to hold the bar BoF
in Anaheim.

Some of the discussion will focus on developing a reference framework and
defining the use cases for emerging cloud services. We also plan to talk
about interfaces and protocol profiles including extensions (if needed) for
implementing (provisioning/maintaining) these services over cloud-based
systems.

Please join this alias and come to the planned bar BoF if you are interested
in this topic.

Thank you.

Bhumip Khasnabish ([email-masked])
Clouds bar BoF Convener

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 22 Feb 2010 09:45:37 -0800

On 2/22/2010 9:38 AM, Romascanu, Dan (Dan) wrote:
>>  A new alias has been created for discussion on this topic:
> [email-masked] <mailto:[email-masked]> .
> Do you mean a mail list? Can you provide subscribe information?

<https://www.ietf.org/mailman/listinfo/clouds>

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Melinda Shore <[email-masked]>
Date: Mon, 22 Feb 2010 11:59:58 -0900

On Feb 22, 2010, at 11:52 AM, Brian E Carpenter wrote:
> My thought exactly. The distinction between cloud computing and open  
> grid
> computing is very small (or possibly zero)

With all due respect, Brian, it's really not.  With cloud
computing you're typically dealing with multitenanting issues
and a bunch of other layer 8-9 stuff that tends (of necessity)
to be reflected down the stack, and I think I can see an
argument for cloud computing belonging in the RAI space,
or at least having substantial overlap.

The infrastructure aspects of it have implications for work
that not only has not been done in the past but has actively
been rejected in the past - see, for example, stuff
around state transfer and management in the rserpool discussions.
It's one thing to talk about network protocols for
carrying stuff around but the {i,r}pc aspects of the work
really have a lot more to do with computation than the IETF
has historically undertaken.

Melinda

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 22 Feb 2010 13:08:38 -0800

On 2/22/2010 12:59 PM, Melinda Shore wrote:
>> My thought exactly. The distinction between cloud computing and open grid

Having recently gone through the exercise of trying to understand what these 
different terms actually meant, I discovered that the underlying problem is that 
you are both right, as are a variety of other people who have other views...

As already noted, the term 'cloud' is now used in many different ways, including 
as a synonym for 'network' and for 'Internet', even amongst technical folk. 
(Really.)

There are some people who have very specific and nuanced technical definitions, 
including distinguishing cloud from grid.  But no set of definitions seems to 
have a broad base of support.

For defining 'cloud', one group I'm participating in decided it was happy with 
the NIST language:

    <http://csrc.nist.gov/groups/SNS/cloud-computing/cloud-def-v15.doc>

d/

-- 

   Dave Crocker

---

From: Melinda Shore <[email-masked]>
Date: Mon, 22 Feb 2010 13:22:16 -0900

On Feb 22, 2010, at 12:08 PM, Dave CROCKER wrote:
> For defining 'cloud', one group I'm participating in decided it was  
> happy with the NIST language:

I can live with that.

Melinda

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 22 Feb 2010 16:35:16 -0800

At 1:08 PM -0800 2/22/10, Dave CROCKER wrote:
>For defining 'cloud', one group I'm participating in decided it was happy with the NIST language:
>

[ Disclaimer: I am working for NIST on a related document. ]

The NIST definition is good for some environments, but it does not lend itself well to an IETF effort that will discuss provisioning, particularly the SaaS and PaaS parts. If we do not scope down more narrowly than "everything that can be virtualized", there is probably no reason to start work on how to provision that everything.

--Paul Hoffman, Director
--VPN Consortium

---

From: Sam Johnston <[email-masked]>
Date: Tue, 23 Feb 2010 01:43:43 +0100

On Tue, Feb 23, 2010 at 1:35 AM, Paul Hoffman <[email-masked]> wrote:

> The NIST definition is good for some environments, but it does not lend
> itself well to an IETF effort that will discuss provisioning, particularly
> the SaaS and PaaS parts. If we do not scope down more narrowly than
> "everything that can be virtualized", there is probably no reason to start
> work on how to provision that everything.
>

Agreed, the NIST document is not without its imperfections. It also hasn't
evolved a great deal, which I think is less to do with having got it right
from the start and more to do with having got it "right enough" for many. I
would also suggest that virtualisation is a red herring in that there is a
lot of focus here because that's where the legacy vendors are at (plus it's
the low hanging fruit - basically compute, storage and network resources and
not much else).

Things start to get interesting when you look at platforms (structured
storage, queues, runtimes and weird and wonderful contraptions like MTurk),
and as for the application layer, that stretches as far and wide as you
like.

Sam

---

From: Tim Bray <[email-masked]>
Date: Mon, 22 Feb 2010 16:45:13 -0800

> If you're proposing OGF you should look at the 6 or 7 other SDOs doing
> useful work on clouds, e.g. the DMTF.  It's a complex situation.

I would have said "ridiculous" actually.  So much standards energy, so
little shipping technology. -Tim

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 22 Feb 2010 18:38:42 +0100

Thanks and Regards,
 
Dan

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Bhumip Khasnabish
	Sent: Sunday, February 21, 2010 8:34 AM
	To: [email-masked]
	Cc: [email-masked]
	Subject: Announcing Clouds bar BoF during IETF-77 (March, 2010,
Anaheim, CA)

	Dear All,

	We wish to inform you of the intent to have a bar BoF during the
IETF-77 meeting in Anaheim, CA (_March 21-26, 2010_) on defining
applications/services and their provisioning/management over cloud-based
system (A/SPOCS).  

[email-masked] .  

	We will send out information about a survey of the time to hold
the bar BoF in Anaheim.  

	Some of the discussion will focus on developing a reference
framework and defining the use cases for emerging cloud services. We
also plan to talk about interfaces and protocol profiles including
extensions (if needed) for implementing (provisioning/maintaining) these
services over cloud-based systems.

	Please join this alias and come to the planned bar BoF if you
are interested in this topic.

	Thank you.

	Clouds bar BoF Convener

---

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Feb 2010 13:07:11 -0500

>>>>> "Dan" == Dan Romascanu <Romascanu> writes:
    Dan> [email-masked] <mailto:[email-masked]> .
 
    Dan> Do you mean a mail list? Can you provide subscribe information?

The participants are aware of the work occuring in the Open Grid Forum,
in the OCCI WG?

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Feb 2010 09:52:27 +1300

My thought exactly. The distinction between cloud computing and open grid
computing is very small (or possibly zero) and we have a sister standards
body that has been working in this area for years. David Chadwick is the
IETF liaison to the OGF.

I can see an argument for additional work on the *implications* of grid/cloud
computing on IETF protocols.

    Brian

---

From: Ole Jacobsen <[email-masked]>
Date: Mon, 22 Feb 2010 13:15:41 -0800 (PST)

I agree with Dave and offer the following article (in two parts) for 
further background reading. (The second part will be available in 
printed form in Anaheim):

http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_12-3/123_cloud1.html

and

http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_12-4/124_cloud2.html

(Whole issues can also be downloaded in PDF format).

We now return to our regular scheduled programming and discussions 
about how to get from various airports to Disneyland.

Ole

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj

On Mon, 22 Feb 2010, Dave CROCKER wrote:

> different terms actually meant, I discovered that the underlying problem is
> that you are both right, as are a variety of other people who have other
> views...
> 
> As already noted, the term 'cloud' is now used in many different ways,
> including as a synonym for 'network' and for 'Internet', even amongst
> technical folk. (Really.)
> 
> There are some people who have very specific and nuanced technical
> definitions, including distinguishing cloud from grid.  But no set of
> definitions seems to have a broad base of support.
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Feb 2010 11:11:53 +1300

Well yes, everybody's right in this area, since the terminology
is so fuzzy and so infected by marketing noise. In any case, I am
not for a moment saying: don't hold a Bar BOF. It seems like an
excellent idea to talk about it. What I am saying is: our sister
standards body the OGF seems like the natural home for this
topic, and we have to be very precise in defining scope to avoid
overlap and confusion.

Regards
   Brian

On 2010-02-23 10:15, Ole Jacobsen wrote:
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Tony Finch <[email-masked]>
Date: Mon, 22 Feb 2010 23:23:45 +0000

> technical folk. (Really.)

I get the impression that this was the original usage, from diagrams where
the network was abstracted as a vague cloud whose details were irrelevant.
Hence "cloud computing" == computing somwhere out in the network where we
don't need to care about the details.

>    <http://csrc.nist.gov/groups/SNS/cloud-computing/cloud-def-v15.doc>

Nice.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
GERMAN BIGHT HUMBER: SOUTHWEST 5 TO 7. MODERATE OR ROUGH. SQUALLY SHOWERS.
MODERATE OR GOOD.

---

From: Scott Brim <[email-masked]>
Date: Mon, 22 Feb 2010 19:39:45 -0500

---

From: "Jeff Wheeler (jewheele)" <[email-masked]>
Date: Mon, 22 Feb 2010 17:05:31 -0800

actually in the DMTF Telco WG we're completing a 3-month study of the metrics and data artifacts used by the various SDOs, consortia and forum currently involved in their own formal cloud standards and the count is 27, that without the vendors inter-cloud management interfaces.

chuckle

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tim Bray
Sent: Monday, February 22, 2010 4:45 PM
To: Scott Brim
Cc: Ole Jacobsen (ole); [email-masked]; [email-masked]; [email-masked]; David Chadwick
Subject: Re: Announcing Clouds bar BoF during IETF-77 (March, 2010, Anaheim, CA)

> useful work on clouds, e.g. the DMTF.  It's a complex situation.

I would have said "ridiculous" actually.  So much standards energy, so little shipping technology. -Tim _______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Feb 2010 15:04:39 +1300

Chuckle? Not really. This is depressing. So maybe the IETF should smile
and stand back politely.

   Brian