Subject: [clouds] scope of the cloud

From: "zhangyunfei" <[email-masked]>
Date: Fri, 9 Apr 2010 14:21:28 +0800

Hi all.
    Some kindly told me that my email is not displayed corretly.So send again.
-------------------------------------------------

Sam and all,
   The topic of standardizing (virtual )resource migration esp. in different clouds you mentioned sounds interesting.Do you have more details to share?Thanks.
    Another point:Is there standard protocols in interconnecting different regions of clusters?I thinks if there are room to expolore,it would be a suitable topic in IETF.

BR
Yunfei

zhangyunfei
2010-04-09

---

From: [email-masked]
Date: Fri, 9 Apr 2010 15:00:18 +0800

Not only (virtual )resource/(or tasks) migration esp. in different clouds, 
but migration from different servers in one cloud, I think it could be 
resonable.

Further, I am thinking could them be harmonized together for the protocol 
aspect?

"zhangyunfei" <[email-masked]> 
发件人:  [email-masked]
2010-04-09 14:21

收件人
"[email-masked]" <[email-masked]>, "sjj" <[email-masked]>
抄送

主题
[clouds] scope of the cloud

Hi all.
    Some kindly told me that my email is not displayed corretly.So send 
again.
-------------------------------------------------
 
Sam and all,
   The topic of standardizing (virtual )resource migration esp. in 
different clouds you mentioned sounds interesting.Do you have more details 
to share?Thanks.
    Another point:Is there standard protocols in interconnecting different 
regions of clusters?I thinks if there are room to expolore,it would be a 
suitable topic in IETF.
 
BR
Yunfei

zhangyunfei
2010-04-09_______________________________________________
clouds mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clouds

---

From: Wang Xu <[email-masked]>
Date: Fri, 9 Apr 2010 15:45:40 +0800

Yunfei and Meng,

Do you have any practical use case of live migration of virtual
machine? I do not find any case of heavy utilization of VM migration.

And some tests indicated that the migration in product environment is
not mature enough yet.

2010/4/9 <[email-masked]>
>
> Not only (virtual )resource/(or tasks) migration esp. in different clouds, but migration from different servers in one cloud, I think it could be resonable.
>
> Further, I am thinking could them be harmonized together for the protocol aspect?
>
>
>
> ________________________________
> zhangyunfei
> _______________________________________________
> clouds mailing list
> [email-masked]

--
Wang Xu

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 9 Apr 2010 16:07:32 +0800

I just want to know more praticial deployment on this point since Sam mentioned this.
----------------------------------
[Sam]
Another issue I ran into while writing cush[3] was how to remotely instruct servers to migrate (live?) resources - for example, moving a virtual machine, database, etc. from one location to another using a mobile device on a 3G connection. I believe WebDAV's COPY and MOVE verbs are a good start (this is what we're using for OCCI) but they could be reviewed and possibly promoted for more generic application.

BR
Yunfei

zhangyunfei
2010-04-09

发件人： Wang Xu
发送时间： 2010-04-09 16:03:32
收件人： meng.yu
抄送： zhangyunfei; [email-masked]
主题： Re:_[clouds]_答复:_scope_of_the_cloud

Yunfei  and  Meng,

2010/4/9   <[email-masked] >
>  "zhangyunfei"   <[email-masked] >
>  "[email-masked]"   <[email-masked] >,  "sjj"   <[email-masked] >
>  抄送
>  主题

--
Wang  Xu

---

From: Sam Johnston <[email-masked]>
Date: Fri, 9 Apr 2010 10:46:21 +0200

Yunfei/Wang/Meng,

My interest was not limited to virtual machines (which require some amount
of choreography on either side of the actual move) but rather files,
databases, code, documents - basically anything that you might want to move
from A to B (where you are not necessarily A or B).

Another area of potential interest is a lightweight "profile" of HTTP for
constrained devices, whereby one does not have to implement a full-blown
HTTP client & server pair simply to query an electricity meter. Some of
these issues were already discussed earlier this week[1]. The same could be
said for application of [vanilla] HTTP to files, databases, etc. (e.g. the
relevant subset of CDMI).

We're also missing a way of describing containers (e.g. hypervisors,
platforms, etc.) and workloads (e.g. applications, virtual machines).
CloudAudit provides a technical solution to the former (but it's out of
scope) and Cisco's James Urquhart has been working on a descriptor format
for the latter[2]. Both of these areas seem appropriate for IETF
involvement, and indeed CloudAudit could be worked into a generic catalog
service (e.g. the legal name of the provider, its location, logo, services,
SLAs, etc.).

I think the best next step would be for to work torwards formalising the
"clouds" effort somewhat, which will necessarily involve enumerating the
opportunities for standards development and prioritising them. IETF-78 would
presumably be a good forum for this activity (assuming it can't be done more
inclusively on this mailing list).

Sam

1. http://nih.blogspot.com/2010_04_01_archive.html
2. http://news.cnet.com/8301-19413_3-10440799-240.html
<http://news.cnet.com/8301-19413_3-10440799-240.html>
On 9 April 2010 10:07, zhangyunfei <[email-masked]> wrote:

> Another issue I ran into while writing cush[3] was how to remotely instruct
> servers to migrate (live?) resources - for example, moving a virtual
> machine, database, etc. from one location to another using a mobile device
> on a 3G connection. I believe WebDAV's COPY and MOVE verbs are a good start
> (this is what we're using for OCCI) but they could be reviewed and possibly
> promoted for more generic application.
>
>
>
> BR
>
> Yunfei
>
>  ------------------------------
>  zhangyunfei
> 2010-04-09
>  ------------------------------
>  *发件人：* Wang Xu
> *发送时间：* 2010-04-09 16:03:32
> *收件人：* meng.yu
> *抄送：* zhangyunfei; [email-masked]
> *主题：* Re:_[clouds]_答复:_scope_of_the_cloud
>
>  Yunfei  and  Meng,
>
> >  Not  only  (virtual  )resource/(or  tasks)  migration  esp.  in
>  different  clouds,  but  migration  from  different  servers  in  one
>  cloud,  I  think  it  could  be  resonable.
> >
> >      The  topic  of  standardizing  (virtual  )resource  migration  esp.
>  in  different  clouds  you  mentioned  sounds  interesting.Do  you  have
>  more  details  to  share?Thanks.
> >        Another  point:Is  there  standard  protocols  in  interconnecting
>  different  regions  of  clusters?I  thinks  if  there  are  room  to
>  expolore,it  would  be  a  suitable  topic  in  IETF.
> >
> >  BR
> >  Yunfei
> >
> >

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 9 Apr 2010 17:20:00 +0800

Thanks Sam for the reply.
Personally I think the migration,resource description(maybe there are similar efforts in other SDOs already) are good topics to discuss.
As for lightweight HTTP, I am not sure if this is an unique problem in cloud applications.It should be treated as an independent problem in my point of view.
Just two cents.

Yunfei

zhangyunfei
2010-04-09

发件人： Sam Johnston
发送时间： 2010-04-09 17:04:20
收件人： zhangyunfei
抄送： Wang Xu; meng.yu; [email-masked]
主题： Re: [clouds] __答复:_scope_of_the_cloud

Yunfei/Wang/Meng,

My interest was not limited to virtual machines (which require some amount of choreography on either side of the actual move) but rather files, databases, code, documents - basically anything that you might want to move from A to B (where you are not necessarily A or B).

Another area of potential interest is a lightweight "profile" of HTTP for constrained devices, whereby one does not have to implement a full-blown HTTP client & server pair simply to query an electricity meter. Some of these issues were already discussed earlier this week[1]. The same could be said for application of [vanilla] HTTP to files, databases, etc. (e.g. the relevant subset of CDMI).

We're also missing a way of describing containers (e.g. hypervisors, platforms, etc.) and workloads (e.g. applications, virtual machines). CloudAudit provides a technical solution to the former (but it's out of scope) and Cisco's James Urquhart has been working on a descriptor format for the latter[2]. Both of these areas seem appropriate for IETF involvement, and indeed CloudAudit could be worked into a generic catalog service (e.g. the legal name of the provider, its location, logo, services, SLAs, etc.).

I think the best next step would be for to work torwards formalising the "clouds" effort somewhat, which will necessarily involve enumerating the opportunities for standards development and prioritising them. IETF-78 would presumably be a good forum for this activity (assuming it can't be done more inclusively on this mailing list).

Sam

BR
Yunfei

zhangyunfei
2010-04-09

发件人： Wang Xu

Yunfei  and  Meng,

--
Wang  Xu

---

From: Gene Golovinsky <[email-masked]>
Date: Fri, 9 Apr 2010 06:59:38 -0500

We're also missing a way of describing containers (e.g. hypervisors, platforms, etc.) and workloads (e.g. applications, virtual machines). CloudAudit provides a technical solution to the former (but it's out of scope) and Cisco's James Urquhart has been working on a descriptor format for the latter[2]. Both of these areas seem appropriate for IETF involvement, and indeed CloudAudit could be worked into a generic catalog service (e.g. the legal name of the provider, its location, logo, services, SLAs, etc.).
[Gene>] I fully agree with that

I think the best next step would be for to work torwards formalising the "clouds" effort somewhat, which will necessarily involve enumerating the opportunities for standards development and prioritising them. IETF-78 would presumably be a good forum for this activity (assuming it can't be done more inclusively on this mailing list).
[Gene>] In one of the previous e-mails to the list Bhumip has outlined areas of Cloud related interests. Then we had a discussion on the list where people expressed their preferences, suggestions and disagreements. Bhumip, since you were already doing this, would you please recap the list taking all that into account?

Cheers.
--Gene

---

From: Bhumip Khasnabish <[email-masked]>
Date: Fri, 9 Apr 2010 08:16:06 -0400

Yes, in progress, and doing this. Plan to publish this soon (may wait a few
more days just to see whether we see any more new comments and/or
suggestions). Thanks.

2010/4/9 Gene Golovinsky <[email-masked]>

> *[Gene>] I fully agree with that*
>
>
>
> *[Gene>] In one of the previous e-mails to the list Bhumip has outlined
> areas of Cloud related interests. Then we had a discussion on the list where
> people expressed their preferences, suggestions and disagreements. Bhumip,
> since you were already doing this, would you please recap the list taking
> all that into account?*
>
> * *
>
> *Cheers.*
>
> *--Gene*
>
>
>
>
>

-- 
Best Regards.

Bhumip Khasnabish (Mobile:+001-781-752-8003, [email-masked])

© 2010 Bhumip Khasnabish. Do not view, print, forward, and save the content
of this email if you are not the intended recipient of the communiqué.

---

From: Sam Johnston <[email-masked]>
Date: Fri, 9 Apr 2010 14:23:34 +0200

> more days just to see whether we see any more new comments and/or

Let me add another to the list then - AAA. Examples include OAuth Web
Resource Authorization Profiles
(draft-hardt-oauth<http://tools.ietf.org/html/draft-hardt-oauth>),
which is already in the IETF pipeline even if OAuth itself is not, and our
new IMAP and SMTP authentication using
OAuth<http://code.google.com/apis/gmail/oauth/>spec, which is not.

Sam

---

From: Mark Webb <[email-masked]>
Date: Tue, 13 Apr 2010 16:38:18 -0400

> platforms, etc.) and workloads (e.g. applications, virtual machines).

I really think this is the realm of DMTF.  They have a good start with  
OVF. There is more to do, (network, security and policy abstraction to  
name a couple) but it would be good for the industry if those  
container issues were mostly handled in this same place.

Mark Webb

---

From: Sam Johnston <[email-masked]>
Date: Wed, 14 Apr 2010 14:42:36 +0200

On 13 April 2010 22:38, Mark Webb <[email-masked]> wrote:

> I really think this is the realm of DMTF.  They have a good start with OVF.
> There is more to do, (network, security and policy abstraction to name a
> couple) but it would be good for the industry if those container issues were
> mostly handled in this same place.
>

That may be true, but what IETF is renowned for is creating relatively
tight, interoperable specifications for well defined/constrained problems.
Others tend to want to boil oceans (e.g. OVF's normative reference to CIM),
which may well be necessary to solve their problems (e.g. "private" cloud)
but not ours (e.g. services like EC2).

Sam

---

From: "Krishna Sankar (ksankar)" <[email-masked]>
Date: Wed, 14 Apr 2010 05:53:22 -0700

Eh ? Is there someplace a statement or an intention which says IETF will work only on “service like EC2” ? 

From: [email-masked] [mailto:[email-masked]] On Behalf Of Sam Johnston
Sent: Wednesday, April 14, 2010 5:43 AM
To: Mark Webb (mwebb)
Cc: [email-masked]
Subject: Re: [clouds] __答复:_scope_of_the_cloud

		We're also missing a way of describing containers (e.g. hypervisors, platforms, etc.) and workloads (e.g. applications, virtual machines).

	I really think this is the realm of DMTF. They have a good start with OVF. There is more to do, (network, security and policy abstraction to name a couple) but it would be good for the industry if those container issues were mostly handled in this same place.

That may be true, but what IETF is renowned for is creating relatively tight, interoperable specifications for well defined/constrained problems. Others tend to want to boil oceans (e.g. OVF's normative reference to CIM), which may well be necessary to solve their problems (e.g. "private" cloud) but not ours (e.g. services like EC2).

Sam

---

From: Sam Johnston <[email-masked]>
Date: Wed, 14 Apr 2010 15:06:25 +0200

> work only on “service like EC2” ?
No - my point is that the needs of enterprise technology vary (often
significantly) from those of Internet-facing services. CDMI is but another
example of a protocol which has a bright future in feature rich products and
services, but which I remain unconvinced is suitable for something like
Amazon S3 (where I'd prefer to see something like a "lite" version of
WebDAV). Others include SAML vs OAuth, ActiveSync vs CalDAV, Exchange vs
IMAP, etc.

Sam

 *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Sam Johnston
> *Sent:* Wednesday, April 14, 2010 5:43 AM
> *To:* Mark Webb (mwebb)
> *Cc:* [email-masked]
> *Subject:* Re: [clouds] __答复:_scope_of_the_cloud
>
>
>
> OVF. There is more to do, (network, security and policy abstraction to name
> a couple) but it would be good for the industry if those container issues
> were mostly handled in this same place.
>
>
>