Subject: [clouds] Use cases

From: Gene Golovinsky <[email-masked]>
Date: Wed, 7 Apr 2010 09:40:40 -0500

Hi.

I just joined the mailing list yesterday and have a few questions.

1.      Is The Cloud Computing use cases white paper still document in progress and it id finished?
2.      I saw references to bar BoF at last IETF meeting, but could not really figure out if the WG was chartered.

Thanks.
--Gene

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 07 Apr 2010 08:47:40 -0600

On 4/7/10 8:40 AM, Gene Golovinsky wrote:

>    2. I saw references to bar BoF at last IETF meeting, but could not
>       really figure out if the WG was chartered. 

It was a bar BoF, not a real BoF. And IMHO the discussion was so
nebulous that folks are a long way from forming a WG.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Gene Golovinsky <[email-masked]>
Date: Wed, 7 Apr 2010 09:57:48 -0500

Well, I think this is a topic worthy of IETF time and attention.
How can I help to move the discussion forward?

Was there any specific area out of the white paper discussed? 
I think Cloud interoperability and security are topics were IETF is traditionally focusing its efforts.

--Gene

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]
Subject: Re: [clouds] Use cases

>       really figure out if the WG was chartered. 

It was a bar BoF, not a real BoF. And IMHO the discussion was so nebulous that folks are a long way from forming a WG.

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Mark Webb <[email-masked]>
Date: Wed, 7 Apr 2010 11:09:15 -0400

I was not there at the BoF, but did get reports from a couple of  
people in attendance.

An important perspective is to ensure IETF does NOT start a new effort  
that overlaps with other SDO and Forum already underway.  The industry  
does not need more SDO declaring they are relevant to cloud computing  
IMO.

Seeking contributions on relevant & IETF appropriate gap analysis is  
the _most_ that should be pursued at this point in time.

Mark Webb

On Apr 7, 2010, at 10:57 AM, Gene Golovinsky wrote:

> _______________________________________________
> clouds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clouds
>

---

From: Gene Golovinsky <[email-masked]>
Date: Wed, 7 Apr 2010 10:45:39 -0500

Mark.
I would agree with  that.
Like you said there are several initiatives going on in SNIA and TOG for example.

I do not see, however, interoperability/API, data exchange formats and security covered anywhere.

--Gene

From: Mark Webb [mailto:[email-masked]]
Sent: Wednesday, April 07, 2010 10:09 AM
To: [email-masked]
Cc: Peter Saint-Andre; Gene Golovinsky
Subject: Re: [clouds] Use cases

I was not there at the BoF, but did get reports from a couple of people in attendance.

An important perspective is to ensure IETF does NOT start a new effort that overlaps with other SDO and Forum already underway.  The industry does not need more SDO declaring they are relevant to cloud computing IMO.

Seeking contributions on relevant & IETF appropriate gap analysis is the _most_ that should be pursued at this point in time.

Mark Webb

--Gene

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [clouds] Use cases

Peter

--
Peter Saint-Andre
https://stpeter.im/

_______________________________________________
clouds mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clouds

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 07 Apr 2010 10:47:35 -0500

I attended the CLOUD's bar BOF. I don't think it is appropriate for IETF to
have a working group on "CLOUD" because it means different things to
different people. Cloud computing is a general term for anything that
involves delivering services over the Internet. I can see three basic
categories: 

*     Infrastructure-as-a-Service (
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1
358983,00.html> IaaS),

*     Platform-as-a-Service (
<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci1332892
,00.html> PaaS) and 

*     Software-as-a-Service (
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1
170781,00.html> SaaS)

There are a lot of stuff under each of the categories above. I suggest
separating them and further studying if there are enough contents for one of
them to become a working group. 

Linda Dunbar 

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mark Webb
Sent: Wednesday, April 07, 2010 10:09 AM
To: [email-masked]
Subject: Re: [clouds] Use cases

I was not there at the BoF, but did get reports from a couple of people in
attendance.

An important perspective is to ensure IETF does NOT start a new effort that
overlaps with other SDO and Forum already underway.  The industry does not
need more SDO declaring they are relevant to cloud computing IMO.  

Seeking contributions on relevant & IETF appropriate gap analysis is the
_most_ that should be pursued at this point in time.

Mark Webb

Was there any specific area out of the white paper discussed?
I think Cloud interoperability and security are topics were IETF is
traditionally focusing its efforts.

--Gene

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]
Subject: Re: [clouds] Use cases

>       really figure out if the WG was chartered.

It was a bar BoF, not a real BoF. And IMHO the discussion was so nebulous
that folks are a long way from forming a WG.

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Mark Webb <[email-masked]>
Date: Wed, 7 Apr 2010 12:05:16 -0400

DMTF with OVF is the primary group for Virtual Machine format &  
exchange for IaaS.   Look for that to evolve into something that will  
allow some abstractions for policy - security.  Given the dynamic  
nature of cloud today, the more abstraction that is allowed the  
better.   This will enable demand to grow and the use-cases to expand  
and viable services to be offered.

The cloud incubator effort, (in DMTF) looks to be spawning several  
other working groups.  Three different APIs have been submitted to the  
cloud incubator and look like a working group will be created to look  
at that.  There are several ways to look at the API user role and/or  
use-case of APIs.  I think DMTF focus will remain IaaS initially for  
the APIs as well.

For Security, Cloud Security Alliance is the clearing house for best  
practices, potential certification process in Cloud Audit.  These may  
end up serving the industry as the security focal point.  There are  
likely _most_ of the components for security existing today in various  
SDO.  So, this profiles (or frameworks) for security are what is most  
needed right now IMO.

Most of my comments are IaaS focused.  I believe PaaS and SaaS are too  
ill defined with no center of gravity to be something mature enough to  
consider standardization yet.  What the industry wants and will  
support in a functional, technical and business models from PaaS and  
SaaS has some design, use and clarification before we will know what  
is worth locking up IMO.

Mark Webb
On Apr 7, 2010, at 11:45 AM, Gene Golovinsky wrote:

> An important perspective is to ensure IETF does NOT start a new  
> effort that overlaps with other SDO and Forum already underway.  The  
> industry does not need more SDO declaring they are relevant to cloud  
> computing IMO.
>

---

From: "Carl Williams" <[email-masked]>
Date: Wed, 7 Apr 2010 12:58:58 -0400

The name is irrelevant and perhaps in future it could change to avoid
distraction.  The technology discussions is what is key and that is what was
discussed in the informal meeting.  From what I can tell the purpose was to
get some informal discussion going first and see what people are thinking.
There seems to be some conclusion that the next step was to conduct a gap
analysis.

Carl

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Linda Dunbar
Sent: Wednesday, April 07, 2010 11:48 AM
To: 'Mark Webb'; [email-masked]
Subject: [clouds] Scope of the Cloud is too big

p  Infrastructure-as-a-Service (
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1
358983,00.html> IaaS),

p  Platform-as-a-Service (
<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci1332892
,00.html> PaaS) and 

p  Software-as-a-Service (
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1
170781,00.html> SaaS)

Linda Dunbar 

  _____  

Mark Webb

--Gene

-----Original Message-----

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 07 Apr 2010 12:16:21 -0500

I find it difficult that people in the same room talking about totally
different subjects. Very hard to get the discussion moving forward. 

Linda 

  _____  

From: Carl Williams [mailto:[email-masked]] 
Sent: Wednesday, April 07, 2010 11:59 AM
To: 'Linda Dunbar'; 'Mark Webb'; [email-masked]
Subject: RE: [clouds] Scope of the Cloud is too big

Carl

Linda Dunbar 

  _____  

Mark Webb

--Gene

-----Original Message-----

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Melinda Shore <[email-masked]>
Date: Wed, 7 Apr 2010 09:23:07 -0800

This all seems really incoherent to me.

The usual approach is "Here's a problem, let's solve it" or
sometimes "Here's a problem and here's the solution."
Undertaking a gap analysis suggests that there's not a problem
that's been identified, but that people want to undertake work
in the area, don't want to work with the other bodies for
whatever reasons, and so are looking for a problem that somebody
else hasn't tackled (yet).  I'm considerably more comfortable
with work being driven by a real problem that's already been
identified, personally.

Melinda

---

From: [email-masked]
Date: Thu, 8 Apr 2010 09:03:13 +0800

I do agree the point is to find the suitable part for IETF without 
overlaps with others.

For me, the interoperability between cloud entities or between different 
clouds could be the candidates.

Meng Yu

Mark Webb <[email-masked]> 
发件人:  [email-masked]
2010-04-07 23:09

收件人
[email-masked]
抄送

主题
Re: [clouds] Use cases

An important perspective is to ensure IETF does NOT start a new effort 
that overlaps with other SDO and Forum already underway.  The industry 
does not need more SDO declaring they are relevant to cloud computing IMO. 

Mark Webb

--Gene

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf 
Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]
Subject: Re: [clouds] Use cases

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Bhumip Khasnabish <[email-masked]>
Date: Thu, 8 Apr 2010 00:22:25 -0400

Thanks for all of the inputs and discussion.
So far looks like the following could be the possible work items in IETF’s
Clouds ...

·         Interoperability

·         API development

·         Data exchange formats (may be use of metadata for defining
services and/or moving services from one cloud to another or using hybrid
cloud)

·         Privacy and security profiles (or frameworks) for privacy and
security in a variety of clouds domains

·         Functional, technical and business models for clarification and
use in Clouds services

Any other suggestions and/or comments?!

Bhumip

+++++++++++++++++++++++++++++++++++
On Wed, Apr 7, 2010 at 12:05 PM, Mark Webb <[email-masked]> wrote:

> DMTF with OVF is the primary group for Virtual Machine format & exchange
> for IaaS.   Look for that to evolve into something that will allow some
> abstractions for policy - security.  Given the dynamic nature of cloud
> today, the more abstraction that is allowed the better.   This will enable
> demand to grow and the use-cases to expand and viable services to be
> offered.
>
> The cloud incubator effort, (in DMTF) looks to be spawning several other
> working groups.  Three different APIs have been submitted to the cloud
> incubator and look like a working group will be created to look at that.
>  There are several ways to look at the API user role and/or use-case of
> APIs.  I think DMTF focus will remain IaaS initially for the APIs as well.
>
> practices, potential certification process in Cloud Audit.  These may end up
> serving the industry as the security focal point.  There are likely _most_
> of the components for security existing today in various SDO.  So, this
> profiles (or frameworks) for security are what is most needed right now
> IMO.
>
> Most of my comments are IaaS focused.  I believe PaaS and SaaS are too ill
> defined with no center of gravity to be something mature enough to consider
> standardization yet.  What the industry wants and will support in a
> functional, technical and business models from PaaS and SaaS has some
> design, use and clarification before we will know what is worth locking up
> IMO.
>
> Mark Webb
>
>  *From:* Mark Webb [mailto:[email-masked] <[email-masked]>]
> *Sent:* Wednesday, April 07, 2010 10:09 AM
> *To:* [email-masked]
> *Cc:* Peter Saint-Andre; Gene Golovinsky
> *Subject:* Re: [clouds] Use cases
>
> that overlaps with other SDO and Forum already underway.  The industry does
> not need more SDO declaring they are relevant to cloud computing IMO.
>
> From: [email-masked] [mailto:[email-masked]<[email-masked]>]
> On Behalf Of Peter Saint-Andre

-- 
Best Regards.

Bhumip Khasnabish (Mobile:+001-781-752-8003, [email-masked])

© 2010 Bhumip Khasnabish. Do not view, print, forward, and save the content
of this email if you are not the intended recipient of the communiqué.

---

From: "Masum Hasan (masum)" <[email-masked]>
Date: Wed, 7 Apr 2010 21:54:28 -0700

-          Interoperability of what? A what level/layer?

-          API development? Yet another? No. There are plethora of them. Mark pointed out DMTF may get into API spec work. There are also OGF OCCI (for compute) and SNIA CDMI (storage). IETF/IRTF could define requirements, specially as they relate to certain aspects of networking (IETF's forte), which other SDOs could use  as input to extend existing APIs (OCCI/vCloud/CDMI).

-          Data exchange format (DEF)? What data? Exchange (virtual appliance) package spec? Consider OVF. Exchange Amazon SimpleDB Table data with Microsoft Azure? Metadata for defining services? Other SDOs are working on this.  Also, Metadata for defining services and DEF are the same? I think, not.  

-          Privacy/security profiles? You got to figure out what other SDOs are not already targeting.

-          The last bullet ... too vague.

--Masum

408 219 9713   Cell                  408 853 5926   Desk

http://home.comcast.net/~masumz/

http://wwwin-people.cisco.com/masum/ (Intranet)

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bhumip Khasnabish
Sent: Wednesday, April 07, 2010 9:22 PM
To: Mark Webb (mwebb); [email-masked]
Cc: [email-masked]
Subject: Re: [clouds] Use cases

So far looks like the following could be the possible work items in IETF's Clouds ...  

·         Interoperability

·         API development 

·         Data exchange formats (may be use of metadata for defining services and/or moving services from one cloud to another or using hybrid cloud)

·         Privacy and security profiles (or frameworks) for privacy and security in a variety of clouds domains

·         Functional, technical and business models for clarification and use in Clouds services 

Bhumip

DMTF with OVF is the primary group for Virtual Machine format & exchange for IaaS.   Look for that to evolve into something that will allow some abstractions for policy - security.  Given the dynamic nature of cloud today, the more abstraction that is allowed the better.   This will enable demand to grow and the use-cases to expand and viable services to be offered. 

The cloud incubator effort, (in DMTF) looks to be spawning several other working groups.  Three different APIs have been submitted to the cloud incubator and look like a working group will be created to look at that.  There are several ways to look at the API user role and/or use-case of APIs.  I think DMTF focus will remain IaaS initially for the APIs as well.

For Security, Cloud Security Alliance is the clearing house for best practices, potential certification process in Cloud Audit.  These may end up serving the industry as the security focal point.  There are likely _most_ of the components for security existing today in various SDO.  So, this profiles (or frameworks) for security are what is most needed right now IMO. 

Most of my comments are IaaS focused.  I believe PaaS and SaaS are too ill defined with no center of gravity to be something mature enough to consider standardization yet.  What the industry wants and will support in a functional, technical and business models from PaaS and SaaS has some design, use and clarification before we will know what is worth locking up IMO.

Mark Webb 

Mark.

I would agree with  that.

--Gene

 

Mark Webb

--Gene

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]
Subject: Re: [clouds] Use cases

Peter

--
Peter Saint-Andre
https://stpeter.im/

 

-- 
Best Regards.

© 2010 Bhumip Khasnabish. Do not view, print, forward, and save the content of this email if you are not the intended recipient of the communiqué.

---

From: Bhumip Khasnabish <[email-masked]>
Date: Thu, 8 Apr 2010 01:40:16 -0400

Surely, these are good inputs and comments since we are still at bar BoF
stage.

As was mentioned earlier, "the interoperability between cloud entities or
between different clouds could be the candidates."

For the API work, yes, we'll look into what  are being *planned* by other
SDOs, and what are actually being *delivered*. The requirements may be
driven by the services (XaaS) and use cases under consideration, and IETF
Clouds group can contribute to that as well.

Metadata may be useful for hiding configuration and provisioning complexity
in each clouds, and may in turn support seamless interoperability.

Service-specific, privacy and security profiles are very important, and as
you mentioned " You got to figure out what other SDOs are not already
targeting " and that's what we plan to do in the Std. survey and
gap analysis.

The last bullet simply mentions the need for business, technical, and
functional ref. framerwork for cloud services.

Thanks again.

Bhumip

On Thu, Apr 8, 2010 at 12:54 AM, Masum Hasan (masum) <[email-masked]>wrote:

> -          API development? Yet another? No. There are plethora of them.
> Mark pointed out DMTF may get into API spec work. There are also OGF OCCI
> (for compute) and SNIA CDMI (storage). IETF/IRTF could define requirements,
> specially as they relate to certain aspects of networking (IETF’s forte),
> which other SDOs could use  as input to extend existing APIs
> (OCCI/vCloud/CDMI).
>
> -          Data exchange format (DEF)? What data? Exchange (virtual
> appliance) package spec? Consider OVF. Exchange Amazon SimpleDB Table data
> with Microsoft Azure? Metadata for defining services? Other SDOs are working
> on this.  Also, Metadata for defining services and DEF are the same? I
> think, not.
>
> -          The last bullet … too vague.
>
>
>
>
>
> --Masum
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Bhumip Khasnabish
> *Sent:* Wednesday, April 07, 2010 9:22 PM
> *To:* Mark Webb (mwebb); [email-masked]
> *Cc:* [email-masked]
>

-- 
Best Regards.

---

From: Gene Golovinsky <[email-masked]>
Date: Thu, 8 Apr 2010 07:36:45 -0500

While I agree that SaaS, IaaS and PaaS are different categories they all basically do the same thing - letting people consume IT functions as service.
As a result the same multiple problem spaces apply: users need to be authenticated, their access need to be controlled, activities audited, data protected, functionality provisioned and the list goes on.

Cloud Security Alliance mentioned earlier does not necessarily deal with those issues. I read their guidelines and it mostly deals with deployment recommendations, but the area of auditing for example is not really covered.

Ability to audit is really important if we want to insure that people that care about compliance actually use cloud technologies. Yet neither ability, nor technology for that is there. While traditional logging (syslog) is not good enough for the cloud simply because we are dealing with shared and dynamically allocated resources and user info is not consistently available.

--Gene

From: [email-masked] [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, April 07, 2010 12:16 PM
To: [email-masked]; 'Mark Webb'; [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

I find it difficult that people in the same room talking about totally different subjects. Very hard to get the discussion moving forward.

Linda

________________________________

The name is irrelevant and perhaps in future it could change to avoid distraction.  The technology discussions is what is key and that is what was discussed in the informal meeting.  From what I can tell the purpose was to get some informal discussion going first and see what people are thinking.  There seems to be some conclusion that the next step was to conduct a gap analysis.

Carl

From: [email-masked] [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, April 07, 2010 11:48 AM
To: 'Mark Webb'; [email-masked]
Subject: [clouds] Scope of the Cloud is too big

I attended the CLOUD's bar BOF. I don't think it is appropriate for IETF to have a working group on "CLOUD" because it means different things to different people. Cloud computing is a general term for anything that involves delivering services over the Internet. I can see three basic categories:
p  Infrastructure-as-a-Service (IaaS<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1358983,00.html>),
p  Platform-as-a-Service (PaaS)<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci1332892,00.html> and
p  Software-as-a-Service (SaaS<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1170781,00.html>)

There are a lot of stuff under each of the categories above. I suggest separating them and further studying if there are enough contents for one of them to become a working group.

Linda Dunbar

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Webb
Sent: Wednesday, April 07, 2010 10:09 AM
To: [email-masked]
Subject: Re: [clouds] Use cases

Mark Webb

--Gene

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [clouds] Use cases

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Gene Golovinsky <[email-masked]>
Date: Thu, 8 Apr 2010 08:01:16 -0500

All of those are fine choices, but I would really focus on Security profiles, auditing (including API)

--Gene

From: Bhumip Khasnabish [mailto:[email-masked]]
Sent: Wednesday, April 07, 2010 11:22 PM
To: [email-masked]; [email-masked]
Cc: Gene Golovinsky; [email-masked]
Subject: Re: [clouds] Use cases

*         Interoperability

*         API development

*         Data exchange formats (may be use of metadata for defining services and/or moving services from one cloud to another or using hybrid cloud)

*         Privacy and security profiles (or frameworks) for privacy and security in a variety of clouds domains

*         Functional, technical and business models for clarification and use in Clouds services

Bhumip

+++++++++++++++++++++++++++++++++++
On Wed, Apr 7, 2010 at 12:05 PM, Mark Webb <[email-masked]<mailto:[email-masked]>> wrote:
DMTF with OVF is the primary group for Virtual Machine format & exchange for IaaS.   Look for that to evolve into something that will allow some abstractions for policy - security.  Given the dynamic nature of cloud today, the more abstraction that is allowed the better.   This will enable demand to grow and the use-cases to expand and viable services to be offered.

Mark Webb

Mark.
I would agree with  that.

--Gene

Mark Webb

--Gene

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [clouds] Use cases

Peter

--
Peter Saint-Andre
https://stpeter.im/

--
Best Regards.

Bhumip Khasnabish (Mobile:+001-781-752-8003, [email-masked]<mailto:[email-masked]>)

---

From: Mark Webb <[email-masked]>
Date: Thu, 8 Apr 2010 09:23:02 -0400

Look at

http://www.cloudaudit.org/

For cloud audit.  It is difficult to specify audit when the services  
are so different today.

The industry has not settled on a small set of services definitions of  
what "cloud" is. So, how does one audit SaaS, PaaS?  When the services  
offered in that space are so different?  IaaS is the most mature and  
perhaps the lcd of cloud.

So, who here thinks that "IT functions as a service" or ITaaS is  
something that IETF can specify?  OK that was rhetorical.  My point  
is, the real opportunity is to look for elements that are mature  
enough to have some problem to be solved defined.  Then ensure you are  
not duplicating what other SDO or Forum are already working on.

Mark Webb

On Apr 8, 2010, at 8:36 AM, Gene Golovinsky wrote:

> While I agree that SaaS, IaaS and PaaS are different categories they  
> all basically do the same thing – letting people consume IT  
> functions as service.
> As a result the same multiple problem spaces apply: users need to be  
> authenticated, their access need to be controlled, activities  
> audited, data protected, functionality provisioned and the list goes  
> on.
>
> Cloud Security Alliance mentioned earlier does not necessarily deal  
> with those issues. I read their guidelines and it mostly deals with  
> deployment recommendations, but the area of auditing for example is  
> not really covered.
>
> Ability to audit is really important if we want to insure that  
> people that care about compliance actually use cloud technologies.  
> Yet neither ability, nor technology for that is there. While  
> traditional logging (syslog) is not good enough for the cloud simply  
> because we are dealing with shared and dynamically allocated  
> resources and user info is not consistently available.
>
> --Gene
>
>
>
> I find it difficult that people in the same room talking about  
> totally different subjects. Very hard to get the discussion moving  
> forward.
>
> Linda
>
> The name is irrelevant and perhaps in future it could change to  
> avoid distraction.  The technology discussions is what is key and  
> that is what was discussed in the informal meeting.  From what I can  
> tell the purpose was to get some informal discussion going first and  
> see what people are thinking.  There seems to be some conclusion  
> that the next step was to conduct a gap analysis.
>
> Carl
>
>
> I attended the CLOUD’s bar BOF. I don’t think it is appropriate for  
> IETF to have a working group on “CLOUD” because it means different  
> things to different people. Cloud computing is a general term for  
> anything that involves delivering services over the Internet. I can  
> see three basic categories:
> p  Infrastructure-as-a-Service (IaaS),
> p  Platform-as-a-Service (PaaS) and
> p  Software-as-a-Service (SaaS)
>
> There are a lot of stuff under each of the categories above. I  
> suggest separating them and further studying if there are enough  
> contents for one of them to become a working group.
>
> Linda Dunbar
>

---

From: Gene Golovinsky <[email-masked]>
Date: Thu, 8 Apr 2010 08:40:52 -0500

http://www.cloudaudit.org/ is an initiative, not a standard.
The plan for the group is to submit proposal to the IETF:
http://searchsecuritychannel.techtarget.com/news/interview/0,289202,sid97_gci1508024,00.html

Which means I am not alone thinking this is a worthy topic for IETF to take on.
When and if the proposal will be submitted there is still going to be a lot of work to make it a standard.

At least two approaches are possible. 1. Do nothing while waiting for Cloud Audit proposal. 2. Start working with the group.
Considering how fast Cloud technologies have been evolving and how critical Security is for the adoption of it I am for #2.

--Gene

From: Mark Webb [mailto:[email-masked]]
Sent: Thursday, April 08, 2010 8:23 AM
To: [email-masked]
Cc: Linda Dunbar; [email-masked]; Gene Golovinsky
Subject: Re: [clouds] Scope of the Cloud is too big

Look at

For cloud audit.  It is difficult to specify audit when the services are so different today.

The industry has not settled on a small set of services definitions of what "cloud" is. So, how does one audit SaaS, PaaS?  When the services offered in that space are so different?  IaaS is the most mature and perhaps the lcd of cloud.

So, who here thinks that "IT functions as a service" or ITaaS is something that IETF can specify?  OK that was rhetorical.  My point is, the real opportunity is to look for elements that are mature enough to have some problem to be solved defined.  Then ensure you are not duplicating what other SDO or Forum are already working on.

Mark Webb

--Gene

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, April 07, 2010 12:16 PM
To: [email-masked]<mailto:[email-masked]>; 'Mark Webb'; [email-masked]<mailto:[email-masked]>
Subject: Re: [clouds] Scope of the Cloud is too big

Linda

To: 'Linda Dunbar'; 'Mark Webb'; [email-masked]<mailto:[email-masked]>

Carl

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, April 07, 2010 11:48 AM
To: 'Mark Webb'; [email-masked]<mailto:[email-masked]>
Subject: [clouds] Scope of the Cloud is too big

I attended the CLOUD's bar BOF. I don't think it is appropriate for IETF to have a working group on "CLOUD" because it means different things to different people. Cloud computing is a general term for anything that involves delivering services over the Internet. I can see three basic categories:
*  Infrastructure-as-a-Service (IaaS<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1358983,00.html>),
*  Platform-as-a-Service (PaaS)<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci1332892,00.html> and
*  Software-as-a-Service (SaaS<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1170781,00.html>)

Linda Dunbar

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Mark Webb

Mark Webb

--Gene

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [clouds] Use cases

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Sam Johnston <[email-masked]>
Date: Thu, 8 Apr 2010 15:38:16 +0200

On 8 April 2010 14:36, Gene Golovinsky <[email-masked]> wrote:

>  While I agree that SaaS, IaaS and PaaS are different categories they all
> basically do the same thing – letting people consume IT functions as
> service.
>
> Agreed - cloud computing shifts computation [back] from the nodes to the
network, typically making it someone else's problem in the process. The
delivery of computing as a service (ala the electricity grid) rather than as
a product (ala a diesel generator) will certainly require some
standardisation effort, particularly given it's far more complicated than
just setting a voltage and frequency.

Regarding the definition, it's not precise but who cares - it doesn't need
to be so long as it's accurate (note that nobody cared that client-server
was imprecise). The best definition I've been able to come up with so far
(with the help of fellow Wikipedians) is "*Internet-based computing, whereby
shared resources, software and information are provided to computers and
other devices on-demand, like a public utility*", which is itself a
refinement of my earlier definition, simply "*Internet ('Cloud') based
development and use of computer technology ('Computing')*". If you try to
drill down from here to improve precision you lose accuracy - trust me, I've
tried. Let's just accept that we're not going to have a
definition/stack/etc. everyone agrees with and move on.

One way to look at it is that the Internet (the global network of networks)
kept us amused for a few decades by relaying packets between nodes at the
edge (most of the time). Some nodes were providers (servers), some consumers
(clients) and others filled both roles (e.g. P2P). It's like the electricity
grid without power stations - cloud computing just adds the latter
(typically in the form of nextgen data centers but could just as easily be
p2p or volunteer computing for all the client cares).

Today we have a number of largely independent "clouds" (Amazon, Google,
Microsoft, etc.) that are loosely coupled with protocols like OpenID as well
as proprietary protocols like Amazon's EC2 and S3. These will eventually
merge into the Intercloud (the global cloud of clouds) and for this to
happen we will certainly need distributed but coordinated (in the sense of
collaboration rather than control) standardisation. I personally believe the
IETF could play a key role here, as it did for the development of the
Internet.

Cheers,

Sam

-- 
*Sam Johnston*
*Technical Program Manager*
Site Reliability Engineering
Google Switzerland GmbH

---

From: Sam Johnston <[email-masked]>
Date: Thu, 8 Apr 2010 17:19:08 +0200

Gene,

You're definitely not alone in thinking this would be a worthy topic for
IETF and as co-conspirator (along with Cisco's Chris Hoff) and author of the
existing CloudAudit draft spec I'd love to see IETF people starting to work
with the group. We have weekly calls on Monday at 10am PST/1pm EST and
discuss in the cloudaudit Google Group[1]. The goal for v1 is to create a
trivial HTTP-based interface that can be implemented by uploading files
rather than coding. Similarly, OGF's OCCI working group has produced a
number of Internet-Drafts that could be picked up by IETF.

Another area that I think would be very interesting for IETF to take on
(moreso than virtualisation management) is a simple, HTTP-based storage API
like Amazon's S3 - only without the potential patent problems[2]. I believe
that HTTP already takes care of many/most of the issues (e.g.
authentication, encryption, ranged GETs, etc.) and IETF has proven
experience in the area (WebDAV).

Another issue I ran into while writing cush[3] was how to remotely instruct
servers to migrate (live?) resources - for example, moving a virtual
machine, database, etc. from one location to another using a mobile device
on a 3G connection. I believe WebDAV's COPY and MOVE verbs are a good start
(this is what we're using for OCCI) but they could be reviewed and possibly
promoted for more generic application.

Considering that most of these APIs (at least the ones I'm involved in) are
trying to be as close as possible to the "uniform interface" of HTTP,
I believe there's benefit to be had in reviewing the relevant RFCs with
these new applications in mind. For example, while HTTP has a perfectly good
metadata channel (headers) and thus obviates the need for envelope formats
(Atom, SOAP, etc), it lacks the ability to link, annotate and categorise
resources. It also has some internationalisation problems (e.g. ASCII) and
inefficient serialisation (e.g. SPDY). HTTP 1.1 has served us well for many
years but perhaps it's time to start thinking about what HTTP 2.0 might look
like?

Sam

1. http://groups.google.com/group/cloudaudit
2. http://tinyurl.com/s3patent
3. http://code.google.com/p/cush/

On 8 April 2010 15:40, Gene Golovinsky <[email-masked]> wrote:

> At least two approaches are possible. 1. Do nothing while waiting for Cloud
> Audit proposal. 2. Start working with the group.
>
> Considering how fast Cloud technologies have been evolving and how critical
> Security is for the adoption of it I am for #2.
>
>
>
> --Gene
>
>
>
>
>
>
>
> *From:* Mark Webb [mailto:[email-masked]]
> *Sent:* Thursday, April 08, 2010 8:23 AM
> *To:* [email-masked]
> *Cc:* Linda Dunbar; [email-masked]; Gene Golovinsky
>
> *Subject:* Re: [clouds] Scope of the Cloud is too big
>
>
>
> Look at
>
>
>
> The industry has not settled on a small set of services definitions of what
> "cloud" is. So, how does one audit SaaS, PaaS?  When the services offered in
> that space are so different?  IaaS is the most mature and perhaps the lcd of
> cloud.
>
>
>
> So, who here thinks that "IT functions as a service" or ITaaS is something
> that IETF can specify?  OK that was rhetorical.  My point is, the real
> opportunity is to look for elements that are mature enough to have some
> problem to be solved defined.  Then ensure you are not duplicating what
> other SDO or Forum are already working on.
>
>
>
> Mark Webb
>

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 08 Apr 2010 10:21:32 -0500

I am looking at a very different angle of the "Cloud". Rather than the "IT
functions as a service", I am looking at Virtual Network Services and
Storage Services which can be offered by Service Providers. 

Are there anyone else interested in this area? Maybe we should form a
separate discussion group. 

Linda Dunbar

  _____  

From: Gene Golovinsky [mailto:[email-masked]] 
Sent: Thursday, April 08, 2010 7:37 AM
To: Linda Dunbar; [email-masked]; 'Mark Webb'; [email-masked]
Subject: RE: [clouds] Scope of the Cloud is too big

While I agree that SaaS, IaaS and PaaS are different categories they all
basically do the same thing - letting people consume IT functions as
service.

As a result the same multiple problem spaces apply: users need to be
authenticated, their access need to be controlled, activities audited, data
protected, functionality provisioned and the list goes on.

Cloud Security Alliance mentioned earlier does not necessarily deal with
those issues. I read their guidelines and it mostly deals with deployment
recommendations, but the area of auditing for example is not really covered.

Ability to audit is really important if we want to insure that people that
care about compliance actually use cloud technologies. Yet neither ability,
nor technology for that is there. While traditional logging (syslog) is not
good enough for the cloud simply because we are dealing with shared and
dynamically allocated resources and user info is not consistently available.

--Gene

Linda 

  _____  

Carl

Linda Dunbar 

  _____  

Mark Webb

--Gene

-----Original Message-----

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Bhumip Khasnabish <[email-masked]>
Date: Thu, 8 Apr 2010 12:07:01 -0400

of course there are and will be many workitems within the theme of
cloud-based systems, services, inter-cloud system, and so on.  Cloud-based
storage, cloud-based mobile-data backup service,  cloud-based network
service in order to maintain service continuity, disaster-tolerant
communications, etc. are a few examples. Can we keep the discussion in the
same group please. Thanks a lot.

On Thu, Apr 8, 2010 at 11:21 AM, Linda Dunbar <[email-masked]> wrote:

>  I am looking at a very different angle of the “Cloud”. Rather than the
> “IT functions as a service”, I am looking at Virtual Network Services and
>  ------------------------------
>
> *From:* Gene Golovinsky [mailto:[email-masked]]
> *Sent:* Thursday, April 08, 2010 7:37 AM
> *To:* Linda Dunbar; [email-masked]; 'Mark Webb'; [email-masked]
>
> *Subject:* RE: [clouds] Scope of the Cloud is too big
>
>
>
> Behalf Of *Linda Dunbar
> *Sent:* Wednesday, April 07, 2010 12:16 PM
> *To:* [email-masked]; 'Mark Webb'; [email-masked]
>   ------------------------------
>
> *From:* Carl Williams [mailto:[email-masked]]
> *Sent:* Wednesday, April 07, 2010 11:59 AM
> *To:* 'Linda Dunbar'; 'Mark Webb'; [email-masked]
> *Subject:* RE: [clouds] Scope of the Cloud is too big
>
>
>
> Behalf Of *Linda Dunbar
> *Sent:* Wednesday, April 07, 2010 11:48 AM
> *To:* 'Mark Webb'; [email-masked]
> *Subject:* [clouds] Scope of the Cloud is too big
>
>
>
> I attended the CLOUD’s bar BOF. I don’t think it is appropriate for IETF to
> have a working group on “CLOUD” because it means different things to
> p     Platform-as-a-Service (PaaS)<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci1332892,00.html>and
>
>    ------------------------------
>
> Behalf Of *Mark Webb

-- 
Best Regards.

---

From: "So, Ning" <[email-masked]>
Date: Thu, 08 Apr 2010 16:08:53 +0000

Carrier/operators indeed do have a unique angle to the Cloud-based
Services, including but not limited to storage, data mining/search,
computing, and so on.  How does this new type of services interwork with
the existing MPLS-based network technologies?  For example, how does
these service interwork with today's L2 and L3 VPN based-services?  How
is the virtual separation of the traffic/data/queries maintained
end-to-end for the security conscious customers?  

Ning So

Lead Engineer

Global Data Network Traffic Planning

972-729-7905

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Linda Dunbar
Sent: Thursday, April 08, 2010 10:22 AM
To: 'Gene Golovinsky'; [email-masked]; 'Mark Webb'; [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

I am looking at a very different angle of the "Cloud". Rather than the
"IT functions as a service", I am looking at Virtual Network Services
and Storage Services which can be offered by Service Providers. 

Linda Dunbar

As a result the same multiple problem spaces apply: users need to be
authenticated, their access need to be controlled, activities audited,
data protected, functionality provisioned and the list goes on.

Cloud Security Alliance mentioned earlier does not necessarily deal with
those issues. I read their guidelines and it mostly deals with
deployment recommendations, but the area of auditing for example is not
really covered. 

Ability to audit is really important if we want to insure that people
that care about compliance actually use cloud technologies. Yet neither
ability, nor technology for that is there. While traditional logging
(syslog) is not good enough for the cloud simply because we are dealing
with shared and dynamically allocated resources and user info is not
consistently available. 

--Gene

Of Linda Dunbar

Linda 

The name is irrelevant and perhaps in future it could change to avoid
distraction.  The technology discussions is what is key and that is what
was discussed in the informal meeting.  From what I can tell the purpose
was to get some informal discussion going first and see what people are
thinking.  There seems to be some conclusion that the next step was to
conduct a gap analysis.

Carl

Of Linda Dunbar

I attended the CLOUD's bar BOF. I don't think it is appropriate for IETF
to have a working group on "CLOUD" because it means different things to
different people. Cloud computing is a general term for anything that
involves delivering services over the Internet. I can see three basic
categories: 

*     Infrastructure-as-a-Service (IaaS
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_
gci1358983,00.html> ),

*     Platform-as-a-Service (PaaS)
<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci133
2892,00.html>  and 

*     Software-as-a-Service (SaaS
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_
gci1170781,00.html> )

There are a lot of stuff under each of the categories above. I suggest
separating them and further studying if there are enough contents for
one of them to become a working group. 

Linda Dunbar 

Of Mark Webb

I was not there at the BoF, but did get reports from a couple of people
in attendance.

Mark Webb

--Gene

-----Original Message-----

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 08 Apr 2010 11:27:19 -0500

Keeping all the discussion in one email list is good. However, I recommend
people state which application scenario their issues are under. So that we
are not comparing apple with orange. 

Linda

  _____  

From: Bhumip Khasnabish [mailto:[email-masked]] 
Sent: Thursday, April 08, 2010 11:07 AM
To: Linda Dunbar
Cc: Gene Golovinsky; [email-masked]; Mark Webb; [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

I am looking at a very different angle of the “Cloud”. Rather than the “IT
functions as a service”, I am looking at Virtual Network Services and
Storage Services which can be offered by Service Providers. 

Linda Dunbar

  _____  

 

 

--Gene

Linda 

  _____  

Carl

Linda Dunbar 

  _____  

Mark Webb

--Gene

-----Original Message-----

Peter

--
Peter Saint-Andre
https://stpeter.im/

-- 
Best Regards.

---

From: "Masum Hasan (masum)" <[email-masked]>
Date: Thu, 8 Apr 2010 10:29:23 -0700

Focusing on specific area, specially as it relates to network (like
"virtual network services for Cloud"),  is a good idea to pursue in IETF
(so far the focus is lacking). 

--Masum

 

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Linda Dunbar
Sent: Thursday, April 08, 2010 8:22 AM
To: 'Gene Golovinsky'; [email-masked]; Mark Webb (mwebb);
[email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

Linda Dunbar

--Gene

Linda 

Carl

p  Infrastructure-as-a-Service (IaaS
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_
gci1358983,00.html> ),

p  Platform-as-a-Service (PaaS)
<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci133
2892,00.html>  and 

p  Software-as-a-Service (SaaS
<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_
gci1170781,00.html> )

Linda Dunbar 

Mark Webb

--Gene

-----Original Message-----

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: "Masum Hasan (masum)" <[email-masked]>
Date: Thu, 8 Apr 2010 10:34:51 -0700

Re. your comment on pursuing "storage API like Amazon's S3" in IETF. Why
that is needed when storage networking SDO SNIA is working on one (SNIA
CDMI)?

--Masum

 

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Sam Johnston
Sent: Thursday, April 08, 2010 8:19 AM
To: Gene Golovinsky
Cc: [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

Gene,

You're definitely not alone in thinking this would be a worthy topic for
IETF and as co-conspirator (along with Cisco's Chris Hoff) and author of
the existing CloudAudit draft spec I'd love to see IETF people starting
to work with the group. We have weekly calls on Monday at 10am PST/1pm
EST and discuss in the cloudaudit Google Group[1]. The goal for v1 is to
create a trivial HTTP-based interface that can be implemented by
uploading files rather than coding. Similarly, OGF's OCCI working group
has produced a number of Internet-Drafts that could be picked up by
IETF.

Another area that I think would be very interesting for IETF to take on
(moreso than virtualisation management) is a simple, HTTP-based storage
API like Amazon's S3 - only without the potential patent problems[2]. I
believe that HTTP already takes care of many/most of the issues (e.g.
authentication, encryption, ranged GETs, etc.) and IETF has proven
experience in the area (WebDAV).

Another issue I ran into while writing cush[3] was how to remotely
instruct servers to migrate (live?) resources - for example, moving a
virtual machine, database, etc. from one location to another using a
mobile device on a 3G connection. I believe WebDAV's COPY and MOVE verbs
are a good start (this is what we're using for OCCI) but they could be
reviewed and possibly promoted for more generic application.

Considering that most of these APIs (at least the ones I'm involved in)
are trying to be as close as possible to the "uniform interface" of
HTTP, I believe there's benefit to be had in reviewing the relevant RFCs
with these new applications in mind. For example, while HTTP has a
perfectly good metadata channel (headers) and thus obviates the need for
envelope formats (Atom, SOAP, etc), it lacks the ability to link,
annotate and categorise resources. It also has some internationalisation
problems (e.g. ASCII) and inefficient serialisation (e.g. SPDY). HTTP
1.1 has served us well for many years but perhaps it's time to start
thinking about what HTTP 2.0 might look like?

Sam

-- 
Sam Johnston

Technical Program Manager

Google Switzerland GmbH

http://searchsecuritychannel.techtarget.com/news/interview/0,289202,sid9
7_gci1508024,00.html

Which means I am not alone thinking this is a worthy topic for IETF to
take on.

When and if the proposal will be submitted there is still going to be a
lot of work to make it a standard.

At least two approaches are possible. 1. Do nothing while waiting for
Cloud Audit proposal. 2. Start working with the group.

Considering how fast Cloud technologies have been evolving and how
critical Security is for the adoption of it I am for #2.

--Gene

Look at 

For cloud audit.  It is difficult to specify audit when the services are
so different today.  

So, who here thinks that "IT functions as a service" or ITaaS is
something that IETF can specify?  OK that was rhetorical.  My point is,
the real opportunity is to look for elements that are mature enough to
have some problem to be solved defined.  Then ensure you are not
duplicating what other SDO or Forum are already working on.

Mark Webb

---

From: Mark Carlson <[email-masked]>
Date: Thu, 08 Apr 2010 11:39:33 -0600

Exactly. http://snia.org/cloud - CDMI is essentially done.

-- mark

On 4/8/10 11:34 AM, Masum Hasan (masum) wrote:
>
> Re. your comment on pursuing "storage API like Amazon's S3" in IETF. 
> Why that is needed when storage networking SDO SNIA is working on one 
> (SNIA CDMI)?
>
> --Masum
>
> Behalf Of *Sam Johnston
> *Sent:* Thursday, April 08, 2010 8:19 AM
> *To:* Gene Golovinsky
> *Cc:* [email-masked]
> You're definitely not alone in thinking this would be a worthy topic 
> for IETF and as co-conspirator (along with Cisco's Chris Hoff) and 
> author of the existing CloudAudit draft spec I'd love to see IETF 
> people starting to work with the group. We have weekly calls on Monday 
> at 10am PST/1pm EST and discuss in the cloudaudit Google Group[1]. The 
> goal for v1 is to create a trivial HTTP-based interface that can be 
> implemented by uploading files rather than coding. Similarly, OGF's 
> OCCI working group has produced a number of Internet-Drafts that could 
> be picked up by IETF.
>
> Another area that I think would be very interesting for IETF to take 
> on (moreso than virtualisation management) is a simple, HTTP-based 
> storage API like Amazon's S3 - only without the potential patent 
> problems[2]. I believe that HTTP already takes care of many/most of 
> the issues (e.g. authentication, encryption, ranged GETs, etc.) and 
> IETF has proven experience in the area (WebDAV).
>
> mobile device on a 3G connection. I believe WebDAV's COPY and MOVE 
> verbs are a good start (this is what we're using for OCCI) but they 
> could be reviewed and possibly promoted for more generic application.
>
> Considering that most of these APIs (at least the ones I'm involved 
> in) are trying to be as close as possible to the "uniform interface" 
> of HTTP, I believe there's benefit to be had in reviewing the relevant 
> RFCs with these new applications in mind. For example, while HTTP has 
> a perfectly good metadata channel (headers) and thus obviates the need 
> for envelope formats (Atom, SOAP, etc), it lacks the ability to link, 
> annotate and categorise resources. It also has some 
> internationalisation problems (e.g. ASCII) and inefficient 
> serialisation (e.g. SPDY). HTTP 1.1 has served us well for many years 
> but perhaps it's time to start thinking about what HTTP 2.0 might look 
> like?
>
> Sam
>
> -- 
> *Sam Johnston*
>
> /Technical Program Manager/
>
> On 8 April 2010 15:40, Gene Golovinsky <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> *From:* Mark Webb [mailto:[email-masked] <mailto:[email-masked]>]
> *To:* [email-masked] <mailto:[email-masked]>
> *Cc:* Linda Dunbar; [email-masked] <mailto:[email-masked]>; 
> Gene Golovinsky
>
>

---

From: Melinda Shore <[email-masked]>
Date: Thu, 8 Apr 2010 10:50:58 -0800

On Apr 8, 2010, at 8:07 AM, Bhumip Khasnabish wrote:
> cloud-based systems, services, inter-cloud system, and so on.  Cloud- 
> based storage, cloud-based mobile-data backup service,  cloud-based  
> network service in order to maintain service continuity, disaster- 
> tolerant communications, etc. are a few examples. Can we keep the  
> discussion in the same group please. Thanks a lot.

I think it might be worthwhile for people who are fishing
for work to do to sit down and take a look at the charters
for some established working groups, with a particular eye
to how the work is scoped, how the deliverables are
defined, and so on.  I think it's kind of weird that
people want to work on something but they aren't sure what -
usually it's an idea or ideas that drive work, or at least
some problem that's got at least some wee little bit of
definition - but as long as people seem intent on taking
this approach it might help to have some sense of what
this flailing about ought to produce.  Work in the IETF is
much more narrowly-focused and precisely-scoped than is
the norm in other standards bodies and/or industry consortia.

Melinda

---

From: Mark Carlson <[email-masked]>
Date: Thu, 08 Apr 2010 13:07:31 -0600

Agreed. If you want a good place to start, go to:

http://cloud-standards.org

We are already coordinating cloud work from the various
SDOs there, and IETF is represented by Dan Romascanu 
<http://www.ietf.org/iesg/bio/dan-romascanu.html>.

-- mark

On 4/8/10 12:50 PM, Melinda Shore wrote:
>> cloud-based systems, services, inter-cloud system, and so on.  
>> Cloud-based storage, cloud-based mobile-data backup service,  
>> cloud-based network service in order to maintain service continuity, 
>> disaster-tolerant communications, etc. are a few examples. Can we 
>> keep the discussion in the same group please. Thanks a lot.
>

---

From: Gene Golovinsky <[email-masked]>
Date: Thu, 8 Apr 2010 14:17:05 -0500

I am sure that different people are interested in aspects of Cloud technologies. Much as there are multiple areas of interest for the Internet.
But precisely because the conversation is still in its infancy it is probably useful to keep it in the same context at least for now.

In the same time to avoid talking past each other and to make the scope more manageable, should we pick a topic or two?
This way conversation will be more focused.

Can I suggest logging and auditing? Like I pointed out before, lack of consistent logging and auditing facilities prevents people requiring compliance from adopting cloud technologies.

--Gene

of course there are and will be many workitems within the theme of cloud-based systems, services, inter-cloud system, and so on.  Cloud-based storage, cloud-based mobile-data backup service,  cloud-based network service in order to maintain service continuity, disaster-tolerant communications, etc. are a few examples. Can we keep the discussion in the same group please. Thanks a lot.
On Thu, Apr 8, 2010 at 11:21 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
I am looking at a very different angle of the "Cloud". Rather than the "IT functions as a service", I am looking at Virtual Network Services and Storage Services which can be offered by Service Providers.
Are there anyone else interested in this area? Maybe we should form a separate discussion group.

Linda Dunbar

________________________________
From: Gene Golovinsky [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, April 08, 2010 7:37 AM
To: Linda Dunbar; [email-masked]<mailto:[email-masked]>; 'Mark Webb'; [email-masked]<mailto:[email-masked]>

--Gene

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Linda Dunbar
Sent: Wednesday, April 07, 2010 12:16 PM
To: [email-masked]<mailto:[email-masked]>; 'Mark Webb'; [email-masked]<mailto:[email-masked]>
Subject: Re: [clouds] Scope of the Cloud is too big

Linda

From: Carl Williams [mailto:[email-masked]<mailto:[email-masked]>]

Carl

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Linda Dunbar
Sent: Wednesday, April 07, 2010 11:48 AM
To: 'Mark Webb'; [email-masked]<mailto:[email-masked]>
Subject: [clouds] Scope of the Cloud is too big

Linda Dunbar

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mark Webb

Mark Webb

--Gene

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 07, 2010 9:48 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [clouds] Use cases

Peter

--
Peter Saint-Andre
https://stpeter.im/

--
Best Regards.

---

From: Mark Webb <[email-masked]>
Date: Thu, 8 Apr 2010 15:29:59 -0400

Not trying to be in disagreement,  However, the job to be done is a  
still experiencing a high rate of change IMO.

So, what of the broad set of things possible within the scope of  
cloud, would you like to log and audit?

Alternately, I think what we are seeing people discuss is CSA-like  
best practices & SAS-70 assurances from providers acting as a  
substitute for audit for some time until services are solidified.

Mark

On Apr 8, 2010, at 3:17 PM, Gene Golovinsky wrote:

> I am sure that different people are interested in aspects of Cloud  
> technologies. Much as there are multiple areas of interest for the  
> Internet.
> But precisely because the conversation is still in its infancy it is  
> probably useful to keep it in the same context at least for now.
>
> In the same time to avoid talking past each other and to make the  
> scope more manageable, should we pick a topic or two?
> Can I suggest logging and auditing? Like I pointed out before, lack  
> of consistent logging and auditing facilities prevents people  
> requiring compliance from adopting cloud technologies.
>
> --Gene
>
>
>
>
>
> I am looking at a very different angle of the “Cloud”. Rather than  
> the “IT functions as a service”, I am looking at Virtual Network  
> Services and Storage Services which can be offered by Service  
> Providers.
> © 2010 Bhumip Khasnabish. Do not view, print, forward, and save the  
> content of this email if you are not the intended recipient of the  
> communiqué.

---

From: "Stephen Fleece" <[email-masked]>
Date: Thu, 8 Apr 2010 12:33:35 -0700

Mark, thanks for bringing this opportunity for up.  There's plenty of
work to do in best practices and standards for all of us, but we need to
be smart about it so we can make the most efficient and positive impact
on industry and society.

Stephen Fleece

TM Forum

From: Mark Carlson [mailto:[email-masked]] 
Sent: Thursday, April 08, 2010 3:08 PM
To: Melinda Shore
Cc: [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

We are already coordinating cloud work from the various
SDOs there, and IETF is represented by Dan Romascanu
<http://www.ietf.org/iesg/bio/dan-romascanu.html> .

-- mark

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 08 Apr 2010 14:53:42 -0500

For a group discussing “logging and auditing” aspects of Cloud, it should
have a separate name for the group (definitely not “Cloud”). 

Having a name being “cloud”, you will just invite all other discussions
which are not related to “Logging and Auditing”. 

Linda 

  _____  

From: Gene Golovinsky [mailto:[email-masked]] 
Sent: Thursday, April 08, 2010 2:17 PM
To: Bhumip Khasnabish; Linda Dunbar
Cc: [email-masked]; Mark Webb; [email-masked]
Subject: RE: [clouds] Scope of the Cloud is too big

I am sure that different people are interested in aspects of Cloud
technologies. Much as there are multiple areas of interest for the Internet.

In the same time to avoid talking past each other and to make the scope more
manageable, should we pick a topic or two?

Can I suggest logging and auditing? Like I pointed out before, lack of
consistent logging and auditing facilities prevents people requiring
compliance from adopting cloud technologies. 

--Gene

 

Linda Dunbar

  _____  

 

 

--Gene

Linda 

  _____  

Carl

Linda Dunbar 

  _____  

Mark Webb

--Gene

-----Original Message-----

Peter

--
Peter Saint-Andre
https://stpeter.im/

-- 
Best Regards.

---

From: Sam Johnston <[email-masked]>
Date: Thu, 8 Apr 2010 23:03:22 +0200

Mark,

I should perhaps have been more specific. I'm well aware of CDMI but am
looking for something simple and lightweight, somewhere between HTTP and
WebDAV rather than a HTTP-based SMB/CIFS. There's certainly applications for
the latter but it wasn't what I had in mind.

Sam

On 8 April 2010 19:39, Mark Carlson <[email-masked]> wrote:

>  Re. your comment on pursuing “storage API like Amazon's S3” in IETF. Why
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Sam Johnston
> [email-masked]://www.ietf.org/mailman/listinfo/clouds
>
>

---

From: Mark Carlson <[email-masked]>
Date: Thu, 08 Apr 2010 15:11:20 -0600

CDMI objects can be accessed through plain old HTTP at their URL
(subject to standard access controls) and can be POSTed without having
to code to CDMI semantics. No "mount" is needed. CDMI is shrink to
fit, so if this is all you offer, you can just put up a cloud that does 
these
functions.

-- mark

On 4/8/10 3:03 PM, Sam Johnston wrote:
> Mark,
>
> I should perhaps have been more specific. I'm well aware of CDMI but 
> am looking for something simple and lightweight, somewhere between 
> HTTP and WebDAV rather than a HTTP-based SMB/CIFS. There's certainly 
> applications for the latter but it wasn't what I had in mind.
>
> Sam
>
> On 8 April 2010 19:39, Mark Carlson <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>>     Re. your comment on pursuing "storage API like Amazon's S3" in
>>     IETF. Why that is needed when storage networking SDO SNIA is
>>     working on one (SNIA CDMI)?
>>
>>     --Masum
>>
>>     http://home.comcast.net/~masumz/ <http://home.comcast.net/%7Emasumz/>
>>
>>     *From:* [email-masked] <mailto:[email-masked]>
>>     [mailto:[email-masked]] *On Behalf Of *Sam Johnston
>>     *Cc:* [email-masked] <mailto:[email-masked]>
>>     You're definitely not alone in thinking this would be a worthy
>>     topic for IETF and as co-conspirator (along with Cisco's Chris
>>     Hoff) and author of the existing CloudAudit draft spec I'd love
>>     to see IETF people starting to work with the group. We have
>>     weekly calls on Monday at 10am PST/1pm EST and discuss in the
>>     cloudaudit Google Group[1]. The goal for v1 is to create a
>>     trivial HTTP-based interface that can be implemented by uploading
>>     files rather than coding. Similarly, OGF's OCCI working group has
>>     produced a number of Internet-Drafts that could be picked up by IETF.
>>
>>     Another area that I think would be very interesting for IETF to
>>     take on (moreso than virtualisation management) is a simple,
>>     HTTP-based storage API like Amazon's S3 - only without the
>>     potential patent problems[2]. I believe that HTTP already takes
>>     care of many/most of the issues (e.g. authentication, encryption,
>>     ranged GETs, etc.) and IETF has proven experience in the area
>>     (WebDAV).
>>
>>     Another issue I ran into while writing cush[3] was how to
>>     remotely instruct servers to migrate (live?) resources - for
>>     example, moving a virtual machine, database, etc. from one
>>     location to another using a mobile device on a 3G connection. I
>>     believe WebDAV's COPY and MOVE verbs are a good start (this is
>>     what we're using for OCCI) but they could be reviewed and
>>     possibly promoted for more generic application.
>>
>>     Considering that most of these APIs (at least the ones I'm
>>     involved in) are trying to be as close as possible to the
>>     "uniform interface" of HTTP, I believe there's benefit to be had
>>     in reviewing the relevant RFCs with these new applications in
>>     mind. For example, while HTTP has a perfectly good metadata
>>     channel (headers) and thus obviates the need for envelope formats
>>     (Atom, SOAP, etc), it lacks the ability to link, annotate and
>>     categorise resources. It also has some internationalisation
>>     problems (e.g. ASCII) and inefficient serialisation (e.g. SPDY).
>>     HTTP 1.1 has served us well for many years but perhaps it's time
>>     to start thinking about what HTTP 2.0 might look like?
>>
>>     Sam
>>
>>     -- 
>>     *Sam Johnston*
>>
>>     When and if the proposal will be submitted there is still going
>>     to be a lot of work to make it a standard.
>>
>>     At least two approaches are possible. 1. Do nothing while waiting
>>     for Cloud Audit proposal. 2. Start working with the group.
>>
>>     Considering how fast Cloud technologies have been evolving and
>>     how critical Security is for the adoption of it I am for #2.
>>
>>     --Gene
>>
>>     *Cc:* Linda Dunbar; [email-masked]
>>     <mailto:[email-masked]>; Gene Golovinsky
>>
>>
>>     The industry has not settled on a small set of services
>>     definitions of what "cloud" is. So, how does one audit SaaS,
>>     PaaS?  When the services offered in that space are so different?
>>      IaaS is the most mature and perhaps the lcd of cloud.
>>
>>     something that IETF can specify?  OK that was rhetorical.  My
>>     point is, the real opportunity is to look for elements that are
>>     mature enough to have some problem to be solved defined.  Then
>>     ensure you are not duplicating what other SDO or Forum are
>>     already working on.
>>
>>     Mark Webb
>>
>>
>>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 9 Apr 2010 10:40:30 +0800

07CACFDBD4D9422C7D7E [email-masked]> <[email-masked]>
Subject: Re: Re: [clouds] Scope of the Cloud is too big
Message-ID: <[email-masked]>
X-mailer: Foxmail 6, 2, 103, 20 [cn]
Mime-Version: 1.0
Content-Type: multipart/alternative;
	boundary="=====003_Dragon318057003331_====="

This is a multi-part message in MIME format.

--=====003_Dragon318057003331_=====
Content-Type: text/plain;
	charset="gb2312"
Content-Transfer-Encoding: base64

--=====003_Dragon318057003331_=====
Content-Type: text/html;
	charset="gb2312"
Content-Transfer-Encoding: base64

--=====003_Dragon318057003331_=====--

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 9 Apr 2010 14:09:58 +0800

28AD5F6B83DA9709D5C0 [email-masked]><[email-masked]> <[email-masked]>
Subject: Re: Re: [clouds] Scope of the Cloud is too big
Message-ID: <[email-masked]>
X-mailer: Foxmail 6, 2, 103, 20 [cn]
Mime-Version: 1.0
Content-Type: multipart/alternative;
	boundary="=====003_Dragon802266145077_====="

--=====003_Dragon802266145077_=====
Content-Type: text/plain;
	charset="gb2312"
Content-Transfer-Encoding: base64

--=====003_Dragon802266145077_=====
Content-Type: text/html;
	charset="gb2312"
Content-Transfer-Encoding: base64

--=====003_Dragon802266145077_=====--

---

From: "Monique Morrow (mmorrow)" <[email-masked]>
Date: Fri, 9 Apr 2010 10:18:14 +0200

Bhumip,

 Having attended-participated at the BoF and following this thread, some of my suggestions moving forward:

1. Clear problem statement; and specifically what corresponding protocol work should the IETF develop and or reuse;

2. To [1] goes an SDO/Forum gap analysis [if not done already] as to assure there is unnecessary replication of work and/or potential of SDO/forum clash  output = scope

3. Identification of use case examples;

4. Finally,  is there any potential for interlock with work being kicked off at the IRTF Virtual Networks Research Group WG?

Best regards

Monique

-----Original Message-----
From: [email-masked] on behalf of Bhumip Khasnabish
Sent: Thu 4/8/2010 9:07 AM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

On Thu, Apr 8, 2010 at 11:21 AM, Linda Dunbar <[email-masked]> wrote:

> "IT functions as a service", I am looking at Virtual Network Services and

-- 
Best Regards.

---

From: Ning Zong <[email-masked]>
Date: Fri, 09 Apr 2010 16:43:41 +0800

I Agree with Monique.

So far, I couldn’t see any concrete problems need to be solved and why IETF
is the right place for such study. IMO, we could not move forward without
getting agreement on these basic issues.

Clear Problem Statement and Gap Analysis on both SDO-wide and protocol-wide
are definitely required at this stage.

My 2 cents.

BR,

Ning Zong

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Monique Morrow (mmorrow)
Sent: Friday, April 09, 2010 4:18 PM
To: Bhumip Khasnabish; Linda Dunbar
Cc: [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

Bhumip,

 Having attended-participated at the BoF and following this thread, some of
my suggestions moving forward:

1. Clear problem statement; and specifically what corresponding protocol
work should the IETF develop and or reuse;

2. To [1] goes an SDO/Forum gap analysis [if not done already] as to assure
there is unnecessary replication of work and/or potential of SDO/forum clash
output = scope

4. Finally,  is there any potential for interlock with work being kicked off
at the IRTF Virtual Networks Research Group WG?

Best regards

Monique

-----Original Message-----
From: [email-masked] on behalf of Bhumip Khasnabish
Sent: Thu 4/8/2010 9:07 AM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

> separate discussion group.
data
> different subjects. Very hard to get the discussion moving forward.
was
> I attended the CLOUD's bar BOF. I don't think it is appropriate for IETF
to
> p     Infrastructure-as-a-Service
(IaaS<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201
_gci1358983,00.html>
> ),
> p     Platform-as-a-Service
(PaaS)<http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci1
332892,00.html>and
> p     Software-as-a-Service
(SaaS<http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201
_gci1170781,00.html>
> )
that
> From: [email-masked]
[mailto:[email-masked]<[email-masked]>]

--
Best Regards.

---

From: "Sun Shaoling" <[email-masked]>
Date: Fri, 9 Apr 2010 18:05:23 +0800

I fully agree with that. I think we shouldn't reinvent APIs or formats defined by other SDOs unless we can prove those are good enough.

2010-04-09 

Sun Shaoling 

发件人： Ning Zong 
发送时间： 2010-04-09  17:02:17 
收件人： 'Monique Morrow (mmorrow)'; 'Bhumip Khasnabish'; 'Linda Dunbar' 
抄送： [email-masked] 
主题： Re: [clouds] Scope of the Cloud is too big 
 
I Agree with Monique.
 
So far, I couldn’t see any concrete problems need to be solved and why IETF is the right place for such study. IMO, we could not move forward without getting agreement on these basic issues.
Clear Problem Statement and Gap Analysis on both SDO-wide and protocol-wide are definitely required at this stage.
 
My 2 cents.
 
BR,
Ning Zong

From: [email-masked] [mailto:[email-masked]] On Behalf Of Monique Morrow (mmorrow)
Sent: Friday, April 09, 2010 4:18 PM
To: Bhumip Khasnabish; Linda Dunbar
Cc: [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big
 
Bhumip,

Best regards

Monique

-----Original Message-----
From: [email-masked] on behalf of Bhumip Khasnabish
Sent: Thu 4/8/2010 9:07 AM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [clouds] Scope of the Cloud is too big

--
Best Regards.

---

From: Bhumip Khasnabish <[email-masked]>
Date: Fri, 9 Apr 2010 06:58:32 -0400

There are both client side and server side API requirements, and we would
need both for effective use and rolling out of cloud-based services.

On Fri, Apr 9, 2010 at 6:05 AM, Sun Shaoling <[email-masked]>wrote:

>  I fully agree with that. I think we shouldn't reinvent APIs or formats
> defined by other SDOs unless we can prove those are good enough.
>
>
> 2010-04-09
>  *发件人：* Ning Zong
> *发送时间：* 2010-04-09  17:02:17
> *收件人：* 'Monique Morrow (mmorrow)'; 'Bhumip Khasnabish'; 'Linda Dunbar'
> *抄送：* [email-masked]
> *主题：* Re: [clouds] Scope of the Cloud is too big
>
> I Agree with Monique.
>
>
>
> So far, I couldn't see any concrete problems need to be solved and why IETF
> Behalf Of *Monique Morrow (mmorrow)
> *Sent:* Friday, April 09, 2010 4:18 PM
> *To:* Bhumip Khasnabish; Linda Dunbar
> *Cc:* [email-masked]
> there is unnecessary replication of work and/or potential of SDO/forum
> clash  output = scope
>
> 4. Finally,  is there any potential for interlock with work being kicked
> off at the IRTF Virtual Networks Research Group WG?
>
> Best regards
>
> Monique
>
> > *From:* Gene Golovinsky [mailto:[email-masked]<[email-masked]>
> ]
> *On
> > *From:* Carl Williams [mailto:[email-masked] <[email-masked]>]
> *On
> > p     Infrastructure-as-a-Service (IaaS<
> http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1358983,00.html
> >
> > ),
> >
> > p     Platform-as-a-Service (PaaS)<
> http://searchcloudcomputing.techtarget.com/sDefinition/0,,sid201_gci1332892,00.html
> >and
> >
> > p     Software-as-a-Service (SaaS<
> http://searchcloudcomputing.techtarget.com/sDefinition/0,290660,sid201_gci1170781,00.html
> >
> > )
> >
> >
> >
> *On
> in
> > From: [email-masked] [mailto:[email-masked]<[email-masked]>
> <[email-masked]>]
> (c) 2010 Bhumip Khasnabish. Do not view, print, forward, and save the content

-- 
Best Regards.

(c) 2010 Bhumip Khasnabish. Do not view, print, forward, and save the content
of this email if you are not the intended recipient of the communiqué.

---

From: Bhumip Khasnabish <[email-masked]>
Date: Fri, 9 Apr 2010 07:03:54 -0400

Thanks Ning. We are seeing wide-spread need to find effective and
implementable answers to these questions in Clouds environment.
We'll certainly add this as one work item.

On Thu, Apr 8, 2010 at 12:08 PM, So, Ning <[email-masked]>wrote:

> computing, and so on.  How does this new type of services interwork with the
> existing MPLS-based network technologies?  For example, how does these
> service interwork with today’s L2 and L3 VPN based-services?  How is the
> virtual separation of the traffic/data/queries maintained end-to-end for the
> security conscious customers?
>
>
>
> Ning So
>
> Lead Engineer
>
> *Sent:* Thursday, April 08, 2010 10:22 AM
> *To:* 'Gene Golovinsky'; [email-masked]; 'Mark Webb'; [email-masked]
>

-- 
Best Regards.

---

From: Bhumip Khasnabish <[email-masked]>
Date: Fri, 9 Apr 2010 07:15:21 -0400

Thanks Masum. We'll certainly add this as a work item for further
discussion. I had an opportunity to talk about this with Monique after the
Clouds bar BoF during IETF-77 as well.

On Thu, Apr 8, 2010 at 1:29 PM, Masum Hasan (masum) <[email-masked]> wrote:

> “virtual network services for Cloud”),  is a good idea to pursue in IETF (so
> far the focus is lacking).
>
>
>
>
>
> --Masum
>
>
>
> *Sent:* Thursday, April 08, 2010 8:22 AM
> *To:* 'Gene Golovinsky'; [email-masked]; Mark Webb (mwebb);
> [email-masked]
>

-- 
Best Regards.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 11 Apr 2010 11:54:05 +0200

Mark,
 
As a matter of clarification (which I repeatedly made in our conference
calls) -  I am not 'representing' the IETF in any formal manner in this
activity. I am participating as an individual contributor. Of course, as
an IETF participant I am sharing information related to the IETF
activities that I am aware about.
 
Dan

	From: Mark Carlson [mailto:[email-masked]] 
	Sent: Thursday, April 08, 2010 10:08 PM
	To: Melinda Shore
	Cc: Bhumip Khasnabish; [email-masked]; Romascanu, Dan (Dan)
	Subject: Re: [clouds] Scope of the Cloud is too big

	
	
	-- mark

			of course there are and will be many workitems
within the theme of cloud-based systems, services, inter-cloud system,
and so on.  Cloud-based storage, cloud-based mobile-data backup service,
cloud-based network service in order to maintain service continuity,
disaster-tolerant communications, etc. are a few examples. Can we keep
the discussion in the same group please. Thanks a lot. 

		I think it might be worthwhile for people who are
fishing 
		for work to do to sit down and take a look at the
charters 
		for some established working groups, with a particular
eye 
		to how the work is scoped, how the deliverables are 
		defined, and so on.  I think it's kind of weird that 
		people want to work on something but they aren't sure
what - 
		usually it's an idea or ideas that drive work, or at
least 
		some problem that's got at least some wee little bit of 
		definition - but as long as people seem intent on taking

		this approach it might help to have some sense of what 
		this flailing about ought to produce.  Work in the IETF
is 
		much more narrowly-focused and precisely-scoped than is 
		the norm in other standards bodies and/or industry
consortia. 
		
		Melinda