Subject: [clouds] IETF-78 Cloud Standards BOF

From: "Chris Fenton \(Iridescent\)" <[email-masked]>
Date: Wed, 28 Jul 2010 13:02:27 +0100

WARNING: contains banned part

Subject: [clouds] IETF-78 Cloud Standards BOF
From: "Chris Fenton \(Iridescent\)" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Date: Wed, 28 Jul 2010 13:02:27 +0100

Hi all,

Thanks for interesting presentations.  To me the cloud without common or
option for a standardised interface/api is not a cloud its a set of service
platforms. We need to move forwards define the topic areas for
standardisation but essentially its all the elements you have for
subscribers to access a data platform from identity thru transport. Then
there are the service management aspects and the service provider
capabilities who want logs session or usage records and finally the
platform owner would need some or at least be able to support the above....

So possible topic areas for definition are :

Service user 
- access 
- transport
- service discovery maybe

Service provider
- Service management (also VM management - movement etc...)
- Subscription management
- charging billing etc...
- basically these are all FCAPS aspects Fault, Configuration, Accounting,
Performance, Security

Platform provider - not so sure what standards apply so long as the
platform itself provides the APis the boxes can be anything 
- Management 
- also FCAPS

CJ

Mr Chris Fenton
+44 7802 221 541
[email-masked]
Skype: chrisfentouk
http://www.iridescentnetworks.com

---

From: "Monique Morrow (mmorrow)" <[email-masked]>
Date: Wed, 28 Jul 2010 14:31:06 +0200

Chris

Do you proposed perhaps a framework draft as a starting point?

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF
 
Hi all,

Thanks for interesting presentations.  To me the cloud without common or option for a standardised interface/api is not a cloud its a set of service platforms. We need to move forwards define the topic areas for standardisation but essentially its all the elements you have for subscribers to access a data platform from identity thru transport. Then there are the service management aspects and the service provider capabilities who want logs session or usage records and finally the platform owner would need some or at least be able to support the above....

Service user 
- access 
- transport

Service provider
- Service management (also VM management - movement etc...)
- Subscription management
- charging billing etc...
- basically these are all FCAPS aspects Fault, Configuration, Accounting, Performance, Security

Platform provider - not so sure what standards apply so long as the platform itself provides the APis the boxes can be anything 
- Management 
- also FCAPS

CJ

Mr Chris Fenton
+44 7802 221 541

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 28 Jul 2010 08:20:07 -0500

It is very nice that Bhumip to create a bar BOF for interested parties to
present different aspects of Cloud.  As we can see that API and Cloud log
are very different from dynamic resource management, which is also different
from Private VPN. They need different expertise. People in Service layer may
think the network wiring too detail and trivial. People worrying about
network details view API as software features which can be application
specific. 

Since ITU-T already starts the Cloud initiative, why not let ITU-T defines
the general framework for Cloud and come to IETF for specific problems?

Linda Dunbar 

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Monique Morrow (mmorrow)
Sent: Wednesday, July 28, 2010 7:31 AM
To: Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: Re: [clouds] IETF-78 Cloud Standards BOF

Chris

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF

Hi all,

Thanks for interesting presentations.  To me the cloud without common or
option for a standardised interface/api is not a cloud its a set of service
platforms. We need to move forwards define the topic areas for
standardisation but essentially its all the elements you have for
subscribers to access a data platform from identity thru transport. Then
there are the service management aspects and the service provider
capabilities who want logs session or usage records and finally the platform
owner would need some or at least be able to support the above....

Service user
- access
- transport

Service provider

Platform provider - not so sure what standards apply so long as the platform
itself provides the APis the boxes can be anything
- Management
- also FCAPS

CJ

Mr Chris Fenton
+44 7802 221 541

---

From: "Monique Morrow (mmorrow)" <[email-masked]>
Date: Wed, 28 Jul 2010 16:37:07 +0200

Linda

That is certainly an approach -- in addition to leveraging and developing IETF-based protocols as discussed today in some of the use cases presented.

Best -monique

-----Original Message-----
From: Linda Dunbar [mailto:[email-masked]]
Sent: Wed 7/28/2010 6:20 AM
To: Monique Morrow (mmorrow); 'Chris Fenton (Iridescent)'; [email-masked]
Cc: [email-masked]; 'Bhumip Khasnabish'
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Linda Dunbar 

  _____  

Chris

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF

Hi all,

Service user
- access
- transport

Service provider

CJ

Mr Chris Fenton
+44 7802 221 541

---

From: "Natale, Bob" <[email-masked]>
Date: Wed, 28 Jul 2010 12:13:27 -0400

Hi,

I think Linda's idea of having a single SDO - and the ITU-T works fine for me in this case - is a good one.

If the IETF endorses it, I could convey that message to the TM Forum Cloud Services Initiative as well.

Each such SDO that agrees with the approach would send a liaison message to the ITU-T Cloud group expressing agreement, stating the focus area(s) best assigned to that SDO (e.g., the IETF-based protocols mentioned by Monique below), identifying any scheduled near-term (1 yr or less?) deliverables in those areas, and soliciting future "assignments" (to be negotiated via open collaboration) from the ITU-T.  With the stipulation that the ITU-T Cloud effort must be open in terms of meetings, documents, and inputs at a minimum.  Or something like that...?

Cheers,
BobN

From: [email-masked] [mailto:[email-masked]] On Behalf Of Monique Morrow (mmorrow)
Sent: Wednesday, July 28, 2010 10:37 AM
To: Linda Dunbar; Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: Re: [clouds] IETF-78 Cloud Standards BOF

Linda

Best -monique

-----Original Message-----
From: Linda Dunbar [mailto:[email-masked]]
Sent: Wed 7/28/2010 6:20 AM
To: Monique Morrow (mmorrow); 'Chris Fenton (Iridescent)'; [email-masked]
Cc: [email-masked]; 'Bhumip Khasnabish'
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Linda Dunbar

  _____

Chris

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF

Hi all,

Service user
- access
- transport

Service provider

CJ

Mr Chris Fenton
+44 7802 221 541

---

From: "Edmonds, AndrewX" <[email-masked]>
Date: Wed, 28 Jul 2010 17:23:38 +0100

Perhaps the cloud-standards.org forum could be a useful "rally" point and compliment this idea? I believe they hold bi-weekly co-ordination-type confcalls.

Andy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Natale, Bob
Sent: Wednesday, July 28, 2010 7:13 PM
To: Monique Morrow (mmorrow); Linda Dunbar; Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: Re: [clouds] IETF-78 Cloud Standards BOF

Hi,

Cheers,
BobN

Linda

Best -monique

-----Original Message-----
From: Linda Dunbar [mailto:[email-masked]]
Sent: Wed 7/28/2010 6:20 AM
To: Monique Morrow (mmorrow); 'Chris Fenton (Iridescent)'; [email-masked]
Cc: [email-masked]; 'Bhumip Khasnabish'
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Linda Dunbar

  _____

Chris

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF

Hi all,

Service user
- access
- transport

Service provider

CJ

Mr Chris Fenton
+44 7802 221 541

-------------------------------------------------------------
Intel Ireland Limited (Branch)
Collinstown Industrial Park, Leixlip, County Kildare, Ireland
Registered Number: E902934

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

---

From: "Monique Morrow (mmorrow)" <[email-masked]>
Date: Wed, 28 Jul 2010 19:02:37 +0200

Bob,

With ITU-T Focus Group Cloud Computing Vice Chair hat on, this suggestion is pragmatic.

In the meantime, as IETF contributor, want to additionally focus on centering in on our use cases-scenarios- applicability of IETF-developed protocols and/or identification of protocols that should be developed within the IETF accordingly.

With warm regards

Monique

PS BoF continues tomorrow!

-----Original Message-----
From: Natale, Bob [mailto:[email-masked]]
Sent: Wed 7/28/2010 9:13 AM
To: Monique Morrow (mmorrow); Linda Dunbar; Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: RE: [clouds] IETF-78 Cloud Standards BOF
 
Hi,

Cheers,
BobN

Linda

Best -monique

-----Original Message-----
From: Linda Dunbar [mailto:[email-masked]]
Sent: Wed 7/28/2010 6:20 AM
To: Monique Morrow (mmorrow); 'Chris Fenton (Iridescent)'; [email-masked]
Cc: [email-masked]; 'Bhumip Khasnabish'
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Linda Dunbar

  _____

Chris

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF

Hi all,

Service user
- access
- transport

Service provider

CJ

Mr Chris Fenton
+44 7802 221 541

---

From: "Natale, Bob" <[email-masked]>
Date: Wed, 28 Jul 2010 13:11:13 -0400

Hi Monique,

I fully agree.  In fact, I meant my first sentence below to read "...of having a single SDO *coordinate* efforts...." ... did *not* mean to imply that there should be only a single SDO in the cloud space, for sure!  Not meant to stifle individual SDO initiative, innovation, or momentum ... just introduce some rational division of labor and coordination of effort/deliverables at the collective SDO level.

Cheers,
BobN

From: Monique Morrow (mmorrow) [mailto:[email-masked]]
Sent: Wednesday, July 28, 2010 1:03 PM
To: Natale, Bob; Linda Dunbar; Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Bob,

With warm regards

Monique

-----Original Message-----
From: Natale, Bob [mailto:[email-masked]]
Sent: Wed 7/28/2010 9:13 AM
To: Monique Morrow (mmorrow); Linda Dunbar; Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Hi,

Cheers,
BobN

Linda

Best -monique

-----Original Message-----
From: Linda Dunbar [mailto:[email-masked]]
Sent: Wed 7/28/2010 6:20 AM
To: Monique Morrow (mmorrow); 'Chris Fenton (Iridescent)'; [email-masked]
Cc: [email-masked]; 'Bhumip Khasnabish'
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Linda Dunbar

  _____

Chris

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF

Hi all,

Service user
- access
- transport

Service provider

CJ

Mr Chris Fenton
+44 7802 221 541

---

From: Sam Johnston <[email-masked]>
Date: Wed, 28 Jul 2010 20:43:14 +0200

Bob/Monique/Linda,

I personally am very sceptical of (and would vigorously oppose) any attempt
to *coordinate* standards in the cloud space and echo Andy Edmonds in
pointing at cloud-standards.org (which already purports to do so). I am
however fully supportive of *collaboration* between standards orgs and
believe cloud-standards.org is as good a (neutral) venue as any, having
participated in a number of their calls. I also don't believe a group exists
(or even could exist) which would be able to objectively assess the cloud
space as each views the problem from a completely different perspective - in
this case the underlying telecommunications infrastructure while one could
argue cloud is more user-centric. Nevertheless the activity may prove useful
for ITU-T's internal use.

What was abundantly clear at today's bar bof is that there are a number of
areas where the IETF can deliver significant value now and we should focus
on these rather than participating in the landrush going on around us - as I
said in my presentation, there are currently no standards in cloud, only
specifications.

Getting back to Chris's original question, I don't think there's much point
in spending any time creating yet another model for cloud, however
enumerating specific potential work areas (e.g. CloudAudit, CloudLog, HTTP
enhancements, ARP222, etc.) would be time well spent... particularly if it
were to result in drafts as is the case for these examples.

Cheers,

Sam

On 28 July 2010 19:11, Natale, Bob <[email-masked]> wrote:

>  Hi Monique,
>
>
>
> I fully agree.  In fact, I meant my first sentence below to read "…of
> having a single SDO **coordinate** efforts…." … did **not** mean to imply
> that there should be only a single SDO in the cloud space, for sure!  Not
> meant to stifle individual SDO initiative, innovation, or momentum … just
> introduce some rational division of labor and coordination of
> effort/deliverables at the collective SDO level.
>
>
>
> Cheers,
>
> BobN
>
>
>
> *From:* Monique Morrow (mmorrow) [mailto:[email-masked]]
> *Sent:* Wednesday, July 28, 2010 1:03 PM
> *To:* Natale, Bob; Linda Dunbar; Chris Fenton (Iridescent);
> [email-masked]
>
> *Cc:* [email-masked]
> *Subject:* RE: [clouds] IETF-78 Cloud Standards BOF
>
>
>
> Bob,
>
> In the meantime, as IETF contributor, want to additionally focus on
> centering in on our use cases-scenarios- applicability of IETF-developed
> protocols and/or identification of protocols that should be developed within
> the IETF accordingly.
>
> With warm regards
>
> Monique
>
> From: Natale, Bob [mailto:[email-masked] <[email-masked]>]
> Each such SDO that agrees with the approach would send a liaison message to
> the ITU-T Cloud group expressing agreement, stating the focus area(s) best
> assigned to that SDO (e.g., the IETF-based protocols mentioned by Monique
> below), identifying any scheduled near-term (1 yr or less?) deliverables in
> those areas, and soliciting future "assignments" (to be negotiated via open
> collaboration) from the ITU-T.  With the stipulation that the ITU-T Cloud
> effort must be open in terms of meetings, documents, and inputs at a
> minimum.  Or something like that...?
>
> Cheers,
> BobN
>
> From: [email-masked] [mailto:[email-masked]<[email-masked]>]
> On Behalf Of Monique Morrow (mmorrow)
> That is certainly an approach -- in addition to leveraging and developing
> IETF-based protocols as discussed today in some of the use cases presented.
>
> Best -monique
>
>
>
> From: Linda Dunbar [mailto:[email-masked] <[email-masked]>]
> From: [email-masked] [mailto:[email-masked]<[email-masked]>]
> On Behalf Of
> Monique Morrow (mmorrow)
> From: Chris Fenton (Iridescent) [mailto:[email-masked]<[email-masked]>
> ]
> platform
> platform
> _______________________________________________
> clouds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clouds
>
>

---

From: "Monique Morrow (mmorrow)" <[email-masked]>
Date: Wed, 28 Jul 2010 22:08:08 +0200

Hi Bob,

Thanks for that clarification [sigh of relief]!

Monique

-----Original Message-----
From: Natale, Bob [mailto:[email-masked]]
Sent: Wed 7/28/2010 10:11 AM
To: Monique Morrow (mmorrow); Linda Dunbar; Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: RE: [clouds] IETF-78 Cloud Standards BOF
 
Hi Monique,

Cheers,
BobN

Bob,

With warm regards

Monique

-----Original Message-----
From: Natale, Bob [mailto:[email-masked]]
Sent: Wed 7/28/2010 9:13 AM
To: Monique Morrow (mmorrow); Linda Dunbar; Chris Fenton (Iridescent); [email-masked]
Cc: [email-masked]
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Hi,

Cheers,
BobN

Linda

Best -monique

-----Original Message-----
From: Linda Dunbar [mailto:[email-masked]]
Sent: Wed 7/28/2010 6:20 AM
To: Monique Morrow (mmorrow); 'Chris Fenton (Iridescent)'; [email-masked]
Cc: [email-masked]; 'Bhumip Khasnabish'
Subject: RE: [clouds] IETF-78 Cloud Standards BOF

Linda Dunbar

  _____

Chris

Monique

-----Original Message-----
From: Chris Fenton (Iridescent) [mailto:[email-masked]]
Sent: Wed 7/28/2010 5:02 AM
To: [email-masked]
Cc: [email-masked]
Subject: [clouds] IETF-78 Cloud Standards BOF

Hi all,

Service user
- access
- transport

Service provider

CJ

Mr Chris Fenton
+44 7802 221 541

---

From: "Monique Morrow (mmorrow)" <[email-masked]>
Date: Wed, 28 Jul 2010 22:49:52 +0200

Sam,

Concur.

I would like to focus the discussion from üeber"coordination to what we can do in the IETF [my own concrete case study of issues included - draft in process]  in terms of what we can do moving forward,

See you tomorrow -

MM

-----Original Message-----
From: Sam Johnston [mailto:[email-masked]]
Sent: Wed 7/28/2010 11:43 AM
To: Natale, Bob
Cc: Monique Morrow (mmorrow); Linda Dunbar; Chris Fenton (Iridescent); [email-masked]; [email-masked]; Mark Carlson
Subject: Re: [clouds] IETF-78 Cloud Standards BOF
 
Bob/Monique/Linda,

Cheers,

Sam

On 28 July 2010 19:11, Natale, Bob <[email-masked]> wrote:

>  Hi Monique,
>
>
>
> I fully agree.  In fact, I meant my first sentence below to read ".of
> having a single SDO **coordinate** efforts.." . did **not** mean to imply
> meant to stifle individual SDO initiative, innovation, or momentum . just

---

From: guyingjie 00107907 <[email-masked]>
Date: Thu, 29 Jul 2010 17:21:56 +0800

Best Regards
Y.J. GU