Subject: Re: [clouds] A cloud ref. framework for your review and comments

From: T Sridhar <[email-masked]>
Date: Sun, 1 Aug 2010 15:29:09 -0700

Hi,

Chris Hoff (Cisco) has done quite a bit of work on the "ontology" of the
cloud. The link is at:

http://www.rationalsurvivability.com/blog/?s=ontology

Can we look at this in relation to the reference framework?

Thanks,
Sridhar

On Fri, Jul 30, 2010 at 3:37 AM, Bhumip Khasnabish <[email-masked]> wrote:

> Dear All,
>
> After the Clouds bar BoF yesterday, a few of us got together to work on
> developing a simple Cloud reference framework.
> Attached pls find the output of that discussion.
>
> We look forward to your constructive comments and suggestions to improve
> and finalize the ref. framework. Thanks  a lot.
>
> Best Regards.
> Bhumip
>
> Bhumip Khasnabish (Mobile:+001-781-752-8003, [email-masked])
>
>
>
> _______________________________________________
> clouds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clouds
>
>

---

From: "Natale, Bob" <[email-masked]>
Date: Sun, 1 Aug 2010 19:25:59 -0400

Hi Sam,

In the general case, I don't think it is accurate to say that [all] private clouds lack multi-tenancy - it's just that their tenant base is restricted relative to that of public clouds.  The tenant base for a private cloud might be multiple departments, divisions, or even multiple distinct corporations (all members of the same conglomerate, for example).  In some cases, those tenant bases will have legal, cultural, or logistical grounds that equate effective independence in this context.

Cheers,
BobN

From: [email-masked] [mailto:[email-masked]] On Behalf Of Sam Johnston
Sent: Saturday, July 31, 2010 5:33 AM
To: Paul Unbehagen
Cc: [email-masked]; Fargano, Michael
Subject: Re: [clouds] A cloud ref. framework for your review and comments

On 30 July 2010 20:20, Paul Unbehagen <[email-masked]<mailto:[email-masked]>> wrote:
Along that vein of thought the network components are just as important as more and more private clouds get built.

Again this is the tail wagging the dog (and assumes you accept the premise that "private" cloud is even cloud given it lacks multi-tenancy and therefore requires significant capex, engineering for peak loads, etc.). Once there is some sanity around emulating legacy (e.g. virtual machines) in the infrastructure space the focus will quickly shift to platforms (app runtimes, databases, queues, etc.). The sooner the better if you ask me.

For now let's keep it simple at the upper level and drill down where & when we need to.

Sam

---

From: Nathaniel Borenstein <[email-masked]>
Date: Sun, 1 Aug 2010 20:01:18 -0500

I missed the BoF, so please excuse me if this is clear to everyone but me, however...

What are we trying to accomplish?

Standards efforts tend to be most successful if there are clear goals in mind.  What I'm seeing is a bunch of people who are excited about the general idea of cloud standards, each with a few particular ideas in mind.  Things like reference architectures can be very useful in the context of a well-developed set of technologies and goals -- Dave Crocker's email architecture document comes to mind.  But they don't do much to help focus on goals in the way that is  almost a prerequisite to a successful WG.

So, I suggest that in the interest of getting somewhere, we might think about the kind of goals suitable for WG creation.  Examples of such goals might be:

-- Making X portable across cloud vendors, where X might be virtual machines, storage grids, email archives, etc.

-- Enhancing security of cloud services by doing Y, where Y might be enhancements to authentication, specification of best practices, etc.  

-- Standardizing interface Z,  where Z might be video streaming, VPN extensions, etc.

I think there are enough goals here for a dozen WG's, but probably not enough people.  Is there a goal or two that enough of us share to give us critical mass?

For my part, I'm most enthused about the first category of goals -- standards to ensure that users aren't locked in to a single vendor.   What are other folks enthused about?  -- Nathaniel

---

From: "Natale, Bob" <[email-masked]>
Date: Mon, 2 Aug 2010 01:41:23 -0400

Hi Nathaniel,

On the topic of avoiding cloud SP lock-in (portability of cloud applications):

- On the business front, the TM Forum Cloud Services Initiative is focusing on this topic, in large measure, and has formed the Enterprise Cloud Leadership Council (ECLC) to address it specifically.  (See http://www.tmforum.org/EnablingCloudServices/8006/home.html)

- On the technical front, the DMTF's Open Virtualization Format and other aspects of its Virtualization Management Initiative provide elements of a workable foundation ... not complete by a long shot, but good work to extend, in my judgment.  (http://www.dmtf.org/standards/mgmt/vman/)

Just noting two initiatives that a related IETF effort could draw on, in any of a variety of ways.

Cheers,
BobN

---

From: Sam Johnston <[email-masked]>
Date: Mon, 2 Aug 2010 08:24:48 +0200

On 2 August 2010 01:25, Natale, Bob <[email-masked]> wrote:

> In the general case, I don't think it is accurate to say that [all] private
> clouds lack multi-tenancy – it's just that their tenant base is restricted
> relative to that of public clouds.  The tenant base for a private cloud
> might be multiple departments, divisions, or even multiple distinct
> corporations (all members of the same conglomerate, for example).  In some
> cases, those tenant bases will have legal, cultural, or logistical grounds
> that equate effective independence in this context.

However you look at it you are significantly limiting the benefit of cloud
by limiting the size of the pool as you still have to engineer for peak
loads and carry 100% of the costs yourself, wasting valuable resources on
maintaining IT rather than applying it to business problems (the latter
being a differentiator, the former a handicap). This may be an improvement
over today's wasteful approach to IT but it's incremental and only applies
to the largest of enterprises and even then only those who implement top
down - many cloud pilots are departmental and therefore little more than the
evolution of virtualisation.

The question often comes up as to whether Amazon EC2 is a "private cloud"
from Amazon's point of view, but this is bogus as they do share the capex,
ops, etc. with many untrusted third parties. As such "community cloud"
(where a number of different organisations form a community to share
infrastructure) is a better emulation of "true" cloud computing than
"private cloud", but the benefits are still limited compared to a massive
multi-tenant infrastructure like that of Amazon, Google and Microsoft.

Anyway this argument is ongoing, unlikely to be resolved here (though the
market will work it out quickly enough) and tangential to the issue of
standards.

Sam

---

From: Sam Johnston <[email-masked]>
Date: Mon, 2 Aug 2010 12:19:49 +0200

Bob/Nathaniel,

At this stage we have proven that there is significant interest in cloud
computing within the IETF community - the bar bof was full and overflowing
into the corridor and many tactical opportunities for work have been
identified with a lot of work already having been done (e.g. Bhumip's SDO
survey, my CloudAudit and HTTP enhancement drafts, etc.). We now need to
find a sensible way forward and my preferred option is to get some runs on
the board by completing specific tasks, some of which have already been
identified. The metric ought to be a> participants willing to do the work
and b> implementors willing to implement it.

I specifically don't think that a top down approach is appropriate here
(e.g. developing a reference framework, prioritising areas for
standardisation, etc.) - groups trying (and failing) at this are a dime a
dozen. I'd also prefer to constrain the group by depth rather than scope -
cloud, like internet, is a very broad area and most topics already overlap
with existing areas/working groups (e.g. CloudLog building on syslog).
There's no point trying to create a mini-IETF within IETF.

As for the two identified below, I think it's telling that the TM Forum felt
the need to appoint a "*Vice President and Head of Digital Media,
Advertising & Cloud Computing Programs*" and consider OVF to be the single
biggest threat to portability in that it could very easily become the Word
DOC format of the cloud. In any case getting caught up in what others are
doing is not going to help us get anything done ourselves.

Sam

On 2 August 2010 07:41, Natale, Bob <[email-masked]> wrote:

> - On the business front, the TM Forum Cloud Services Initiative is focusing
> on this topic, in large measure, and has formed the Enterprise Cloud
> Leadership Council (ECLC) to address it specifically.  (See
> http://www.tmforum.org/EnablingCloudServices/8006/home.html)
>
> - On the technical front, the DMTF's Open Virtualization Format and other
> aspects of its Virtualization Management Initiative provide elements of a
> workable foundation ... not complete by a long shot, but good work to
> extend, in my judgment.  (http://www.dmtf.org/standards/mgmt/vman/)
>
> Standards efforts tend to be most successful if there are clear goals in
> mind.  What I'm seeing is a bunch of people who are excited about the
> general idea of cloud standards, each with a few particular ideas in mind.
>  Things like reference architectures can be very useful in the context of a
> well-developed set of technologies and goals -- Dave Crocker's email
> architecture document comes to mind.  But they don't do much to help focus
> on goals in the way that is  almost a prerequisite to a successful WG.
>
> So, I suggest that in the interest of getting somewhere, we might think
> about the kind of goals suitable for WG creation.  Examples of such goals
> might be:
>
> -- Making X portable across cloud vendors, where X might be virtual
> machines, storage grids, email archives, etc.
>
> -- Enhancing security of cloud services by doing Y, where Y might be
> enhancements to authentication, specification of best practices, etc.
>
> I think there are enough goals here for a dozen WG's, but probably not
> enough people.  Is there a goal or two that enough of us share to give us
> critical mass?
>
> For my part, I'm most enthused about the first category of goals --
> standards to ensure that users aren't locked in to a single vendor.   What
> are other folks enthused about?  -- Nathaniel
>
>

---

From: Gene Golovinsky <[email-masked]>
Date: Mon, 2 Aug 2010 08:40:48 -0500

Hi Nathaniel.

While lots of people are excited about general technology, several very concrete ideas were presented at the BoF.

It is true that Cloud is diverse, but some problem spaces are understood better that others.
Security and Interfaces are examples of those better understood areas.
If you look at the list of IDs committed for the next meeting, you will see just that.

Cheers.
--Gene

---

From: Paul Unbehagen <[email-masked]>
Date: Mon, 2 Aug 2010 12:21:11 -0600

Hey Sam,

I agree that the market will work it out and is already moving in this direction or else we wouldn't be having these discussions. I also agree with Bob that there are different semantics for private. 

I think most who attend a cloud bof also get the analogy to the public electric grid as a similar model for cost savings for IT, but in that analogy not every source of electric power is always from the public grid and for that matter where it is from a utility it's not the same public utility provider in different places or applications.  Which means as time goes on there will be several public and private cloud models.  So, it's not so much the tail wagging the dog as it's two different dogs that share a lot in common.   

Let's also be sure not to become too myopic and forget that not everyone will connect to a giant public cloud. There are and will be more private clouds in the market. As there is more to the decision of using the cloud than just economic such as legal, security, and proximity.

--
Paul

On Aug 2, 2010, at 12:24 AM, Sam Johnston <[email-masked]> wrote:

> In the general case, I don't think it is accurate to say that [all] private clouds lack multi-tenancy – it's just that their tenant base is restricted relative to that of public clouds.  The tenant base for a private cloud might be multiple departments, divisions, or even multiple distinct corporations (all members of the same conglomerate, for example).  In some cases, those tenant bases will have legal, cultural, or logistical grounds that equate effective independence in this context.
> 
> However you look at it you are significantly limiting the benefit of cloud by limiting the size of the pool as you still have to engineer for peak loads and carry 100% of the costs yourself, wasting valuable resources on maintaining IT rather than applying it to business problems (the latter being a differentiator, the former a handicap). This may be an improvement over today's wasteful approach to IT but it's incremental and only applies to the largest of enterprises and even then only those who implement top down - many cloud pilots are departmental and therefore little more than the evolution of virtualisation.
> 
> The question often comes up as to whether Amazon EC2 is a "private cloud" from Amazon's point of view, but this is bogus as they do share the capex, ops, etc. with many untrusted third parties. As such "community cloud" (where a number of different organisations form a community to share infrastructure) is a better emulation of "true" cloud computing than "private cloud", but the benefits are still limited compared to a massive multi-tenant infrastructure like that of Amazon, Google and Microsoft.
> 
> Anyway this argument is ongoing, unlikely to be resolved here (though the market will work it out quickly enough) and tangential to the issue of standards.
> 
> Sam
>

---

From: Sam Johnston <[email-masked]>
Date: Tue, 3 Aug 2010 08:34:08 +0200

On 2 August 2010 20:21, Paul Unbehagen <[email-masked]> wrote:

I think most who attend a cloud bof also get the analogy to the public
> electric grid as a similar model for cost savings for IT, but in that
> analogy not every source of electric power is always from the public grid
> and for that matter where it is from a utility it's not the same public
> utility provider in different places or applications.
>

Indeed people still use generators today - primarily for backup and off-grid
applications - but the quantity of electricity delivered by such systems is
negligible compared to that generated by large power stations (capable of
producing in the order of 1,000 megawatts *each*). I see no reason why the
same wouldn't happen in the IT industry now, 100 years later, and am quite
sure the generator industry at the time presented similar arguments in its
defense as we're seeing from the private cloud parade today.

Let's also be sure not to become too myopic and forget that not everyone
> will connect to a giant public cloud. There are and will be more private
> clouds in the market. As there is more to the decision of using the cloud
> than just economic such as legal, security, and proximity.
>

As people necessarily become more objective about these decisions I believe
market forces will ultimately win out. Server huggers are placing themselves
at a huge disadvantage to more agile "digital native" organisations who can
differentiate by spending resources on the application rather than
maintenance of IT.

In any case I believe this strip covers all the pertinent issues in adequate
detail: http://goo.gl/AaKB ;)

Sam