Subject: [codesprints] New datatracker release: v2.23

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 25 Mar 2009 01:52:05 +0100

Hi,

This is an automatic notification about a new datatracker release, 
v2.23, generated when running the mkrelease script.

Release notes:

ietfdb (2.23)
  * Fixed a wrong link in the html agenda (from Henrik)
  * Removed the explicit database server ip address in settings.py
    (from Henrik)
  * Integrated updated authorization system.  This requires applying
    database fixups as follows:
	cd /a/www/ietf-datatracker/2.23/ietf
	python manage.py dbshell < ../test/sql_fixup.sql
    The existing htpasswd file can be imported into this new system
    as follows:
	export PYTHONPATH=/a/www/ietf-datatracker/2.23
	export DJANGO_SETTINGS_MODULE=ietf.settings
	/a/www/ietf-datatracker/2.23/ietf/bin/import-users /a/www/htpasswd
    Please capture the output of the import-users script, as it will
    help us resolve any troubles that users have.
  * Fixed infinite loop in wrapping code that prevented display of certain
    document comments

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/2.23'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 24 Mar 2009 17:55:50 -0700

These release notes and pretty much all of this release is Bill's
work, but my silly mkrelease script doesn't preserve the release
note author information of the changelog when composing the letter
it sends out.  (Will fix.)

	Henrik

---

From: Glen <[email-masked]>
Date: Tue, 24 Mar 2009 18:11:24 -0700

>>     help us resolve any troubles that users have.

This release is installed.  The output was captured as directed:

glen@core3:/a/www/ietf-datatracker/2.23>
/a/www/ietf-datatracker/2.23/ietf/bin/import-users /a/www/htpasswd
Could not map [email-masked] to person
Already in system as adrian when adding [email-masked]
([email-masked])
Could not map [email-masked] to person
Could not map [email-masked] to person
Adding azinin to ex-IESG (user_level 2)
Adding becarpenter to ex-IESG (user_level 2)
Adding bellovin to ex-IESG (user_level 2)
Already in system as becarpenter when adding [email-masked]
([email-masked])
Already in system as bert_wijnen when adding bwijnen (None)
Changing username from bert_wijnen to bwijnen
Adding bwijnen to ex-IESG (user_level 2)
Could not map cginsbur to person
Adding chris_newman to IESG (user_level 1)
Could not map [email-masked] to person
Could not map cmm to person
Could not map [email-masked] to person
Adding david to ex-IESG (user_level 2)
Already in system as david_putzolu when adding dputzolu (None)
Changing username from david_putzolu to dputzolu
Adding dan_romascanu to IESG (user_level 1)
Adding david_ward to IESG (user_level 1)
Could not map [email-masked] to person
Could not map [email-masked] to person
Could not map [email-masked] to person
Already in system as fenner when adding fenner (None)
Adding fenner to ex-IESG (user_level 2)
Adding cullen_jennings to IESG (user_level 1)
Adding freed to ex-IESG (user_level 2)
Could not map galvin to person
Could not map gcunning to person
Could not map [email-masked] to person
Adding glen2 to Secretariat (user_level 0)
Could not map [email-masked] to person
Could not map [email-masked] to person
Could not map [email-masked] to person
Adding hardie to ex-IESG (user_level 2)
Adding hartmans to ex-IESG (user_level 2)
Already in system as harald_alvestrand when adding hta (None)
Changing username from harald_alvestrand to hta
Adding hta to ex-IESG (user_level 2)
Could not map iana to person
Could not map [email-masked] to person
Could not map [email-masked] to person
Adding jari_arkko to IESG (user_level 1)
Already in system as jari_arkko when adding [email-masked]
([email-masked])
Adding jpeterson to IESG (user_level 1)
Could not map kem to person
Could not map [email-masked] to person
Could not map klm to person
Could not map [email-masked] to person
Could not map [email-masked] to person
Adding lars_eggert to IESG (user_level 1)
Could not map lgw to person
Adding lisa_dusseault to IESG (user_level 1)
Adding magnus_westerlund to IESG (user_level 1)
Adding mankin to ex-IESG (user_level 2)
Could not map [email-masked] to person
Could not map [email-masked] to person
Could not map mlarson to person
Already in system as margaret_wasserman when adding mrw (None)
Changing username from margaret_wasserman to mrw
Adding mrw to ex-IESG (user_level 2)
Adding narten to ex-IESG (user_level 2)
Already in system as narten when adding [email-masked]
([email-masked])
Already in system as freed when adding [email-masked]
([email-masked])
Could not map nomcom05 to person
Could not map nomcom to person
Already in system as erik_nordmark when adding nordmark (None)
Changing username from erik_nordmark to nordmark
Adding nordmark to ex-IESG (user_level 2)
Could not map [email-masked] to person
Adding paf to ex-IESG (user_level 2)
Already in system as paf when adding [email-masked] ([email-masked])
Adding pasi_eronen to IESG (user_level 1)
Adding ronald_bonica to IESG (user_level 1)
Could not map rbunch to person
Adding ross_callon to IESG (user_level 1)
Could not map [email-masked] to person
Already in system as pete_resnick when adding
[email-masked]
([email-masked])
Adding rhousley to IESG (user_level 1)
Could not map [email-masked] to person
Adding sah to ex-IESG (user_level 2)
Could not map sam to person
Already in system as jeffrey_schiller when adding schiller (None)
Changing username from jeffrey_schiller to schiller
Adding schiller to ex-IESG (user_level 2)
Could not map sconte to person
Already in system as bellovin when adding [email-masked]
([email-masked])
Adding sob to ex-IESG (user_level 2)
Already in system as sob when adding [email-masked] ([email-masked])
Could not map [email-masked] to person
Already in system as raustein when adding [email-masked] ([email-masked])
Already in system as raustein when adding [email-masked] ([email-masked])
Could not map [email-masked] to person
Could not map [email-masked] to person
Could not map sweilnau to person
Adding tim_polk to IESG (user_level 1)
Adding townsley to IESG (user_level 1)
Could not map w3c-policy-people to person
Could not map wnl to person
Could not map av1 to person
Could not map mb1 to person
Already in system as tkurakova when adding [email-masked]
([email-masked])
Could not map [email-masked] to person
Already in system as cotton when adding [email-masked]
([email-masked])
Already in system as jpeterson when adding [email-masked]
([email-masked])
Could not map nlw to person
Already in system as pasi_eronen when adding [email-masked]
([email-masked])
Adding pasi_eronen to IESG (user_level 1)
Could not map sm1 to person
Already in system as rajeev_koodli when adding [email-masked]
([email-masked])
Could not map ietf to person
Could not map [email-masked] to person
Could not map ietfreg to person
Already in system as aaronf when adding [email-masked] ([email-masked])
Could not map [email-masked] to person
Already in system as david_bryan when adding [email-masked]
([email-masked])
Already in system as david when adding [email-masked]
([email-masked])
Could not map ietf1 to person
Adding priyanka to Secretariat (user_level 0)
Could not map stevey to person
Could not map mer to person
Could not map lan to person
Could not map [email-masked] to person
glen@core3:/a/www/ietf-datatracker/2.23>