Subject: [codesprints] New datatracker release: v2.44

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 01 Mar 2010 13:06:04 +0100

Hi,

This is an automatic notification about a new datatracker release, 
v2.44, generated when running the mkrelease script.

Release notes:

ietfdb (2.44)
  From Robert:
  * Moved old (1995-2003) liaison statements from the template file
    to the database. This requires applying database fixups as
    follows:
        cd /a/www/ietf-datatracker/2.44/ietf
        PYTHONPATH=../ python manage.py dbshell < ../test/liaison_fixup.sql
    And updating the liaison files as follows:
	cd /a/www/ietf-datatracker/documents/LIAISON/
        # TAKE A BACKUP OF THE WHOLE DIRECTORY, JUST IN CASE
	. /a/www/ietf-datatracker/2.44/test/liaison_fixup.sh
  From Pasi:
  * Use new look for more pages
  * Make obsoletes/updates/etc. lists links (with new urlize_ietf_docs 
    template filter)
  * Always show year in /idtracker/status/ dates
  * /doc/rfcNNNN/: show the internet-draft name (if known) and link to its 
    history; show information about post-RFC IESG processing
  * Use yellow for 'abstain' also in /iesg/agenda/documents/
  * IESG ballot grid icon: show 'abstain' as yellow instead of gray
  * IESG telechat agenda: include "private" links also if logged in, link 
    from document list
  * Added /doc/all/ page
  * Better output if /doc/ search doesn't match anything
  * Show state-change-notice-to field in /doc/ (to AD/secretariat)
  * Make IESG telechat agenda feed discoverable
  * Added IPR/dependency links and edit/add buttons for RFCs, too; some 
    template refactoring
  * Avoid exceptions from MySQL when searching for non-ASCII draft names/WG 
    acronyms/etc.
  * Handle non-ASCII characters gracefully in old cgi-bin script redirects
  * IPR search: handle non-numeric RFC numbers/ID document tags gracefully 
    (instead of uncaught exception)
  * Change Atom feeds (+couple of other places) to point to /doc/draft-.. 
    instead of /idtracker/draft-.../
  From Henrik:
  * In PersonOrOrgInfo.email(), try harder to find a relevant email address.
    The new code will eventually fall back to a broad filter which matches that
    of the perl code which creates WG charter pages, where the old code would
    sometimes result in django-generated charter pages with missing email
    addresses.
  * Serve ipr disclosures which are available on the server directly, 
    instead of through an external http link in an <iframe/>.  The <iframe/> 
    method can result in mixing https and http content in the page, which some 
    browser take issue with.
  * Add back in rudimentary Django Admin support which was lost in the 0.96 
    -> 1.1 transition.
ietfdb (2.43)
  From Pasi:
  * New main datatracker page!
  * Use normal POST instead of AJAX for search, in order to be able to go
    back to the search result list with the browser back button
  * Added pointers (but no redirect yet) to new pages to /idtracker/ and 
    /idtracker/draft-foo-bar/
  * Added javascript redirect for /drafts/draft-foo-bar/ page
  * Fix history/comment tab for RFCs
  * Added more links to other versions (like tools html)
  * Fixed bug in submitting general license statements
  * Fixed ballot icon width problem in Safari (regression introduced in 
    2.42)
  * Replaced /drafts/all_id.html with redirect (there are no links to it, 
    and according to logs nobody is using it)
  * Added rel=nofollow to various links
  * Improve coloring for "for N days" information

The new version is available through SVN checkout, with
  'svn checkout http://svn.tools.ietf.org/svn/tools/ietfdb/tags/2.44'

Regards,

	Henrik
	(via the mkrelease script)

---

From: Glen <[email-masked]>
Date: Mon, 01 Mar 2010 16:34:07 -0800

This has been deployed, with updates executed as directed.

Glen