Subject: [codesprints] SVN/TRAC for the datatracker and xml2rfc has been moved from tools.ietf.org to ietf.org

From: Robert Sparks <[email-masked]>
Date: Thu, 13 May 2021 13:27:45 -0500

All -

If you have working copies that you want to keep using, you should 
change the svn server they point to using the svn command as follows:

$ svn relocate https://svn.tools.ietf.org/svn/tools/ietfdb 
https://svn.ietf.org/svn/tools/ietfdb

$ svn up

You would do similar things if you have working copies of xml2rfc.

Fresh checkouts should be made using 
https://svn.ietf.org/svn/tools/ietfdb going forward.

Trac has also been moved. Redirects are in place to help you land in the 
right places, but please update any bookmarks you find.

Please help me spot and correct places in the documentation (the sprint 
pages at the ietfdb wiki will need a global update - I'm happy to let 
someone else do that if they have the energy.

RjS

---

From: Russ Housley <[email-masked]>
Date: Thu, 13 May 2021 14:42:46 -0400

Robert:

What URL do we use to review tickets?  It was http://wiki.tools.ietf.org/tools/ietfdb

Russ

> On May 13, 2021, at 2:27 PM, Robert Sparks <[email-masked]> wrote:
> 
> All -
> 
> If you have working copies that you want to keep using, you should change the svn server they point to using the svn command as follows:
> 
> 
> $ svn relocate https://svn.tools.ietf.org/svn/tools/ietfdb https://svn.ietf.org/svn/tools/ietfdb
> 
> $ svn up
> 
> Fresh checkouts should be made using https://svn.ietf.org/svn/tools/ietfdb going forward.
> 
> Trac has also been moved. Redirects are in place to help you land in the right places, but please update any bookmarks you find.
> 
> Please help me spot and correct places in the documentation (the sprint pages at the ietfdb wiki will need a global update - I'm happy to let someone else do that if they have the energy.
> 
> RjS
> 
> _______________________________________________
> codesprints mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codesprints

---

From: Robert Sparks <[email-masked]>
Date: Thu, 13 May 2021 13:48:07 -0500

Note that that URL redirects to https://trac.ietf.org/trac/ietfdb

You'll need to login (with your datatracker credentials) to view tickets.

fwiw, I'm considering changing the permissions to allow viewing tickets 
anonymously again - we started requiring that at tools.ietf.org to help 
avoid the extra load from badly-behaved robots. I think we could better 
handle that with cloudflare, but there is some setup investigation that 
needs to happen first.

RjS