Subject: [codesprints] Commit triggers no working completely

From: Robert Sparks <[email-masked]>
Date: Tue, 1 Jun 2021 18:05:52 -0500

Unless I'm missing something obvious:

when I ran

> (env) rjsparks@unformal 7.30.1.dev0 % svn commit -m 'Redirect to 
> materials page
> for attempts to see proceedings for meetings that do not yet have 
> schedules. Fix
> es #3294. Commit ready for merge.'
>
> Sending        ietf/meeting/tests_views.py
> Sending        ietf/meeting/views.py
> Transmitting file data ..done
> Committing transaction...
> Committed revision 19055.
>
The commit hooks picked up the Commit ready for merge phrase, but they 
did not pick up the Fixes #3294 phrase. I had to go close the ticket 
manually.

Have others seen this?

RjS

---

From: Russ Housley <[email-masked]>
Date: Wed, 2 Jun 2021 09:06:16 -0400

The same happened for ticket #3270.

> On Jun 1, 2021, at 7:05 PM, Robert Sparks <[email-masked]> wrote:
> 
>> (env) rjsparks@unformal 7.30.1.dev0 % svn commit -m 'Redirect to materials page
>> for attempts to see proceedings for meetings that do not yet have schedules. Fix
> The commit hooks picked up the Commit ready for merge phrase, but they did not pick up the Fixes #3294 phrase. I had to go close the ticket manually.
> 
> Have others seen this?
> 
> RjS
> 
> _______________________________________________
> codesprints mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/codesprints

---

From: Robert Sparks <[email-masked]>
Date: Wed, 2 Jun 2021 11:02:58 -0500

I found where it is broken, and am working on correcting it.

Don't worry about it being broken - keep committing - I'll clean up 
anything that's not right as soon as the fix is in place.

(The issue is a missing package that is surprisingly hard to install. 
I'm quite puzzled about discovering it this late - several of us had 
tested this in the trials of the new repository and things appeared to 
be working at that time).

RjS

---

From: Robert Sparks <[email-masked]>
Date: Wed, 2 Jun 2021 11:27:45 -0500

I believe this is fixed now.

See https://trac.ietf.org/trac/ietfdb/ticket/3297

RjS

On 6/2/21 11:02 AM, Robert Sparks wrote:
>>> The commit hooks picked up the Commit ready for merge phrase, but 
>>> they did not pick up the Fixes #3294 phrase. I had to go close the 
>>> ticket manually.
>>>
>>> Have others seen this?
>>>
>>> RjS
>>>