Subject: [coman] are we there yet?

From: Michael Richardson <[email-masked]>
Date: Mon, 11 Mar 2013 09:32:02 -0400

Is the aim of COMAN to form a WG?  
The list has been rather quiet.

-- 
Michael Richardson
-on the road-

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 11 Mar 2013 14:02:25 +0000

Forming a WG is an option. However, we have left this open and dependent on the community interest.

Do you think it is important and should be pushed?

Can folks please comment on the draft recently submitted?

Cheers, 
Mehmet 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of ext
> Michael Richardson
> Sent: Monday, March 11, 2013 9:32 AM
> To: [email-masked]
> Subject: [coman] are we there yet?
> 
>

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 11 Mar 2013 07:35:09 -0700

I think that if enough interest is formed, it would be good to form a WG.
It has indeed been a little quiet on this list. Personally, I think that
the IETF does not yet have good answers to management of constrained
devices and networks.

The draft is a good step and is valuable to the community, IMO.

Best regards
Ulrich

On Mon, Mar 11, 2013 at 7:02 AM, Ersue, Mehmet (NSN - DE/Munich) <
[email-masked]> wrote:

> _______________________________________________
> coman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/coman
>

---

From: peter van der Stok <[email-masked]>
Date: Mon, 11 Mar 2013 15:57:38 +0100

+1

will the group still meet to also discuss the technology draft?

Peter

Ulrich Herberg schreef op 2013-03-11 15:35:
> I think that if enough interest is formed, it would be good to form a
> WG. It has indeed been a little quiet on this list. Personally, I
> think that the IETF does not yet have good answers to management of
> constrained devices and networks.
> 
> On Mon, Mar 11, 2013 at 7:02 AM, Ersue, Mehmet (NSN - DE/Munich)
> <[email-masked]> wrote:
> 
>> https://www.ietf.org/mailman/listinfo/coman [1]
> 
> 
> 
> Links:
> ------
> [1] https://www.ietf.org/mailman/listinfo/coman
>

---

From: <[email-masked]>
Date: Mon, 11 Mar 2013 15:10:56 +0000

Hi all

I believe the work currently done at Coman is of interest and needed.
Whether it warrants creation of a new WG or could be made fit into an existing WG is beyond my appreciation.
I will comment on the draft shortly.
Cheers,

Dominique

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de peter van der Stok
Envoyé : lundi 11 mars 2013 10:58
À : [email-masked]
Objet : Re: [coman] are we there yet?

+1

Peter

Ulrich Herberg schreef op 2013-03-11 15:35:
>>> From: [email-masked] [mailto:[email-masked]] On
>>> Behalf Of ext Michael Richardson

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 11 Mar 2013 15:26:00 +0000

I don't want to sound negative but I would like to measure the interest on Coman based on the comments to the last draft. 

Cheers,
Mehmet

Sent from my iPad.
Mehmet Ersue

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 11 Mar 2013 15:29:44 +0000

We did not plan an official meeting in a meeting room.

If you guys are interested we can come together Thursday lunch time in the IETF Lounge area.

Cheers,
Mehmet

Sent from my iPad.
Mehmet Ersue

---

From: Benoit Claise <[email-masked]>
Date: Mon, 11 Mar 2013 12:31:50 -0400

> constrained devices and networks.
Granted.
However, we also need motivated expert people doing work in that area.
This second part is not obvious to me at the present time.

Regards, Benoit
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     > From: [email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked] <mailto:[email-masked]>] On
>     Behalf Of ext
>     > Michael Richardson
>     > To: [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: James Nguyen <[email-masked]>
Date: Mon, 11 Mar 2013 14:31:51 -0400

+1

-- 
James Nguyen
Email: [email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Mon, 11 Mar 2013 17:19:25 -0400

>>>>> "NSN" == NSN  <Ersue> writes:
    NSN> Forming a WG is an option. However, we have left this open and
    NSN> dependent on the community interest.

    NSN> Do you think it is important and should be pushed?

    NSN> Can folks please comment on the draft recently submitted?

I'm afraid I don't know which draft that is.
I'm guessing... draft-ersue-constrained-mgmt-03  ??

-- 
Michael Richardson
-on the road-

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 11 Mar 2013 22:53:33 +0000

Correct. See attachment.

Cheers, 
Mehmet 

> Sent: Monday, March 11, 2013 5:19 PM
> To: Ersue, Mehmet (NSN - DE/Munich)
> Cc: [email-masked]
> Subject: Re: [coman] are we there yet?
> 
> 

Subject: [coman] Review of draft-ersue-constrained-mgmt-03 on "Management of Networks with Constrained Devices: Problem Statement, Use Cases and Requirements"
From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: ext Benoit Claise <[email-masked]>, "ext Romascanu, Dan (Dan)" <[email-masked]>, Juergen Schoenwaelder <[email-masked]>
Date: Thu, 14 Feb 2013 17:11:18 +0000
List-Id: Management of Constrained Networks and Devices <coman.ietf.org>

Hi All,

based on the agreement in the OPS-DIR meeting in IETF 83 and the support of the O&M AD Benoit Claise we set up the Coman (COnstrained MANanagement) activity and the corresponding maillist on May 16, 2012.

Since then quite a number of people worked on the document on "Management of Networks with Constrained Devices: Problem Statement, Use Cases and Requirements" with their text contributions and comments. Many thanks to all who helped getting it to the current stage.

http://tools.ietf.org/html/draft-ersue-constrained-mgmt-03

With this email we would like to start a review of the draft above.
Please provide your comments to any of the maillists on the Too-list (please CC Coman maillist).
We hope on a useful discussion concerning the problem statement, use cases and requirements.

As the next step, we decided during IETF 85 to provide a new draft with a gap analysis on missing standards at the IETF for the purpose of Constrained Device&Network Management with the goal to highlight new work at IETF. This draft will be written just after getting the above document more stable based on your comments.

Thank you in advance.

Cheers,
Mehmet

Coman maillist info:
List address: [email-masked]
Archive:   http://www.ietf.org/mail-archive/web/coman/
To subscribe:  https://www.ietf.org/mailman/listinfo/coman

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 11 Mar 2013 17:41:17 -0700

On Mon, Mar 11, 2013 at 2:19 PM, Michael Richardson
<[email-masked]>wrote:

> [..]

Yes, I think that is the draft Ersue was talking about.

Best
Ulrich

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 11 Mar 2013 17:44:21 -0700

ah, sorry, just saw your reply, Mehmet.

>From my point of view, the question is not whether the topic fills a gap in
the IETF (which IMO it clearly does), but rather whether there is enough
interest and work force to pursue the task. I would like to contribute.

Best
Ulrich

---

From: Likepeng <[email-masked]>
Date: Tue, 12 Mar 2013 01:00:19 +0000

+1.
I think the work is valuable in IETF.
We should try to push it and form a WG.
Kind Regards
Kepeng
On Mon, Mar 11, 2013 at 10:35 AM, Ulrich Herberg <[email-masked]<mailto:[email-masked]>> wrote:
I think that if enough interest is formed, it would be good to form a WG. It has indeed been a little quiet on this list. Personally, I think that the IETF does not yet have good answers to management of constrained devices and networks.

Best regards
Ulrich

On Mon, Mar 11, 2013 at 7:02 AM, Ersue, Mehmet (NSN - DE/Munich) <[email-masked]<mailto:[email-masked]>> wrote:
Forming a WG is an option. However, we have left this open and dependent on the community interest.

Cheers,
Mehmet

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of ext
> Michael Richardson
> To: [email-masked]<mailto:[email-masked]>
_______________________________________________
coman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/coman

_______________________________________________
coman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/coman

--
James Nguyen
Email: [email-masked]<mailto:[email-masked]>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 12 Mar 2013 02:40:22 +0100

> We should try to push it and form a WG.

To do what exactly?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 11 Mar 2013 18:46:40 -0700

I think a first step could be to do a gap analysis: in how far do existing
IETF standards suffice to manage constrained networks and devices (e.g.,
based on the requirements listed in Mehmet's draft). If we conclude that
they are sufficient, the work is done. If not, I could imagine that the
work would consist in specifying new management protocol(s) that fulfill
the requirements.

Ulrich

---

From: Likepeng <[email-masked]>
Date: Tue, 12 Mar 2013 01:55:39 +0000

>To do what exactly?

As far as I can see, the main scope is to manage the constrained device.

Currently we have some protocols to manage mobile devices, like OMA DM. And we have SNMP to manage networks. But these protocols are too heavy to be used to manage the constrained devices. That is why I think the work is valid.

I notice that we have two drafts available already, one is about the problem statement, and use cases, the other one is the gap analysis, to identify the gaps between the requirements and the current standards.
http://tools.ietf.org/html/draft-ersue-constrained-mgmt-03
https://datatracker.ietf.org/doc/draft-greevenbosch-coman-candidate-tech/

We have a good start point, and can continue to work towards the intended scope.

Kind Regards
Kepeng

-----邮件原件-----
发件人: Juergen Schoenwaelder [mailto:[email-masked]] 
发送时间: 2013年3月12日 9:40
收件人: Likepeng
抄送: James Nguyen; Ulrich Herberg; Ersue, Mehmet (NSN - DE/Munich); [email-masked]; ext Michael Richardson
主题: Re: [coman] are we there yet?

To do what exactly?

/js

---

From: Zach Shelby <[email-masked]>
Date: Mon, 11 Mar 2013 22:20:15 -0400

Hi,

We are just completing a new OMA Lightweight M2M standard which includes an efficient Object system for managing constrained devices over CoAP. It has a highly optimised form of Object format which is applicable for device management, network management and also application data. If you are interested, I will present more information about this new standard at the CoRE meeting on Wednesday. 

Taking this into account, I definitely do not believe there is a need to develop new protocols to manage these device. The whole point is that we need to use the same protocol for management and the application. 

The OMA Lightweight activity only defines a standard set of device, connectivity, firmware and location objects. The IPSO Alliance is working on some application data Objects. Therefore I would see a need for an IETF effort to help define more Objects for the purpose of managing constrained devices and networks, which could then be registered with the OMA registry. 

Regards,
Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: Likepeng <[email-masked]>
Date: Tue, 12 Mar 2013 03:28:20 +0000

>Therefore I would see a need for an IETF effort to help define more Objects for the purpose of managing constrained devices and networks, which could then be registered with the OMA registry.

OK, sounds good. 

Kind Regards
Kepeng

-----邮件原件-----
发件人: Zach Shelby [mailto:[email-masked]] 
发送时间: 2013年3月12日 10:20
收件人: Likepeng
抄送: Juergen Schoenwaelder; Ersue, Mehmet (NSN - DE/Munich); James Nguyen; [email-masked]; Ulrich Herberg; ext Michael Richardson
主题: Re: [coman] are we there yet?

Hi,

Regards,
Zach

---

From: Michael Richardson <[email-masked]>
Date: Tue, 12 Mar 2013 12:14:52 -0400

> To do what exactly?

for a LLN which has been *provisioned* with a layer-2 set of keys,
and has an existing security infrastructure based upon those keys
(i.e. the key is not compromised), I would like a protocol that
is capable of rekeying all or a subset of nodes/motes.

-- 
Michael Richardson
-on the road-

---

From: Michael Richardson <[email-masked]>
Date: Tue, 12 Mar 2013 12:16:46 -0400

>>>>> "Zach" == Zach Shelby <[email-masked]> writes:
    Zach> We are just completing a new OMA Lightweight M2M standard
    Zach> which includes an efficient Object system for managing
    Zach> constrained devices over CoAP. It has a highly optimised form
    Zach> of Object format which is applicable for device management,
    Zach> network management and also application data. If you are
    Zach> interested, I will present more information about this new
    Zach> standard at the CoRE meeting on Wednesday.  

Awesome!!!!

is that:
                        CoRE Resource Directory
                draft-shelby-core-resource-directory-05

-- 
Michael Richardson
-on the road-

---

From: Zach Shelby <[email-masked]>
Date: Tue, 12 Mar 2013 14:52:12 -0400

>                draft-shelby-core-resource-directory-05

Lightweight M2M (LWM2M) is a system standard in the Open Mobile Alliance. It includes DTLS, CoAP, Block, Observe, SenML and Resource Directory and weaves them into a device-server interface along with an Object structure. It uses a subset of the Resource Directory functionality, so the Resource Directory spec in CoRE is a more general solution.

In the Wed CoRE meeting I will be presenting a few slides on this (starts at page 113 of http://tools.ietf.org/agenda/86/slides/slides-86-core-1.pdf). You can also access the entire specification at:

http://member.openmobilealliance.org/ftp/Public_documents/DM/LightweightM2M/Permanent_documents/OMA-TS-LightweightM2M-V1_0_0-20130301-D.zip  

Regards,
Zach

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 12 Mar 2013 19:56:58 +0100

> http://member.openmobilealliance.org/ftp/Public_documents/DM/LightweightM2M/Permanent_documents/OMA-TS-LightweightM2M-V1_0_0-20130301-D.zip  

Since you seem to know this well, any chance to get information how
this new OMA collection of protocols addresses the requirements
written down in the coman document? I think this would be useful input
for this list to have.

/js

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 12 Mar 2013 21:47:01 +0000

I am not sure I get the point.

Is it the proposal that we should use OMA LwM2M for the purpose of Coman, or is it meant that more than what OMA LwM2M specifies is not needed?

Ideally, we need to support all management dimensions on the one side: the management protocol, the information model and the necessary data models, and an appropriate modeling language.
On the other hand different management tasks need to be addressed, e.g. fault, performance and security management and not only configuration.

I think we need also understand that in the Coman draft, M2M is just one use case between many.

It would be indeed useful to elaborate, how far OMA LwM2M supports the network management requirements listed in the Coman draft, which cover both management of constrained devices and the management of networks with diverse topologies containing constrained and non-constrained devices.

Mehmet

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 12 Mar 2013 18:39:52 -0400

On Mar 12, 2013, at 14:52, Zach Shelby <[email-masked]> wrote:

> page 113 of http://tools.ietf.org/agenda/86/slides/slides-86-core-1.pdf

I reshuffled the slides for the updated agenda, now starts at 97.

I'll try to be there on Thu.

Grüße, Carsten

---

From: Zach Shelby <[email-masked]>
Date: Wed, 13 Mar 2013 11:37:09 -0400

Hi Mehmet,

I'll be happy to compare this to the requirements in the Coman draft. Will report back when I am done. 

We don't know what the point is yet, just letting you know there is work being done in this space that is used for solving the same problem and already using IETF protocols. As a vendor making IoT systems with very embedded devices, I can say one thing for sure, we will not be using multiple protocols to do Device Management, Network Management and Application Data. These need to be enabled using the same set of security and transfer protocols, and ideally using the same interfaces and data models as much as possible.

For sure the IETF has a role to play in making great MIBs for managing networks and protocols. We just need to figure out how to make those MIBs available for use over a general IoT protocol that we already would be using for other purposes on a device. And we also need to align that with the other standards activities happening in this space (OMA, OneM2M etc.). For instance, I would love to be able to use the 6LoWPAN and RPL MIBs that Juergen has created over CoAP. 

So I guess to be perfectly blunt, creating a new protocol is a non-starter for COMAN. But at the same time I am sure there are lots of things we can do on top of existing protocols and systems. We just need to figure out what the gaps are.

Regards,
Zach

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 13 Mar 2013 17:03:14 +0100

On Wed, Mar 13, 2013 at 11:37:09AM -0400, Zach Shelby wrote:

> For instance, I would love to be able to use the 6LoWPAN and RPL
> MIBs that Juergen has created over CoAP.

You might have seen that it is possible to serialize data into JSON if
that makes you feel more comfortable. Which verbs you use to initiate
transfers I can't tell - put you kind of claim that OMA has solved
this problem, so I am looking forward to learn more. (Perhaps I also
misunderstand, which is most likely. ;-)

/js

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 13 Mar 2013 16:12:14 +0000

Just to be short (the long version can be discussed in the hallway):

- We are not going to reinvent CoAP. 
- Though I don't believe OMA LwM2M satisfies the use cases and requirements we have.

Cheers, 
Mehmet 

> From: ext Zach Shelby [mailto:[email-masked]]
> Sent: Wednesday, March 13, 2013 11:37 AM
> Cc: [email-masked]; Michael Richardson
> We don't know what the point is yet, just letting you know there is work being done in
> this space that is used for solving the same problem and already using IETF protocols.
> As a vendor making IoT systems with very embedded devices, I can say one thing for
> sure, we will not be using multiple protocols to do Device Management, Network
> Management and Application Data. These need to be enabled using the same set of
> security and transfer protocols, and ideally using the same interfaces and data models
> as much as possible.
> 
> For sure the IETF has a role to play in making great MIBs for managing networks and
> protocols. We just need to figure out how to make those MIBs available for use over a
> general IoT protocol that we already would be using for other purposes on a device.
> And we also need to align that with the other standards activities happening in this
> space (OMA, OneM2M etc.). For instance, I would love to be able to use the 6LoWPAN
> and RPL MIBs that Juergen has created over CoAP.
> 
> So I guess to be perfectly blunt, creating a new protocol is a non-starter for COMAN.
> But at the same time I am sure there are lots of things we can do on top of existing
> protocols and systems. We just need to figure out what the gaps are.
> 
> Regards,
> Zach
> 
> > Is it the proposal that we should use OMA LwM2M for the purpose of Coman, or is it
> meant that more than what OMA LwM2M specifies is not needed?
> >
> > Ideally, we need to support all management dimensions on the one side: the
> management protocol, the information model and the necessary data models, and an
> appropriate modeling language.
> > On the other hand different management tasks need to be addressed, e.g. fault,
> performance and security management and not only configuration.
> >
> > It would be indeed useful to elaborate, how far OMA LwM2M supports the network
> management requirements listed in the Coman draft, which cover both management of
> constrained devices and the management of networks with diverse topologies
> containing constrained and non-constrained devices.
> >
> > Mehmet
> >
> >
> >
> >> Lightweight M2M (LWM2M) is a system standard in the Open Mobile Alliance. It
> includes DTLS, CoAP, Block, Observe, SenML and Resource Directory and weaves them
> into a device-server interface along with an Object structure. It uses a subset of the
> Resource Directory functionality, so the Resource Directory spec in CoRE is a more
> general solution.
> >>
> >> In the Wed CoRE meeting I will be presenting a few slides on this (starts at page
> 113 of http://tools.ietf.org/agenda/86/slides/slides-86-core-1.pdf). You can also access
> the entire specification at:
> >>
> >>
> http://member.openmobilealliance.org/ftp/Public_documents/DM/LightweightM2M/Perm
> anent_documents/OMA-TS-LightweightM2M-V1_0_0-20130301-D.zip
> >>
> >> Regards,
> >> Zach
> >>
> >> --

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 13 Mar 2013 12:25:04 -0400

Zach,

On Wed, Mar 13, 2013 at 11:37 AM, Zach Shelby <[email-masked]> wrote:
> [...]
> We just need to figure out what the gaps are.

I agree with that. It would be the first step. Whether we need a new
protocol, or can use and extend existing protocols would follow from
the gap analysis.

I have no opinion yet whether OMA M2M would be fulfilling the
requirements that we are defining, so I am looking forward to see your
gap analysis for that protocol.

On Thursday, I think we should also talk about whether to request a
BOF for Berlin or not. COMAN has been around for a few IETFs now and I
see a good approach, but like Benoit said, we need to be sure there
are enough people interested (and more importantly, willing to do the
work). Also, we'd need a clear charter in case we want to apply for a
BOF.

Thanks
Ulrich

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 13 Mar 2013 16:49:26 +0000

As discussed in the last meeting, the precondition for a successful BOF is a gap analysis, which highlights potential new work and justifies at the end a new WG.

So, we need to go through this step first. And I see the discussion on and the review of the requirements as part of the gap analysis.

The question now is who is going to do such a gap analysis. Is it me alone or are other people going to write any drafts, which underline missing parts?

Cheers, 
Mehmet 

> From: ext Ulrich Herberg [mailto:[email-masked]]
> Sent: Wednesday, March 13, 2013 12:25 PM
> To: Zach Shelby
> Cc: Ersue, Mehmet (NSN - DE/Munich); [email-masked]; Michael Richardson

---

From: Michael Richardson <[email-masked]>
Date: Wed, 13 Mar 2013 17:50:15 -0400

>>>>> "Zach" == Zach Shelby <[email-masked]> writes:
    Zach> We don't know what the point is yet, just letting you know
    Zach> there is work being done in this space that is used for
    Zach> solving the same problem and already using IETF protocols. As
    Zach> a vendor making IoT systems with very embedded devices, I can
    Zach> say one thing for sure, we will not be using multiple
    Zach> protocols to do Device Management, Network Management and
    Zach> Application Data. These need to be enabled using the same set
    Zach> of security and transfer protocols, and ideally using the same
    Zach> interfaces and data models as much as possible.

My take is that the "MIB" abstraction is useful because it describes a
data model.  I think that writing MIBs is useful here, but translating
the result to ASN.1 for transport over SNMP is not.  

I think that we should probably use COAP. A gateway should be *possible*
that translates SNMP or Netconf/Yang to CoAP-management.  Whether such a
thing is desired or not, I don't yet know.

-- 
Michael Richardson
-on the road-

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 13 Mar 2013 20:04:43 -0400

> thing is desired or not, I don't yet know.

ASN.1/SNMP may be one problem that we can work around.

But the data model of SMIv2 MIBs was designed to fit ASN.1.

A newer approach such as Yang may enable us to tailor the data models more towards what we actually need in the constrained space.

Before we can do the tailoring, we need to know what we need.
We have the 6LoWPAN and RPL MIBs as fleshed out prototypes for a solution.
Is this the kind of information that people need for managing smart object networks?
How do we find out?

Grüße, Carsten

---

From: Bert Greevenbosch <[email-masked]>
Date: Thu, 14 Mar 2013 15:18:23 +0000

Hi Juergen, all,

The following draft gives a high-level overview of technologies related to the coman requirements:
https://datatracker.ietf.org/doc/draft-greevenbosch-coman-candidate-tech/

The draft aims at indentifying technologies and gaps. There is a section about OMA LwM2M.

Best regards,
Bert

________________________________________
From: [email-masked] [[email-masked]] on behalf of Juergen Schoenwaelder [[email-masked]]
Sent: 13 March 2013 02:56
To: Zach Shelby
Cc: [email-masked]; Michael Richardson
Subject: Re: [coman] are we there yet?

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 14 Mar 2013 16:53:20 +0100

> The draft aims at indentifying technologies and gaps. There is a section about OMA LwM2M.

Thanks. I knew about your draft, I overlooked that it also talks about
OMA LwM2M.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 14 Mar 2013 18:33:50 +0100

> Is this the kind of information that people need for managing smart object networks?

The 6LoWPAN MIB defines very basic counters that actually did help us
in our lab to _troubleshoot_ issues with both 802.15.4 radios and
Contiki's 6lowpan implementation. I would assume others face similar
issues that we see (e.g. a decent probability for 802.15.4 frames to
not arrive combined with Contiki's notion of "once I start to
reassemble a packet, I wait for remaining fragments, dropping
everything else until I am done or I eventually timeout in case one of
the fragments got lost"). I am not blaming Contiki, they do have
limits in the number of reassembly buffers they can support. Its just
that issues like these are out there and do impact stuff (we did run
into this while we were trying to measure how well out TLS/DTLS
implementation is doing and we got rather surprising results due to
stuff happening in the 6lowpan layer).

The implementation and runtime costs for these counters is small, I
actually doubt you can provide a similar troubleshooting mechanism at
lower costs instrumentation wise. For me, MIB modules are primarily
about what to instrument, that is finding agreement which counters are
needed and when they are exactly incremented so that it is clear how
the counters relate to each other. Sure, with MIB module there is an
implicit binding how to access those counters via SNMP. But there have
always been alternate ways to access such counters (e.g. via CLIs or
other interfaces). I hope this implicit binding to SNMP is not taken
as a reason to not standardize such basic counters.

/js