Subject: Re: [coman] Review of draft-ersue-constrained-mgmt-03 on "Management of Networks with Constrained Devices: Problem Statement, Use Cases and Requirements"

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 4 Apr 2013 16:10:52 +0000

As agreed with some of you in Orlando, I would like to encourage you to send your comments on the current Coman draft to the Coman maillist.

We especially need your feedback and comments on the requirements section:
http://tools.ietf.org/html/draft-ersue-constrained-mgmt-03#section-4

Thank you.

Cheers, 
Mehmet 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of ext
> Ersue, Mehmet (NSN - DE/Munich)
> Sent: Thursday, February 14, 2013 6:11 PM
> To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Cc: ext Benoit Claise; ext Romascanu, Dan (Dan); Juergen Schoenwaelder
> Subject: [coman] Review of draft-ersue-constrained-mgmt-03 on "Management of
> Networks with Constrained Devices: Problem Statement, Use Cases and Requirements"
> 
> Hi All,
> 
> based on the agreement in the OPS-DIR meeting in IETF 83 and the support of the
> O&M AD Benoit Claise we set up the Coman (COnstrained MANanagement) activity and
> the corresponding maillist on May 16, 2012.
> 
> Since then quite a number of people worked on the document on "Management of
> Networks with Constrained Devices: Problem Statement, Use Cases and Requirements"
> with their text contributions and comments. Many thanks to all who helped getting it to
> the current stage.
> 
> http://tools.ietf.org/html/draft-ersue-constrained-mgmt-03
> 
> With this email we would like to start a review of the draft above.
> Please provide your comments to any of the maillists on the Too-list (please CC Coman
> maillist).
> We hope on a useful discussion concerning the problem statement, use cases and
> requirements.
> 
> As the next step, we decided during IETF 85 to provide a new draft with a gap analysis
> on missing standards at the IETF for the purpose of Constrained Device&Network
> Management with the goal to highlight new work at IETF. This draft will be written just
> after getting the above document more stable based on your comments.
> 
> Thank you in advance.
> 
> Cheers,
> Mehmet
> 
> Coman maillist info:
> List address: [email-masked]
> Archive:   http://www.ietf.org/mail-archive/web/coman/
> To subscribe:  https://www.ietf.org/mailman/listinfo/coman
> 
> 
> 
> 
> _______________________________________________
> coman mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/coman

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 5 Apr 2013 15:14:05 +0000

Dear Maciek,

we had a similar discussion on RPL some time ago. Please see the mail thread at: http://www.ietf.org/mail-archive/web/coman/current/msg00000.html

> 1) Draft is quite generic, and it's hard to say what is the relation of COMAN to existing specifications from 6LoWPAN, ROLL and CORE groups. In these specs there are some undefined points (for example in RFC6550 there are 18 "out of scope" labels). Is it the purpose of COMAN to provide the way to fill the gaps?

The purpose of COMAN is actually at the first place to collect the use cases and requirements for the “management of networks with constrained devices”. A management solution may or may not use CoAP and the protocol stack you have in mind. Coman discussion is open in that sense.

We also differentiate between “network operation” (or operational needs) and “network management”. The former is out-of-scope for Coman.

We might need a data model to configure RPL parameters at some point. AFAIK this is currently being developed in ROLL WG.
Are there any “specific requirements” coming exclusively from the use of RPL, on the network management functionality (e.g. for fault mgmt, self-configuration, etc.)?

2) The draft doesn't mention RPL routing anywhere. Use of RPL seems to be "strongly coupled" to such requirements like self-healing, or network topology discovery. Is the purpose of COMAN to cover mostly non-RPL networks?
Any network requiring management functionality may use RPL for routing. We looked at self-healing from the management application pov. and on self-healing of a device. We did not look at self-healing of a network, which can be initiated on routing layer as I assume this concerns more the operation of a network. Please give us your thoughts how this could be done.

For the time being we also don’t make any suggestion for the use of a management protocol or of any solution. This can be any light version of SNMP or NETCONF, a new API on top of CoAP or another new protocol requiring RPL.
The selection of the management protocol or the selection of the protocol stack is part of the solution decision.

Our current plan is to finalize the requirements discussion and provide a gap analysis for these requirements.

Cheers,
Mehmet

From: ext Maciej Wasilak [mailto:[email-masked]]
Sent: Friday, April 05, 2013 12:23 PM
To: Ersue, Mehmet (NSN - DE/Munich)
Subject: Re: [coman] Review of draft-ersue-constrained-mgmt-03 on "Management of Networks with Constrained Devices: Problem Statement, Use Cases and Requirements"

Mehmet,

my (newbie) questions about purpose:

1) Draft is quite generic, and it's hard to say what is the relation of COMAN to existing specifications from 6LoWPAN, ROLL and CORE groups. In these specs there are some undefined points (for example in RFC6550 there are 18 "out of scope" labels). Is it the purpose of COMAN to provide the way to fill the gaps?

2) The draft doesn't mention RPL routing anywhere. Use of RPL seems to be "strongly coupled" to such requirements like self-healing, or network topology discovery. Is the purpose of COMAN to cover mostly non-RPL networks?
Best Regards
Maciek

2013/4/4 Ersue, Mehmet (NSN - DE/Munich) <[email-masked]<mailto:[email-masked]>>
As agreed with some of you in Orlando, I would like to encourage you to send your comments on the current Coman draft to the Coman maillist.

Thank you.

Cheers,
Mehmet

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of ext
> To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> List address: [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
coman mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/coman