Subject: [conex] Comments on draft-kutscher-conex-mobile-03.txt

From: Nandita Dukkipati <[email-masked]>
Date: Thu, 29 Mar 2012 03:20:11 +0200

Following are my first parse of comments/questions
on draft-kutscher-conex-mobile-03.txt (as individual contributor). Please
fwd to your co-authors - I do not have their emails right now.

Nandita
-------------

1. First of, this is a nice draft elucidating the use of ConEx in mobile
scenarios. At a high level, my take is that the draft expands upon the use
scenarios presented in ConEx Concepts and Uses, but putting it in the
context of mobile networks.

Mobile networks are an apt example for ConEx usage given their limited
bandwidth and the fact that they already perform some sort of detailed
per-use volume accounting. As you mention, hopefully adding congestion
based accounting can be built upon it.

2. Sec 3.4 ConEx as a Form of Differential QoS
I don't get this para at all. Please consider rewording.

3. A high level question: do you have any data on loss rates (exposed to
TCP) in mobile (cellular) networks?

Is it true that link layer protocols perform aggressive retransmissions to
mask losses from higher layers such as TCP - and if so, what does this
property mean in the context of ConEx. If very little loss is exposed to
higher layers, how will the end systems give ConEx feedback to the network?

A discussion on those lines would be great in this draft.

4. Finally, the draft is filled with many 3GPP acronyms of which I know
very little - but I guess you can't do anything about that :-)

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 29 Mar 2012 09:49:13 +0100

Nandita,

At 02:20 29/03/2012, Nandita Dukkipati wrote:
>4. Finally, the draft is filled with many 3GPP acronyms of which I 
>know very little - but I guess you can't do anything about that :-)

Given the intended audience is 3GPP types, I guess this is fine.

In a previous review, I think I caught all the abbrevs that weren't 
explained. I think they have all been fixed now.

Bob

________________________________________________________________
Bob Briscoe,                                BT Innovate & Design

---

From: Dirk Kutscher <[email-masked]>
Date: Thu, 29 Mar 2012 10:57:38 +0000

Thanks a lot for the feedback, Nandita.

Regarding section 3.4, I agree that this can be explained better. The main message was that CONEX might be used to provide a more dynamic, more flexible form of QoS compared to the existing static bearer class selection.

Regarding loss rates, best effort traffic would get 10^-6 or better (per standard at least). That's for the wireless link.

For CONEX, I think we would be interested in end-to-end (at least terminal-to-gateway) loss rates. Such data is normally not easy to obtain, but you can expect significantly higher loss rates there (caused by congestion).

I think it's a good idea to include more discussion on this.

Regarding the acronyms, yes there are many. As Bob mentioned, we think that we have at least spelled out most of them now - it's possible that some translation to Internet terms can be useful - we will consider that.

Cheers,
Dirk

From: Nandita Dukkipati [mailto:[email-masked]]
Sent: Donnerstag, 29. März 2012 03:20
To: Dirk Kutscher; Suresh Krishnan
Cc: [email-masked]
Subject: Comments on draft-kutscher-conex-mobile-03.txt

Following are my first parse of comments/questions on draft-kutscher-conex-mobile-03.txt (as individual contributor). Please fwd to your co-authors - I do not have their emails right now.

Nandita
-------------

1. First of, this is a nice draft elucidating the use of ConEx in mobile scenarios. At a high level, my take is that the draft expands upon the use scenarios presented in ConEx Concepts and Uses, but putting it in the context of mobile networks.

Mobile networks are an apt example for ConEx usage given their limited bandwidth and the fact that they already perform some sort of detailed per-use volume accounting. As you mention, hopefully adding congestion based accounting can be built upon it.

3. A high level question: do you have any data on loss rates (exposed to TCP) in mobile (cellular) networks?

Is it true that link layer protocols perform aggressive retransmissions to mask losses from higher layers such as TCP - and if so, what does this property mean in the context of ConEx. If very little loss is exposed to higher layers, how will the end systems give ConEx feedback to the network?

4. Finally, the draft is filled with many 3GPP acronyms of which I know very little - but I guess you can't do anything about that :-)